Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 22 Sep 2014, 18:28
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Desktop
Coming Soon: LXDE
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [7 Posts]  
Author Message
bark_bark_bark

Joined: 05 Jun 2012
Posts: 809
Location: USA

PostPosted: Fri 29 Jun 2012, 14:20    Post subject:  Coming Soon: LXDE  

LXDE (Lightweight X11 Desktop Environment) is personally my favorite Desktop Environment, and I want to make it as a .PET & .SFS, but...

BEFORE I make it I have some questions:

-What is the actual current version number?
-What are ALL the dependencies required?
-How do I make it available/compatible for all pupies 4.31 and up?

_________________
Desktop: Intel 945PSN Motherboard, 3.2Ghz P-IV "Prescott 2M", 2GB RAM, 500GB WD HDD, Windows 7
Back to top
View user's profile Send private message 
disciple

Joined: 20 May 2006
Posts: 6435
Location: Auckland, New Zealand

PostPosted: Fri 29 Jun 2012, 23:03    Post subject:  

Quote:
-What is the actual current version number?

I didn't realise there was an overall version number for the whole of LXDE (rather than just separate version numbers for each package).
Quote:
-What are ALL the dependencies required?

LXDE isn't really monolithic like most "desktop environments". It is a set of programs that are pretty loosely coupled, or not coupled at all. So it depends on which of the LXDE programs you want to include.
E.g. you might just want lxpanel (or probably lxpanelx) and pcmanfm (probably not the legacy version - the "next generation" version has been becoming pretty stable over the last few months, although it is still missing some features).
And some of the dependencies will be optional.

Quote:
How do I make it available/compatible for all pupies 4.31 and up?

Compile it on Puppy 4.3.1 (or older).
I believe you will have some trouble with that though - I think you'll need to upgrade some of the build tools and things. Is it really worth supporting 4.3.2? To be honest, I'd be inclined to suggest people should use a woof Puppy based on Debian, Slackware or Ubuntu, and just install LXDE from that distro if they want it.

_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send private message 
nilsonmorales


Joined: 15 Apr 2011
Posts: 485
Location: El salvador

PostPosted: Sat 30 Jun 2012, 00:49    Post subject: look this old post maybe help  

http://murga-linux.com/puppy/viewtopic.php?t=36592
Back to top
View user's profile Send private message MSN Messenger 
Gnuxo

Joined: 09 Feb 2012
Posts: 365

PostPosted: Sat 30 Jun 2012, 18:02    Post subject:  

If you make LXDE, include Spacefm instead of pcmanfm.
Spacefm is based on pcmanfm but including some great features that pcmanfm will never have.
Back to top
View user's profile Send private message 
disciple

Joined: 20 May 2006
Posts: 6435
Location: Auckland, New Zealand

PostPosted: Sun 01 Jul 2012, 00:53    Post subject:  

By the same token spacefm doesn't benefit from the changes that are in the "next generation" pcmanfm.
_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send private message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Sun 01 Jul 2012, 02:48    Post subject:  

Saluki has xfce is that not almost as good as LXDE?
_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1424
Location: Malvern, Worcs, UK

PostPosted: Tue 09 Apr 2013, 15:58    Post subject:  

Add LXDE to various puppies by SFS - slacko, precise, upup-precise....
_________________
LxPup-14.03 = Puppy + LXDE
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [7 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Desktop
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0540s ][ Queries: 11 (0.0051s) ][ GZIP on ]