Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 30 Aug 2014, 16:34
All times are UTC - 4
 Forum index » Advanced Topics » Hardware
unable to mount external usb hard drive
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
gaherzog

Joined: 11 Apr 2010
Posts: 9

PostPosted: Sat 30 Jun 2012, 09:53    Post_subject:  unable to mount external usb hard drive
Sub_title: unable to mount external usb hard drive
 

puppy 5.2.8 on a new LT4004u netbook unable to mount external hard drive wd IDE 80GB does not show up on desktop puppy is booting from sdb flash drive windows 7 is on on sda1

does show here as sdc:
sh-4.1# fdisk -l

Disk /dev/sda: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 1 1698 13631488 27 Unknown
/dev/sda2 * 1698 1710 102400 7 HPFS/NTFS
/dev/sda3 1710 38914 298834944 7 HPFS/NTFS

Disk /dev/sdb: 7948 MB, 7948206080 bytes
255 heads, 63 sectors/track, 966 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 966 7759363+ b W95 FAT32
Warning: invalid flag 0x0000 of partition table 5 will be corrected by w(rite)

Disk /dev/sdc: 80.0 GB, 80026361856 bytes
251 heads, 63 sectors/track, 9884 cylinders
Units = cylinders of 15813 * 512 = 8096256 bytes

Device Boot Start End Blocks Id System
/dev/sdc1 1 1859 14691328 83 Linux
/dev/sdc2 1859 5641 29902849 5 Extended
sh-4.1#


sh-4.1# dmesg | tail
sd 8:0:0:0: Attached scsi generic sg3 type 0
sd 8:0:0:0: [sdc] 156301488 512-byte logical blocks: (80.0 GB/74.5 GiB)
sd 8:0:0:0: [sdc] Write Protect is off
sd 8:0:0:0: [sdc] Mode Sense: 00 38 00 00
sd 8:0:0:0: [sdc] Assuming drive cache: write through
usb-storage: device scan complete
sd 8:0:0:0: [sdc] Assuming drive cache: write through
sdc: sdc1 sdc2 < >
sd 8:0:0:0: [sdc] Assuming drive cache: write through
sd 8:0:0:0: [sdc] Attached SCSI disk
sh-4.1#

how can I retrieve data from this disk? and perhaps use it as external hd?
thanks
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9061
Location: Stratford, Ontario

PostPosted: Sat 30 Jun 2012, 11:30    Post_subject:  

Run Gparted and check Drive sdc. What does it say?
Back to top
View user's profile Send_private_message 
gaherzog

Joined: 11 Apr 2010
Posts: 9

PostPosted: Sat 30 Jun 2012, 13:32    Post_subject:  

partition=unallocated
file system=unallocated
size=74.53GiB
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9061
Location: Stratford, Ontario

PostPosted: Sat 30 Jun 2012, 14:12    Post_subject:  

gaherzog wrote:
partition=unallocated
file system=unallocated
size=74.53GiB

That's why Puppy can't mount it.

When did it last work? What data is on it?

I was going to suggest that you try to mount it in Windows. But if the partition table shows it as Linux, that's probably not going to work.
Back to top
View user's profile Send_private_message 
gaherzog

Joined: 11 Apr 2010
Posts: 9

PostPosted: Sat 30 Jun 2012, 14:48    Post_subject:  

it was in my former pc which died about 10 days ago. I got a brief message about a cpu failure due to overclocking; then nothing. not even the flash screen. I removed 2 hard drives; one sata and one lde. The sata works via usb, the ide does not. the ide has most of the data on it. The loss of the data is not a major consequence, but it is a major irritation.
Back to top
View user's profile Send_private_message 
gaherzog

Joined: 11 Apr 2010
Posts: 9

PostPosted: Sat 30 Jun 2012, 19:00    Post_subject:  

Is the data recoverable? Is the drive salvageable?

any ideas anyone?
Back to top
View user's profile Send_private_message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3964
Location: Kiel,Germany

PostPosted: Sat 30 Jun 2012, 19:30    Post_subject:  

http://www.logilink.eu/showproduct/AU0006C.htm

Adaptor i use : needs usb-storage driver loaded . To change attached drives, usb-storage has to be unloaded to be able to refresh /proc/partitions .
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0496s ][ Queries: 11 (0.0031s) ][ GZIP on ]