Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Dec 2014, 18:22
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Fatdog64-600 Final and 601 (July 2012)
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 13 of 23 Posts_count   Goto page: Previous 1, 2, 3, ..., 11, 12, 13, 14, 15, ..., 21, 22, 23 Next
Author Message
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Tue 24 Jul 2012, 14:28    Post_subject: wine-1.5.9-i486_v1.pet  

Green_dome's latest wine-1.5.9-i486_v1.pet works fine without any modifications in using new frugal installation of Fatdog64-601.
image-1.jpg
 Description   
 Filesize   48.17 KB
 Viewed   1197 Time(s)

image-1.jpg

Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9373
Location: Stratford, Ontario

PostPosted: Tue 24 Jul 2012, 18:59    Post_subject:  

[Edit] Go here for GTK-mpscan v1.1.
Edited_times_total
Back to top
View user's profile Send_private_message 
smokey01


Joined: 30 Dec 2006
Posts: 1857
Location: South Australia

PostPosted: Tue 24 Jul 2012, 19:13    Post_subject: Re: wine-1.5.9-i486_v1.pet  

Jim1911 wrote:
Green_dome's latest wine-1.5.9-i486_v1.pet works fine without any modifications in using new frugal installation of Fatdog64-601.


Jim do you have a link please.

_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send_private_message Visit_website 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Tue 24 Jul 2012, 23:54    Post_subject: Re: wine-1.5.9-i486_v1.pet  

smokey01 wrote:
Jim1911 wrote:
Green_dome's latest wine-1.5.9-i486_v1.pet works fine without any modifications in using new frugal installation of Fatdog64-601.


Jim do you have a link please.
Latest Wine
Back to top
View user's profile Send_private_message 
smokey01


Joined: 30 Dec 2006
Posts: 1857
Location: South Australia

PostPosted: Wed 25 Jul 2012, 09:15    Post_subject:  

Is there a Pet or SFS available for Skype 4.0.0.8?

Ta

_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send_private_message Visit_website 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Wed 25 Jul 2012, 10:49    Post_subject:  

smokey01 wrote:
Is there a Pet or SFS available for Skype 4.0.0.8?

Ta
This one for LHP64 may work.
Back to top
View user's profile Send_private_message 
smokey01


Joined: 30 Dec 2006
Posts: 1857
Location: South Australia

PostPosted: Wed 25 Jul 2012, 16:31    Post_subject:  

Jim1911 wrote:
smokey01 wrote:
Is there a Pet or SFS available for Skype 4.0.0.8?

Ta
This one for LHP64 may work.


Thanks but no.

_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send_private_message Visit_website 
smokey01


Joined: 30 Dec 2006
Posts: 1857
Location: South Australia

PostPosted: Thu 26 Jul 2012, 06:27    Post_subject:  

jamesbond I just tried to build VirtualBox with your script and it failed.

Any idea what might be wrong? This is the error from the command prompt:

# VirtualBox
VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/opt/VirtualBox/VirtualBox.so",) failed: libGL.so.1: wrong ELF class: ELFCLASS32
#

Your script:

#!/bin/ash
if ! which make || ! which gcc; then
Xdialog --infobox "Install devx first." 0 0 10000
exit
fi

Xdialog --no-buttons --infobox "Downloading, please wait ..." 0 0 1000000 &
PID=$!

cd /tmp
TMPFILE=$(mktemp)
wget -O $TMPFILE http://dlc.sun.com/virtualbox/LATEST.TXT
VERSION=$(cat $TMPFILE)
wget -O $TMPFILE http://dlc.sun.com/virtualbox/$VERSION/
FILE=$(sed -n '/amd64\.run/ {s/^.*"\(V.*_amd64.run\)".*$/\1/;p}' $TMPFILE)
rm $TMPFILE
wget http://dlc.sun.com/virtualbox/$VERSION/$FILE
chmod +x $FILE
kill $PID

Xdialog --no-buttons --infobox "Installing, please wait ..." 0 0 1000000 &
PID=$!
./$FILE
kill $PID

Xdialog --infobox "Done. The file is stored in /tmp/$FILE in case you want to keep it." 0 0 10000

Thanks

Edit: I have just installed VirtualBox before installing the Nvidia driver and it worked fine. It appears Nvidia installs a driver file and a couple of symlinks which causes VirtualBox some grief. Rather wierd. See screeny for files. The numbering of the libGL files has the same number as the Nvidia driver.
libGL.jpg
 Description   
 Filesize   5.2 KB
 Viewed   922 Time(s)

libGL.jpg


_________________
Puppy Software <-> Distros <-> Puppy Linux Tips

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
smokey01


Joined: 30 Dec 2006
Posts: 1857
Location: South Australia

PostPosted: Thu 26 Jul 2012, 06:33    Post_subject:  

Another problem.

# mpg321
mpg321: error while loading shared libraries: libao.so.2: cannot open shared object file: No such file or directory

Sorry..

_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send_private_message Visit_website 
gnomic

Joined: 20 Aug 2010
Posts: 77

PostPosted: Thu 26 Jul 2012, 08:04    Post_subject: wpa_gui  

So since wpa_gui is afaict the only software provided at gui level for using wifi, this amounts to saying the end user has to configure wpa_supplicant.conf before using wifi is possible? Unclear why the usual Puppy gui utils for wifi are not present, eg SNS, or have I failed to locate them?
Back to top
View user's profile Send_private_message 
jamesbond

Joined: 26 Feb 2007
Posts: 2232
Location: The Blue Marble

PostPosted: Thu 26 Jul 2012, 08:56    Post_subject:  

smokey01,

Re: virtualbox - do you install nvidia driver using the available pet, or do you use getnvidia? I haven't tested getnvidia yet but I suspect that it also pulls 32-bit driver and that overwrites the 64-bit libGL.so.1. The fact that you did manage to install virtualbox before installing the driver seems to confirm this.

Re: mpg321, yes, we need to recompile mpg321. For the time being, just symlink libao.so.4 to libao.so.2 in /usr/lib64
Code:
ln -s /usr/lib64/libao.so.4 /usr/lib64/libao.so.2


gnomic, you have the choice of using either wpa_gui or network-wizard.

_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread
Back to top
View user's profile Send_private_message 
smokey01


Joined: 30 Dec 2006
Posts: 1857
Location: South Australia

PostPosted: Thu 26 Jul 2012, 17:21    Post_subject:  

jamesbond wrote:
smokey01,

Re: virtualbox - do you install nvidia driver using the available pet, or do you use getnvidia? I haven't tested getnvidia yet but I suspect that it also pulls 32-bit driver and that overwrites the 64-bit libGL.so.1. The fact that you did manage to install virtualbox before installing the driver seems to confirm this.

Re: mpg321, yes, we need to recompile mpg321. For the time being, just symlink libao.so.4 to libao.so.2 in /usr/lib64
Code:
ln -s /usr/lib64/libao.so.4 /usr/lib64/libao.so.2


I generally download the 64 bit nVidia driver directly from the site.

NVIDIA-Linux-x86_64-295.59.run

jamesbond wrote:
The fact that you did manage to install virtualbox before installing the driver seems to confirm this.


I agree but I'm not sure how this is happening.
nvidia.tar.gz
Description 
gz

 Download 
Filename  nvidia.tar.gz 
Filesize  1.07 KB 
Downloaded  143 Time(s) 

_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send_private_message Visit_website 
smokey01


Joined: 30 Dec 2006
Posts: 1857
Location: South Australia

PostPosted: Thu 26 Jul 2012, 17:32    Post_subject:  

In another Fatdog-600 frugal install video is working fine but VirtualBox won't work.

See attached screenies.

Mmm, a bit strange.
lib2.jpg
 Description   report-video says it working
 Filesize   39.29 KB
 Viewed   876 Time(s)

lib2.jpg

lib.jpg
 Description   It is 32 bit, not 64.
 Filesize   46.86 KB
 Viewed   845 Time(s)

lib.jpg


_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send_private_message Visit_website 
jamesbond

Joined: 26 Feb 2007
Posts: 2232
Location: The Blue Marble

PostPosted: Thu 26 Jul 2012, 22:12    Post_subject:  

smokey01 wrote:
I generally download the 64 bit nVidia driver directly from the site.

NVIDIA-Linux-x86_64-295.59.run

If you install the driver directly from source, it is imperative that you do not install the 32-bit compatibility library. The screenshot above (from a clean install, I suppose?) only confirms my suspicion - libGL.so.1 is now a 32-bit library instead of 64-bit.

_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread
Back to top
View user's profile Send_private_message 
smokey01


Joined: 30 Dec 2006
Posts: 1857
Location: South Australia

PostPosted: Fri 27 Jul 2012, 06:26    Post_subject:  

jamesbond wrote:
smokey01 wrote:
I generally download the 64 bit nVidia driver directly from the site.

NVIDIA-Linux-x86_64-295.59.run

If you install the driver directly from source, it is imperative that you do not install the 32-bit compatibility library. The screenshot above (from a clean install, I suppose?) only confirms my suspicion - libGL.so.1 is now a 32-bit library instead of 64-bit.


I'm not sure how you prevent 32-bit compatibility. When I run the script like:

sh NVIDIA-Linux-x86_64-295.59.run

The screen is quite messy and it's hard to follow the prompts. Previous attempts with 32-bit, not problems at all.

Anyway, I installed the nvidia-295.59-601.pet from the Fatdog Package Manager and it installed all the correct drivers. Then I installed VirtualBox that worked properly too.

What special things did you do to make the the pet?

Thanks

_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 13 of 23 Posts_count   Goto page: Previous 1, 2, 3, ..., 11, 12, 13, 14, 15, ..., 21, 22, 23 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0895s ][ Queries: 12 (0.0081s) ][ GZIP on ]