Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 28 Nov 2014, 08:37
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Touchpad Can't Tap (Solved)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [14 Posts]  
Author Message
johnywhy

Joined: 20 Aug 2011
Posts: 353

PostPosted: Tue 10 Jul 2012, 05:16    Post subject:  Touchpad Can't Tap (Solved)  

hi

i think i've seen as solution for this, but cannot find it.

tapping the touchpad does not work. enabling in flSynclient does not help. in fact, tapping was pre-enabled on this fresh lucid install. Disabling and then re-enabling does not help.

any ideas?

thanks!

_________________
asus X502C notebook pc

Last edited by johnywhy on Wed 11 Jul 2012, 11:22; edited 1 time in total
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 4055
Location: World_Hub

PostPosted: Tue 10 Jul 2012, 05:42    Post subject:  

Might be one'a these under- input device..
Code:
Option "MaxTapTime" "220"
Option "MaxTapMove" "220"
Back to top
View user's profile Send private message 
johnywhy

Joined: 20 Aug 2011
Posts: 353

PostPosted: Tue 10 Jul 2012, 07:01    Post subject:  

seems my xorg.conf already contains that. The current settings:

Quote:
Section "InputDevice"
Identifier "Synaptics Mouse"
Driver "synaptics"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "LeftEdge" "1700"
Option "RightEdge" "5300"
Option "TopEdge" "1700"
Option "BottomEdge" "4200"
Option "FingerLow" "25"
Option "FingerHigh" "30"
Option "MaxTapTime" "220"
Option "MaxTapMove" "220"
Option "VertScrollDelta" "100"
Option "MinSpeed" "0.10"
Option "MaxSpeed" "0.30"
Option "AccelFactor" "0.0030"
Option "SHMConfig" "on"
#Option "Repeater" "/dev/ps2mouse"
EndSection


so, i guess that's not it? thanks, tho'

_________________
asus X502C notebook pc
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 4055
Location: World_Hub

PostPosted: Tue 10 Jul 2012, 07:12    Post subject:  

Does your xorg log show any errors? Guessing- are your i2c modules loaded?
Back to top
View user's profile Send private message 
johnywhy

Joined: 20 Aug 2011
Posts: 353

PostPosted: Tue 10 Jul 2012, 07:23    Post subject:  

Not sure, have a look. Attached.

Quote:
sh-4.1# lsmod
Module Size Used by
i915 183740 2
drm_kms_helper 17823 1 i915
drm 106327 3 i915,drm_kms_helper
i2c_algo_bit 3539 1 i915
iptable_mangle 1189 0
iptable_nat 2666 0
nf_nat 10083 1 iptable_nat
ipt_REJECT 1485 1
nf_conntrack_ftp 4020 0
nf_conntrack_irc 2359 0
iptable_filter 958 1
xt_state 895 4
nf_conntrack_ipv4 7063 7 iptable_nat,nf_nat
nf_conntrack 36999 6 iptable_nat,nf_nat,nf_conntrack_ftp,nf_conntrack_irc,xt_state,nf_conntrack_ipv4
nf_defrag_ipv4 755 1 nf_conntrack_ipv4
ip_tables 7321 3 iptable_mangle,iptable_nat,iptable_filter
snd_hda_codec_realtek 165209 1
snd_hda_intel 14978 0
snd_hda_codec 38539 2 snd_hda_codec_realtek,snd_hda_intel
snd_pcm_oss 26845 0
snd_mixer_oss 9963 1 snd_pcm_oss
snd_pcm 45385 3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_page_alloc 4645 2 snd_hda_intel,snd_pcm
snd_seq_dummy 907 0
arc4 962 2
uvcvideo 44782 0
videodev 27339 1 uvcvideo
v4l1_compat 9930 2 uvcvideo,videodev
ecb 1377 2
snd_seq_oss 18888 0
snd_seq_midi 3156 0
snd_seq_midi_event 3592 2 snd_seq_oss,snd_seq_midi
snd_rawmidi 11924 1 snd_seq_midi
fan 2478 0
snd_seq 32379 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_seq_device 3601 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd_timer 11986 2 snd_pcm,snd_seq
atl1e 56234 0
snd 30859 11 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,.....
.....snd_seq_oss,snd_rawmidi,snd_seq,snd_seq_device,snd_timer
atl1c 21536 0
soundcore 3403 1 snd
ath9k 53765 0
led_class 1733 1 ath9k
ath9k_common 1629 1 ath9k
ath9k_hw 188147 2 ath9k,ath9k_common
ath 6106 2 ath9k,ath9k_hw
i2c_i801 6146 0
mac80211 99898 2 ath9k,ath9k_common
serio_raw 2928 0
i2c_core 11497 6 i915,drm_kms_helper,drm,i2c_algo_bit,videodev,i2c_i801
cfg80211 90319 4 ath9k,ath9k_common,ath,mac80211
pcspkr 1179 0
sg 19093 0
fbcon 27736 69
bitblit 3514 1 fbcon
softcursor 805 1 bitblit
tileblit 1509 1 fbcon
font 6916 1 fbcon
shpchp 21148 0
pci_hotplug 18286 1 shpchp
intel_agp 19189 1
agpgart 18904 2 drm,intel_agp
battery 7164 0
video 14642 1 i915
output 1120 1 video
thermal 9263 0
evdev 5517 1
ac 2143 0
button 3522 1 i915
processor 24987 2
fuse 42549 0
aufs 110466 1
nls_iso8859_1 2937 1
nls_cp437 4465 1
usb_storage 29717 0
usbhid 18009 0
squashfs 15984 1
uhci_hcd 15444 0
ehci_hcd 25830 0
usbcore 91279 6 uvcvideo,usb_storage,usbhid,uhci_hcd,ehci_hcd
sh-4.1#
xorglog.zip
Description 
zip

 Download 
Filename  xorglog.zip 
Filesize  10.65 KB 
Downloaded  102 Time(s) 

_________________
asus X502C notebook pc

Last edited by johnywhy on Wed 11 Jul 2012, 11:17; edited 1 time in total
Back to top
View user's profile Send private message 
ICPUG

Joined: 24 Jul 2005
Posts: 1290
Location: UK

PostPosted: Tue 10 Jul 2012, 12:59    Post subject:  

Please follow the instructions here (written for Slacko but maybe your parameters in lucid have got changed with fiddling)

http://www.murga-linux.com/puppy/viewtopic.php?p=578267#578267
Back to top
View user's profile Send private message 
johnywhy

Joined: 20 Aug 2011
Posts: 353

PostPosted: Tue 10 Jul 2012, 13:26    Post subject:  

You mean, enable tapping in flSynclient? As I mentioned in the op, "enabling in flSynclient does not help. tapping was pre-enabled on this fresh lucid install. Disabling and then re-enabling does not help."

Thanks, tho!

Not a hardware issue, since tapping works on other puppies.

Theoretically, deleting my pupsave should return me to factory fresh. Will try that. And then re-add everything I installed in this pup until I lose tapping again....

_________________
asus X502C notebook pc
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 4055
Location: World_Hub

PostPosted: Tue 10 Jul 2012, 20:38    Post subject:  

Johny.. I can't say'fer sure but, if it were me- I'd reinstall this.
Back to top
View user's profile Send private message 
johnywhy

Joined: 20 Aug 2011
Posts: 353

PostPosted: Tue 10 Jul 2012, 23:33    Post subject:  

Thanks, Semme. It's cool to learn about the touchpad daemon (or are those device drivers?). However, if that's part of the lucid sfs, then deleting my pupsave would accomplish the same, right? I mean, the lucid sfs never gets modified from it's original state, right?

Update: Duplicating this issue did not take much. I downloaded the latest Lupu installer, burned it to a USB flash drive with BootFlash, booted the usb drive, and got the "Personalize Puppy" window.

At that point, the touchpad could still tap.

Then I changed my timezone to Los Angeles GMT -8, and clicked "Yes" on "Restart X Server?". Then xWindows restarted.

At that point, the touchpad could NOT tap.

Does anyone else consider this a bug in lupu-528.005.iso?

Update: installed the udev version Semme linked above (of course, had to download the deb file, can't use apt-get on puppy). Rebooted. Checked flSyclient tap settings. Still no tappity-tap (that means, touchpad tapping still does not work). 

_________________
asus X502C notebook pc
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 4055
Location: World_Hub

PostPosted: Wed 11 Jul 2012, 07:06    Post subject:  

If there's a *load-touchpad-settings* executable with these lines in Startup:
Code:
#!/bin/bash
[ -s "$HOME/.flSynclient" ] || exit
grep -Ewq '(Elantech|Alps|Synaptics)' /proc/bus/input/devices || exit
flsynclient -s

I'd say add this to your xorg.conf.

Maybe a few clues starting here..
Back to top
View user's profile Send private message 
ICPUG

Joined: 24 Jul 2005
Posts: 1290
Location: UK

PostPosted: Wed 11 Jul 2012, 07:49    Post subject:  

johnywhy wrote:

Then I changed my timezone to Los Angeles GMT -8, and clicked "Yes" on "Restart X Server?". Then xWindows restarted.

At that point, the touchpad could NOT tap.

Does anyone else consider this a bug in lupu-528.005.iso?



Well - it is certainly a feature! Residents of LA are not allowed to tap!

I'll have to reset my timezone and see what happens.

When I install Lucid I reset my timezone (to Europe-London) during the first boot procedure. When I get a desktop I shutdown and create a save file. I now boot again and make any touchpad changes ( I usually have to enable horizontal scrolling if I remember correctly). Then it works.

I presume a reboot after you have changed your time zone does not help the situation?

By the way - I made my original suggestion because, with Slacko, I did not just have to re-enable tapping. Other settings had to be changed as well. From your words in the op I wondered if you had just toggled the disable/enable setting and not bothered with the other parameters I mentioned.

Do you make any changes to the video driver, screen resolution or do you let Puppy do its own thing?
Back to top
View user's profile Send private message 
johnywhy

Joined: 20 Aug 2011
Posts: 353

PostPosted: Wed 11 Jul 2012, 11:22    Post subject:  

i went back to those instructions and found the issue-- taptime was preset to 0. changing it to 225 fixed this issue.

i maintain, a preset taptime of 0 on a fresh lupu install is a bug, tho easily rectifiable if one knows how.

thanks!

_________________
asus X502C notebook pc
Back to top
View user's profile Send private message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11164
Location: Arizona USA

PostPosted: Wed 11 Jul 2012, 12:02    Post subject:  

johnywhy wrote:
i went back to those instructions ...
What instructions? What file contains the taptime settings and where is it? Confused
Back to top
View user's profile Send private message 
johnywhy

Joined: 20 Aug 2011
Posts: 353

PostPosted: Wed 11 Jul 2012, 12:09    Post subject:  

Please see here
http://www.murga-linux.com/puppy/viewtopic.php?p=639574#639574

_________________
asus X502C notebook pc
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [14 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0820s ][ Queries: 12 (0.0047s) ][ GZIP on ]