Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 23 Apr 2014, 17:17
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Geany 0.21 and GeanyVc in Saluki
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
mankand007

Joined: 12 Jul 2012
Posts: 13

PostPosted: Fri 13 Jul 2012, 13:47    Post subject:  Geany 0.21 and GeanyVc in Saluki  

Hi,

The installed Geany version in Saluki is 0.19. How do I upgrade it to 0.21, and how do i install geanyvc plugin?
Back to top
View user's profile Send private message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3860
Location: Kiel,Germany

PostPosted: Fri 13 Jul 2012, 13:53    Post subject:  

Just download the source and compile Razz

Geany 0.21 has a nice feature to remember the settings from the sub-windows like "search and replace" but it becomes a larger binary every new version . I have compiled it on racy/or saluki but without socket support so have not posted it here .

*

What is GeanyVc Plugin Question
Back to top
View user's profile Send private message Visit poster's website 
mankand007

Joined: 12 Jul 2012
Posts: 13

PostPosted: Fri 13 Jul 2012, 13:59    Post subject:  

Geanyvc is the version control plugin for geany.

I haven't compiled much. So a bit wary about screwing up my system.

Is it simple and straightforward to compile geany in Saluki?

Should i have devx installed?

Are there any other dependencies to mind?

I found both Geany 0.21 and geany-plugins from http://208.109.22.214/puppy/viewtopic.php?t=75864&sid=d895dad5b2f9b4dea139d2dfca6f179a.

Can I use them in Saluki?

[Edit]: Installed the above pets, but they require glibc 2.11. Saluki has only 2.10


Sorry for so many questions Very Happy
Back to top
View user's profile Send private message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3860
Location: Kiel,Germany

PostPosted: Fri 13 Jul 2012, 15:50    Post subject:  

mankand007 wrote:
Geanyvc is the version control plugin for geany.

I haven't compiled much. So a bit wary about screwing up my system.

Is it simple and straightforward to compile geany in Saluki?

Should i have devx installed?

Are there any other dependencies to mind?

I found both Geany 0.21 and geany-plugins from http://208.109.22.214/puppy/viewtopic.php?t=75864&sid=d895dad5b2f9b4dea139d2dfca6f179a.

Can I use them in Saluki?

[Edit]: Installed the above pets, but they require glibc 2.11. Saluki has only 2.10


Sorry for so many questions Very Happy


Because of the glibc version hassle i run Puppy 4 . I compile mostly myself now . Needs some time to get all the -dev packages for the headers or compile them too .

You need devx.sfs loaded/installed to compile.

Geany is usually a "nice source" that compiles without hassles .

Many apps that are offered as binary downloads from the official source homepages, not from distro homepages, are apparently compiled against "really old" glibc and gcc : Firefox-10, Opera-11, java-1.7.05 pre-compiled still run on my Puppy 4s installation . Multimedia might be different, at least for vlc .

I would try them out by extracting them in an optional folder which should create something like /opt/PKG_NAME/usr/bin/pkg_binary . Just open a terminal and see if
Code:
/opt/PKG_NAME/usr/bin/pkg_binary
runs .

For a beginner i am not really sure why you think you would need geanyvc then .

my plugins are
Code:
ls /usr/lib/geany |grep '\.so$'

classbuilder.so
export.so
filebrowser.so
htmlchars.so
saveactions.so
splitwindow.so

Plus vte via sakura terminal : sakura-2.4.2 + vte-0.28.2
Back to top
View user's profile Send private message Visit poster's website 
playdayz


Joined: 25 Apr 2008
Posts: 3788

PostPosted: Fri 13 Jul 2012, 16:29    Post subject:  

Quote:
Geany is usually a "nice source" that compiles without hassles .

I concur with that. I have compiled 0.21 for Lucid--it is in 5.2.8.005--but I did not compile any plugins (it seems to be using either the original plugins or default plugins). I will check if I did anything special, but as I recall it was straightforward. No, nothing special, which would make it
Code:
./configure --prefix=/usr

I am not the most meticulous compiler though Wink so I am not saying that is the best set of configure options/.

The plugins in Lucid are classbuilder, export, filebrowser, htmlchars, savereactions, and splitwindow.
Back to top
View user's profile Send private message 
Geoffrey


Joined: 30 May 2010
Posts: 1223
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Sat 14 Jul 2012, 00:06    Post subject:  

I've Compiled the latest Geany 1.22 and Plugins for Saluki here.

http://saluki-linux.com/Forum/viewtopic.php?f=4&t=337
Geoffrey

_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0554s ][ Queries: 11 (0.0033s) ][ GZIP on ]