Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 21 Oct 2014, 22:06
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
[Résolu] driver carte graphique
Moderators: Béèm, darkerror05
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
jopervasco

Joined: 25 Mar 2011
Posts: 291

PostPosted: Sat 14 Jul 2012, 15:32    Post_subject:  [Résolu] driver carte graphique  

Bonjour,
je lance un programme qui normalement ouvre une console plein écran et le message suivant apparait
Quote:
svgalib : Rage driver must be used, but not found.

j'ai installé le paquet svgalib 1.9.25 mais ça ne change rien

_________________
Slacko 5.3.3 vraiment sympa Smile

Edited_time_total
Back to top
View user's profile Send_private_message 
oui

Joined: 20 May 2005
Posts: 2096
Location: near Woof (Germany) :-) Acer Laptop emachines 2 GB RAM AMD64. franco-/germanophone, +/- anglophone

PostPosted: Sat 14 Jul 2012, 16:25    Post_subject:  

tu peux régler dans /etc/X11/xorg.conf un pilote de carte graphique. en fait, les linux modernes tentent d'abord de se suffir d'un pilote multivalent (par exemple xvesa). et si Xwindow apparait, ce qu'ils peuvent détecter, ils sont contents. si tu veux plus (accélération surtout), tu dois mettre la main à la pâte!

rage semble être une branche de la famille ATI. j'ai une carte ATI radeon sur mon portable, que je n'utilise pratiquement plus à cause de sa résolution médiocre, donc je perds l'expérience, mais c'est un vrai poison...

http://www.downloadsource.net/c114/VIA/

car il existe plusieurs pilotes ATI, et selon le linux, c'est l'un ou l'autre ou aucun qui fonctionne (le mieux, si plusieurs fonctionne, ce pour une seule et même machine!). c'est la même chose avec les cartes INTEL, mais avec les cartes ATI, c'est pire... avec un puppy c'est le pilote ati, avec l'autre radeon, dans certains linux, il fut appelé VIA, je ne sais pas s'il existe un pilote spécifique rage...

essaie de changer le réglage dans xorg.conf.

si écran bleu ou noir, repasse en mode caractère en appelant la console 2 ou la 3 (mais ce n'est pas toujours possible, car les gestionnaires de fenêtre, par exemple JWM, sont parfois réglés pour intercepter et donc interdire de telles manips. dans un tel cas, la seule solution pragmatique que je connaisse, est d'opter pour une autre version de puppy, cela va plus vite que de consacrer un temps fou à ruser avec un système rébarbatif!)

bonne chance...
Back to top
View user's profile Send_private_message 
Médor


Joined: 26 May 2011
Posts: 1733

PostPosted: Sat 14 Jul 2012, 18:01    Post_subject:  

Bonsoir,

Pour info, la description du paquet svgalib-bin (1:1.9.25-3) debian

Debian fr wrote:
Utilitaires d'affichage pour les consoles en SVGA

svgalib fournit des capacités graphiques aux programmes s'exécutant dans une console système, sans être sous X Window. Il utilise l'accès direct au matériel vidéo pour fournir un accès de bas niveau aux modes graphiques standards VGA et SVGA. Ne marche qu'avec certains matériels vidéo ; à utiliser avec précaution.


Pour une base Slackware 13.37 : svgalib-1.9.25-i486-2.txz
Voir la doc : /usr/doc/svgalib-1.9.25/* ainsi que les pages de man, notamment /usr/man/man7 :
svgalib.faq.7.gz, svgalib.chips.7.gz, ...

Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send_private_message 
jopervasco

Joined: 25 Mar 2011
Posts: 291

PostPosted: Sun 15 Jul 2012, 12:26    Post_subject:  

bonjour,
voila les infos que je peux vous donner..
Quote:
sh-4.1# report-video
fglrx
Slacko Puppy, version 5.3.3 on dim. 15 juil. 2012

Chip description:
5.0 VGA compatible controller
ATI Technologies Inc M880G [Mobility Radeon HD 4200] 0.0 VGA compatible controller
ATI Technologies Inc Manhattan [Mobility Radeon HD 5000 Series] (rev ff)
oem: ATI ATOMBIOS
product: RS880M 01.00

X Server: Xorg
Driver used: fglrx

X.Org version: 1.9.5
dimensions: 1366x768 pixels (361x203 millimeters)
depth of root window: 24 planes

...the above also recorded in /tmp/root/ as report-video,
and archived with xorg.conf and Xorg.0.log as report-video-full.gz
Back to top
View user's profile Send_private_message 
Médor


Joined: 26 May 2011
Posts: 1733

PostPosted: Sun 15 Jul 2012, 20:24    Post_subject:  

Bonsoir jopervasco,

Le fichier de configuration se trouve dans /etc/vga/libvga.config
D'origine, la puce graphique est auto-détectée :
Code:
# Chipset type:
#
# Use one of the following force chipset type.
#>>Autodetects if no chipset is specified.<<
#
#>>If you have a PCI or AGP card, don't use chipset type forcing.<<
# If the card is not autodetected, its a bug, and it will probably
# not work even with forcing. Try running vgatest (with no chipset
# line), and send to me (matan@svgalib.org) the output, a copy of
# /proc/pci (or lspci -n -vv) and whatever info you have on the card.
#
#>>If a chipset driver gives trouble, try forcing VGA.<<

# chipset VGA      # Standard VGA
# chipset EGA      # EGA
# chipset ET3000   # Tseng ET3000
# chipset ET4000   # Tseng ET4000
# chipset Cirrus   # Cirrus Logic GD542x/543x/544x
# chipset TVGA      # Trident TVGA8900/9000
# chipset Oak      # Oak Technologies 037/067/077
# chipset S3      # S3 chipsets
# chipset GVGA6400   # Genoa 6400
# chipset ARK      # ARK Logic
# chipset ATI      # old ATI VGA
# chipset Mach32   # ATI Mach32
# chipset ALI      # ALI2301
# chipset Mach64   # ATI Mach64 - deprecated, use RAGE driver
# chipset ET6000        # Tseng ET6000
# chipset APM       # Alliance Technology AT 24/25/3D
# chipset NV3      # nVidia Riva 128
# chipset VESA          # nicely behaved Vesa Bioses
# chipset MX      # MX86251 (some Voodoo Rush boards)
# chipset PARADISE    # WD90C31
# chipset RAGE      # RagePro (and might work with some older mach64)
# chipset BANSHEE   # Banshee/V3.
# chipset SIS      # SiS 5597/6326/620/530 cards / integrated vga.
# chipset I740      # Intel i740 based cards.
# chipset NEOMAGIC
# chipset LAGUNA   # Cirrus Logic Laguna series (546X)
# chipset FBDEV      # Use kernel fbdev, instead of direct hardware.
# chipset G400      # Matrox Mystique/G100/G200/G400/G450
#>>chipset R128   # Ati Rage128 and Radeon<<
# chipset SAVAGE   # S3 chipsets Savage, Virge, and some Trio64
# chipset MILLENNIUM   # Matrox Millennium and Millennium II
# chipset I810      # Intel i810/815 integrated video
# chipset TRIDENT               # Trident PCI and AGP chipsets
# chipset RENDITION   # Rendition V2100/V2200
# chipset G450C2
# chipset C&T           # Chips and Technologies
# chipset PM2
# chipset UNICHROME

Donc cette puce Radeon ne semble pas être correctement supportée (svgalib : Rage driver must be used, but not found.)
Reste à tester (en mode console, sans X) en forçant avec : chipset VGA, en enlevant le '#' en début de ligne.


Cordialement,
Médor.

_________________
Recherches Puppy|Index Puppy|Index FR|Tuto Toutou
Back to top
View user's profile Send_private_message 
jopervasco

Joined: 25 Mar 2011
Posts: 291

PostPosted: Mon 16 Jul 2012, 02:38    Post_subject:  

Bonjour,
merci ça semble fonctionner correctement.
en mettant
Quote:
"chipset VGA # Standard VGA"
alors un grand merci.
_________________
Slacko 5.3.3 vraiment sympa Smile
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars ) » Pour les francophones
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0735s ][ Queries: 11 (0.0139s) ][ GZIP on ]