Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 24 Nov 2014, 20:47
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
Canon Printer Drivers - Updated 2014
Post new topic   Reply to topic View previous topic :: View next topic
Page 13 of 14 [196 Posts]   Goto page: Previous 1, 2, 3, ..., 11, 12, 13, 14 Next
Author Message
rcrsn51


Joined: 05 Sep 2006
Posts: 9260
Location: Stratford, Ontario

PostPosted: Sun 10 Aug 2014, 20:07    Post subject:  

I have posted a link to an MX510 printer driver here. Click the small grey Download button on the left.

If your remote user can install it successfully, we can look at the scanner driver.
Back to top
View user's profile Send private message 
prnt_prbl

Joined: 10 Aug 2014
Posts: 10

PostPosted: Sun 10 Aug 2014, 20:56    Post subject:  

Thx a lot man. I must have overlooked that post, I thought I went over all 12 pages in your thread Embarassed

I will email this file to the user and we will see tomorrow if it works.
The PET installs like any other PET? Just click and it will place drivers in the correct place? And then the printer will show up?

Or is it first to run the PET and then run the CUPS /localhost/631 and go to the administration part?

And just to be sure, the printer must be turned on before starting the install, yes?

Thx for this great thread. I will post link in my thread to your download if that is ok.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9260
Location: Stratford, Ontario

PostPosted: Sun 10 Aug 2014, 20:59    Post subject:  

prnt_prbl wrote:
Thx a lot man. I must have overlooked that post, I thought I went over all 12 pages in your thread

I just made it.

Quote:
The PET installs like any other PET? Just click and it will place drivers in the correct place?

Yes.
Quote:
And then the printer will show up?

No.

Quote:
Or is it first to run the PET and then run the CUPS /localhost/631 and go to the administration part?

Yes. Is the printer local USB or networked?

Quote:
And just to be sure, the printer must be turned on before starting the install, yes?

Yes.
Back to top
View user's profile Send private message 
prnt_prbl

Joined: 10 Aug 2014
Posts: 10

PostPosted: Sun 10 Aug 2014, 21:25    Post subject:  

The printer is a network printer, wlan. Apparently it shows up on the network for windows 8 users. But not for the Puppy precise 5.7.1 user.

So the CUPS interface will detect the printer and the printer will show up
if clicked ctrl + p ie on a website?
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9260
Location: Stratford, Ontario

PostPosted: Sun 10 Aug 2014, 21:49    Post subject:  

prnt_prbl wrote:
But not for the Puppy precise 5.7.1 user.

Is this before or after you have installed the driver and done a CUPS install?
Back to top
View user's profile Send private message 
prnt_prbl

Joined: 10 Aug 2014
Posts: 10

PostPosted: Sun 10 Aug 2014, 23:21    Post subject:  

rcrsn51 wrote:
prnt_prbl wrote:
But not for the Puppy precise 5.7.1 user.

Is this before or after you have installed the driver and done a CUPS install?



This was before install. I will give my "phone support" again tomorrow and I am sure things will work out.

I'll just try first the PET install and then run the CUPS again.


Btw. It seems some of the wizards remove all files in the print directory.

I'll post here tomorrow to tell how things worked.
Back to top
View user's profile Send private message 
prnt_prbl

Joined: 10 Aug 2014
Posts: 10

PostPosted: Mon 11 Aug 2014, 09:07    Post subject:  

Seems there is some small problems getting this to work.
Clicking the PET puts the drivers in /usr/share/cups/model/canonmx510.ppd

Then when I have them click Setup>Setup Cups Printing the printer can not be detected. The printer does however return Ping on 10.0.0.2.

Is there a way to manually add the printer IP to CUPS?
Can I alter the cups config or in any other way manually tell CUPS where to look for printer?
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9260
Location: Stratford, Ontario

PostPosted: Mon 11 Aug 2014, 09:32    Post subject:  

Do they have a firewall running?

[Edit] They will also need the canon_net_backend-3.90.pet from Page 1.

If that still doesn't work, I will need to rebuild the MX510 package.
Back to top
View user's profile Send private message 
prnt_prbl

Joined: 10 Aug 2014
Posts: 10

PostPosted: Mon 11 Aug 2014, 09:58    Post subject:  

Sure thing. Manual setup of firewall fixed it all.

Thx a lot for great and quick response. Now it is working like a charm.

Time to try the scanner as well, feeling lucky now Very Happy
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9260
Location: Stratford, Ontario

PostPosted: Mon 11 Aug 2014, 10:19    Post subject:  

Quote:
Clicking the PET puts the drivers in /usr/share/cups/model/canonmx510.ppd

The PPD is just a text configuration file. The driver code is elsewhere, like in /usr/lib.

I have posted the scanner PETS here.
Back to top
View user's profile Send private message 
prnt_prbl

Joined: 10 Aug 2014
Posts: 10

PostPosted: Mon 11 Aug 2014, 13:52    Post subject:  

Thx man, will do the scanner tomorrow.
Great work man. Smile
Back to top
View user's profile Send private message 
Dromeno

Joined: 12 Sep 2008
Posts: 538

PostPosted: Fri 22 Aug 2014, 02:54    Post subject: Canon Pixma MG 4250 (4200 series) request
Subject description: for Lucid Puppy 528
 

I hope somebody can help me out with this one.

According to the sane project the Canon MG 4250 should be able to work under Xsane:

http://www.sane-project.org/sane-backends.html#S-PIXMA

unfortunately it is not. Perhaps an udate is required for pixma_backend_5xx-1.0.23.pet because sane-backends is at version sane-backends-1.0.24

The other option would be to get the scanner working under scangear. But this one also needs updating, I can find the 1.40 version at this forum
scangearmp_common-1.40.pet but it appears the 2.00 version is needed.

I tried to install the Ubuntu .debs in Lucid Puppy as well as Carolina but it did not work out

http://robert.penz.name/532/a-howto-for-using-a-canon-pixma-mg4250-under-ubuntu/

http://www.canon.nl/Support/Consumer_Products/products/Fax__Multifunctionals/InkJet/PIXMA_MG_series/pixma_mg4250.aspx?type=download&softwaredetailid=tcm:16-994783&os=&language=

I am currently out of options... any help would be greatly appreciated!
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9260
Location: Stratford, Ontario

PostPosted: Fri 22 Aug 2014, 05:19    Post subject:  

Go back to the Canon scanner driver thread and read the paragraph at the top of the main post, specifically about candi.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9260
Location: Stratford, Ontario

PostPosted: Sat 23 Aug 2014, 04:46    Post subject:  

No reply? That's too bad. I was looking for someone to test the Canon pixma driver in SANE v1.0.24.
Back to top
View user's profile Send private message 
Dromeno

Joined: 12 Sep 2008
Posts: 538

PostPosted: Sat 23 Aug 2014, 05:25    Post subject: candi damages 2fs?
Subject description: drops out of x
 

Hi rcrsn51,

Yes I want to test it! The candi option did not work yet. I installed candi 1.3 pet and then

cnijfilter-common_3.80-1_i386.deb
cnijfilter-mg4200series_3.80-1_i386.deb
scangearmp-common_2.00-1_i386.deb
scangearmp-mg4200series_2.00-1_i386.deb

all via the terminal candi ... option as advised.

They all installed in lucid puppy 528 but after tat puppy would not boot anymore (dropped out of X after reboot). I was not succesfull with xorgwizard either. Sad Fortunately I have a backup of the 2fs from which I am posting now.

what can I now do?
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 13 of 14 [196 Posts]   Goto page: Previous 1, 2, 3, ..., 11, 12, 13, 14 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0782s ][ Queries: 12 (0.0083s) ][ GZIP on ]