Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 30 Oct 2014, 09:03
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects » Localization Project
official (momanager) language packs
Moderators: Lobster, MU, raffy
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 14 [196 Posts]   Goto page: Previous 1, 2, 3, 4, ..., 12, 13, 14 Next
Author Message
Bert


Joined: 30 Jun 2006
Posts: 954

PostPosted: Tue 14 May 2013, 07:52    Post subject:  

L18L wrote:
Bert wrote:

So you are waited hand and foot Laughing

http://www.redensarten-index.de/suche.php?suchbegriff=~~Hand%20und%20Fuss%20haben&suchspalte[]=rart_ou
Sorry, German only Embarassed

Nice image Arrow momanager's logo Smile


Haha, just for fun I typed 'momanager' in search engine>images and was surprised something came up. I didn't even look at the origin of this great image. Now I did: Momager.nl, an artists booking agency.

Aber Herr L18L, deine Unternehmung hat Hand und Fuß - ich mache mit! Smile

Dict.cc looks good! Seems to be more complete in German than in Dutch though.

Bleib Pate stehen bitte ... Laughing

_________________


Back to top
View user's profile Send private message 
rodin.s

Joined: 22 Sep 2010
Posts: 338
Location: Ukraine

PostPosted: Sat 18 May 2013, 14:57    Post subject: fast momanager bug  

Fast MoManager has some bug when entry moves from the right dropdown list to the left one. I guess when this move takes place MoManager should be updated. MoManager shouldn't be updated when entry from left dropdown list is edited.
Back to top
View user's profile Send private message 
Bert


Joined: 30 Jun 2006
Posts: 954

PostPosted: Sat 18 May 2013, 15:12    Post subject: Re: fast momanager bug  

rodin.s wrote:
Fast MoManager has some bug when entry moves from the right dropdown list to the left one. I guess when this move takes place MoManager should be updated. MoManager shouldn't be updated when entry from left dropdown list is edited.


I'm glad you brought this up. I thought it was me, not really knowing what I'm doing, causing this instability.

I usually close Momanager when this happens. Restarting it after rebooting the X server doesn't seem to help. A complete reboot is needed.

In my case about 2/3 of the top-selection box (the long list) on the right side suddenly moves to the left.

The opposite also happens: three or four items going back from left to right in the Appinfo selection box. Opening one of them for editing, editing and then closing it, all four items are back to the left side of Momanager.

Shocked Smile

EDIT 19-05 After rereading rodin s.'s post I now realise he is talking about a different bug...maybe related to what I'm experiencing?
What I describe above is definetely abnormal behaviour, not caused by something I did wrong, as far as I can see. (fresh install)

But apologies to rodin s. for taking the focus away from his report.

_________________


Back to top
View user's profile Send private message 
L18L

Joined: 19 Jun 2010
Posts: 2530
Location: Moved from Hosla to www.eussenheim.de

PostPosted: Sun 19 May 2013, 08:21    Post subject: fast momanager
Subject description: bug fix
 

Thank you both reports are useful.

It was me who made the mistake.
I did not notice because I had not much at the right side.
It had used the wrong variable.

#130519 L18L bug fix: instead of APKGNAME use ASCRIPT, DESKFILE, XMLFILE, ABIN; code for sss and menu categories unchanged

I have tested: now only 1 (the right one) is moved from right to left.

This is at the beginning of the left list which is in my experience very useful because you do not need to search it in the long list when you want to edit it.

The lists are only updated (entry moved from right to left) when "create" button was used.

Content of entire directory /tmp/momanager is deleted when you restart momanager (2 minutes or more wait.....), no need for restart X or reboot.....

----

edit 20130520
deleted attachment (downloaded 7 times)
bug fixed version 20130520 5 posts down

Last edited by L18L on Mon 20 May 2013, 05:23; edited 1 time in total
Back to top
View user's profile Send private message 
Bert


Joined: 30 Jun 2006
Posts: 954

PostPosted: Sun 19 May 2013, 10:33    Post subject:  

Wow, that was fast! Special Sunday Service Very Happy

Proudly running momanager 20130529...the first script ever to arrive from the future Laughing

A question I need to ask for peace of mind: yesterday I translated Pfind.

Pfind has 5 entries in momanager:

* Pfind/box_yesno
* Pfind/func
* Pfind/func_filter
* Pfind/func_openwith
* Pfind/pfind

I translated the first one, box_yesno and saved.

Now all 5 of them are in the left column in momanager. And the translated Pfind is looking good, running pfine...

I opened an other (than box_yesno) file and the content is the same as box_yesno.

Is this default behaviour (and okay for pfind) or also a result of the former momanager version?

Thanks in advance!

_________________


Back to top
View user's profile Send private message 
rodin.s

Joined: 22 Sep 2010
Posts: 338
Location: Ukraine

PostPosted: Sun 19 May 2013, 11:28    Post subject:  

If several scripts have same textdomain, then one common po-file is used for all of them. So it doesn't matter which one of them to choose.
Now I am going to test new MoManager.
Back to top
View user's profile Send private message 
Bert


Joined: 30 Jun 2006
Posts: 954

PostPosted: Sun 19 May 2013, 15:18    Post subject:  

rodin.s wrote:
If several scripts have same textdomain, then one common po-file is used for all of them. So it doesn't matter which one of them to choose.
Now I am going to test new MoManager.


Understood Idea

Thanks for your help!

_________________


Back to top
View user's profile Send private message 
L18L

Joined: 19 Jun 2010
Posts: 2530
Location: Moved from Hosla to www.eussenheim.de

PostPosted: Mon 20 May 2013, 03:55    Post subject: fast momanager
Subject description: multiple scripts for 1 TEXTDOMAIN
 

rodin.s wrote:
If several scripts have same textdomain, then one common po-file is used for all of them. So it doesn't matter which one of them to choose.
Now I am going to test new MoManager.

current momanager does not update correctly these.
I am working on it now ( Arrow xEXTRASCRIPTS )
Special Monday service Laughing
Back to top
View user's profile Send private message 
L18L

Joined: 19 Jun 2010
Posts: 2530
Location: Moved from Hosla to www.eussenheim.de

PostPosted: Mon 20 May 2013, 05:09    Post subject: fast momanager
Subject description: bug fix: multiple scripts for 1 TEXTDOMAIN
 

L18L wrote:
...I am working on it now...

... done 130520
Code:
    #no_to_yes $CACHE/NOMO_XML "${ASCRIPT}" $CACHE/YESMO_XML  # update YESMO_XML NOMO_XML #130519
    SCRIPTS="`cat /tmp/momanager/xEXTRASCRIPTS | rev | cut -d'.' -f2- | rev`" #130520
    no_to_yes $CACHE/NOMO_XML "${SCRIPTS}" $CACHE/YESMO_XML  # update YESMO_XML NOMO_XML #130520


xEXTRASCRIPTS are used Instead of ASCRIPT.
xEXTRASCRIPTS always exists even there is one script only.
.sh has to be cut off of the script names xEXTRASCRIPTS

fast momanager-20130520 will be uploaded soon.... [edit] ...done Smile

------
edit
forget this
take next one Laughing

[edit] attachment deleted
use momanager-20130522 at
http://murga-linux.com/puppy/viewtopic.php?t=81259&start=31 please

[edit]use momanager-20130609 at
http://murga-linux.com/puppy/viewtopic.php?t=81259&start=85

Last edited by L18L on Sun 09 Jun 2013, 08:25; edited 3 times in total
Back to top
View user's profile Send private message 
L18L

Joined: 19 Jun 2010
Posts: 2530
Location: Moved from Hosla to www.eussenheim.de

PostPosted: Mon 20 May 2013, 13:11    Post subject: fast momanager
Subject description: another bug fix
 

Bert wrote:
...Proudly running momanager 20130529...the first script ever to arrive from the future Laughing


... and here comes the second script from the future (tomorrow):

fast momanager-20130521 can handle create and edit of the created pot from binary now..... (pretty cryptic)

Entry in left list is different from entry in right list, so it had to be changed by sed:
Code:
   sed -i "s#(${ANAME}#(${TRANSLANG} ${AMO}#" $CACHE/YESBIN_XML #130521


[edit] attachment deleted
use momanager-20130522 at
http://murga-linux.com/puppy/viewtopic.php?t=81259&start=31 please

[another edit] or better:
http://www.murga-linux.com/puppy/viewtopic.php?t=81259&start=50
edit
or simply use newer momanager.pet: http://www.murga-linux.com/puppy/viewtopic.php?t=81259&start=57

edit
or simply use newer momanager.pet: http://www.murga-linux.com/puppy/viewtopic.php?t=81259&start=85

Last edited by L18L on Sun 09 Jun 2013, 08:27; edited 5 times in total
Back to top
View user's profile Send private message 
Bert


Joined: 30 Jun 2006
Posts: 954

PostPosted: Mon 20 May 2013, 14:56    Post subject: Re: fast momanager
Subject description: another bug fix
 

Replying quickly, before it's tomorrow... Smile

Running 20130521 now, no visible changes, I play with it some more tonight.

L18L wrote:

.... (pretty cryptic)

Yes Confused

But I do hope it can help in this situation, which happens too often:



Imagine "WOOF1.po" being empty window...and "WOOF.po" non-existant..

grrr.

Also this is re-occuring: translated XML files showing up on the right side again. Always the same four. As soon as one is edited, all four are on the left side again:


Today I translated petget. Of the nine petget entries only one is showing up translated ('configure' the one I translated first.)
No errors, no warnings in Poedit.
I checked several of the petget.po's in terminal (msgfmt), again no errors. Put the created .mo's in LC_MESSAGES, no difference.

Hope this can be useful.

_________________


Back to top
View user's profile Send private message 
L18L

Joined: 19 Jun 2010
Posts: 2530
Location: Moved from Hosla to www.eussenheim.de

PostPosted: Tue 21 May 2013, 04:03    Post subject: Re: fast momanager
Subject description: another bug fix
 

Thank you Bert, comments are always helpful.
Bert wrote:
...Imagine "WOOF1.po" being empty window...and "WOOF.po" non-existant..

That is correct: there is no script named WOOF or TEXTDOMAIN=WOOF
Where does this happen?
Edit
script
menu category
menu entry
XML file ?

I am going to check XML files now...
Back to top
View user's profile Send private message 
L18L

Joined: 19 Jun 2010
Posts: 2530
Location: Moved from Hosla to www.eussenheim.de

PostPosted: Tue 21 May 2013, 05:31    Post subject: Re: fast momanager
Subject description: another bug fix
 

L18L wrote:
...I am going to check XML files now...

found it Laughing
find line
echo $NOXML_XML > $CACHE/NOXML_XML #130505
and change it to:
#echo $NOXML_XML > $CACHE/NOXML_XML #130505
echo -n "$NOXML_XML" > $CACHE/NOXML_XML #130522

thus every XML file has its own single line
and only the one which has been created is correctly moved to the list on the left side.



edit

or simply use new momanager.pet: http://www.murga-linux.com/puppy/viewtopic.php?t=81259&start=50
edit
or simply use newer momanager.pet: http://www.murga-linux.com/puppy/viewtopic.php?t=81259&start=57
edit
or simply use newer momanager.pet: http://www.murga-linux.com/puppy/viewtopic.php?t=81259&start=85

Last edited by L18L on Sun 09 Jun 2013, 08:28; edited 3 times in total
Back to top
View user's profile Send private message 
Bert


Joined: 30 Jun 2006
Posts: 954

PostPosted: Tue 21 May 2013, 05:44    Post subject:  

Hi L18L,

It happened while trying to open and edit a file in left column, scripts.("scripts that have a mo file"). (and happens all the time)

I have now discovered what happened while translating petget:

I was happily translating away the petget entries, moving one after the other to the left side. After having translated about 9 entries, I opened the right dropdown again, to start the next one. Only to discover there were no petget entries left in the right side list!

With my newly acquired knowledge (thanks Sergey) I concluded the entries that disappeared must have all had the same text domain as the last one I translated.

But...after I installed Momanager-20130521 and checked the right side scripts dropbox, there were 7 petget items waiting for translation!

I think that clearly shows there's a bug...

_________________


Back to top
View user's profile Send private message 
Bert


Joined: 30 Jun 2006
Posts: 954

PostPosted: Tue 21 May 2013, 06:08    Post subject:  

Yes! You found it. Congrats!

(...and I found the search function in Geany Wink )

I did the change you proposed with Momanager closed. Then opened it again and edited the first of the four entries. It moved to the left, without taking the others with it, great!
After editing them all, I closed and restarted momanager: only 1 item returned to the right side xml box: AppInfo.xml (build_gettext-plus-0.5)

Maybe because that is not a default puppy app..?

_________________


Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 14 [196 Posts]   Goto page: Previous 1, 2, 3, 4, ..., 12, 13, 14 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects » Localization Project
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1017s ][ Queries: 12 (0.0111s) ][ GZIP on ]