Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 27 Aug 2014, 19:17
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
How to use MicroSD card? (Solved)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [4 Posts]  
Author Message
squareballer

Joined: 16 Oct 2012
Posts: 2

PostPosted: Tue 16 Oct 2012, 17:52    Post subject:  How to use MicroSD card? (Solved)
Subject description: Puppy doesn't seem to be able to see it
 

After a few failed attempts to burn a Puppy image to my MicroSD card using various tools on Windows 7, I remembered that I can do this from a Puppy live CD. So I format the MicroSD card, boot up a Puppy live CD, and I attempt to use both the Puppy Universal Installer and the Puppy to USB tool (I forget exactly what it's called).

Unfortunately, neither program can detect my MicroSD card Sad I tried all the options including USB and such but it keeps saying there's no device present. My MicroSD card is in the USB card reader it came with. It seems that Puppy can't see it at all, as it sees the CD drive and my hard drive but nothing else. What could cause this? Am I missing a driver or something?

Thanks for helping.
Back to top
View user's profile Send private message 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11024
Location: Arizona USA

PostPosted: Tue 16 Oct 2012, 21:13    Post subject:  

You say you formatted the micro SD card. Did you actually put a filesystem on it? Linux only sees filesystems, not empty devices.

To format it with a filesystem in Puppy, use System -> Gparted partition manager. Format it ext2 or 3 if you intend to install Puppy on it. You can even partition it with Gparted, then format one partition ext2, for Puppy, and the other partition NTFS or FAT32 so it can be used by both Puppy and Windows. However, if you do that it might complicate getting Puppy to boot from the micro SD card.
Back to top
View user's profile Send private message 
squareballer

Joined: 16 Oct 2012
Posts: 2

PostPosted: Wed 17 Oct 2012, 00:27    Post subject: Fixed it  

I got it working; it was the USB port. Apparently, only one of my USB ports works when I am in Linux. Thanks for the filesystem info, I changed it from FAT32 to Ext2 before I ran the installer and now it works fine.
Back to top
View user's profile Send private message 
greengeek

Joined: 20 Jul 2010
Posts: 2493
Location: New Zealand

PostPosted: Wed 17 Oct 2012, 04:19    Post subject:  

What hardware are you running on? How many usb ports does it have? Also, if you have time, is there any chance of testing the non-functional port by adding a usb hub of some sort between the bad port and the SD adapter? I'm interested to know if that makes any difference at all.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [4 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0503s ][ Queries: 11 (0.0103s) ][ GZIP on ]