Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 00:20
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Audio
Can't adjust headphone volume [SOLVED]
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
sheldonisaac

Joined: 21 Jun 2009
Posts: 425
Location: Philadelphia, PA

PostPosted: Wed 24 Oct 2012, 09:38    Post_subject:  Can't adjust headphone volume [SOLVED]  

I got a used Dell D610 Latitude laptop some months ago.

Primarily I use Lucid Puppy 5.2.8-005.

Yesterday I plugged in headphones, and find that I can't adjust the volume in Pmusic.

Please let me know how to fix it, or where to ask.

(Previously I'd used only the built-in speakers, and the volume adjusting worked OK.)



Thanks,

Sheldon

Edited_times_total
Back to top
View user's profile Send_private_message 
musher0


Joined: 04 Jan 2009
Posts: 4257
Location: Gatineau (Qc), Canada

PostPosted: Wed 24 Oct 2012, 11:59    Post_subject:  

Hello, sheldon.

Have you tried controlling the volume with the mixer app in the tray instead of with pmusic?

You should have a loudspeaker icon in your tray. (See attached picture.) Left-click on it and a slide bar will appear. You can then modulate the volume by clicking on a particular level on the slide bar.

I hope this helps.
slidebar-mixer.jpg
 Description   
 Filesize   6.13 KB
 Viewed   788 Time(s)

slidebar-mixer.jpg


_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send_private_message Visit_website 
sheldonisaac

Joined: 21 Jun 2009
Posts: 425
Location: Philadelphia, PA

PostPosted: Wed 24 Oct 2012, 14:02    Post_subject:  

musher0 wrote:
Hello, sheldon.

Have you tried controlling the volume with the mixer app in the tray instead of with pmusic?
Yes, thank you, musher0 - it has no effect; I think the headphones are at the highest volume?

However, if I right-click, I can choose "Full Window" and get a Retrovol with lots of sliders, including headphone.

Quote:

You should have a loudspeaker icon in your tray. (See attached picture.) Left-click on it and a slide bar will appear. You can then modulate the volume by clicking on a particular level on the slide bar.

I hope this helps.

That has always worked fine for the built-in speakers.

I will try the same software on a 'desktop' computer, to see whether this hardware has something to do with the problem.

I posted a new question, out of concern that adding to another thread mught be considered wrong.

If there is somewhere else to ask, I'll be glad to try.

Thanks,

Sheldon
Back to top
View user's profile Send_private_message 
musher0


Joined: 04 Jan 2009
Posts: 4257
Location: Gatineau (Qc), Canada

PostPosted: Thu 25 Oct 2012, 00:19    Post_subject:  

Hi, Sheldon.

Hum.. I once had a problem on dpup 4.84 with sgmixer. It's a very complete mixer, but every once and a while, using it, for some reason, made the "mixer" device at /dev/mixer disappear, and I'd have to recopy it from /initrd/pup_ro2/dev/mixer.

Of course, if you don't have a mixer device available, you can't have sound.
Maybe check if a "mixer" device exists in your /dev directory?

Let us know. BFN.

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send_private_message Visit_website 
CatDude


Joined: 03 Jan 2007
Posts: 1485
Location: UK

PostPosted: Thu 25 Oct 2012, 08:57    Post_subject:  

Hello sheldonisaac

sheldonisaac wrote:

However, if I right-click, I can choose "Full Window" and get a Retrovol with lots of sliders, including headphone.

Have you tried increasing the PCM level in retrovol ?
That effects the volume in pmusic and the browser here.

Catdude
.

_________________

Back to top
View user's profile Send_private_message 
sheldonisaac

Joined: 21 Jun 2009
Posts: 425
Location: Philadelphia, PA

PostPosted: Thu 25 Oct 2012, 09:10    Post_subject:  

musher0 wrote:
Hi, Sheldon.

Hum.. I once had a problem on dpup 4.84 with sgmixer. It's a very complete mixer, but every once and a while, using it, for some reason, made the "mixer" device at /dev/mixer disappear, and I'd have to recopy it from /initrd/pup_ro2/dev/mixer.

Of course, if you don't have a mixer device available, you can't have sound.
Maybe check if a "mixer" device exists in your /dev directory?

Let us know. BFN.


Seems to be there?

Code:
crw-rw-rw- 1 root root 14, 11 2005-02-27 16:07 /dev/amixer
crw-rw---- 1 root root 14,  0 2012-10-25 07:27 /dev/mixer
crw-rw---- 1 root root 14, 16 2012-04-04 07:11 /dev/mixer1
crw-rw---- 1 root root 14, 32 2012-04-04 07:11 /dev/mixer2
Back to top
View user's profile Send_private_message 
sheldonisaac

Joined: 21 Jun 2009
Posts: 425
Location: Philadelphia, PA

PostPosted: Thu 25 Oct 2012, 09:35    Post_subject:  

CatDude wrote:
Hello sheldonisaac

sheldonisaac wrote:

However, if I right-click, I can choose "Full Window" and get a Retrovol with lots of sliders, including headphone.

Have you tried increasing the PCM level in retrovol ?
That effects the volume in pmusic and the browser here.
.


Catdude, the PCM in Retrovol is at maximum.
Neither the slider in Pmusic or the "regular" volume control (little speaker icon at bottom of screen) can change the headphone volume.

As I said, those controls do work if the headphone is not plugged in, ie they control the volume of the computer's speakers.

Thanks,
Sheldon
Back to top
View user's profile Send_private_message 
greengeek

Joined: 20 Jul 2010
Posts: 2596
Location: New Zealand

PostPosted: Thu 25 Oct 2012, 13:36    Post_subject:  

sheldonisaac wrote:
However, if I right-click, I can choose "Full Window" and get a Retrovol with lots of sliders, including headphone.

Did that headphone slider have any effect on the headphone volume? And is the problem excessive volume, or insufficient volume?
Back to top
View user's profile Send_private_message 
sheldonisaac

Joined: 21 Jun 2009
Posts: 425
Location: Philadelphia, PA

PostPosted: Thu 25 Oct 2012, 17:05    Post_subject:  

greengeek wrote:
sheldonisaac wrote:
However, if I right-click, I can choose "Full Window" and get a Retrovol with lots of sliders, including headphone.

Did that headphone slider have any effect on the headphone volume? And is the problem excessive volume, or insufficient volume?

Yes, greengeek, thank you.
In the Retrovol window, both the PCM slider and the headphone slider can make the headphone volume louder or quieter.

The problem was excessive volume and the inability to control.
I can use the PCM or the headphone slider to set the headphone volume to an acceptable level, but am still unable to use the "regular" volume control, or the Pmusic slider. I see now that hovering over the latter says "Speaker channel: Master".

Just tried to right-click an mp3 file, and chose "Play with Gnome-mplayer"
The volume control in that software does work.
----------------

EDIT: Oops. Blush.

In Pmusic preferences, one can set the "Speaker channel" to several different things. I set it to PCM.
Now Pmusic's volume slider works to control loudness of headphones.

Maybe I should have asked in the Pmusic thread.

Thanks a lot, everyone.

Sheldon
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Audio
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0723s ][ Queries: 12 (0.0075s) ][ GZIP on ]