Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 22 Dec 2014, 06:05
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Older Puppies and glib 2.8 ...
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
paulh177


Joined: 22 Aug 2006
Posts: 875
Location: ST862228

PostPosted: Sat 10 Nov 2012, 06:52    Post_subject:  Older Puppies and glib 2.8 ...  

Opera 12.10 has just been released and I can't use it on my Puppy 4.31 netbook as it requires glib 2.8.

on the other hand, I haven't been able to get any of the 5.x Puppies to run satisfactorily on my netbook (an older Acer AOA).

Am I correct in thinking that it would be extremely difficult (if not nearly impossible) to replace glib with 2.8 on my 4.31 Puppy?

_________________
Want to report a bug or problem? Have a read of this first ...
Back to top
View user's profile Send_private_message 
puppyluvr


Joined: 06 Jan 2008
Posts: 3229
Location: Chickasha Oklahoma

PostPosted: Sat 10 Nov 2012, 20:38    Post_subject:  

Very Happy Hello,
Yea, I tried to update glib once...
Shame as it killed my puppy...
Glib is deeply integrated..
Have you tried 214x?
You could, I suppose, try to woof up a 4 series pup with glib2.8..
IDK...

_________________
Close the Windows, and open your eyes, to a whole new world
http://puppylinuxstuff.meownplanet.net/puppyluvr/
Puppy Linux Users Group on Facebook

Puppy since 2.15CE...
Back to top
View user's profile Send_private_message Visit_website 
Dewbie

Joined: 15 Apr 2010
Posts: 1783

PostPosted: Mon 12 Nov 2012, 03:59    Post_subject:  

Install this, then glib 2.8.
(Test it first with a separate save file.)
Back to top
View user's profile Send_private_message 
paulh177


Joined: 22 Aug 2006
Posts: 875
Location: ST862228

PostPosted: Mon 12 Nov 2012, 07:41    Post_subject:  

Dewbie, many thanks (also thank you to the forum member who PM'd me, and to puppyluvr)

I installed the libc6 patch then got a glib 2.8.6 source package from gtk.org. That compiled with only warnings, and installed without error.

I am getting locale warnings when i run some stuff, but i can probably live with that.

I'm typing this from Opera 12.10 on a testbed frugal ... so, so far so good ... I'll run with this for a few days and report back with any problems I encounter

excellent support from the Puppy crew!

_________________
Want to report a bug or problem? Have a read of this first ...
Back to top
View user's profile Send_private_message 
paulh177


Joined: 22 Aug 2006
Posts: 875
Location: ST862228

PostPosted: Mon 12 Nov 2012, 13:14    Post_subject:  

it was pointed out to me by PM that the glibc I compiled was rather earlier than the version for which the libc6 was made, and that in any case I probably only needed the libc6 patch anyway.

so i've tested with a freshly copied save file from my non-glib2.8 system, installing only the libc6 patch ... opera 12.10 runs fine with just that installed.

for completeness, i did get glibc 2.11.3 sources and tried to compile, but configure objected that cpuid.h was required but couldn't be found. It is on the system, but as i've got what i wanted (a working opera 12.10) I'm not pursuing that line.

_________________
Want to report a bug or problem? Have a read of this first ...
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0463s ][ Queries: 11 (0.0044s) ][ GZIP on ]