Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Dec 2014, 19:58
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Video
How to set eeePC to display 1024 x 600?
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
sp0

Joined: 03 Dec 2012
Posts: 5

PostPosted: Mon 03 Dec 2012, 12:45    Post_subject:  How to set eeePC to display 1024 x 600?  

Have spent most of the day trying to get 1024x600 instead of 800x600 on an Asus eeePC X101CH.

The "personalise settings" option only offers 800x600 and less.
Xorgwizard offers 1024x600, but when X finishes loading it is still 800x600.

Some old posts say to use 915resolution. This says "Intel chipset detected" but cannot identify chipset ID bf18086.

Have tried:
- Slacko 5.3.3.
- Puppeee 1.0. Again, sticks to 800x600.
- Precise 5.2.2. Won't boot. Either get a black screen or a message saying it can't find the .sfs file even though that's on the boot device. (I'm using unetbootin to create USB stick).
- Reading forum posts. Hundreds of them. Many out of date, so now even more confused.
- Installing a mesa driver, and manually choosing intel driver. Neither helped.
- Installing the patched 915resolution mentioned in the forum (although other posts suggest it is no longer needed).

Help! Thanks.
Back to top
View user's profile Send_private_message 
sp0

Joined: 03 Dec 2012
Posts: 5

PostPosted: Mon 03 Dec 2012, 13:43    Post_subject:  

If it helps, it appears this netbook has an Intel GMA 3600 series video adapter. I see some grim postings on the net suggesting this is poorly supported in Linux, although also some saying drivers are maybe now available...

Frustrating if this is no good, as I bought this tiny netbook specifically to run Puppy!

Thanks for any guidance on this.
Back to top
View user's profile Send_private_message 
prehistoric


Joined: 23 Oct 2007
Posts: 1321

PostPosted: Mon 03 Dec 2012, 14:21    Post_subject:  

Have you tried Precise Puppy 5.4.2? This has installed w/o problems on two eee machines I know of, though I don't remember the exact graphics chips. You might also try Lupu 5.28.005 which is pretty solid now. .
Back to top
View user's profile Send_private_message 
FeodorF


Joined: 07 Jul 2010
Posts: 173
Location: Heidelberg, Germany

PostPosted: Mon 03 Dec 2012, 16:01    Post_subject:  800x600x16 resolution sounds bad - but it aint!
Sub_title: Puppy Linux and low resolution
 

I found an old S3 trio 32 graphic card and I had to give it a try with Precise Puppy 5.4.2

How does the outcome look like?

I would call it acceptable.
800x600_NoProblemWithPuppyLinux.jpg
 Description   
 Filesize   89.81 KB
 Viewed   2935 Time(s)

800x600_NoProblemWithPuppyLinux.jpg

Back to top
View user's profile Send_private_message 
sp0

Joined: 03 Dec 2012
Posts: 5

PostPosted: Mon 03 Dec 2012, 17:47    Post_subject:  

prehistoric wrote:
Have you tried Precise Puppy 5.4.2? ...
Lupu 5.28.005 which is pretty solid now. .

Regrettably Lupu has same symptoms as others - the installer sees I have 1024x800, but by the time X has started it's only offering 800x600 or less.

As for Precise 5.4.2, I had already tried that (a typo above, sorry). What happens is that when I start it from a USB stick, created with unetbootin OR with Puppy's installer, it gets to loading kernel drivers, then blanks the screen and stays there.
Back to top
View user's profile Send_private_message 
tempestuous

Joined: 10 Jun 2005
Posts: 5293
Location: Australia

PostPosted: Tue 04 Dec 2012, 10:36    Post_subject:  

Your Eee X101CH has one of the most recent Atom processors, the N2600, which is part of the "Cedarview" family. These differ significantly from earlier Atoms in that their graphics processor (model GMA3600/GMA3650) is non-Intel, it's PowerVR.
And there's no opensource Xorg graphics driver for it.

I'm presently trying to package the latest (closed-source) PowerVR graphics driver, as supplied by Intel here -
http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=21938

It involves compiling a totally new AGP kernel module, and I think this new module is likely to succeed only with the latest kernels, so right now I'm setting up a compile environment for Slacko 5.4.

If you're happy to test this new package once ready, I suggest you download Slacko 5.4 in the meantime, and see if you can successfully boot to it.
It's important to get the "PAE" version of Slacko 5.4 - since I will be compiling a kernel module compatible with this version. The name of the ISO is:
slacko-5.3.9.5-opera-PAE.iso
Back to top
View user's profile Send_private_message 
sp0

Joined: 03 Dec 2012
Posts: 5

PostPosted: Tue 04 Dec 2012, 17:17    Post_subject:  

Many thanks for working on this driver!

tempestuous wrote:
download Slacko 5.4 in the meantime, and see if you can successfully boot to it.
It's important to get the "PAE" version of Slacko 5.4 - since I will be compiling a kernel module compatible with this version. The name of the ISO is:
slacko-5.3.9.5-opera-PAE.iso

Couldn't find that file but did try slacko-5.4-opera-PAE.iso and I get an error about a corrupt kernel file on booting (USB created with unetbootin).
Back to top
View user's profile Send_private_message 
tempestuous

Joined: 10 Jun 2005
Posts: 5293
Location: Australia

PostPosted: Wed 05 Dec 2012, 01:19    Post_subject:  

OK, forget about Slacko 5.4, the new driver won't compile against its 3.4.17 kernel.
I will try an earlier Puppy version/kernel version in the next day or so.
Back to top
View user's profile Send_private_message 
tempestuous

Joined: 10 Jun 2005
Posts: 5293
Location: Australia

PostPosted: Wed 05 Dec 2012, 20:19    Post_subject:  

sp0, I have successfully compiled the cedarview graphics driver under Slacko 5.3.3-PAE.
I should have it packaged shortly.

I suggest you get Slacko 5.3.3-PAE up and running on your Eee X101CH.

Be careful, I suspect some of your downloads are corrupt. It's best to download the ISO in Linux, and don't use the download function of a web-browser, use the commandline utility "wget" - it's extremely reliable.
So to download Slacko 5.3.3-PAE, do this -
Code:
cd /path/to/where/I/want/to/download/my/iso
wget ftp://distro.ibiblio.org/puppylinux/puppy-5.3.3/slacko-5.3.3-highmem-PAE-SCSI.iso
Back to top
View user's profile Send_private_message 
arj_pup

Joined: 04 Nov 2011
Posts: 16
Location: india

PostPosted: Mon 07 Jan 2013, 23:15    Post_subject:  

tempestuous wrote:
sp0, I have successfully compiled the cedarview graphics driver under Slacko 5.3.3-PAE.
I should have it packaged shortly.

I suggest you get Slacko 5.3.3-PAE up and running on your Eee X101CH.

Be careful, I suspect some of your downloads are corrupt. It's best to download the ISO in Linux, and don't use the download function of a web-browser, use the commandline utility "wget" - it's extremely reliable.
So to download Slacko 5.3.3-PAE, do this -
Code:
cd /path/to/where/I/want/to/download/my/iso
wget ftp://distro.ibiblio.org/puppylinux/puppy-5.3.3/slacko-5.3.3-highmem-PAE-SCSI.iso


we will be grateful if you upload the packaged driver or the modules, i tried to compile the stuff my self according to an intel guide myself but i was not able to load module/run x org, i might have messed things up, ill be really grateful if u do so, i am compatible with any puppy version esp slacko 5.3.3
Back to top
View user's profile Send_private_message 
tempestuous

Joined: 10 Jun 2005
Posts: 5293
Location: Australia

PostPosted: Thu 10 Jan 2013, 07:57    Post_subject:  

I have just posted a HOWTO for Cedarview graphics support in Slacko, here -
http://www.murga-linux.com/puppy/viewtopic.php?t=83636

arj_pup I have sent you a PM about testing the full third-party Xorg driver update.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Video
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0703s ][ Queries: 12 (0.0043s) ][ GZIP on ]