Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 26 Nov 2014, 17:53
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
How to use Wake-On-Lan in Slacko 5.3.3?
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
ally


Joined: 19 May 2012
Posts: 863
Location: lincoln

PostPosted: Thu 13 Dec 2012, 14:38    Post_subject:  How to use Wake-On-Lan in Slacko 5.3.3?
Sub_title: Broadcom BCM5751; Dell GX620
 

hey boys and girls

your help please

I have a couple of Dell gx520/gx620 machines that I have been having trouble with the wake-on-lan settings, neither would!

I have just installed Windows on the gx520 that I'm gifting to a young 'un in need (puppy dual booted like it or not!) and have after some googling found that if I set the device driver settings to magic packet in device manager then WOL works

how can I achieve a similar result in puppy (slacko 5.3.3)

thanks

Smile
Back to top
View user's profile Send_private_message Visit_website 
ally


Joined: 19 May 2012
Posts: 863
Location: lincoln

PostPosted: Thu 13 Dec 2012, 15:36    Post_subject:  

ok, a little more digging around

in a user manual pdf from broadcom it says that it can be switched using:

b57udiag -w 1 (1 on, 0 off)

this is an msdos command

anything similar for puppy......

Smile
Back to top
View user's profile Send_private_message Visit_website 
ally


Joined: 19 May 2012
Posts: 863
Location: lincoln

PostPosted: Thu 13 Dec 2012, 17:25    Post_subject:  

further digging..............

I have seen that ethtool is bundled so used:

ethtool eth0 -s wol g

when I ran ethtool eth0 is showed wol with g switch but still doesn't work

confused

help please..........!!!

cheers

Smile
Back to top
View user's profile Send_private_message Visit_website 
Flash
Official Dog Handler


Joined: 04 May 2005
Posts: 11164
Location: Arizona USA

PostPosted: Thu 13 Dec 2012, 23:20    Post_subject:  

I assume you've confirmed in the BIOS that the computer is in fact capable of wake-on-LAN.
Back to top
View user's profile Send_private_message 
ally


Joined: 19 May 2012
Posts: 863
Location: lincoln

PostPosted: Fri 14 Dec 2012, 06:16    Post_subject:  

hey flash

yes I have, thanks

it's definitely a software switch as the windows version shows, I spent ages googling, seems there is a "enable_wol=1" switch for the driver which I have tried using 'modprob tg3 enable_wol=1" but to be honest I stabbing in the dark

from what I understand it's turned off in the kernel unless you turn it on

this machine is connected to my hifi stack and acts as my music server, getting less mobile now so it would help if I could switch remotely

the thing the pishing me off the most is windows does and so far puppy doesn't, ggggrrrrr!!

the machine I built for a gift took a couple of hours to load but didn't find the ethernet, audio, video and system chipset, puppy, 40 secs and everything found!!! outstanding!!

Smile
Back to top
View user's profile Send_private_message Visit_website 
ally


Joined: 19 May 2012
Posts: 863
Location: lincoln

PostPosted: Fri 25 Jan 2013, 09:22    Post_subject:  

>> bump

I'm still struggling with this one

ethtool etho report wol=g (wol enabled) but I still can't get wake-on-lan to work

any help here would be really appreciated

Smile
Back to top
View user's profile Send_private_message Visit_website 
npierce

Joined: 28 Dec 2009
Posts: 858

PostPosted: Sat 26 Jan 2013, 10:51    Post_subject:  

I know next to nothing about WOL, but since you've had no recent responses from anyone else, I decided to take a look into this.

Since the network interface should be brought down properly before power-down, I took a look at /etc/rc.d/rc.shutdown to see if that was doing so. It looks like it is.

But then I noticed that after it brings the interface down it executes these line of code:
Code:
# Unload the Ethernet drivers on shutdown to prevent battery drain.
for i in `lsmod | cut -d' ' -f1 | tr '\n' ' '`
do
 if grep -q "^$i " /etc/networkmodules; then
  modprobe -r "$i"
 fi
done

The battery drain that those lines prevent happens because the PC is listening on the network for the MagicPacket or other WOL option. So those lines of code are great to have if you happen to have a laptop with the problem that they solve, but not so great if you really want to use WOL.

Back-up /etc/rc.d/rc.shutdown, then edit the original to comment-out or remove those lines. See if that helps.
Back to top
View user's profile Send_private_message 
ally


Joined: 19 May 2012
Posts: 863
Location: lincoln

PostPosted: Sat 26 Jan 2013, 11:40    Post_subject:  

thanks for taking the time

the problem must be along these lines as I've read threads across the web with a similar outlook

I read something last night about power to the nic, the OP commented that if the machine is unplugged and reconnected it works

I tried your suggestion without success but a cable out (and wait for the nic light to discharge) and replug solves the problem

what really pisses on my chips is that it works in windows so I've gotta get to the bottom of it!!!!

thanks again for trying

Smile
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0626s ][ Queries: 11 (0.0112s) ][ GZIP on ]