Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 30 Oct 2014, 13:38
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Perl version mismatch
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
Nexus

Joined: 08 Jun 2012
Posts: 14

PostPosted: Fri 04 Jan 2013, 21:34    Post_subject:  Perl version mismatch  

I'm trying to use ndiswrapper to get wireless, but this is the error I get:

Code:

Perl API version v5.16.0 of Fcntl does not match v5.14.0 at /usr/share/perl15/XSLoader.pm line 92.
Compilation failed in require at /usr/sbin/ndiswrapper-1.9 line 20.
BEGIN failed--compilation aborted at /usr/sbin/ndiswrapper-1.9 line 20.


perl --version confirms that I am using version 5.14.2 (not 5.14.0!), which came with my fresh full install of Precise Puppy 5.4.3. No idea where these references to 5.16 come from. How can I fix this problem?
Back to top
View user's profile Send_private_message 
Hotdog


Joined: 29 Sep 2011
Posts: 109
Location: Georgia USA

PostPosted: Sat 05 Jan 2013, 13:51    Post_subject:  

Nexus,

If Perl comes with Precise and you have the devx loaded you could possibly have two versions of Perl on your machine. I had a similar situation with Python on Puppy 5.2.8. Both versions of Python were too comingled to fix so I reloaded Puppy from backup.

_________________
Puppy 528, Full Install
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0383s ][ Queries: 11 (0.0034s) ][ GZIP on ]