Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 23 Aug 2017, 15:29
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
XAMPP 1.8.1 - server package
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 3 [44 Posts]   Goto page: Previous 1, 2, 3 Next
Author Message
gyro

Joined: 28 Oct 2008
Posts: 1400
Location: Brisbane, Australia

PostPosted: Mon 07 Mar 2016, 09:11    Post subject:  

Atle wrote:
Ok Pri... I happen to suffer from the "bleeding edge" syndrome:-)

When i first make something, I like to be like... bleeding edge:-)
Then download the latest, directly from the xampp site, and follow the install instructions.
There will be problems, but these can be sorted, see rojun's post above.
I did this a while ago, so can't remember the exact commands I used.
I did it a bit different from rojun, because all the files in the lampp directory are owned by "nobody:nobody" in my install. So I might have changed both apache and mysql configs so they run as "nobody".
I currently running xampp 5.6.15-1.

gyro
Back to top
View user's profile Send private message 
Atle

Joined: 19 Nov 2008
Posts: 598
Location: Oslo, Norway

PostPosted: Sat 19 Mar 2016, 10:18    Post subject:  

Hi Gyro... thanks for the tips...

I made a spinnoff based on Super Lucid Puppy the Lupu 004.

The customization that is made is that its tanked up with:

Xampp PHP7(2-3 times faster than PHP5.X they say)
Joomla 3.5Beta6 with PHP7 support(installed, but untouched)
Wlanmaker 1.2 that uses hostadp to create a AP of you wifichip(if supported)

Desktop icons to start and stop xampp. Also to start and stop the AP function.

Note that the desktop icon for start/stop AP goes missing after install. Just drag it out of its folder /root/scripts/ to have it back on desktop.

This is made for those that like to experiment a little and that wants the latest and greatest here and now:-)

SULU004(5.2.8.7)

http://www.mediafire.com/download/l183od52ds59ix7/custom-puppy.iso

UPDATE...

LUPU 5.2.8.7 also ready

http://www.mediafire.com/download/31pgtpaugcidk9x/5.2.8.7Lupu_Xampp_Joomla.iso

PS... If you got a 64 bits computer there is another version available based on fatdog, but its not a iso, but rather two compressed files that needs grub4dos to get it into the game. That one has some more things done with Joomla whereas one can upload and download files to the server.
Has also wlanmaker etc.

File 1

http://www.mediafire.com/download/9xzoyat7kdsbjgk/boot.tar.gz

File 2

http://www.mediafire.com/download/0o6bp862vqqrlah/fd64save.tar.gz

Last edited by Atle on Sat 19 Mar 2016, 19:03; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
solo


Joined: 14 Nov 2013
Posts: 390

PostPosted: Sat 19 Mar 2016, 14:48    Post subject:  

I just discovered XAMPP and decided to dabble with PHP for a bit, which was very interesting. I really like this package, and I really appreciate the work you put into it.

I was wondering though, for those of us who have a frugal install and depend on keeping our savefile nice and trim, would it at all be possible to have a setup in which the server would run outside the savefile?

You could create a website without having to worry about any size constraints.

Or is there a very easy way to configure the current XAMPP package to achieve this?
Back to top
View user's profile Send private message 
Atle

Joined: 19 Nov 2008
Posts: 598
Location: Oslo, Norway

PostPosted: Sat 19 Mar 2016, 17:20    Post subject:  

Got some good news for you there Solo...

And it all depends on what puppy your using.

The different puppies have different savefile names, so even with all the variants Rerwin have made out of 5.2.8.7, you can have several of them at the same partition without that crashing with savefiles.

So what puppy are you using?

Right now the offering is Lupu5.2.8.7, Sulu004(5.2.8.7) and FatDog.

The two next is Tahrpup with PAE and then something for the oldies(486)
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
solo


Joined: 14 Nov 2013
Posts: 390

PostPosted: Sun 20 Mar 2016, 06:40    Post subject:  

I'm quite firmly stuck in the 'oldies' camp, running Puppy Precise 5.7.1.

There's no hurry though. My knowledge of webdesign comes from an era when framesets were still the fashion, so let's just say I won't be rolling out any fancy web applications any time soon.

I'm slowly but faithfully typing my way through beginners tutorials at this point.
Back to top
View user's profile Send private message 
Atle

Joined: 19 Nov 2008
Posts: 598
Location: Oslo, Norway

PostPosted: Sun 20 Mar 2016, 06:57    Post subject:  

So then you can make use of either of the 32 bis versions without having sharefiles conflicts in my opinion. I assume your PC is a 32 bit then.

FYI... Anything can be installed to the server. Just create a folder, unzip whatever into it and then give the entire folder a ugly 777 permission. If a database is created and ready, you use mysql as database user with no password.

Wordpress got a version out that has PHP7 support as well, but i did not include it.

I happen to look for a solution where i go outside the limits of php.ini, joomla etc with upload of files. I struggle with getting large files uploads.

I got my joomla to accept files up to around 250mb, but that is where it stops.

My aim is 4gb Laughing

BTW Solo... I discover that you might need to change the script a bit if your wlan goes from wlan0 to wlan1. Then Wlanmaker will not start.


atle
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
gyro

Joined: 28 Oct 2008
Posts: 1400
Location: Brisbane, Australia

PostPosted: Fri 22 Apr 2016, 09:08    Post subject:  

solo wrote:
would it at all be possible to have a setup in which the server would run outside the savefile?
Before you install XAMPP, create a directory in "/mnt/home", e.g. "/mnt/home/lampp".
Then copy this directory to "/opt/lampp" as a symbolic link.
Then manually add the group and user "mysql", (see rojun's post on page 1).
Then run the XAMPP installer.

I just installed the latest XAMPP 7.0.5-0 on Tahrpup 6.0.5, without any problem.

gyro
Back to top
View user's profile Send private message 
Atle

Joined: 19 Nov 2008
Posts: 598
Location: Oslo, Norway

PostPosted: Mon 02 May 2016, 09:52    Post subject:  

A updated version of Sulu004 with Xampp (7.0.4) and Joomla 3.5.1 is uploaded.

It also has Wlanmaker installed and the DNSmasq "trick" as well.

The only problem I could see is that desktop icons does not appear in the remaster and must be pulled out of root/scripts in order to be there.

Download
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
frourio

Joined: 04 Jan 2017
Posts: 112

PostPosted: Wed 18 Jan 2017, 20:21    Post subject:  

I've been trying Rojun's solution of manually adding a group and user but I'm running into this error on terminal in Tahrpup6.0.5:

Quote:
Adding group `mysql' (GID 1001) ...

addgroup: `/usr/sbin/groupadd -g 1001 mysql' returned error code 1. Exiting.


Any suggestions?

I also tried running:

Code:
adduser -G mysql mysql


And got:
Quote:
Option g is ambiguous (gecos, gid, group)


I tried replacing -G with --group but that still didn't work. I think I have to get the first command running successfully before I can start worrying about the second one.
Back to top
View user's profile Send private message 
rockedge


Joined: 11 Apr 2012
Posts: 376
Location: Connecticut, United States

PostPosted: Wed 18 Jan 2017, 22:30    Post subject:  

try just using
Code:
#adduser mysql
#addgroup mysql


for XAMPP just this will do the trick to create user group
adduser username newgroup
Code:
#adduser mysql mysql


I usually only use adduser mysql for XAMPP installs
Back to top
View user's profile Send private message Visit poster's website 
frourio

Joined: 04 Jan 2017
Posts: 112

PostPosted: Thu 19 Jan 2017, 00:07    Post subject:  

Same error:
add_user.png
 Description   
 Filesize   9.79 KB
 Viewed   221 Time(s)

add_user.png

Back to top
View user's profile Send private message 
rockedge


Joined: 11 Apr 2012
Posts: 376
Location: Connecticut, United States

PostPosted: Thu 19 Jan 2017, 15:33    Post subject:  

open the Puppy Package Manager, select uninstall and check the list.

if you find on this list "adduser" or "passwd" select them and remove and uninstall them. Try again with

Code:
#adduser mysql


I have had these installed as dependencies on top of the original tahr install and cause problems.
Back to top
View user's profile Send private message Visit poster's website 
frourio

Joined: 04 Jan 2017
Posts: 112

PostPosted: Thu 19 Jan 2017, 21:52    Post subject:  

Ok found them, but I'm a bit hesitant to remove them.

Are those related to my previous attempts to install XAMPP, or are they something that ships with Puppy? Will it not cause other problems with other operations/apps if I remove them?

On a secondary note, does anyone have a very up-to-date SFS of XAMPP? Once I remove them, I'd prefer to add XAMPP via SFS if possible.
Back to top
View user's profile Send private message 
rockedge


Joined: 11 Apr 2012
Posts: 376
Location: Connecticut, United States

PostPosted: Fri 20 Jan 2017, 00:22    Post subject:  

no these on the list are not shipped. They do not belong to XAMPP either. I experiment extensively with setting up Puppy Linux as a web server in various forms and flavors... I run into this often....trust me XAMPP will work after these are removed. And the adduser and passwd will function again as original. I can make an SFS of XAMPP if need be. I may have XAMPP 1.8.1 floating around and also I have had good success with xampp-linux-5.6.14-4.
Either way...but you will see it will work again once you remove these from the uninstall list.....the original fresh puppy has an empty list.
Back to top
View user's profile Send private message Visit poster's website 
frourio

Joined: 04 Jan 2017
Posts: 112

PostPosted: Fri 20 Jan 2017, 01:16    Post subject:  

Ok will remove them and try.

Once I remove them, do I have to manually "adduser" in terminal and then run the installer, or do I just run the installer?

I think I had tried the 1.8.1 version on Tahrpup without any luck, but also, isn't that a little dated now?
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 3 [44 Posts]   Goto page: Previous 1, 2, 3 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1061s ][ Queries: 14 (0.0097s) ][ GZIP on ]