Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 31 Oct 2014, 02:21
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Slacko 5.5 Final
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 3 of 27 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, ..., 25, 26, 27 Next
Author Message
tlchost

Joined: 05 Aug 2007
Posts: 1729
Location: Baltimore, Maryland USA

PostPosted: Mon 04 Feb 2013, 20:12    Post_subject: getlibre is broken  

get libreoffice is now broken with bootable usb drive...tells me it does not support DVD or low ram installs....works fine in the non-beta versions of Slacko.

Note: This problem cropped up with the upgrade pet for the ppm that was pulled because it was defective.

Video, sound, internet, 16 gigs of memory and 2 tb drive all show up and work as they should.

Thom
Back to top
View user's profile Send_private_message Visit_website 
Billtoo


Joined: 07 Apr 2009
Posts: 2138
Location: Ontario Canada

PostPosted: Mon 04 Feb 2013, 20:45    Post_subject: Slacko 5.4.1 Beta
Sub_title: flash drive install continued
 

I moved my 8gb flash drive install over to my acer desktop pc, it went
straight to the desktop using the nouveau driver.
I downloaded the latest proprietary nvidia driver and after removing
the nouveau driver I compiled that:

video-info-glx1.5.1 Mon 4 Feb 2013 on Slacko Puppy 5.4.0.2 Linux3.4.28-PAE i686
0.0 VGA compatible controller:nVidia CorporationG84[GeForce 8600 GT] (rev a1)
oem: NVIDIA
product: G84 Board - p402h00 Chip Rev

X Server: Xorg Driver: nvidia
X.Org version: 1.12.3
dimensions: 2880x900 pixels (746x231 millimeters)
depth of root window: 24 planes

direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 8600 GT/PCIe/SSE2
OpenGL version string: 3.3.0 NVIDIA 313.09

Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz
Core 0: @1603 1: @1603 2: @1603 3: @1603 MHz

...the above also recorded at '/tmp/root/video-info-glx'.

This pc also has a Hauppauge pvr card in it.
That was fairly easy Smile
screenshot2.jpg
 Description   
 Filesize   48.72 KB
 Viewed   1013 Time(s)

screenshot2.jpg

Back to top
View user's profile Send_private_message 
JustGreg

Joined: 24 May 2005
Posts: 720
Location: Connecticut USA

PostPosted: Mon 04 Feb 2013, 22:08    Post_subject:
Sub_title: It worked
 

I burned the ISO to a CDROM and tried it.

On my Acer Aspire Rev R1600. It work fine, booted directly into the desktop without a hitch. The correct driver was selected for Nvidia card.

On my ASUS EeePC model 1201 HAB, it was a different story. The xorg server failed to be configured correctly. I had to do a manual setup using xorgwizard after the failure to the console. I selected "modeselect" driver and the standard 1368 by 768 by 16 graphics mode. I did not test the configuration, but, finished. The xwin command started the xorg server started correctly. I did have the block cursor. After going through the start screens for time, keyboard and internet, zcedar script was shown and hitting enter corrected the mouse cursor to the normal pointer. A restart after creation of a save file showed no problems.

The only problem area is the start screens that are shown before the start of zcedar.sh script. One has to know the upper left hand corner of the box cursor is the same as the tip of arrow pointer to select items. Without this knowledge, it is confusing on how to select items in the two startup configuration windows.

I hope this helps.

_________________
Enjoy life, Just Greg
Live Well, Laugh Often, Love Much
Back to top
View user's profile Send_private_message 
Sage

Joined: 04 Oct 2005
Posts: 4800
Location: GB

PostPosted: Tue 05 Feb 2013, 02:57    Post_subject:  

Quote:
If flashplayer woes continue

Not worth abandoning Opera because the user has problems selecting the correct FP version! Trial & error always works. It's not video card/driver specific - it's the cr*p Adobe company. Yet another Yank $$$ syndrome!
Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7840
Location: qld

PostPosted: Tue 05 Feb 2013, 05:46    Post_subject: Re: getlibre is broken  

tlchost wrote:
get libreoffice is now broken with bootable usb drive...tells me it does not support DVD or low ram installs....works fine in the non-beta versions of Slacko.

This is strange, but I guess there is some conflict. I'll resolve it soon because I want the program ready for when libreoffice-4.0 is released some time soon, perhaps very soon. Currently it does download (4.0-rc) but it is slightly broken, PLUS, they have in their infinite wisdom added dependency on gconf (heaven knows why), a bloated crappy gnome library that does nothing more than sort out some configuration files.. Confused I'll have to throw in a warning to grab that package from PPM and install it.

JustGreg wrote:
On my ASUS EeePC model 1201 HAB, it was a different story. The xorg server failed to be configured correctly. I had to do a manual setup using xorgwizard after the failure to the console. I selected "modeselect" driver and the standard 1368 by 768 by 16 graphics mode. I did not test the configuration, but, finished. The xwin command started the xorg server started correctly. I did have the block cursor. After going through the start screens for time, keyboard and internet, zcedar script was shown and hitting enter corrected the mouse cursor to the normal pointer. A restart after creation of a save file showed no problems.

It may be my bad there as I had 24 colors set in the xorg.conf-poulsbo template. We'll try it once more in the next beta and see if we can't get X starting without xorgwizard and if it fails then we'll add a note to the "official" known issues. Thankfully, intel has dropped production of laptops with those fickle chipsets, which may be bad luck for you and thousands of others as they receive less attention from developers. Alan Cox is the main guy who has done most of the work on this issue (A,C is a recently "retired" kernel dev, intel, red hat employee and X.org dev.)

JustGreg wrote:
The only problem area is the start screens that are shown before the start of zcedar.sh script. One has to know the upper left hand corner of the box cursor is the same as the tip of arrow pointer to select items. Without this knowledge, it is confusing on how to select items in the two startup configuration windows.
I'll shift zcedar.sh up the pecking order, actually to /usr/sbin and call it from /usr/sbin/delayedrun before any of the other timezone/keyboard/locale gui's.

Sage wrote:
Not worth abandoning Opera because the user has problems selecting the correct FP version! Trial & error always works. It's not video card/driver specific - it's the cr*p Adobe company. Yet another Yank $$$ syndrome!
Hopefully ziggy's issue is isolated and only related to his graphics driver. As said, I'll likely use the slightly older kernel from 5.4 for the next beta and hope it doesn't break JustGreg's above situation.

-------------------------------------------------------------------------------------------------------

Check this out.. <-- http://code.google.com/p/svg-edit/

It's an svg plug-in for most popular browsers. I don't even know how to install it but you can unzip it in a dir and run the index.html file. Pretty cool. Probably if it's installed in the browser and correct mime added to the browser it could be made to open svg files by clicking. It's less than 1 M.
capture31006.jpg
 Description   
 Filesize   30.88 KB
 Viewed   957 Time(s)

capture31006.jpg


_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
tlchost

Joined: 05 Aug 2007
Posts: 1729
Location: Baltimore, Maryland USA

PostPosted: Tue 05 Feb 2013, 06:06    Post_subject: Re: getlibre is broken  

01micko wrote:
tlchost wrote:
get libreoffice is now broken with bootable usb drive...tells me it does not support DVD or low ram installs....works fine in the non-beta versions of Slacko.

This is strange, but I guess there is some conflict. I'll resolve it soon because I want the program ready for when libreoffice-4.0 is released some time soon, perhaps very soon. Currently it does download (4.0-rc) but it is slightly broken, PLUS, they have in their infinite wisdom added dependency on gconf (heaven knows why), a bloated crappy gnome library that does nothing more than sort out some configuration files.. Confused I'll have to throw in a warning to grab that package from PPM and install it.


FWIW, I used getlibreoffice to create version 3.6.5 in the non-beta Slacko(OAE Opera) with no problems.
Back to top
View user's profile Send_private_message Visit_website 
01micko


Joined: 11 Oct 2008
Posts: 7840
Location: qld

PostPosted: Tue 05 Feb 2013, 06:47    Post_subject:  

Please test this version of inkscape lite. I had to patch it to get it to compile, as I did with full inkscape. The binary is about 240k bigger, but if it woks well it's better than not working.

I also had to fluff around to get it to compile, some weird linker error, but it wasn't too hard to fix. I'll post the patch, it applies cleanly to BK's source.

Hope it works! (hmmmm.. been hoping THAT a lot lately!)

PET -- http://www.smokey01.com/01micko/pet_packages-slacko14/inkscapelite-0.36.3-i486-s14.pet 604k
inkscape_glib_slacko.diff.gz
Description  PATCH
gz

 Download 
Filename  inkscape_glib_slacko.diff.gz 
Filesize  432 Bytes 
Downloaded  229 Time(s) 

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
zigbert


Joined: 29 Mar 2006
Posts: 5760
Location: Valåmoen, Norway

PostPosted: Tue 05 Feb 2013, 08:02    Post_subject:  

Hi

The updated inklite had no positive effect on my svg logo.
The plugin showed the svg correct, but acts very slow when it comes to editing.


Thanks a lot for your effort Mick
Sigmund

--------------
Edit:
Testing has been with Slacko 5.3.3

_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
01micko


Joined: 11 Oct 2008
Posts: 7840
Location: qld

PostPosted: Tue 05 Feb 2013, 08:15    Post_subject:  

Sigmund,

Can you please try dia from the Salix repo, graphics section of PPM. It's 3.1M xz compressed, which, when dev and doc are stripped add 3M to the iso. Maybe I'll get the source and compile it, might get a better result, of course if it is a suitable app. (5.3.3 should have it too IIRC).

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
zigbert


Joined: 29 Mar 2006
Posts: 5760
Location: Valåmoen, Norway

PostPosted: Tue 05 Feb 2013, 10:19    Post_subject:  

I have tested Dia - Let's keep inklite Wink
We know about the issue - and grab it, if we find another solution.


Sigmund

_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
zigbert


Joined: 29 Mar 2006
Posts: 5760
Location: Valåmoen, Norway

PostPosted: Tue 05 Feb 2013, 10:27    Post_subject:  

Don't want to fuss too much, but have you tested the updated gtkdialog-splash. I mentioned it before 5.3.3, and you responded that there is an issue with the -margin/-border setting (see link). BUT - this is no issue to already existing splash-code which doesn't use these settings.

I have never had any issues with it, and I just install the newer one....
As said; No fuss - your choice!!!!


Sigmund

_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
Billtoo


Joined: 07 Apr 2009
Posts: 2138
Location: Ontario Canada

PostPosted: Tue 05 Feb 2013, 10:35    Post_subject: Slacko 5.4.1 Beta  

I did a manual frugal install to an ext4 formatted 8gb SDHC card using
grub4dos as the bootloader.
It went straight to the desktop using the radeon driver and sound etc.
was all working.
I ran the cpu frequency scaling utility.
I installed the amd-driver-installer-catalyst-13.1-legacy-linux-x86.x86_64.run
proprietary graphics driver:

Report Video 1.4-Tue 5 Feb 2013 on Slacko Puppy 5.4.0.2 - Linux 3.4.28-PAE i686
Chip description:
5.0 VGA compatible controller: ATI Technologies Inc Radeon HD 3200 Graphics
oem: ATI ATOMBIOS
product: RS780 01.00
X Server: Xorg Driver used: fglrx
X.Org version: 1.12.3
dimensions: 1440x900 pixels (380x238 millimeters)
depth of root window: 24 planes
OpenGL
Vendor Advanced Micro Devices, Inc.
Renderer ATI Radeon HD 3200 Graphics
Version 3.3.11672 Compatibility Profile Context
Direct Rendering Y_es
# glxgears
17422 frames in 5.0 seconds = 3484.281 FPS
17468 frames in 5.0 seconds = 3493.596 FPS
17479 frames in 5.0 seconds = 3495.781 FPS
Computer
Processor 4x AMD Phenom(tm) II X4 810 Processor
Memory 7975MB (195MB used)

I installed my favorite applications from ppm and pets.
It's working well so far.
screenshot.jpg
 Description   
 Filesize   97.79 KB
 Viewed   845 Time(s)

screenshot.jpg

Back to top
View user's profile Send_private_message 
zigbert


Joined: 29 Mar 2006
Posts: 5760
Location: Valåmoen, Norway

PostPosted: Tue 05 Feb 2013, 11:00    Post_subject:  

More Flash testing
- Can't get Opera to play youtube video with any of the offered Flash-versions in GetFlash.
- Both Firefox-18 and Chromium-25 works (only tested with the latest version of Flashplayer offered in GetFlash
- On the other hand, installing Chromium knocked out Rox pinboard and corrupted My gtk2. Using the default gtk-theme shows most of the gui, so I can still navigate. Wow - This is getting fun Very Happy


Sigmund

_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
ally


Joined: 19 May 2012
Posts: 856
Location: lincoln

PostPosted: Tue 05 Feb 2013, 12:55    Post_subject:  

5.4.02 running well with no hanging

powercut has resulted in a shorter uptime for testing but all ok so far

Smile

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
SFR


Joined: 26 Oct 2011
Posts: 1081

PostPosted: Tue 05 Feb 2013, 15:28    Post_subject:  

Zigbert wrote:
Can't get Opera to play youtube video with any of the offered Flash-versions in GetFlash.

As I have mentioned in Slacko-5.4 bug thread I've observed similar behaviour:
me wrote:
If I launch Slacko in VBox, then indeed, Flash doesn't work at all and there are graphical glitches in Opera.
But then again when booted in real environment, everything's fine...
IIRC, I read somewhere that this can be caused by Xorg/Vesa differences, but most likely there's a lot more factors...

Anyway, out of curiosity, I launched 5.4.0.2 in VBox again paying attention for any differences.
In my Toshiba/Acer Slacko boots into desktop using 24 bitplanes, but in VBox - only 16 bitplanes...
So, using xorgwizard I changed color depth to 24 bitplanes...and YT started to work; graphical glitches have gone also (see screenshots).
It's quite a long shot, but maybe this is also the cause of your problems..?

@Mick: +1 for updated gtkdialog-splash - I'm using it since 5.2.8 without any troubles.

HTH
Greetings!
16bitplanes.jpeg
 Description   
 Filesize   78.85 KB
 Viewed   774 Time(s)

16bitplanes.jpeg

24bitplanes.jpeg
 Description   
 Filesize   95.24 KB
 Viewed   749 Time(s)

24bitplanes.jpeg


_________________
[O]bdurate [R]ules [D]estroy [E]nthusiastic [R]ebels => [C]reative [H]umans [A]lways [O]pen [S]ource
Omnia mea mecum porto.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 3 of 27 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, ..., 25, 26, 27 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1175s ][ Queries: 12 (0.0151s) ][ GZIP on ]