Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 16 Apr 2014, 04:26
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
How to use Redshiftgui in Slacko?
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 3 [36 Posts]   Goto page: Previous 1, 2, 3 Next
Author Message
Semme

Joined: 07 Aug 2011
Posts: 3256
Location: World_Hub

PostPosted: Wed 20 Feb 2013, 13:56    Post subject:  

Grab this. Extract the redshiftgui binary to /usr/bin >> it'll overwrite the other.

Though the two are the same version, the md5's don't match.

Whether it's something else- I'm unsure.
Back to top
View user's profile Send private message 
Rope

Joined: 20 Feb 2013
Posts: 241

PostPosted: Wed 20 Feb 2013, 14:03    Post subject:  

I extracted all files to /usr/bin Same error in console.
_________________
Puppy Slacko 5.7 frugal (windows installer)
Broken Windows XP after switching from Intel to AMD
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3256
Location: World_Hub

PostPosted: Wed 20 Feb 2013, 14:05    Post subject:  

For now I don't know. If someone knows the answer- be my guest.

There's a cli we could adjust, but not without further research..
Back to top
View user's profile Send private message 
Rope

Joined: 20 Feb 2013
Posts: 241

PostPosted: Wed 20 Feb 2013, 14:07    Post subject:  

OK thanks Smile
_________________
Puppy Slacko 5.7 frugal (windows installer)
Broken Windows XP after switching from Intel to AMD
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3256
Location: World_Hub

PostPosted: Wed 20 Feb 2013, 14:08    Post subject:  

Hey- your Slack's which version?
Back to top
View user's profile Send private message 
Rope

Joined: 20 Feb 2013
Posts: 241

PostPosted: Wed 20 Feb 2013, 14:22    Post subject:  

Operating System: Slacko Puppy 5.4
Desktop Window Manager: JWM vsvn-581
Desktop Start: xwin jwm

_________________
Puppy Slacko 5.7 frugal (windows installer)
Broken Windows XP after switching from Intel to AMD
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3256
Location: World_Hub

PostPosted: Wed 20 Feb 2013, 15:35    Post subject:  

I don't think your issue's with the version. I think maybe that Windows installer.

Anyway- try this and shoot me an update: redshiftgui -m VidMode

If nogo, check PPM for libgeoclue.
Back to top
View user's profile Send private message 
Rope

Joined: 20 Feb 2013
Posts: 241

PostPosted: Wed 20 Feb 2013, 16:01    Post subject:  

redshiftgui -m VidMode seems to work Smile at least the preview.Thanks
Now, how do I make redshiftgui start with the OS?

_________________
Puppy Slacko 5.7 frugal (windows installer)
Broken Windows XP after switching from Intel to AMD
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3256
Location: World_Hub

PostPosted: Wed 20 Feb 2013, 16:20    Post subject:  

In ~/Startup, rt-clk >> new >> script >> name it rs_gui.sh? Or to your liking..

Now open as text and add this line under #!/bin/sh: redshiftgui -n -o -m VidMode

How well this works you might be telling me before I know. The -o switch??

I grabbed the latest NOGUI which is 1.7. A few of the switches are different so..

These below- as you can see..
Code:
RedshiftGUI (0.2.1) help:
  -b  --bright       <BRIGHTNESS> Brightness (0.1 - 1)
  -c  --crt          <CRTC> CRTC to apply adjustment to (RANDR only)
  -g  --gamma        <R:G:B> Additional gamma correction to apply
  -l  --latlon       <LAT:LON> Latitude and longitude
  -m  --method       <METHOD> Method to use (Auto, RANDR, VidMode)
  -n  --no-gui       Run in console mode (no GUI).
  -o  --oneshot      Adjust color and then exit (no GUI)
  -r  --speed        <SPEED> Transition speed (default 1000 K/s)
  -s  --screen       <SCREEN> Screen to apply to
  -t  --temps        <DAY:NIGHT> Color temperature to set at daytime/night
  -v  --verbose      <LEVEL> Verbosity of output (0 = err/warn, 1 = info, 2 = verbose)
      --map          (Advanced) Temperature map
      --min          Start GUI minimized
  -d  --disable      Start GUI disabled
  -h  --help         Display this help message
Back to top
View user's profile Send private message 
Rope

Joined: 20 Feb 2013
Posts: 241

PostPosted: Wed 20 Feb 2013, 16:46    Post subject:  

I cant find rt-clk

I found this:
Quote:
You can easily create a "symlink" (symbolic link) to an executable.
For example, say that you wanted to run /usr/local/bin/rubix (a game)
everytime Puppy is started. Use ROX-Filer (the file manager) and open
two windows, one on /usr/local/bin, the other on /root/Startup.
Then just drag 'rubix' across and a menu will popup and ask if you want
to copy, move or link, and you choose to link.

but my-applications is empty

_________________
Puppy Slacko 5.7 frugal (windows installer)
Broken Windows XP after switching from Intel to AMD
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3256
Location: World_Hub

PostPosted: Wed 20 Feb 2013, 16:57    Post subject:  

Oh.. rt-clk means Laughing just that >> right click.

Your startup folder's here >> /root/Startup

You find it? This >> ~/ << refers to *users* home.

And for the line up top >> yank the -o.
Code:
#!/bin/sh
redshiftgui -n -m VidMode


As to what you posted, it's >> link relative.
Back to top
View user's profile Send private message 
Rope

Joined: 20 Feb 2013
Posts: 241

PostPosted: Wed 20 Feb 2013, 17:17    Post subject:  

ok done thanks Smile
let's see if it works next boot.

_________________
Puppy Slacko 5.7 frugal (windows installer)
Broken Windows XP after switching from Intel to AMD
Back to top
View user's profile Send private message 
Rope

Joined: 20 Feb 2013
Posts: 241

PostPosted: Wed 20 Feb 2013, 17:19    Post subject:  

Why my-applications/bin is empty?
_________________
Puppy Slacko 5.7 frugal (windows installer)
Broken Windows XP after switching from Intel to AMD
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3256
Location: World_Hub

PostPosted: Wed 20 Feb 2013, 17:21    Post subject:  

I have no idea? Very Happy Is there *supposed to be* sumpthin there?
Back to top
View user's profile Send private message 
Rope

Joined: 20 Feb 2013
Posts: 241

PostPosted: Wed 20 Feb 2013, 17:34    Post subject:  

I know nothing, but if I installed something e.g. redshiftgui shouln it be there?
_________________
Puppy Slacko 5.7 frugal (windows installer)
Broken Windows XP after switching from Intel to AMD
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 3 [36 Posts]   Goto page: Previous 1, 2, 3 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0567s ][ Queries: 11 (0.0042s) ][ GZIP on ]