Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 17 Apr 2014, 14:07
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Turn off dead key mode on keyboard settings?
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [3 Posts]  
Author Message
darrenforster99

Joined: 25 Sep 2007
Posts: 7

PostPosted: Thu 28 Feb 2013, 14:51    Post subject:  Turn off dead key mode on keyboard settings?
Subject description: How do I turn off dead key mode?
 

Recently my puppy linux was all working fine, until suddenly it messed up and it turned the entire screen like a green-screen colour, except the mouse still being white.

To fix this I tried everything and nothing would work pfix=clean pfix=purge, etc - nothing at all, so in the end the only solution was to delete the SFS files from the hard drive (first backing up anything I had in there), and re-install Puppy from fresh from the CD.

Since re-installing Puppy from the CD from fresh I've had a major problem with the keyboard.

I set up the keyboard in exactly the same way I had done previously, setting it to UK GB settings and everything (as I live in the UK), but something went wrong.

Every time I try and type some of the special characters I have to remember to press space for example

'
"
^
~

if I forget to press space I sometimes get other foreign characters like ä or â, ś, ñ depending on which character I type next, or if I press the same key again I might get weird quotes like ´ or ¨.

I searched on the net and it would appear I've got dead keys enabled. I don't know how I've done this but it's a pain in the backside (especially as sometimes I switch between this computer and one running Windows which doesn't do this so I need to remember each time).

I've looked through the keyboard settings and on the internet for a way to make this revert to the old method.

On the internet it refers to it as a dead key mode which allows international typing easily, but I only speak English and only type English so I have no need for it.

I looked through the settings and the only reference I can find to dead key moe is in XkbConfigutation in the Layout Variants options which gives me two choices - either

1: intl gb: international (with Dead keys)
2: dvorak gb: dvorak

Now I know what Dvorak is so I don't want that, but I can't see a setting for intl gb: international (without Dead keys).

Where is this option, or how do I turn off the dead keys mode?
Back to top
View user's profile Send private message 
L18L

Joined: 19 Jun 2010
Posts: 2473
Location: Burghaslach, Germany somewhere also known as "Hosla"

PostPosted: Thu 28 Feb 2013, 15:24    Post subject: Re: Turn off dead key mode on keyboard settings?
Subject description: How do I turn off dead key mode?
 

darrenforster99 wrote:
Where is this option, or how do I turn off the dead keys mode?

Maybe you should try to turn on Layout Variant nodeadkeys Question
nodeadkeys.png
 Description   
 Filesize   38.22 KB
 Viewed   132 Time(s)

nodeadkeys.png

Back to top
View user's profile Send private message 
npierce

Joined: 28 Dec 2009
Posts: 854

PostPosted: Thu 28 Feb 2013, 15:35    Post subject:  

Does this text appear at the top of the dialog box that lists the variants?
Quote:
You are currently using the following variants:
intl gb: international (with dead keys)

If so, you do want to choose:

1: intl gb: international (with Dead keys)

Doing so will remove it.

After clicking OK, don't forget to click Yes (in the XKB Configuration Manager dialog) to activate new settings.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [3 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0578s ][ Queries: 12 (0.0138s) ][ GZIP on ]