Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 23 Sep 2014, 18:43
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Only Quirky live CD works in old P2 PC with 152 MB RAM
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [9 Posts]  
Author Message
rvijay127

Joined: 06 Dec 2009
Posts: 12

PostPosted: Fri 01 Mar 2013, 12:46    Post subject:  Only Quirky live CD works in old P2 PC with 152 MB RAM
Subject description: Various other issues
 

I have an old IBM PC 333 Mhz with 152Mb Ram that dates back to 1999. I have given a generous swap partition of 512Mb on the 4.2Gb hard drive. Puppy Wary for older PCs gives kernel panic and crashes. Only Puppy Quirky Live CD works on this PC.


Following are the issues on this PC:
1. A20 Fail
This messge comes during boot before even grub loads. Keyboard was verified to be ok by using another KB. Even opened case and cleared dust. Bios was reset to defaults. Nothing Helped. Tried to install memtest from Puppy4, hoping it will install grub. This didn't happen. Due to A20 Fail grub4dos and grublegacy both fail to load on boot. It will be good to overcome this problem.

2. This PC doesnt play ogg or mps files it just sits there. However, sound is ok when I play burger king and it used to stream net radio before. However, I installed proxy and firewall, after this the streaming doesn't work also. ALSA config was tried but this didn't work as the drivers couldn't be found.

More Basic Related info.: Kernel: Linux 2.6.31.14 (i586) PCI Devices Host bridge Silicon Integrated Systems [SiS] 5597 [SiS5582] ISA bridge Silicon Integrated Systems [SiS] SiS85C503/5513 IDE interface Silicon Integrated Systems [SiS] 5513 [IDE] USB Controller Silicon Integrated Systems [SiS] USB 1.1 Controller Ethernet controller Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ Multimedia audio controller Cirrus Logic CS 4614/22/24/30 [CrystalClear SoundFusion Audio Accelerator] Serial controller Rockwell International HCF 56k Data/Fax Modem VGA compatible controller Silicon Integrated Systems [SiS] 5597/5598/6326 VGA Questions: 1. How can I make Links browser the default in Puppy Linux (using Puppy Quirky 1.4) ? 2. Sound Problem This PC plays streaming music, net radio ok. However, it doesn't play sound files. I tried both mp3 and ogg vorbis. How can I get drivers for the sound card below: Multimedia audio controller Cirrus Logic CS 4614/22/24/30 [CrystalClear SoundFusion Audio Accelerator] 3. Playing Video Files This PC doesn't play video files. I tried to do a Video upgrade, it tried to get this file from ibiblio but failed saying link broken. It also said that I have the needed drivers, but getting this may help improve performance: Mesa-5.6.2-W5.pet I tried to look on the net for this but all links are old and don't exist. VGA compatible controller Silicon Integrated Systems [SiS] 5597/5598/6326 VGA Display Resolution 1024x768 pixels Vendor The X.Org Foundation Version 1.3.0 I was able to do 2 and 3 above with Win 98. I found install disks for this. However, Win98 has no support and being on net with it is real insecure. Hence, I prefer to use Linux for this.
Back to top
View user's profile Send private message 
rvijay127

Joined: 06 Dec 2009
Posts: 12

PostPosted: Fri 01 Mar 2013, 12:49    Post subject:  

I have a long thread about this PC here:

http://www.linuxquestions.org/questions/linux-desktop-74/linux-for-old-pentium-2-pc-4175449680/page6.html
Back to top
View user's profile Send private message 
ally


Joined: 19 May 2012
Posts: 848
Location: lincoln

PostPosted: Fri 01 Mar 2013, 15:00    Post subject:  

2.

may be a processing problem, I used an p3 650hz laptop and a media centre wired to the hifi, played mp3's but if I tried to run the equalizer (in vlc) it just couldn't cope and fell over

Smile
Back to top
View user's profile Send private message Visit poster's website 
rvijay127

Joined: 06 Dec 2009
Posts: 12

PostPosted: Fri 01 Mar 2013, 18:14    Post subject:  

Yes, when I play a CD then it plays
but makes a huge whirring noise that
covers the main music. This whirring noise is from the CD spinning.

It doesn't read DVDs, Bios not even setup for that.
Back to top
View user's profile Send private message 
rokytnji


Joined: 20 Jan 2009
Posts: 1332
Location: Pecos/ Texas

PostPosted: Fri 01 Mar 2013, 18:55    Post subject:  

Back to top
View user's profile Send private message Visit poster's website 
oui

Joined: 20 May 2005
Posts: 2080
Location: near Woof (Germany) :-) Acer Laptop emachines 2 GB RAM AMD64. franco-/germanophone, +/- anglophone

PostPosted: Sat 02 Mar 2013, 19:19    Post subject: Re: Only Quirky live CD works in old P2 PC with 152 MB RAM
Subject description: Various other issues
 

rvijay127 wrote:
I have an old IBM PC 333 Mhz with 152Mb Ram that dates back to 1999. I have given a generous swap partition of 512Mb on the 4.2Gb hard drive. Puppy Wary for older PCs gives kernel panic and crashes. Only Puppy Quirky Live CD works on this PC.


enjoy it! Quirky is a really very good choice Idea

rgds
Back to top
View user's profile Send private message 
rvijay127

Joined: 06 Dec 2009
Posts: 12

PostPosted: Mon 04 Mar 2013, 10:22    Post subject:  

I tried to get the correct ALSA drivers and configure. Got the following error: # ./configure checking for gcc... no checking for cc... no checking for cl.exe... no configure: error: no acceptable C compiler found in $PATH See `config.log' for more details. # Link for the driver is as follows: ftp://ftp.alsa-project.org/pub/drive...0.22.1.tar.bz2
Back to top
View user's profile Send private message 
rvijay127

Joined: 06 Dec 2009
Posts: 12

PostPosted: Mon 04 Mar 2013, 10:25    Post subject:  

Also, for X, drivers are suggested here: http://www.winischhofer.net/linuxsispart4.shtml However, The version of X that I have on my system as per below is not in the above link. So not sure how to proceed here. # X -version X Window System Version 1.3.0 Release Date: 19 April 2007 X Protocol Version 11, Revision 0, Release 1.3 Build Operating System: UNKNOWN Current Operating System: Linux puppypc 2.6.31.14 #1 SMP Mon Oct 25 23:28:59 GMT-8 2010 i586 Build Date: 13 September 2010 Before reporting problems, check http://wiki.x.org to make sure that you have the latest version. Module Loader present # _______
Back to top
View user's profile Send private message 
rvijay127

Joined: 06 Dec 2009
Posts: 12

PostPosted: Mon 04 Mar 2013, 23:55    Post subject:  

I setup the Proxy using Setup in Puppy Quirky 1.4 and now it is stopping a lot of services. It always starts when I boot my PC.
How can this be stopped ?

# env | grep -i proxy
http_proxy=http://foo.org:8080
ftp_proxy=ftp://foo.org:8080
#

Disabling the firewall by commenting in the rc.local didn't help.

Thanks.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [9 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0695s ][ Queries: 11 (0.0030s) ][ GZIP on ]