Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 24 Jul 2014, 19:10
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Wireless adaptor with ADSL
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
tytower

Joined: 24 Feb 2007
Posts: 440
Location: Green Island Cairns for the winter

PostPosted: Fri 01 Mar 2013, 17:43    Post_subject:  Wireless adaptor with ADSL  

Iv'e got this working with a driver that Pemasu made a pet of for me.

It mostly works but lately it is taking longer and longer to actually get online. Sometimes it just goes striaght on and other times it will take me 15-20 minutes of boot reboot
I try to connect and get failed messages on the DHCP part of it so I reboot the machine and try again or I reboot the router and try again .
Usually this fixes it but lately It just takes longer and longer .

Today I just had to go back to a cable to get connected. bloody impossible to keep FA ing with it.

Here is a log I am getting atm

Code:
Information about this interface:
 Interface: wlan0  Driver: rtl8192cu  Bus: usb  MacAddress: 00:9E:95:9C:4D:1F
 Description: Realtek 8192C/8188C 802.11n USB wireless
 
STEP1a: ifconfig wlan0 up
STEP1b: iwlist wlan0 scan
wlan0     Scan completed :
          Cell 01 - Address: 00:26:F2:57:06:C6
                    ESSID:"NETGEAR"
                    Protocol:IEEE 802.11bg
                    Mode:Master
                    Frequency:2.412 GHz (Channel 1)
                    Encryption key:on
                    Bit Rates:54 Mb/s
                    Extra:wpa_ie=dd160050f20101000050f20201000050f20201000050f202
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD970050F204104A0001101044000102103B00010310470010824FF22B8C7D41C5A13144F534E12555102100074E455447454152102300164E4554474541522044474E3130303020526F757465721024000A312E30302E34355F77771042000831323334353637381054000800060050F2040001101100164E4554474541522044474E3130303020526F757465721008000201AA103C000103
                    Quality=101/100  Signal level=56/100 
STEP1c: ifconfig wlan0 down
STEP2: iwconfig wlan0 mode managed
STEP3: iwconfig wlan0 channel 1
STEP4: iwconfig wlan0 essid "NETGEAR"
STEP5a: ifconfig wlan0 up
STEP5b: wpa_supplicant -B -Dwext -iwlan0 -c"/etc/simple_network_setup/wpa_supplicant.conf-NETGEAR-00:9E:95:9C:4D:1F"
ioctl[SIOCSIWAP]: Operation not permitted
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
Running: wpa_cli -i wlan0 status
wpa_state=SCANNING

ERROR, TIMEOUT. Have not got an Access Point.
Result of 'iwconfig wlan0':
wlan0     unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency=2.412 GHz  Access Point: Not-Associated   
          Sensitivity:0/0 
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


STEP5a: ifconfig wlan0 up
STEP5b: wpa_supplicant -B -Dwext -iwlan0 -c"/etc/simple_network_setup/wpa_supplicant.conf-NETGEAR-00:9E:95:9C:4D:1F"
ioctl[SIOCSIWAP]: Operation not permitted
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
Running: wpa_cli -i wlan0 status
wpa_state=SCANNING

ERROR, TIMEOUT. Have not got an Access Point.
Result of 'iwconfig wlan0':
wlan0     unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency=2.412 GHz  Access Point: Not-Associated   
          Sensitivity:0/0 
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


STEP5a: ifconfig wlan0 up
STEP5b: wpa_supplicant -B -Dwext -iwlan0 -c"/etc/simple_network_setup/wpa_supplicant.conf-NETGEAR-00:9E:95:9C:4D:1F"
ioctl[SIOCSIWAP]: Operation not permitted
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
Running: wpa_cli -i wlan0 status
wpa_state=ASSOCIATING

ERROR, TIMEOUT. Have not got an Access Point.
Result of 'iwconfig wlan0':
wlan0     unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency=2.412 GHz  Access Point: Not-Associated   
          Sensitivity:0/0 
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


STEP5a: ifconfig wlan0 up
STEP5b: wpa_supplicant -B -Dwext -iwlan0 -c"/etc/simple_network_setup/wpa_supplicant.conf-NETGEAR-00:9E:95:9C:4D:1F"
ioctl[SIOCSIWAP]: Operation not permitted
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
Running: wpa_cli -i wlan0 status
wpa_state=DISCONNECTED

ERROR, TIMEOUT. Have not got an Access Point.
Result of 'iwconfig wlan0':
wlan0     unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency=2.412 GHz  Access Point: Not-Associated   
          Sensitivity:0/0 
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


 
*********************************************************
LAST 10 LINES of /var/log/messages:
Mar  2 20:49:15 puppypc28819 user.warn kernel: [ 2914.513423] ==>power_saving_ctrl_wk_hdl change rf to OFF...LED(0x00028008)....
Mar  2 20:49:15 puppypc28819 user.warn kernel: [ 2914.513424]
Mar  2 20:49:15 puppypc28819 user.warn kernel: [ 2914.513426] ===> rtw_ips_pwr_down...................
Mar  2 20:49:15 puppypc28819 user.warn kernel: [ 2914.513673] ====> rtw_ips_dev_unload...
Mar  2 20:49:15 puppypc28819 user.warn kernel: [ 2914.537172] usb_read_port_cancel
Mar  2 20:49:15 puppypc28819 user.warn kernel: [ 2914.537671] usb_write_port_cancel
Mar  2 20:49:15 puppypc28819 user.warn kernel: [ 2914.537691] ==> rtl8192cu_hal_deinit
Mar  2 20:49:15 puppypc28819 user.warn kernel: [ 2914.537693] bkeepfwalive(0)
Mar  2 20:49:15 puppypc28819 user.warn kernel: [ 2914.537694] card disble without HWSM...........
Mar  2 20:49:15 puppypc28819 user.warn kernel: [ 2914.543059] <=== rtw_ips_pwr_down..................... in 30ms

_________________
Neither my Family nor my Property are Government issues. Governments should do what they were designed to do Manage the larger issues best done by Governments
To stop corruption give them 3 times the penalty. Get their agreement on first employment.

Edited_time_total
Back to top
View user's profile Send_private_message 
tytower

Joined: 24 Feb 2007
Posts: 440
Location: Green Island Cairns for the winter

PostPosted: Mon 04 Mar 2013, 05:03    Post_subject:  

Not getting much
Had a look at wpa-supplicant which is a program that runs when you want to connect . Its configuration file is in /etc/wpa-supplicant.conf

but in /etc/simplenetworksetup/wpa-supplicant.conf there is one too and a connections file?

My log file above looks a bit odd with that long line of hex across the page

_________________
Neither my Family nor my Property are Government issues. Governments should do what they were designed to do Manage the larger issues best done by Governments
To stop corruption give them 3 times the penalty. Get their agreement on first employment.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0617s ][ Queries: 11 (0.0030s) ][ GZIP on ]