Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 02 Oct 2014, 05:13
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
alphaOS [closed]
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 10 of 47 Posts_count   Goto page: Previous 1, 2, 3, ..., 8, 9, 10, 11, 12, ..., 45, 46, 47 Next
Author Message
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Tue 26 Mar 2013, 11:32    Post_subject:  

Latest addition to spkg_gui, packages listed by category..

Every package must belong to one of 8 supported categories:
utilities development games graphics network multimedia office system
alphaos-20130326162505.png
 Description   
 Filesize   55.02 KB
 Viewed   1210 Time(s)

alphaos-20130326162505.png

Back to top
View user's profile Send_private_message Visit_website 
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Tue 26 Mar 2013, 11:52    Post_subject:  

rcrsn51,

Thank you very much for that report.

Now, I cannot remove cups completely because it is required to compile some packages. Or it is optional dependency, but if it's not present at compile time then programs like evince for example would not be able to print.

gtk3 require cups newer than 1.2, I hope that 1.4 is not too old for any other package
Code:
    if test $CUPS_API_MAJOR -gt 1 -o \
            $CUPS_API_MAJOR -eq 1 -a $CUPS_API_MINOR -lt 2; then
      as_fn_error $? "CUPS >= 1.2 not found" "$LINENO" 5
    fi

http://www.cups.org/software.php

I could compile older cups version 1.4.8 if you that it's better, what I like is that source size for that version is almost two times smaller than 1.6.

It's not problem because I planned to soon recompile everything, after adjusting package manager to leave locale files for every package in. That will increase size of the iso for 15-20 Mb but every program will have support for all languages.
Back to top
View user's profile Send_private_message Visit_website 
rcrsn51


Joined: 05 Sep 2006
Posts: 9159
Location: Stratford, Ontario

PostPosted: Tue 26 Mar 2013, 12:23    Post_subject:  

Rebuilding alphaOS from scratch with CUPS 1.4.8 would definitely help.

When my package replaces CUPS 1.6, it changes some things with gtk that require fixing. It works, but a native install of 1.4.8 would be better.

When you are ready to rebuild, send me a PM. I will give you my ./configure. It needs to be compatible with the other printing components.
Back to top
View user's profile Send_private_message 
ojowinter

Joined: 10 Mar 2013
Posts: 7

PostPosted: Tue 26 Mar 2013, 21:18    Post_subject:  

I noticed lack of some scalable icons in alphaos's Faenza.

https://github.com/Valama/valama

Valama need three icons.

x status/changes-prevent-symbolic.svg
x action/edit-clear-all-symbolic.svg
o action/edit-find-symbolic.svg
x emblem/emblem-system-symbolic.svg

It seem to be edit-find-symbolic is ok.
http://dl.dropbox.com/u/1053962/arpha-20130327101338.png

PS: Perhaps cannot see treeview toggle switch in currently alpha's gtk theme.
Back to top
View user's profile Send_private_message 
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Wed 27 Mar 2013, 04:36    Post_subject:  

x status/changes-prevent-symbolic.svg
x action/edit-clear-all-symbolic.svg
x emblem/emblem-system-symbolic.svg


I will add first one, other two are not in Faenza theme, but there are similar names:
edit-clear-symbolic.svg will link to edit-clear-all-symbolic.svg
emblem-system.svg will link to emblem-system-symbolic.svg
Back to top
View user's profile Send_private_message Visit_website 
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Wed 27 Mar 2013, 05:13    Post_subject:  

GTK+ 3.8.0 released 25 Mar 2013

https://mail.gnome.org/archives/gtk-list/2013-March/msg00019.html
http://worldofgnome.org/what-gtk-3-8-will-bring-for-developers/

It will be in next alphaos version 3.0!
Back to top
View user's profile Send_private_message Visit_website 
ojowinter

Joined: 10 Mar 2013
Posts: 7

PostPosted: Thu 28 Mar 2013, 05:59    Post_subject:  

wow, I truly appreciate your time and effort!

I noticed one point issue.
Build option without --enable-broadway-backend seem to be broadwayd not created.
So new feature is not available Sad

# broadawayd
Listing on /root/.cache/broadway1.socket

and then type in new tab
# GDK_BACKEND=broadway sakura
go address in browser!
http://localhost:8080

sakura is compatible with gtk3
so It's works in firefox!
Back to top
View user's profile Send_private_message 
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Fri 29 Mar 2013, 08:02    Post_subject:  

I wanted to test broadway backend and terminal in browser seems like interesting idea but it didn't work

[root@alphaos ~]# GDK_BACKEND=broadway sakura
Unable to init server
Segmentation fault
[root@alphaos ~]#

And that broadawayd command is missing, although gtk3 is compiled with --enable-broadway-backend.
Back to top
View user's profile Send_private_message Visit_website 
ojowinter

Joined: 10 Mar 2013
Posts: 7

PostPosted: Fri 29 Mar 2013, 09:08    Post_subject:  

hi. I remember that certainly broadwayd is created in gtk+-3.8.0/gdk/broadway directory.
and then make install into /usr/bin.

Maybe def script strip bin command in package function?
However I try to test, I think that it is currently in early stage..
Back to top
View user's profile Send_private_message 
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Fri 29 Mar 2013, 09:18    Post_subject:  

funny mistake - I wanted to remove gtk-update-icon-cache in package function because it is already provided by gtk2, but removed everything in /usr/bin. So gtk3 is compiling again, will add screenshot later if brodway works.

Edit:
Now it's working.. bellow are screenshots of sakura terminal and lxtask running inside firefox.
alphaos-20130329145031.png
Description 
png

 Download 
Filename  alphaos-20130329145031.png 
Filesize  109.71 KB 
Downloaded  139 Time(s) 
alphaos-20130329144937.png
Description 
png

 Download 
Filename  alphaos-20130329144937.png 
Filesize  68.47 KB 
Downloaded  138 Time(s) 
Back to top
View user's profile Send_private_message Visit_website 
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Sat 30 Mar 2013, 05:16    Post_subject:  

After version 3.8 gnome-games package was split into separate modules.

I've compiled gnome-tetravex, that was part of gnome-games but now is separate package with
just 45 KB and no dependencies outside main iso.

This game will be in repository after releasing version 3.0.
Back to top
View user's profile Send_private_message Visit_website 
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Sat 30 Mar 2013, 05:26    Post_subject:  

alphaOS version 3.0 with gtk 3.8 and glib 2.36 is probably going to be most up-to-date linux distribution in the world, matching arch testing repository for example. After releasing this new iso, versions of those and others main system libraries will be locked, you can think of it as long term support. So later In version 4 I will update programs like evince, deadbeef or firefox, but gtk, glibc, libpng and other libraries version will not change. Off course idea is to not break compatibility with packages from the repository after every system update.
Back to top
View user's profile Send_private_message Visit_website 
ethan42411

Joined: 30 Mar 2013
Posts: 3

PostPosted: Sat 30 Mar 2013, 05:48    Post_subject:  

How to make file name can display in Chinese and Japanese?

I'm sorry for my English.
Back to top
View user's profile Send_private_message 
Arefacti

Joined: 10 Oct 2012
Posts: 165

PostPosted: Sat 30 Mar 2013, 06:30    Post_subject: very interesting !
Sub_title: internationalization
 

Hello,
very very interesting !
works well on my asus eeepc 1000H
curiously Firefox don't want to bookmark but opera yes !

It will be possible to get a international part on the alpha forum ? (for French, Deustch, Hispana and so on) ?

Thanks for your job, I LIKE Archlinux AND Puppy, great meeting !
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9159
Location: Stratford, Ontario

PostPosted: Sat 30 Mar 2013, 08:40    Post_subject: Re: very interesting !
Sub_title: internationalization
 

Arefacti wrote:
curiously Firefox don't want to bookmark

This works for me.

1. View > Toolbars > Bookmarks Toolbar

2. Right-click on the bookmarks toolbar and add a folder.

3. When you save a bookmark, make sure that you select your folder.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 10 of 47 Posts_count   Goto page: Previous 1, 2, 3, ..., 8, 9, 10, 11, 12, ..., 45, 46, 47 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1027s ][ Queries: 12 (0.0274s) ][ GZIP on ]