Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 29 Aug 2014, 08:25
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
alphaOS [closed]
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 15 of 47 [697 Posts]   Goto page: Previous 1, 2, 3, ..., 13, 14, 15, 16, 17, ..., 45, 46, 47 Next
Author Message
ndrancs


Joined: 02 Apr 2013
Posts: 40

PostPosted: Fri 05 Apr 2013, 18:09    Post subject: gt 430  

simargl wrote:
mike delaw wrote:
ATI RADEON 9550.

Please upload AlphaOS4 on Sourceforge ...

it's uploading Wink


hi simargl, Thanks for the version 4 without nouveau. Wink
i have a vga card, nvidia gt 430, and download the driver from here ftp://download.nvidia.com/XFree86/Linux-x86 after compile it succesfully, and run alphaosx, i see the desktop but my key and mouse not working, but the conky Uptime is working. i examine the xorg log file, #less /var/log/Xorg.0.log the keyboard and mouse are disable.

can i have glipper in googlecode repo? and ffmpeg with libvorbis, libmp3lame, libfaac, libaacplus,x264, like in arhhpup version.

current ffmpeg with so many disable feature:
Code:

[root@alphaos ~]# ffmpeg
ffmpeg version 1.1.4 Copyright (c) 2000-2013 the FFmpeg developers
  built on Mar 29 2013 10:03:43 with gcc 4.7.2 (alphaOS)
  configuration: --prefix=/usr --enable-shared --enable-runtime-cpudetect --enable-x11grab --enable-gpl --enable-postproc --enable-libfreetype --enable-zlib --disable-libvorbis --disable-avisynth --disable-bzlib --disable-frei0r --disable-gnutls --disable-libaacplus --disable-libass --disable-libcelt --disable-libopencore-amrnb --disable-libopencore-amrwb --disable-libopencv --disable-libcdio --disable-libdc1394 --disable-libfaac --disable-libgsm --disable-libmodplug --disable-libmp3lame --disable-libnut --disable-libopenjpeg --disable-libpulse --disable-librtmp --disable-libschroedinger --disable-libspeex --disable-libstagefright-h264 --disable-libtheora --disable-libutvideo --disable-libv4l2 --disable-libvo-aacenc --disable-libvo-amrwbenc --disable-libvpx --disable-libx264 --disable-libxavs --disable-libxvid --disable-openal --disable-debug --disable-yasm --disable-doc --disable-ffprobe --disable-ffserver --disable-static
  libavutil      52. 13.100 / 52. 13.100
  libavcodec     54. 86.100 / 54. 86.100
  libavformat    54. 59.106 / 54. 59.106
  libavdevice    54.  3.102 / 54.  3.102
  libavfilter     3. 32.100 /  3. 32.100
  libswscale      2.  1.103 /  2.  1.103
  libswresample   0. 17.102 /  0. 17.102
  libpostproc    52.  2.100 / 52.  2.100
Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...

Use -h to get full help or, even better, run 'man ffmpeg'


Thanks you very much, and sorry for my bad english.
Back to top
View user's profile Send private message 
Arefacti

Joined: 10 Oct 2012
Posts: 165

PostPosted: Sat 06 Apr 2013, 01:58    Post subject: problem openbox
Subject description: after xfce4
 

Hello

I tested XFCE4 and wanted to return to openbox.

So, I removed xfce4 packages and re start X
openbox start well but the menu had problems. Those windows appears and the applications don't start :

Invalid output from pipe-menu "openbox-menu /etc/xdg/menus/lxde-applications.menu"

Have you ideas please ?
Back to top
View user's profile Send private message 
ndrancs


Joined: 02 Apr 2013
Posts: 40

PostPosted: Sat 06 Apr 2013, 04:14    Post subject: Re: problem openbox
Subject description: after xfce4
 

Arefacti wrote:
Hello

I tested XFCE4 and wanted to return to openbox.

So, I removed xfce4 packages and re start X
openbox start well but the menu had problems. Those windows appears and the applications don't start :

Invalid output from pipe-menu "openbox-menu /etc/xdg/menus/lxde-applications.menu"

Have you ideas please ?


add this to kernel paramater:

Code:
pfix=purge
Back to top
View user's profile Send private message 
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Sat 06 Apr 2013, 04:29    Post subject:  

New packages added:

parcellite-1.1.4-1.spkg
Lightweight GTK+ clipboard manager

polkit-0.104-2.spkg
Toolkit for controlling system-wide privileges

gconf-3.2.6-1.spkg
A configuration database system
Back to top
View user's profile Send private message Visit poster's website 
ndrancs


Joined: 02 Apr 2013
Posts: 40

PostPosted: Sat 06 Apr 2013, 04:33    Post subject:  

simargl wrote:
New packages added:

parcellite-1.1.4-1.spkg
Lightweight GTK+ clipboard manager

polkit-0.104-2.spkg
Toolkit for controlling system-wide privileges

gconf-3.2.6-1.spkg
A configuration database system


hi simargl
thanks for the update, and how about ffmpeg, may i compile it myself?
Back to top
View user's profile Send private message 
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Sat 06 Apr 2013, 04:34    Post subject: Re: gt 430  

ndrancs wrote:
can i have glipper in googlecode repo? and ffmpeg with libvorbis, libmp3lame, libfaac, libaacplus,x264, like in arhhpup version.

glipper has too many python dependencies, so instead there is parcellite added to repository. I wanted to make ffmpeg small so maybe too much is disabled http://alphaos.freeforums.org/multimedia-codecs-missing-t36.html. will check that later.
Back to top
View user's profile Send private message Visit poster's website 
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Sat 06 Apr 2013, 04:40    Post subject:  

ndrancs wrote:
thanks for the update, and how about ffmpeg, may i compile it myself?

yes, please
I'm thinking to use configure options like here for next version (except --enable-nonfree)
http://crux.nu/ports/crux-3.0/contrib/ffmpeg/Pkgfile
Back to top
View user's profile Send private message Visit poster's website 
Arefacti

Joined: 10 Oct 2012
Posts: 165

PostPosted: Sat 06 Apr 2013, 06:52    Post subject: Re: problem openbox
Subject description: after xfce4
 

ndrancs wrote:
Arefacti wrote:
Hello

I tested XFCE4 and wanted to return to openbox.

So, I removed xfce4 packages and re start X
openbox start well but the menu had problems. Those windows appears and the applications don't start :

Invalid output from pipe-menu "openbox-menu /etc/xdg/menus/lxde-applications.menu"

Have you ideas please ?


add this to kernel paramater:

Code:
pfix=purge


Thanks ndrancs, but don't work
Back to top
View user's profile Send private message 
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Sat 06 Apr 2013, 06:58    Post subject:  

commit history https://bitbucket.org/simargl/alphaos
Quote:
Up: ffmpeg (1.2)
add: libdvdread 4.2.0
add: libdvdnav 4.2.0
add: libbluray 0.2.3
add: faad2 2.7
add: xvidcore 1.3.2
add: x264 20130206
add: speex 1.2rc1
add: opencore-amr 0.1.3
add: libva 1.1.0
add: libtheora 1.1.1
add: lame 3.99.5


Quote:
[root@alphaos ~]# ffmpeg
ffmpeg version 1.2 Copyright (c) 2000-2013 the FFmpeg developers
built on Apr 6 2013 12:44:49 with gcc 4.7.2 (alphaOS)
configuration: --prefix=/usr --mandir=/usr/share/man --enable-vaapi --enable-gpl --enable-version3 --enable-avfilter --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libmp3lame --enable-libspeex --enable-libtheora --enable-libvorbis --enable-libx264 --enable-libxvid --enable-shared --enable-pthreads --enable-postproc --enable-x11grab --enable-small --disable-debug --disable-static --disable-doc --disable-htmlpages --disable-manpages
libavutil 52. 18.100 / 52. 18.100
libavcodec 54. 92.100 / 54. 92.100
libavformat 54. 63.104 / 54. 63.104
libavdevice 54. 3.103 / 54. 3.103
libavfilter 3. 42.103 / 3. 42.103
libswscale 2. 2.100 / 2. 2.100
libswresample 0. 17.102 / 0. 17.102
libpostproc 52. 2.100 / 52. 2.100
Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...

Use -h to get full help or, even better, run 'man ffmpeg'
[root@alphaos ~]#
Back to top
View user's profile Send private message Visit poster's website 
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Sat 06 Apr 2013, 07:00    Post subject: Re: problem openbox
Subject description: after xfce4
 

Arefacti wrote:
Hello

I tested XFCE4 and wanted to return to openbox.

So, I removed xfce4 packages and re start X
openbox start well but the menu had problems. Those windows appears and the applications don't start :

Invalid output from pipe-menu "openbox-menu /etc/xdg/menus/lxde-applications.menu"

Have you ideas please ?

Can you verify that lxde-applications.menu is in folder /etc/xdg/menus. Maybe try to remove /root/.cache it should force menu to recreate. And what is output "openbox-menu /etc/xdg/menus/lxde-applications.menu" in terminal

Cheers
Back to top
View user's profile Send private message Visit poster's website 
Arefacti

Joined: 10 Oct 2012
Posts: 165

PostPosted: Sat 06 Apr 2013, 07:41    Post subject: Re: problem openbox
Subject description: after xfce4
 

simargl wrote:
Arefacti wrote:
Hello

I tested XFCE4 and wanted to return to openbox.

So, I removed xfce4 packages and re start X
openbox start well but the menu had problems. Those windows appears and the applications don't start :

Invalid output from pipe-menu "openbox-menu /etc/xdg/menus/lxde-applications.menu"

Have you ideas please ?

Can you verify that lxde-applications.menu is in folder /etc/xdg/menus. Maybe try to remove /root/.cache it should force menu to recreate. And what is output "openbox-menu /etc/xdg/menus/lxde-applications.menu" in terminal

Cheers


Hello, Simargl
thanks for your answer.
I had a save, so I use it !
Back to top
View user's profile Send private message 
ndrancs


Joined: 02 Apr 2013
Posts: 40

PostPosted: Sat 06 Apr 2013, 17:51    Post subject:  what  

simargl wrote:
commit history https://bitbucket.org/simargl/alphaos
Quote:
Up: ffmpeg (1.2)
add: libdvdread 4.2.0
add: libdvdnav 4.2.0
add: libbluray 0.2.3
add: faad2 2.7
add: xvidcore 1.3.2
add: x264 20130206
add: speex 1.2rc1
add: opencore-amr 0.1.3
add: libva 1.1.0
add: libtheora 1.1.1
add: lame 3.99.5


Quote:
[root@alphaos ~]# ffmpeg
ffmpeg version 1.2 Copyright (c) 2000-2013 the FFmpeg developers
built on Apr 6 2013 12:44:49 with gcc 4.7.2 (alphaOS)
configuration: --prefix=/usr --mandir=/usr/share/man --enable-vaapi --enable-gpl --enable-version3 --enable-avfilter --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libmp3lame --enable-libspeex --enable-libtheora --enable-libvorbis --enable-libx264 --enable-libxvid --enable-shared --enable-pthreads --enable-postproc --enable-x11grab --enable-small --disable-debug --disable-static --disable-doc --disable-htmlpages --disable-manpages
libavutil 52. 18.100 / 52. 18.100
libavcodec 54. 92.100 / 54. 92.100
libavformat 54. 63.104 / 54. 63.104
libavdevice 54. 3.103 / 54. 3.103
libavfilter 3. 42.103 / 3. 42.103
libswscale 2. 2.100 / 2. 2.100
libswresample 0. 17.102 / 0. 17.102
libpostproc 52. 2.100 / 52. 2.100
Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...

Use -h to get full help or, even better, run 'man ffmpeg'
[root@alphaos ~]#


what exactly is the difference between versions 1.1.4 and 1.2, I would have seen this when downloading in ffmpeg.org yesterday. maybe you know?

if I'm not mistaken, I think mplayer2 must be recompiled as well?

Okay, I'll try to download this commit, to see if it can be directly applied in version 4.
Back to top
View user's profile Send private message 
Arefacti

Joined: 10 Oct 2012
Posts: 165

PostPosted: Mon 08 Apr 2013, 02:11    Post subject:  Print  

Hello !

what about the rcrsn51's proposition ?

http://murga-linux.com/puppy/viewtopic.php?t=84870&start=135

I want to print with a lexmark S305 wifi, and the lexmark_inkjet_legacy-1.0.1.pet was working perfectly.

Cheers
Back to top
View user's profile Send private message 
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Mon 08 Apr 2013, 03:34    Post subject:  

I've tested some audio and video formats with new mplayer
.mp4
.ogg (works in deadbeef)
.ogv
.flv
.avi
.mov
.mpg
.swf

.wmv
.wma

Personally I couldn't care less for wmv and wma, what is your opinion. Maybe you have idea what is missing to make them work (some DLL file) , terminal output is bellow
Code:
[root@alphaos test_media]# mplayer testing.wma
MPlayer2 UNKNOWN (C) 2000-2012 MPlayer Team

Playing testing.wma.
Detected file format: asf (libavformat)
[lavf] stream 0: audio (wmav2), -aid 0, -alang eng
Clip info:
 WM/ToolName: Cool Edit Pro
 WM/ToolVersion: 2.01.3097.0
 WMFSDKVersion: 9.00.00.2980
 WMFSDKNeeded: 0.0.0.0000
 IsVBR: 0
 DeviceConformanceTemplate: L2
 WM/WMADRCPeakReference: 23197
 WM/WMADRCAverageReference: 3216
Load subtitles in .
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
Unsupported sample format
Unsupported sample format
ADecoder init failed :(
Could not open audio decoder ffmpeg.
Opening audio decoder: [dmo] Win32/DMO decoders
Win32 LoadLibrary failed to load: /usr/lib/codecs/wmadmod.dll
IMediaObject ERROR: 0x82a51ec  could not open DMO DLL (0x0 : 0)
ERROR: Could not open required DirectShow codec wmadmod.dll.
ADecoder preinit failed :(
Could not open audio decoder dmo.
Opening audio decoder: [acm] Win32/ACM decoders
Loading codec DLL: 'divxa32.acm'
Win32 LoadLibrary failed to load: /usr/lib/codecs/divxa32.acm
Can't open library divxa32.acm
ACM_Decoder: Unappropriate audio format
Could not load/initialize Win32/ACM audio codec (missing DLL file?).
ADecoder preinit failed :(
Could not open audio decoder acm.
Cannot find codec for audio format 0x161.
Audio: no sound
Video: no video


Exiting... (End of file)
Back to top
View user's profile Send private message Visit poster's website 
ndrancs


Joined: 02 Apr 2013
Posts: 40

PostPosted: Mon 08 Apr 2013, 03:51    Post subject: win32 codec  

perhaps this codec?
http://www.mplayerhq.hu/MPlayer/releases/codecs/
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 15 of 47 [697 Posts]   Goto page: Previous 1, 2, 3, ..., 13, 14, 15, 16, 17, ..., 45, 46, 47 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1148s ][ Queries: 12 (0.0141s) ][ GZIP on ]