Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 16 Dec 2017, 01:48
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Games
steam
Post new topic   Reply to topic View previous topic :: View next topic
Page 5 of 6 [85 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Author Message
Aminux

Joined: 23 May 2013
Posts: 8

PostPosted: Fri 19 Dec 2014, 15:01    Post subject:  

Its installed but doesnt run, for some reason...
Im using an amd card, could that be the reason.
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3149
Location: wales

PostPosted: Fri 19 Dec 2014, 15:05    Post subject:  

runs on my inbuilt amd graphics ...

when you installed it and it asked you if you wanted to move it .... did you answer yes or no?

if you answered yes ....what partition type is your puppy on? ext3, ext4, ntfs, fat?
if you answered no ... do you have a save file or save folder?

i need to update the install message as it's a bit confusing!!

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Xenialpup64, ibuilt with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
Aminux

Joined: 23 May 2013
Posts: 8

PostPosted: Fri 19 Dec 2014, 15:11    Post subject:  

666philb wrote:
runs on my inbuilt amd graphics ...

when you installed it and it asked you if you wanted to move it .... did you answer yes or no?

if you answered yes ....what partition type is your puppy on? ext3, ext4, ntfs, fat?
if you answered no ... do you have a save file or save folder?

i need to update the install message as it's a bit confusing!!



I moved it, puppy linux is installed on hd frugal install ext4 partition.
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3149
Location: wales

PostPosted: Fri 19 Dec 2014, 15:22    Post subject:  

click the home/file icon top left.... then click the 'eye' to show hidden files and look in /.local/share. there should be a steam folder symlink. (if it's a triangle with red writing let me know)

try running it in a terminal

Code:
steam

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Xenialpup64, ibuilt with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
Aminux

Joined: 23 May 2013
Posts: 8

PostPosted: Fri 19 Dec 2014, 21:12    Post subject:  

I have figured out what the problem was, low ram since i only have 2gb of memory, it starts to update when running on a live usb, but then ram is used up and so it closes steam.
I tried to do a full install to solve the ram prob and now am facing a new issue, i get kernel panics everytime i try boot from hd when a full install is performed.
If i try a Frugal install, i have about 1gb ram left but steam doesnt run, for some unknown reason to me.
Back to top
View user's profile Send private message 
linuxcbon

Joined: 09 Aug 2007
Posts: 1165

PostPosted: Wed 24 Dec 2014, 20:16    Post subject:  

hi,
I still cant make it work. Can you please tell us the exact steps how to make it run ?
Here is what i tried in precise 5.7.1
- install devx
- install steam.pet
- click : menu fun steam
- close agreement text and agree "yes"
- click : menu fun steam
--> a window appears and disappears quickly
Code:
# steam
Unable parse command line: Unknown option --question
Setting up Steam content in /root/.local/share/Steam
mkdir: can't create directory '/root/.local/share/Steam': No such file or directory
/usr/bin/steam: line 98: cd: /root/.local/share/Steam: No such file or directory

thanks
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3149
Location: wales

PostPosted: Fri 26 Dec 2014, 18:20    Post subject:  

check in /root/.local/share see if there's a broken steam symlink there ... if so delete it and try running it again
_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Xenialpup64, ibuilt with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
linuxcbon

Joined: 09 Aug 2007
Posts: 1165

PostPosted: Fri 26 Dec 2014, 22:17    Post subject:  

666philb wrote:
check in /root/.local/share see if there's a broken steam symlink there ... if so delete it and try running it again

Yes there is a broken steam symlink there. I deleted it and then run steam, it downloaded the update correctly. Can you correct the pet for it maybe ?
Back to top
View user's profile Send private message 
Griot


Joined: 12 Sep 2014
Posts: 131
Location: Serbia

PostPosted: Tue 19 May 2015, 13:39    Post subject:  

Hi, phillb & folks.

Here's what I got from urxvt when typed steam. I'm using Precise 5.71, save2dir option.

Code:
# steam
  File "/usr/bin/steamdeps", line 367
   
    ^
SyntaxError: EOF while scanning triple-quoted string literal
Running Steam on Linux 3.9.11 32-bit
STEAM_RUNTIME is enabled automatically
/initrd/mnt/dev_save/Steam/steam.sh: line 730:  7734 Illegal instruction     $STEAM_DEBUGGER "$STEAMROOT/$STEAMEXEPATH" "$@"
mv: cannot stat `/root/.steam/registry.vdf': No such file or directory
Installing bootstrap /initrd/mnt/dev_save/Steam/bootstrap.tar.xz
Reset complete!
Restarting Steam by request...
  File "/usr/bin/steamdeps", line 367
   
    ^
SyntaxError: EOF while scanning triple-quoted string literal
Running Steam on Linux 3.9.11 32-bit
STEAM_RUNTIME has been set by the user to: /initrd/mnt/dev_save/Steam/ubuntu12_32/steam-runtime
/initrd/mnt/dev_save/Steam/steam.sh: line 730:  7861 Illegal instruction     $STEAM_DEBUGGER "$STEAMROOT/$STEAMEXEPATH" "$@"


Well, NO, there is no line 367 in file
Code:
/usr/bin/steamdeps
'cause script ends at line 366. Confused
YES, there are many triple-quoted strings in file
Code:
/initrd/mnt/dev_save/Steam/steam.sh:
for whatever reason.
Dunno... :dummy-noob:
Would you... Thanks! Wink
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3149
Location: wales

PostPosted: Thu 21 May 2015, 04:19    Post subject:  

hi Griot

i've just tried the steam.pet on a vanilla precise and it worked fine for me

check in /root/.local/share and see if there's a broken symlink

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Xenialpup64, ibuilt with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
Griot


Joined: 12 Sep 2014
Posts: 131
Location: Serbia

PostPosted: Thu 21 May 2015, 07:42    Post subject:  

Hi, Phil. Thanks for your reply.

No, link is ok and it points to /mnt/home/Steam. I checked all dirs in
~/.steam and found a few broken symlinks there.

File '4.6.3' symlink to '4.6' @
Code:
/root/.steam/bin32/steam-runtime/i386/usr/lib/gcc/i686-linux-gnu/
==> File doesn't exist.

Two broken links here
Code:
/root/.steam/bin32/steam-runtime/i386/usr/share/doc/
'libgcc1' and 'libstdc++6' both pointed to 'gcc-4.6-base' ==>File doesn't exist.

These two 'bin64' and 'sdk64 '@ /root/.steam/ are also broken, both pointing to non-existing file /root/.steam/sdk64. I guess the latter are not essential for my 32-bit CPU?

I've also checked Steam dependencies and they're fine.
That's it - ideas no more. Confused

Cheers!
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3149
Location: wales

PostPosted: Thu 21 May 2015, 08:14    Post subject:  

what partition type is /mnt/home ... fat ext ntfs?
_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Xenialpup64, ibuilt with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
Griot


Joined: 12 Sep 2014
Posts: 131
Location: Serbia

PostPosted: Thu 21 May 2015, 08:20    Post subject:  

All partitions are ext3.
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 3149
Location: wales

PostPosted: Tue 26 May 2015, 04:50    Post subject:  

hi griot

try booting live and then installing the steam.pet again. choose not to make the link to /mnt/home this time (as you can do it manually later)

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Xenialpup64, ibuilt with xenial xerus packages http://murga-linux.com/puppy/viewtopic.php?t=107331
Back to top
View user's profile Send private message 
PurpleMarble

Joined: 18 Jun 2015
Posts: 13
Location: Canada

PostPosted: Fri 19 Jun 2015, 14:17    Post subject:  

Is there a way to run it as spot? Since it doesn't seem safe running as root, so I don't think I will be using it.

EDIT: I don't want to risk running as root.

Last edited by PurpleMarble on Thu 15 Oct 2015, 20:51; edited 2 times in total
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 5 of 6 [85 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Games
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1140s ][ Queries: 14 (0.0262s) ][ GZIP on ]