Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 23 Apr 2014, 06:28
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
PUI Issue/Problem
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [7 Posts]  
Author Message
nic2109

Joined: 01 Jan 2007
Posts: 406
Location: Hayslope, near Middlemarch, Midlands, England

PostPosted: Mon 01 Apr 2013, 10:43    Post subject:  PUI Issue/Problem
Subject description: Puppy Universal Installer doesn't create bootable USB Flash Drive
 

I have tried using PUI to install Precise Puppy to a USB Flash drive but without success. Every attempt led to 'No Operating System'.

I've tried FAT16, FAT32, EXT2, EXT3 and EXT4 partitions but all are the same. It's an HP Pavilion DM1 which boots quite happily from EXT2 into Lucid Puppy and to Fatdog64 from EXT4.

Both 5.4.1 and 5.5 versions of Precise Puppy present the same problem.

Nick
Back to top
View user's profile Send private message 
darkcity


Joined: 23 May 2010
Posts: 2411
Location: near here

PostPosted: Mon 01 Apr 2013, 17:51    Post subject:  

Which Puppy are you using to the PUI on?

ie. are you using-

Precise 5.4.1 to Install Precise 5.4.1 to USB flash drive
Precise 5.5 to Install Precise 5.5 to USB flash drive

When you partitioned the USB did you flag it as bootable, and your BIOS is set to boot from USB flash?

Is it the same model of flash drive you have known to work with Lucid and fatdogg?

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send private message Visit poster's website 
rcrsn51


Joined: 05 Sep 2006
Posts: 8563
Location: Stratford, Ontario

PostPosted: Mon 01 Apr 2013, 19:28    Post subject: Re: PUI Issue/Problem
Subject description: Puppy Universal Installer doesn't create bootable USB Flash Drive
 

nic2109 wrote:
Every attempt led to 'No Operating System'.

That sounds like you haven't installed a boot loader.

Run Grub4Dos Bootloader Config.

Make sure that you pick your flash drive, not your main hard drive as the target device.
Back to top
View user's profile Send private message 
nic2109

Joined: 01 Jan 2007
Posts: 406
Location: Hayslope, near Middlemarch, Midlands, England

PostPosted: Tue 02 Apr 2013, 17:07    Post subject: PUI Issues
Subject description: PUI Issues
 

darkcity wrote:
Which Puppy are you using to the PUI on?

ie. are you using-

Precise 5.4.1 to Install Precise 5.4.1 to USB flash drive
Precise 5.5 to Install Precise 5.5 to USB flash drive



I booted from a live CD each time: 5.4.1 or 5.5

darkcity wrote:
When you partitioned the USB did you flag it as bootable, and your BIOS is set to boot from USB flash?



Yes, the USB drive has its Boot flag set, and yes I chose the appropriate boot device.

darkcity wrote:

Is it the same model of flash drive you have known to work with Lucid and fatdogg?

No; it's a different model, but both are Sandisk "Cruser" drives. I've installed loads of puppies onto USB flash drives and never had this issue before.

_________________
Nick
Back to top
View user's profile Send private message 
nic2109

Joined: 01 Jan 2007
Posts: 406
Location: Hayslope, near Middlemarch, Midlands, England

PostPosted: Tue 02 Apr 2013, 17:09    Post subject: Re: PUI Issue/Problem
Subject description: Puppy Universal Installer doesn't create bootable USB Flash Drive
 

rcrsn51 wrote:
nic2109 wrote:
Every attempt led to 'No Operating System'.

That sounds like you haven't installed a boot loader.

Run Grub4Dos Bootloader Config.

Make sure that you pick your flash drive, not your main hard drive as the target device.


Thanks. I've never had to do that before, but will give it a try.

_________________
Nick
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 434

PostPosted: Sat 06 Apr 2013, 00:59    Post subject:  

What about Mbr? I use to put mbr on the usbflash by syslinux package. I previously use Fat32 e boot option by gparted before launching Universal Installer.
Back to top
View user's profile Send private message 
nic2109

Joined: 01 Jan 2007
Posts: 406
Location: Hayslope, near Middlemarch, Midlands, England

PostPosted: Mon 08 Apr 2013, 17:32    Post subject: Re: PUI Issue/Problem
Subject description: Puppy Universal Installer doesn't create bootable USB Flash Drive
 

nic2109 wrote:
rcrsn51 wrote:
nic2109 wrote:
Every attempt led to 'No Operating System'.

That sounds like you haven't installed a boot loader.

Run Grub4Dos Bootloader Config.

Make sure that you pick your flash drive, not your main hard drive as the target device.


Thanks. I've never had to do that before, but will give it a try.


Thanks. That worked just fine. It's even better than I've been used to as now if I plug in the flash drive before booting I get the Grub menu and can choose whether to use Puppy or Windoze whereas in the past I've had to catch it at the right moment and select the boot device.

Hurrah! And thanks for the tip. Very Happy

_________________
Nick
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [7 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0505s ][ Queries: 11 (0.0031s) ][ GZIP on ]