Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 09:34
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Games
Where can I get SDL libraries for Flare? (Solved)
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 2 of 2 Posts_count   Goto page: Previous 1, 2
Author Message
muggins

Joined: 20 Jan 2006
Posts: 6688
Location: lisbon

PostPosted: Fri 26 Apr 2013, 12:28    Post_subject:  

Just booted p528, without save file, installed SDL.pet, then sfs_loaded flare sfs, and it runs with no complaints whatsoever.

Perhaps, if you opened a console & entered flare, some errors might give some clues why it's not working for you.
Back to top
View user's profile Send_private_message 
wimpy


Joined: 22 Aug 2012
Posts: 302
Location: Essex, UK

PostPosted: Fri 26 Apr 2013, 12:51    Post_subject:  

muggins wrote:
Just booted p528, without save file, installed SDL.pet, then sfs_loaded flare sfs, and it runs with no complaints whatsoever.

Perhaps, if you opened a console & entered flare, some errors might give some clues why it's not working for you.

Which SDLpet did you use? I did get rid of a SDL file in order to get Freeciv to run properly. Freeciv works fine at the moment. I thought the flare-0.18.sfs file contained all the required sdl files. Is there any particular directory I should be in on the console when typing flare.

_________________
Lucid ,Precise, Carolina, Shiba_inu, Lx_pup - all frugal
Back to top
View user's profile Send_private_message 
muggins

Joined: 20 Jan 2006
Posts: 6688
Location: lisbon

PostPosted: Sat 27 Apr 2013, 04:20    Post_subject:  

I forgot that the flare sfs I uploaded already has SDL libraries bundled with it. I just rebooted p528 in ram mode & it runs fine.

You don't need to be in any particular directory to run flare.
Back to top
View user's profile Send_private_message 
wimpy


Joined: 22 Aug 2012
Posts: 302
Location: Essex, UK

PostPosted: Sat 27 Apr 2013, 08:42    Post_subject:  

Typing <flare> in the termnal does nothing - just "command not found".
I can't get it to work in my vanilla 5.2.8 (just the CD) either. Using the vanilla 5.2.8 , I end up with a blank screen so that I have to use the xorgwizard to set the screen resolution and driver.
The recommended resolution for my monitor is 1920x1080 but the wizard will invariably set something lower, presumably using vesa.
Thanks again for your help. I can get get it to work in Slacko, so, if I feel a desperate urge to play the game, I can always boot that up. Smile
EDIT: I tried typing <flare> in the vanilla 5.2.8 and got a missing libpng.so.3 (which seems to come via a link from libpng 12 - http://208.109.22.214/puppy/viewtopic.php?t=68875&sid=6608f11127b5b78534fe3d922091532d). libpng12, itself, seems to be part of the SDL.pet which I removed, - it interfered with the sdl packs required for freeciv.

_________________
Lucid ,Precise, Carolina, Shiba_inu, Lx_pup - all frugal
Back to top
View user's profile Send_private_message 
muggins

Joined: 20 Jan 2006
Posts: 6688
Location: lisbon

PostPosted: Sat 27 Apr 2013, 11:47    Post_subject:  

Which freeciv version did you install? I installed Scottman's version, (from this thread), and it runs fine with the SDL libraries from the flare sfs, and with the libpng.so.3 link.

I suspect the problems you're having are due to SDL incompatibilities and maybe leftover stuff from the previous flare.

Try booting a fresh install of lupu528, into ram with pfix=ram, then sfs_load the flare sfs, then install scottman's freeciv, and I'm sure they'll both work.
Back to top
View user's profile Send_private_message 
wimpy


Joined: 22 Aug 2012
Posts: 302
Location: Essex, UK

PostPosted: Sat 27 Apr 2013, 15:47    Post_subject:  

Yes. The version I have is from the thread you mention.. I have three versions of Lucid 5.2.8. The main version (contains all my applications such as FF, TB, printing through network etc.), a test version with just FF, and the vanilla one which runs straight of the closed iso CD and doesn't save to the USB stick. The first 2 have 2fs save files on the stick. I'll try the pfix=ram on the vanilla version and report back. But since the vanilla version does not (to my knowledge) have any SDL libraries loaded, I would have expected flare*.sfs to have worked fine without any incompatibilities.
EDIT: I tried pfix=ram at the boot prompt but it came back with a message that it couldn't find the kernel files. It then proceeded to load vmlinuz and initrd and offer in its usual way a choice of the the 3 versions: no personal file, the main personal 2fs file and the test personal 2fs. Sad

_________________
Lucid ,Precise, Carolina, Shiba_inu, Lx_pup - all frugal
Back to top
View user's profile Send_private_message 
muggins

Joined: 20 Jan 2006
Posts: 6688
Location: lisbon

PostPosted: Sat 27 Apr 2013, 18:34    Post_subject:  

Yes, if you select "no personal file", then you'll be running lupu in RAM. Yes, the flare sfs already has the relevant SDL library files.

Could any other forum members try booting lupu into RAM, sfsloading the flare sfs & verify whether or not it works for them?
Back to top
View user's profile Send_private_message 
wimpy


Joined: 22 Aug 2012
Posts: 302
Location: Essex, UK

PostPosted: Sun 28 Apr 2013, 05:10    Post_subject:  

I booted the vanilla lucid 5.2.8, added your SDL.pet and linked libpng12.so.0.42.0 and libpng.so.3. I used sfs-load on the flare sfs and it then worked fine. The problem at the moment is that, on my main Lucid 5.2.8, sfs -load says it is updating the menu but doesn't. I'm not sure how to to create a Menu entry or what to point it to wrt the loaded sfs file..
_________________
Lucid ,Precise, Carolina, Shiba_inu, Lx_pup - all frugal
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 2 of 2 Posts_count   Goto page: Previous 1, 2
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Games
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0583s ][ Queries: 11 (0.0072s) ][ GZIP on ]