Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 10:36
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
Random computer freeze with Puppy Precise 5.28/5.5
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
rrolsbe

Joined: 15 Nov 2006
Posts: 182

PostPosted: Sat 18 May 2013, 15:47    Post_subject:  Random computer freeze with Puppy Precise 5.28/5.5
Sub_title: Not sure what is causing Puppy Precise to lockup
 

Update: The /etc/X11/xorg.conf file (attached) works until acpi=off boot option is issued. Replaced with original xorg.conf from sfs file and now it boots using acpi=off.

Experts

I have a new Dell Inspiron 15Z Special Edition (7520) laptop with hybrid Graphics. I am fighting a very random freezing problem while booted into Puppy Precise.

I believe the problem might be that Puppy Precise is trying to use both the Intel HD4000 and ATI Radeon HD7730M graphics (Not sure)

I had a lockup problem using Puppy Precise 5.28 until I started booting with the "puppy acpi=off" this seems to have fixed the VERY random lockup problem. I did some trouble shooting before trying the acpi=off boot option, so something else might be involved in the 5.28 fix. Not sure exactly what this did to fix the problem? Note: I also could not adjust the screen brightness using the (Fn+F4/F5) hot keys until I added the acpi-=off boot option.

I am having the same VERY random lockup problem with Puppy Precise 5.5 (same kernel as Precise 5.28 version 3.2.29); however, When I use the acpi=off boot option, it does NOT successfully boot into the graphical Puppy desktop.

As I do not require high-end graphics, using the Intel HD4000 graphics would be sufficient. I am creating a Custom Puppy boot DVD (Using Precise 5.5) that I hope will boot and and not lockup on several different laptop models; therefore, to remain generic, I hope a simple boot option (if required) will solve the lockup problem.

Puppy Presice 5.28/5.5 both drain the battery VERY quickly! Not sure what is causing this? Booting Mint 14 (Ubuntu based) on the Dell (7520) has never given me any problems (I verified it is using the ATI Radeon xorg).

Any help solving the random lockup problem would be GREATLY appreciated. Any other Puppy Precise/Dell 7520 advice would also be appreciated.

Regards, Ron
xorg.conf_acpi-off_broke.gz
Description  I was using this attached xorg.conf booting from the ISO in VirtualBox for testing. Not I am booting from a boot CD on bare metal.
gz

 Download 
Filename  xorg.conf_acpi-off_broke.gz 
Filesize  2.2 KB 
Downloaded  65 Time(s) 
Back to top
View user's profile Send_private_message 
davids45


Joined: 26 Nov 2006
Posts: 652
Location: Chatswood, NSW

PostPosted: Sun 19 May 2013, 01:37    Post_subject: Also having very random "freezes" with recent kernel Pups
Sub_title: but very infrequent - maybe once a week
 

G'day rrolsbe,
Just to mention my very random but reasonably infrequent "freezes" with virtually all recent kernel Pups, say for the last six months?
The Pup boots up OK and runs well until the screen goes suddenly black and then a second later, I see a screen of white text messages. The computer still runs and in some cases completes the task it was doing when this happened. Sometimes I still have the mouse cursor but the keyboard is always dead as far as the computer is concerned.
I have not seen any pattern to the screen text messages (I look at those toward the bottom of the screen which I guess involve the last things happening before the freeze or loss of signal).
I did notice lines with "EIP......SS:ESP...." then "CR2..." surrounded by lots of numbers in a few cases. But not always - sometimes I recall seeing "acpi" in the last lines of text.
I'm assuming I have either a RAM or CPU/motherboard problem.
I did have a Radeon graphics card in this desktop but took that out and have been using the on-board Intel graphics for a month or so - but still get this infrequent "freeze".
Restarting (pressing the reset button) the just-frozen Pup seems to be quite OK and runs without further problem. I can't deliberately cause the freeze.
I think I see a freeze when running a "bigger" program (e.g. Libre Office, Seamonkey) but not with a simple game (e.g. solitaire, freecell) or just having the computer idling.
Full & Frugal Pups both show the problem.
I'm curious to hear of any similar experiences or of any advice as to what to try (or buy).
David S.
Back to top
View user's profile Send_private_message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Sun 19 May 2013, 06:17    Post_subject:  

I have not tested 5.5 yet so got curious that two of you
had problem. My computer is some 3 to 5 years old now.
HP/Compaq SR 5622 it has odd graphics too? G98 Geforce 9300GE
Which acts up sometimes but works good in Lupu 528-005 AFAIK.

So I try to install the Precise 5.5 now and tell the result where okay.

I could see the Eurovision song Contest 3 hours without any crash
and I looked at youtube no crash so it could be about your graphics there

_________________
I use Google Search on Puppy Forum
not an ideal solution though

Edited_time_total
Back to top
View user's profile Send_private_message 
ally


Joined: 19 May 2012
Posts: 852
Location: lincoln

PostPosted: Sun 19 May 2013, 16:20    Post_subject:  

hey rrolsbe

I had a similar issue with an acer 8935g crashing due to overheating

it too had switchable graphics, it was this that caused the problems, as soon as I disabled the dual graphics it resolved the problem

HTH

Smile
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0528s ][ Queries: 12 (0.0048s) ][ GZIP on ]