Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 02 Sep 2014, 02:54
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Racy 5.3 on USB-memory - won't boot
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [12 Posts]  
Author Message
turboscrew

Joined: 29 Nov 2011
Posts: 108

PostPosted: Sun 19 May 2013, 05:26    Post subject:  Racy 5.3 on USB-memory - won't boot
Subject description: puppy_racy_5.3.sfs is not found
 

What's wrong?
I installed racy 5.3 on an USB memory as it describes in the instructions (for windows):
http://puppylinux.org/wikka/InstallationFrugal

When I booted, I got the black dots, the two red dots then announcement that:
puppy_racy_5.3.sfs is not found.

In the ISO-file there was only PUPPY_RA.SFS which I renamed to puppy_racy_5.3.sfs on the USB memory, but still no luck. Same error.

[edit]
Oops, the numbers in the version were swapped. It should have been 5.3 not 3.5. Corrected that (and a couple of typos).

Last edited by turboscrew on Mon 20 May 2013, 07:03; edited 2 times in total
Back to top
View user's profile Send private message 
turboscrew

Joined: 29 Nov 2011
Posts: 108

PostPosted: Mon 20 May 2013, 06:32    Post subject:  

Ooops, I read one set of instructions, but not the other that very clearly says what's wrong:
http://puppylinux.com/flash-puppy.htm

It still doesn't find the "main" sfs.
The same problem with racy 5.5.

Racy 5.2.2 works fine.
(Is there anything easier to install than racy 5.2.2 on USB-stick?)
Back to top
View user's profile Send private message 
turboscrew

Joined: 29 Nov 2011
Posts: 108

PostPosted: Tue 21 May 2013, 03:51    Post subject:    

To put it in an other way: has something changed since racy 5.2.2 such that the directions for manual frugal install onto USB-stick using windows host doesn't apply anymore?

I followed the directions (here) and racy 5.2.2 installed fine (and runs fine on at least two laptops: Thinkpad T400 and a Fujitsu Siemens Amilo Li 2732 Very Happy ).

Racy 5.3 (or 5.5) didn't. It kept whining about puppy_racy_5.3.sfs (puppy_racy_5.5.sfs) not found.

I tried with images from nluug and ibiblio. The md5sums matched.
I used 7-zip (and Linux Mint) to extract the files to the USB stick.
(vmlinuz, initrd.gz and the "main" sfs)

What am I doing wrong?
syslinux.cfg doesn't seem to contain anything release-dependent.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9066
Location: Stratford, Ontario

PostPosted: Tue 21 May 2013, 06:40    Post subject:  

I just did a flash drive install of Racy 5.5 and it worked fine.

What does your syslinux.cfg file look like? Mine has

Code:
default vmlinuz initrd=initrd.gz pmedia=usbflash
Back to top
View user's profile Send private message 
turboscrew

Joined: 29 Nov 2011
Posts: 108

PostPosted: Tue 21 May 2013, 07:31    Post subject:  

Here's the whole thing:

Code:

###---for FLASH MEMORY drives only---###
ui menu.c32
prompt 0
timeout 20
ontimeout puppy
menu title SYSLINUX system loader

LABEL puppy
   MENU LABEL System GNU/Linux Puppy
   COM32 linux.c32
   KERNEL /vmlinuz
   INITRD /initrd.gz
   APPEND pmedia=usbflash pfix=fsck,copy pkeys=us boot_delay=0 bootmem_debug debug earlyprintk=vga,keep elevator=noop initcall_debug load_ramdisk=1 loglevel=7 max_loop=256 prompt_ramdisk=0 rootdelay=0 ro video=800x600 vmalloc=384M


With this same syslinux.cfg racy 5.2.2 works fine.

This is the directory listing of the USB stick:

Code:
L:\>dir
 Volume in drive L is KINGSTON
 Volume Serial Number is 3433-3231

 Directory of L:\

14.04.2010  22:54               166 autorun.inf
14.09.2011  12:07           361 248 unInstaller.exe
14.09.2011  12:07         1 934 624 urDrive.exe
21.05.2013  08:34     1 073 741 824 racysave-racy_522_save.3fs
19.05.2013  12:01               453 syslinux.cfg
17.11.2011  13:15         2 729 376 vmlinuz
20.05.2013  13:11        94 998 560 devx_racy_5.2.2.sfs
17.11.2011  13:15         1 801 209 initrd.gz
17.11.2011  13:21       112 013 344 puppy_racy_5.2.2.sfs
               9 File(s)  1 287 580 804 bytes
               0 Dir(s)   6 376 931 328 bytes free


Some of it seem to be windows stuff, but it hasn't bothered wit 5.2.2, so
I haven't removed that stuff.

If I replace the vmlinuz, initrd.gz and puppy_racy_5.2.2.sfs with the same from racy 5.3 or 5.5 ISO, it doesn't work.

If I then replace the files back to the ones from racy 5.2.2 ISO it works again.

(Added devx later and created the savefile.)

[edit]

Swapped to the racy 5.5 files and again:

Code:
L:\>dir
 Volume in drive L is KINGSTON
 Volume Serial Number is 3433-3231

 Directory of L:\

14.04.2010  22:54               166 autorun.inf
14.09.2011  12:07           361 248 unInstaller.exe
14.09.2011  12:07         1 934 624 urDrive.exe
19.05.2013  12:01               453 syslinux.cfg
02.03.2013  18:05         2 745 440 vmlinuz
02.03.2013  18:05         1 877 065 initrd.gz
02.03.2013  18:11       125 440 032 puppy_racy_5.5.sfs
               7 File(s)    132 359 028 bytes
               0 Dir(s)   7 532 154 880 bytes free


Quote:
Searcing for Puppy files......puppy_racy_5.5.sfs not found. Dropping out to initial-ramdisk console...


[some blabber about IBM trackpoint]
Quote:

# _


Where did you get the ISO-image?
I think the one I used now was from nluug.
The 5.3 was from ibiblio.
Back to top
View user's profile Send private message 
turboscrew

Joined: 29 Nov 2011
Posts: 108

PostPosted: Wed 22 May 2013, 09:24    Post subject:  

Wary 5.5 from ibiblio does the same thing.

BTW, I used windows :
"syslinux.exe -m -a X:"
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9066
Location: Stratford, Ontario

PostPosted: Wed 22 May 2013, 10:05    Post subject:  

Have you tried booting the flash drive on different machines?
Back to top
View user's profile Send private message 
turboscrew

Joined: 29 Nov 2011
Posts: 108

PostPosted: Wed 22 May 2013, 10:43    Post subject:  

Only racy 5.2.2. It seems to work. The other games were played on Thinkpad T400.

Could it be that the newer racy/wary versions need the /boot and /syslinux stuff? The Windows-version of setup doesn't make those directories, and no .c32-files are found on the USB stick. (Racy 5.2.2 still works fine.)
Back to top
View user's profile Send private message 
turboscrew

Joined: 29 Nov 2011
Posts: 108

PostPosted: Wed 22 May 2013, 16:54    Post subject:  

Tried racy 5.5 from ibiblio on the Fujitsu-Siemens - the same problem.

Is there a way to get the boot log onto the USB stick for later checking?
I think I saw something about not being able to load CMD32 or something...
Hard to say, because I can't scroll the console.
Back to top
View user's profile Send private message 
turboscrew

Joined: 29 Nov 2011
Posts: 108

PostPosted: Thu 23 May 2013, 02:10    Post subject:  

I looked at the init in initrd.gz and found that it logs in /tmp/puppy-file-search.log.
There was only:
Code:
ALLDRVS=
Back to top
View user's profile Send private message 
turboscrew

Joined: 29 Nov 2011
Posts: 108

PostPosted: Fri 24 May 2013, 08:27    Post subject:  

I tried to see what's wrong by adding some debugs into the "init"-script in the file "initrd.gz".

My debug-lines can be found by searching 'JAA' in the init-script.

I got:

/tmp/puppy-file-search.log:

Code:

JAA 1: PUPXXXSFS = puppy_racy_5.5.sfs DISTRO_PUPPYSFS = puppy_racy_5.5.sfs
JAA 12: PMEDIA =  PDEV1 =  PSUBDIR =  PUPSFS =
JAA 13: PMEDIA = usbflash PDEV1 =  PSUBDIR =  PUPSFS =
ALLDRVS=
JAA 14: PCPARTS0 =  PDEV1 =  PSUBDIR =  PUPSFS =
JAA 15: PCPARTS0 =  PDEV1 =  PSUBDIR =  PUPSFS =
JAA 16: PCPARTS0 =  PDEV1 =  PSUBDIR =  PUPSFS =
JAA 2: search func: param = ata PMEDIA = usbflash PCPART0 =
JAA 19: DROPOUT = puppy_racy_5.5.sfs


I had to manually "copy" from the display, because I didn't come up with any way to get the file out of the machine (memory).

I'm trying to boot from a Kingston G3 8GB USB-stick (pre-)formatted as FAT32.

Adding boot parameter "pdev1" (in the syslinux.cfg) doesn't help?
It only seems to do search on ATA (search_func parameter = "ata").

BTW there is a difference: in 5.2.2 init there are:
Code:
mount -t proc none /proc
mount -t sysfs none /sys
mount -t rootfs -o remount,rw rootfs /
ln -s /proc/mounts /etc/mtab #resize2fs,e2fsck need this.

a little after the boot parameter handling.
In 5.5 init those are in the beginning under an "if":

Code:
#120215 internationalize... (based on work by L18L)
if [ ! $1 ];then
 mount -t proc none /proc
 mount -t sysfs none /sys
 mount -t rootfs -o remount,rw rootfs /
 ln -s /proc/mounts /etc/mtab #resize2fs,e2fsck need this.
init.zip
Description 
zip

 Download 
Filename  init.zip 
Filesize  28.52 KB 
Downloaded  73 Time(s) 
Back to top
View user's profile Send private message 
turboscrew

Joined: 29 Nov 2011
Posts: 108

PostPosted: Mon 27 May 2013, 07:35    Post subject:  

I tried burning a CD, booting it and installing wit the installer from within the racy 5.5 onto the USB stick and it works fine.

I checked the results of the two ways, and the only difference seems to be the boot:

16 -r--r--r-- 1 jaa jaa 13671 May 27 07:19 racy_5.5_inst/ldlinux.sys
56 -r--r--r-- 1 jaa jaa 55296 May 19 11:51 racy_5.5/ldlinux.sys

and

syslinux.cfg:

Code:
cat racy_5.5/syslinux.cfg
###---for FLASH MEMORY drives only---###
ui menu.c32
prompt 0
timeout 20
ontimeout puppy
menu title SYSLINUX system loader

LABEL puppy
   MENU LABEL System GNU/Linux Puppy
   COM32 linux.c32
   KERNEL /vmlinuz
   INITRD /initrd.gz
   APPEND pmedia=usbflash pfix=fsck,copy pkeys=fi boot_delay=0 bootmem_debug debug earlyprintk=vga,keep elevator=noop initcall_debug load_ramdisk=1 loglevel=7 max_loop=256 prompt_ramdisk=0 rootdelay=0 ro video=800x600 vmalloc=384M

cat racy_5.5_inst/syslinux.cfg
default vmlinuz initrd=initrd.gz pmedia=usbflash pkeys=fi



Funny that racy 5.2.2 boots fine with the racy_5.5 stuff, but racy 5.5 doesn't.
Racy 5.5 boots with the racy_5.5_inst stuff fine.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [12 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0829s ][ Queries: 12 (0.0056s) ][ GZIP on ]