Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 31 Oct 2014, 03:46
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking
Share files (LAN) between two Puppy computers? [SOLVED]
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Author Message
PaulR

Joined: 04 May 2005
Posts: 246
Location: UK

PostPosted: Tue 28 May 2013, 12:42    Post_subject:  Share files (LAN) between two Puppy computers? [SOLVED]  

Most of what I've read on the forum deals with Windows to Puppy or vice versa or seems out of date - how do I set up a shared directory on a Puppy PC and connect to it from another Puppy?

I've tried YASSM with username 'root' and password '' and the correct host name but how do I set a directory as 'shared' ?(maybe to do with permissions/groups??).

Or do I need to install something else? This is on Slacko 5.5 btw.

Cheers

Paul

Edited_time_total
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9214
Location: Stratford, Ontario

PostPosted: Tue 28 May 2013, 12:45    Post_subject: Re: How to share files on a LAN between two Puppy computers  

PaulR wrote:
how do I set up a shared directory on a Puppy PC and connect to it from another Puppy?

I've tried YASSM with username 'root' and password '' and the correct host name but how do I set a directory as 'shared' ?(maybe to do with permissions/groups??)

YASSM is Samba client software - you need to set up a Samba server. Read here for a simple method.
Back to top
View user's profile Send_private_message 
PaulR

Joined: 04 May 2005
Posts: 246
Location: UK

PostPosted: Tue 28 May 2013, 13:04    Post_subject:  

Thanks, that was what I was expecting but I couldn't see any other way to share files except via FTP (but that's not very convenient).

I noticed samba 3.x and 4.0 in the repositories but didn't want to install anything unnecessarily.

I'll read up on that link.

Paul
Back to top
View user's profile Send_private_message 
PaulR

Joined: 04 May 2005
Posts: 246
Location: UK

PostPosted: Tue 28 May 2013, 13:13    Post_subject:  

That looks pretty straightforward.

Would it be possible to edit smb.conf such that an automatically mounted USB drive was shared? I'm trying to set up a single point to store all our home photos, videos, documents etc. and thought I could put them on a (large capacity) portable drive plugged into an old netbook PC and have that share the contents of the drive (a sort of DIY NAS!).

Performance isn't an issue as it would be for fairly infrequent access.

Paul
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9214
Location: Stratford, Ontario

PostPosted: Tue 28 May 2013, 13:28    Post_subject:  

PaulR wrote:
Would it be possible to edit smb.conf such that an automatically mounted USB drive was shared?

Just change "/mnt/home" to "/mnt/sdbx". You need to ensure that the drive is mounted before the server is started.
Back to top
View user's profile Send_private_message 
PaulR

Joined: 04 May 2005
Posts: 246
Location: UK

PostPosted: Tue 28 May 2013, 13:33    Post_subject:  

Excellent many thanks for the help. Again! Very Happy

Paul
Back to top
View user's profile Send_private_message 
PaulR

Joined: 04 May 2005
Posts: 246
Location: UK

PostPosted: Tue 28 May 2013, 14:24    Post_subject:  

The instructions worked with one minor alteration:

On the client I'm using YASSM's Samba share select. The 'server' value in 'samba-select.dat' needed setting to the server's hostname rather than the netbios name (pupserver). So, my client entry looks like this:

Code:
EeePC Share,root,woofwoof,pupshare,eeepc


Next up, auto-start the server and auto-mount the disk!

Paul
Back to top
View user's profile Send_private_message 
PaulR

Joined: 04 May 2005
Posts: 246
Location: UK

PostPosted: Tue 28 May 2013, 15:34    Post_subject:  

The auto-start script works fine but for some reason trying to mount a USB device within that script doesn't work.

After boot I can open a terminal and do 'mount /dev/sdb /mnt/sdb' and it mounts properly (and is accessible via YASSM!).

Any suggestions?

Paul
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9214
Location: Stratford, Ontario

PostPosted: Tue 28 May 2013, 18:08    Post_subject:  

PaulR wrote:
Any suggestions?

What is the line that you added to the auto-start script? Did you remove the # symbol?

Try putting a "sleep 5" command above the mount command.
Back to top
View user's profile Send_private_message 
PaulR

Joined: 04 May 2005
Posts: 246
Location: UK

PostPosted: Wed 29 May 2013, 07:17    Post_subject:  

Yes I uncommented the line Laughing , I'll try putting in the delay and see if that does it.

Paul
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9214
Location: Stratford, Ontario

PostPosted: Wed 29 May 2013, 07:43    Post_subject:  

rcrsn51 wrote:
What is the line that you added to the auto-start script?
Back to top
View user's profile Send_private_message 
PaulR

Joined: 04 May 2005
Posts: 246
Location: UK

PostPosted: Wed 29 May 2013, 12:19    Post_subject:  

Having just read up on the mount command, not fully understanding how Puppy's file system works and taking your hint I realise I'd made a mistake. I've corrected it and the device is now being mounted within the script.

Code:
mount /dev/sdb /mnt


does the trick.

Thanks once again for YASSM and the hand-holding!

Paul
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9214
Location: Stratford, Ontario

PostPosted: Wed 29 May 2013, 12:24    Post_subject:  

PaulR wrote:
Code:
mount /dev/sdb /mnt

That doesn't make any sense. It should look like
Code:
mount /dev/sdb1 /mnt/sdb1

If the mount point /mnt/sdb1 does not exist yet, you should use
Code:
mkdir /mnt/sdb1
mount /dev/sdb1 /mnt/sdb1
Back to top
View user's profile Send_private_message 
PaulR

Joined: 04 May 2005
Posts: 246
Location: UK

PostPosted: Wed 29 May 2013, 13:09    Post_subject:  

Well, as per my earlier post, I was using mount /dev/sdb /mnt/sdb (which worked from a terminal but not in the start up script). After reading several pages I gathered that the mount point (directory) had to exist but wasn't sure if I could create it under /mnt or if so whether it would be persistent across boots.

In any event mount /dev/sdb /mnt does work even if it's not supposed to!

If I look in /mnt it contains just the directories on the USB device. If I then mount sda1 that appears in the correct place... /mnt/sda1

That said I'd rather do it the right way so I'll create the directory and mount it 'properly'.

Paul
capture12306.png
 Description   
 Filesize   124.04 KB
 Viewed   576 Time(s)

capture12306.png

Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9214
Location: Stratford, Ontario

PostPosted: Wed 29 May 2013, 13:16    Post_subject:  

Your screen capture shows "sdb" instead of "sdb1". Maybe the device was formatted in some kind of "super-floppy" mode that does not have a partition table.

In that case, /dev/sdb would be correct.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 2 Posts_count   Goto page: 1, 2 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Networking
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0757s ][ Queries: 12 (0.0100s) ][ GZIP on ]