Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 28 Aug 2014, 03:28
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
Epson NX330
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [5 Posts]  
Author Message
W6LQR

Joined: 08 Jun 2005
Posts: 29
Location: Landers, California, U.S.A.

PostPosted: Mon 17 Jun 2013, 00:28    Post subject:  Epson NX330
Subject description: Epson driver not workiing
 

I am trying to install a Epson NX330 on an old Laptop running Lucid Puppy. The driver worked fine on an ACER Aspire running Mint Linux but not on a Compaq 700Z. Cups correctly recognizes the printer on the LAN but won't print.

Driver: Epson-stylus_NX330_Series-epson-driver.ppd.gz

What am I missing ?

Jerry - W6LQR
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9058
Location: Stratford, Ontario

PostPosted: Mon 17 Jun 2013, 06:13    Post subject: Re: Epson NX330
Subject description: Epson driver not workiing
 

W6LQR wrote:
Driver: Epson-stylus_NX330_Series-epson-driver.ppd.gz

That's not a driver - it's just a PPD file. Have you installed the whole Epson driver package? There is a link to it here.

For testing purposes, I would hook the printer directly to your Puppy machine by USB. Once you have the correct driver, you can try the network setup.
Back to top
View user's profile Send private message 
W6LQR

Joined: 08 Jun 2005
Posts: 29
Location: Landers, California, U.S.A.

PostPosted: Mon 17 Jun 2013, 14:29    Post subject: Epson NX330  

I should have mentioned I downloaded the .deb file from Epson and installed
in Lucid Puppy 5.2.5, no errors reported and said installed ok. It didn't show
in Cups list of printers though and there must be hundreds of them. oh for the
old days of dot matrix printers and Centronix standard!

Cups says then provide a PPD file which I did. I also connected directly to
the printer but still no luck.

"epson-inkjet-printer-201105w_1.0.0-1lsb3.2_i386.deb
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9058
Location: Stratford, Ontario

PostPosted: Mon 17 Jun 2013, 15:37    Post subject:  

That driver package won't work OOTB in Puppy. Hence the link I provided above. Did you read the thread directly under this one?
Back to top
View user's profile Send private message 
W6LQR

Joined: 08 Jun 2005
Posts: 29
Location: Landers, California, U.S.A.

PostPosted: Mon 17 Jun 2013, 18:44    Post subject: Epson NX330  

Problem solved !!

Used "epson_inkjet_printer_escpr-1.2.2" as you suggested and am now able to
print !!

Thank you
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [5 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0487s ][ Queries: 11 (0.0032s) ][ GZIP on ]