Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 22:56
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
How to use HP Laserjet 1020+ printer in Lucid 5.2.8?
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
Shanghai Ed

Joined: 23 Jun 2013
Posts: 3

PostPosted: Sun 23 Jun 2013, 21:45    Post_subject:  How to use HP Laserjet 1020+ printer in Lucid 5.2.8?  

I am a relative newcomer to Linux. I have had success using Ubuntu 12.04 on my desktop pc. Now I want to use Puppy on an old pc that is struggling to cope with Windows XP and Ubuntu.
I chose Lucid Puppy 5.2.8 which I installed onto a Toshiba 4GB usb memory stick.
My problem - I cannot get the printer working.
I used CUPS (Menu/Setup/CUPS Printer Wizard). All seemed to go well. I added the printer (HP LaserJet 1020 plus, connection usb://HP/LaserJet%201020), configured it’s settings, set it as my default printer. However, when I used the maintenance function to print a test page, CUPS said I was successful but my printer remained lifeless. I tried printing from abiword. Again CUPS says I was successful but nothing came out of my printer.
I checked on-line for help (http://www.murga-linux.com/puppy/viewtopic.php?t=59015)
I installed hplip_print-3.13.4.pet but without success.
The printer works with Windows XP, I did not try it with Ubuntu.
I would be grateful for any assistance with this matter.
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9203
Location: Stratford, Ontario

PostPosted: Sun 23 Jun 2013, 22:18    Post_subject:  

When you installed your LJ1020 in CUPS, you would have seen the note "requires proprietary plugin". The hplip_print-3.13.4.pet does not contain plugins, so you need to use the foo2xxx_rcrsn-2013.02.05.pet instead. It is discussed in the Help.
Back to top
View user's profile Send_private_message 
Shanghai Ed

Joined: 23 Jun 2013
Posts: 3

PostPosted: Sun 23 Jun 2013, 23:23    Post_subject:  

Thanks for your suggestion but...

I installed foo2xxx_rcrsn-2013.02.05.pet and ran the command "chmod 666 /dev/null"

Now the printer makes a "whiz whir" sound when I reboot the pc, which is more than it did before, but it still does not print. Neither from a test print from CUPS nor from attempting to print an abiword .odt

Previously I ran through CUPS several times before posting for help, I never received the "requires proprietary plugin" message.
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 24 Jun 2013, 02:30    Post_subject:  

I have HP LJ1020 and it works fine with foo2xxx pet. I have used old year 2009 foo2xxx pet, I havent had need to update.

I suggest you to start from fresh install so that installed hplip pet does not have any interference, as uninstalled it might still disturb.

Conclusion. You need just working foo2xxx pet and maybe restart X after installation, nothing else.
Back to top
View user's profile Send_private_message 
Shanghai Ed

Joined: 23 Jun 2013
Posts: 3

PostPosted: Mon 24 Jun 2013, 05:53    Post_subject:  

Problem solved.

First I tried as you suggested, but no luck.
Then I tried with Slack Puppy, no luck.
Then I discovered Precise Puppy and it worked fine.

As I said, I'm a relative newcomer to Linux. With the benefit of hindsight I suspect that after downloading the foo2 file I should have moved it to a specific file. I didn't. However, Precise Puppy seems to know where to put the file.

Thanks for your encouragement, it was good to know for certain that someone else had managed to get that model of printer working with Puppy.
Back to top
View user's profile Send_private_message 
greengeek

Joined: 20 Jul 2010
Posts: 2596
Location: New Zealand

PostPosted: Sun 04 Aug 2013, 02:45    Post_subject:  

I just stumbled across this thread while trying to install an HP LJ1015 (very similar to the 1020 I guess...) and saw the comment about Precise having detected the 1020 correctly, so I tried Precise 5.6.1 and sure enough all I had to do was run the cups printer wizard and go through the add printer screen and it automatically installed my LJ1015. (Cups test page showed that it was using "Cups+ Gutenprint v5.2.8-pre1" driver via cups 1.4.8 although the test page had the right margin missing so not quite perfect)

Then I thought I would try it with Lupuplus Libre (which is based on Lucid 5.2.8) and it also found the printer automatically - so possibly the extra files that were missing from Lucid 5.2.8 are already in place in Lupuplus Libre (which I think is Lucid 5.2.8 version-005) (Cups test page showed that it was using "hpcups 3.12.2 driver via cups 1.4.3" and the printout was perfectly aligned and looked good)

EDIT :Yes it seems that Lupuplus Libre does have extra HP files. Check out halfway down first post on this page:
http://murga-linux.com/puppy/viewtopic.php?t=70855
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9203
Location: Stratford, Ontario

PostPosted: Sun 04 Aug 2013, 03:27    Post_subject:  

greengeek wrote:
(very similar to the 1020 I guess...)

Actually it's not, despite HP's convoluted model numbering.

The 1020 requires additional plugin/firmware code. So you either need a full HPLIP package (like in Ubuntu) or the reverse-engineered foo2xxx.

The 1015 does not. So you can use either the open-source Gutenprint driver or a cut-down Puppy version of HPLIP.
Back to top
View user's profile Send_private_message 
greengeek

Joined: 20 Jul 2010
Posts: 2596
Location: New Zealand

PostPosted: Sun 04 Aug 2013, 14:12    Post_subject:  

Thanks for the clarification. In that case is it likely that LupuPlus Libre would still require the aforementioned packages manually added before it could support the 1020?
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9203
Location: Stratford, Ontario

PostPosted: Sun 04 Aug 2013, 16:13    Post_subject:  

greengeek wrote:
In that case is it likely that LupuPlus Libre would still require the aforementioned packages manually added before it could support the 1020?

Definitely. You have two choices.

1. I believe that LupuPlus Libre has lluamco's hpliplite package from here.. In which case, you can try his additional plugin installer.

2. Get the foo2xxx driver from here.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0595s ][ Queries: 11 (0.0051s) ][ GZIP on ]