Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 24 Apr 2014, 04:46
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Educational
How to use ANKI flashcard program in Precise 5.6? (Solved)
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [10 Posts]  
Author Message
giannis4

Joined: 28 Jun 2013
Posts: 62

PostPosted: Fri 28 Jun 2013, 09:45    Post subject:  How to use ANKI flashcard program in Precise 5.6? (Solved)  

Hello.I am a new user of Puppy Linux Precise 5.6 and I want to install a flashcard program called ANKI.I ve tried through PPM,installed the package with its dependencies but the problem is that ANKI is not running.I have also tried to install ANKI through its homepage website but again with no success.
Can somebody help me pls?I cant find any solution.
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1512
Location: wales

PostPosted: Fri 28 Jun 2013, 12:42    Post subject: Re: I need help with ANKI  

giannis4 wrote:
Hello.I am a new user of Puppy Linux Precise 5.6 and I want to install a flashcard program called ANKI.I ve tried through PPM,installed the package with its dependencies but the problem is that ANKI is not running.I have also tried to install ANKI through its homepage website but again with no success.
Can somebody help me pls?I cant find any solution.


hi giannis4, welcome to the forums...

i just tried installing anki from the precise PPM and running it in a terminal got
Code:
ImportError: No module named sip
so installed python-sip (type it in the find box) from the PPM and it fired up.

let me know how you get on

_________________
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
LÖVE2d, a collection of 27 lua gameshttp://www.murga-linux.com/puppy/viewtopic.php?t=76739
Back to top
View user's profile Send private message 
giannis4

Joined: 28 Jun 2013
Posts: 62

PostPosted: Fri 28 Jun 2013, 13:43    Post subject: Re: I need help with ANKI  

Thank you so much for helping me.It runs great.I am very grateful my friend.!!!!!
Back to top
View user's profile Send private message 
Dromeno

Joined: 12 Sep 2008
Posts: 534

PostPosted: Sat 12 Oct 2013, 08:55    Post subject: How to use ANKI in Carolina 1.0?  

I would like to install ANKI in Carolina. I have installed the anki-2.0.13.deb from the anki site, then sip and portaudio from Carolina's repository. Still something is missing, terminal reports:

Please build and install the PortAudio Python bindings first.
Traceback (most recent call last):
File "/usr/bin/anki", line 5, in <module>
import aqt
File "/usr/share/anki/aqt/__init__.py", line 6, in <module>
from aqt.qt import *
File "/usr/share/anki/aqt/qt.py", line 16, in <module>
from PyQt4.QtCore import *
ImportError: No module named PyQt4.QtCore
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1512
Location: wales

PostPosted: Sat 12 Oct 2013, 12:23    Post subject:  

hi dromeno,

that error is because you're missing python-qt4.... here's some other python stuff it requires ...


python (>= 2.6.6-7~)
python-beautifulsoup
python-qt4 (>= 4.4)
python-simplejson (>= 1.7.3)
python-sqlalchemy (>= 0.5.3)

i also needed python-sip and QT4

_________________
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
LÖVE2d, a collection of 27 lua gameshttp://www.murga-linux.com/puppy/viewtopic.php?t=76739
Back to top
View user's profile Send private message 
Dromeno

Joined: 12 Sep 2008
Posts: 534

PostPosted: Sun 13 Oct 2013, 02:38    Post subject: Is it something else?  

666philb,

Are you sure that is all what is missing? I have installed

python-qt4_4.7.2-0ubuntu1_i386.deb
python-simplejson_2.0.9-1build1_i386.deb

and the Python version of Carolina is 2.7.2

but the error message of the terminal stays the same:

Please build and install the PortAudio Python bindings first.
Traceback (most recent call last):
File "/usr/bin/anki", line 5, in <module>
import aqt
File "/usr/share/anki/aqt/__init__.py", line 6, in <module>
from aqt.qt import *
File "/usr/share/anki/aqt/qt.py", line 16, in <module>
from PyQt4.QtCore import *
ImportError: No module named PyQt4.QtCore
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1512
Location: wales

PostPosted: Mon 14 Oct 2013, 12:21    Post subject:  

hi dromeno,

i downloaded carolina to have a look and all i needed was ....

anki.deb from the anki website
pyqt and dependencies from carolinas PPM
i also had the devx installed

and it fired up

_________________
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
LÖVE2d, a collection of 27 lua gameshttp://www.murga-linux.com/puppy/viewtopic.php?t=76739
Back to top
View user's profile Send private message 
Dromeno

Joined: 12 Sep 2008
Posts: 534

PostPosted: Tue 15 Oct 2013, 04:44    Post subject: ANKI solved in Carolina  

666philb -thanks a lot! PyQT was the missing part!

(I have alwas problems with installing Python entities. I am struggeling with another one as well: qtqr, a tool for creating/decoding QR codes. Software is here:

http://ftp.telfort.nl/pub/mirror/ubuntu/ubuntu/pool/universe/q/qr-tools/

- do you happen to know how I install the qrtools part?
i.e. qr-tools_1.2-2.debian.tar.gz

I have installed the python qrtools and qtqr but I still get:

Traceback (most recent call last):
File "/usr/bin/qtqr", line 15, in <module>
from qrtools import QR
ImportError: No module named qrtools
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1512
Location: wales

PostPosted: Wed 16 Oct 2013, 06:42    Post subject:  

hi dromeno,

i did manage to get it to start (don't know if it fully works though) here's the list Smile ....

install the devx,

and the following from the PPM....

pyqt
python.dev
imagemagick
PIL (python imaging library)

then i installed the following debian squeeze i386 packages from here....http://pkgs.org/search/?keyword=zbar


I didn't install the pythonzbar & pythonzbarpygtk packages from there as i've found python packages not to mix well, they are usually better to be compiled and installed from the host machine.
You could try the two python packages from there to see if they work or do what i did .....

right click on these links and choose 'save link as'
https://bitbucket.org/pypa/setuptools/raw/bootstrap/ez_setup.py python setuptools installer
https://raw.github.com/pypa/pip/master/contrib/get-pip.pypython pip installer

run the scripts in a terminal eg... python ez_setup.py

once installed we can use pip, which is a python module installer ....
Code:
pip install zbar


your qr-tools package should hopefully run now ... by clicking on qtqr.py


_________________
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
LÖVE2d, a collection of 27 lua gameshttp://www.murga-linux.com/puppy/viewtopic.php?t=76739
Back to top
View user's profile Send private message 
giannis4

Joined: 28 Jun 2013
Posts: 62

PostPosted: Tue 29 Oct 2013, 08:09    Post subject:  

Hello.Now I am using the new puppy slacko 5.6 but ANKI is not in the PPM.I would like to install ANKI again but I dont know what I have to do.I am looking for some help.Thank you.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [10 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Educational
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0547s ][ Queries: 11 (0.0049s) ][ GZIP on ]