Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 09 Dec 2019, 02:09
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
How to get rtorrent to use magnet links
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [1 Post]  
Author Message

Joined: 02 Jan 2009
Posts: 179

PostPosted: Sun 30 Jun 2013, 02:31    Post subject:  How to get rtorrent to use magnet links  

I like rtorrent because unlike other torrent clients, it does not slow down my system or my internet connection.

So with magnet links becoming the standard for bitorrent use, I wanted rtorrent to use them with ease. There is actually a workaround by using free websites that convert magnet links to torrent files websites but I liked the challenge of avoiding them!

So first of all I ensured I had rtorrent 0.8.9 and the appropriate libtorrent pets installed.


Thanks to the user who posted those pets.

Earlier versions cannot support magnet links. With 0.8.9 users can press backspace and simply copy the link to the magnet file. This will place the "*.meta" file in rtorrent, but will not begin the download. Further steps are required.

I then created an .rtorrent.rc file with session directory and DHT enabled. Sample rc file:

However I was getting error messages. A little research told me rorrent works with magnet links via a standard called DHT, and that DHT needed bootstrapping to work. Bootstrapping could work in a few ways, such as downloading a torrent file with DHT mapping, like these:

I also tried a couple of other things, such as using a bash script and downloading well known open source torrent files like ubuntu.

For a long time nothing seemed to happen, the .meta files just sat in rtorrent without activity. Then after a few hours I tried to c+p the link to another magnet file and hey presto! It started!

I have since copied all this with another system with eventual success. I have no idea which of the above tactics actually made the difference however, so i welcome input from my more knowledgeable Puppy peers Smile
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [1 Post]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0244s ][ Queries: 11 (0.0047s) ][ GZIP on ]