Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 15 Sep 2019, 18:25
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
USB-Microphone Samson in Slacko 5.5
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [13 Posts]  
Author Message
sancxjo


Joined: 29 Apr 2013
Posts: 93
Location: Russia

PostPosted: Sat 06 Jul 2013, 04:32    Post subject:  USB-Microphone Samson in Slacko 5.5  

Hello to all!

Mined external microphone: Samson Q2U. But I do not understand how to set it up.
The idea I have to run the program and hear yourself in the headphones (Samson). Headphones working, microphone system to see, but there is no sound recording.
USB-microphone how to adjust?

In the alsamixer sliders according to the microphone is not one. Through the control center trying to change the sound settings has led to the fact that in general the sound disappeared and Skype began to fall at startup. I had to delete the configuration file and re-configure the system.

If I understand the configuration settings in file: /etc/init.d/10alsa
Here is the line I do not like:
Code:
set Mic 0% mute

Replacement
Code:
set Mic 90% unmute

did not help.
In alsamixer replacement cards default to Samson Q2U also fruitless. Confused
VLC installed the program and featured a microphone! Smile
It remains to understand where his slider, as the Mic in alsamixer does not affect him ...

Last edited by sancxjo on Sat 06 Jul 2013, 09:49; edited 2 times in total
Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 1999
Location: London, England

PostPosted: Sat 06 Jul 2013, 08:31    Post subject:  

If it is a USB microphone it will appear as a different soundcard on your system. With alsamixer you press F6 (I think) to select the soundcard and then choose the USB soundcard and press "Enter".

A new set of slider controls should appear which you can use to control the microphone settings. Remember that there are 2 different settings, the one for the volume of your microphone in your headphones is the "Playback" level setting, but the one for the volume you are SENDING to others (in Skype for example) is the "Capture" or "Recording" level setting.

_________________
Oscar in England

Back to top
View user's profile Send private message 
sancxjo


Joined: 29 Apr 2013
Posts: 93
Location: Russia

PostPosted: Sat 06 Jul 2013, 08:48    Post subject:  

These are the controls in my alsamixer:
Mic
Mic Boos
Mic Boost

Mic Boos - these are two channels on earphones?

If in alsamixer the card to establish Samson Q2U, the set of a Capture romper suit consists of three: Bass, Treble and Mic. The first two for what?
In configuration file/etc/init.d/10alsa and to leave:
Code:
set Mic of 90% of unmute
?
Last edited by sancxjo on Sat 06 Jul 2013, 09:30; edited 1 time in total
Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 1999
Location: London, England

PostPosted: Sat 06 Jul 2013, 09:28    Post subject:  

I understand "Mic Boost", but I don't know what "Mic Boos" is. Sounds like "Mic Boost" with a typing error, but if you have "Mic Boost" and "Mic Boos" then I am confused.

In alsamixer you can press F3 to only show Playback controls or F4 to only show Capture controls. That might help to show what each slider is doing.

Maybe the microphone can only be used for Capture. If so you will not hear the microphone in your headphones, but other people on Skype will hear you. Use the echo test to check this.

I like to hear my own voice in my headphones, but I use microphones which connect via the jack socket, not the USB ports.

_________________
Oscar in England

Back to top
View user's profile Send private message 
sancxjo


Joined: 29 Apr 2013
Posts: 93
Location: Russia

PostPosted: Sat 06 Jul 2013, 09:47    Post subject:  

If the card is chosen by default
Mic Boos romper suit is visible (their two as two channels) only in a mode all (F5)
The Mic Boost slider is visible in a mode capture (F4) and in a mode reproduction (F3). Yes, this strengthening of a microphone is probable.
But I likely need to specify the card not by default, and Samson Q2U.
In the VLC program I perfectly heard myself in earphones from this microphone. And not only, but also any rustle - sensitivity high.

The test on Skype executed an echo. Works! Smile
Thanks for cooperation! By the way the microphone and earphones took in England that is cheaper. Wink
Back to top
View user's profile Send private message 
sancxjo


Joined: 29 Apr 2013
Posts: 93
Location: Russia

PostPosted: Sun 07 Jul 2013, 05:55    Post subject:  

alsa doesn't keep a card choice.
Simplest, in my opinion, in the startup folder to add a script but as it is correct to write the identifier of the card I don't know

Here list of cards.
Code:
# cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfe878000 irq 43
 1 [Microphone     ]: USB-Audio - Samson Q2U Microphone
                      Samson Technologies Samson Q2U Microphone at usb-0000:00:1d.7-5.1, full speed
 2 [U0x46d0x802    ]: USB-Audio - USB Device 0x46d:0x802
                      USB Device 0x46d:0x802 at usb-0000:00:1d.7-5.2, high speed

I tried options:
Code:
alsamixer --card="Samson Q2U Microphone"
,
Code:
alsamixer -c Microphone
,
Code:
alsamixer -c 1
But doesn't work. How the team correctly looks?
Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 1999
Location: London, England

PostPosted: Sun 07 Jul 2013, 07:28    Post subject:  

It is best not to try to make a USB soundcard the default in alsa. There is no need to do this.

Just leave the HDA intel card as the default in alsa / Puppy.

Use the Options settings in Skype to select the USB microphone soundcard for Skype.

You can do the same in VLC or each application that you want to use with the USB soundcard at any time.

_________________
Oscar in England

Back to top
View user's profile Send private message 
sancxjo


Joined: 29 Apr 2013
Posts: 93
Location: Russia

PostPosted: Sun 07 Jul 2013, 08:46    Post subject:  

The matter is that just in Skype also doesn't pass an echo the test while in alsamixer I won't expose the card as a microphone. In settings of Skype it is now chosen: Samson Q2U Microphone, USB Audio (hw 1,0) There are also other options with the same microphone, and I didn't try everything, but I think as will depend on a card choice in alsamixer.
In VLC when I choose "Open Capture Device", I hear myself in headphones and no need to change the card in alsamixer (is default).
Precord and Pavrecord also recorded without changing the card in alsamixer (is default).
Apparently Skype is a different story altogether.

In general it is necessary to either leave as is and get used to. Or bind change cards in alsamixer to Skype. That is, write a script that will change the map with the default on Samson and will do so only when you start Skype.

Last edited by sancxjo on Sun 07 Jul 2013, 09:35; edited 1 time in total
Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 1999
Location: London, England

PostPosted: Sun 07 Jul 2013, 09:28    Post subject:  

The card choice in alsamixer is just to select the card so you can control the volume settings of each card. It does not switch cards in Skype or other applications. Puppy should remember these volume settings.

I thought maybe you were trying to use Alsawizard or Multiple Sound Card Wizard to change the default card. USB devices can easily be unplugged so Puppy will try to prevent you from setting a USB soundcard as the default.

There will usually be more than one option for each card in Skype. Probably it will be the first one "Samson Q2U Microphone ......." in the list, but you may need to try them all to find the correct one.

You also have a checkbox in the Skype Options for "Allow Skype to automatically adjust my mixer levels". If you are setting things up manually yourself it is best to remove the tick from this.

When you do the echo test if the volume is too high or too low you may need to go back into alsamixer to alter the level until it is right.

_________________
Oscar in England

Back to top
View user's profile Send private message 
sancxjo


Joined: 29 Apr 2013
Posts: 93
Location: Russia

PostPosted: Sun 07 Jul 2013, 09:41    Post subject:  

In Skype 6 options with this Samson. Well, not 60 Very Happy
Back to top
View user's profile Send private message 
sancxjo


Joined: 29 Apr 2013
Posts: 93
Location: Russia

PostPosted: Sun 07 Jul 2013, 09:52    Post subject:  

Strangely, now working on Skype all 6 options. But you have to reboot to make sure.
Back to top
View user's profile Send private message 
sancxjo


Joined: 29 Apr 2013
Posts: 93
Location: Russia

PostPosted: Sun 07 Jul 2013, 10:09    Post subject:  

In Skype does not work the first time. Only after the climb to the settings, and even leave the same choice that works. It is every time before use Skype I have to go into settings. Is that an inherited it from Windows? While in other programs, I also choose to card... Well get used to it somehow.
Back to top
View user's profile Send private message 
OscarTalks


Joined: 05 Feb 2012
Posts: 1999
Location: London, England

PostPosted: Sun 07 Jul 2013, 10:25    Post subject:  

You mean Skype is not remembering the soundcard device setting?

Sorry for the question, but are you remembering to click the "Save" button in the Skype Options?

_________________
Oscar in England

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [13 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0588s ][ Queries: 11 (0.0174s) ][ GZIP on ]