Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 20 Oct 2014, 07:29
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
slacko-5.6 Final - plus testing next
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 31 [465 Posts]   Goto page: Previous 1, 2, 3, 4, ..., 29, 30, 31 Next
Author Message
ally


Joined: 19 May 2012
Posts: 851
Location: lincoln

PostPosted: Mon 08 Jul 2013, 08:57    Post subject:  

posting from a lenovo t500 P8400 dual core and GM45 chipset

ethernet/sound and drives working OOTB

liking the new look to the dialogue boxes, gnumeric, transmission, abiword all working well so far

Smile
Back to top
View user's profile Send private message Visit poster's website 
SFR


Joined: 26 Oct 2011
Posts: 1077

PostPosted: Mon 08 Jul 2013, 08:58    Post subject:  

Oh, a new version - cool! Very Happy

And here's the first problem:
In 5.5 after formatting a partiton (via Gparted) the relevant drive icon on the pinboard gets refreshed immediately after exiting Gparted.
in 5.6-alpha it doesn't get refreshed and clicking such an icon invokes pmount.
Way to reproduce:
1. Format an existent partition to different filesystem than current (eg. fat32 -> ext4)
2. Exit Gparted and click an icon of that partition.
It has something to do with the new pup_event_frontend_d, because the old one makes 5.6-alpha working as before...

As for updates, there's also available updated ptiming-1.0.0 (Zigbert).

And the deadlock problem seems to be non-existent in the whole k3.1... line.

PS. I'm running alpha in VBox for now.

Greetings!

_________________
[O]bdurate [R]ules [D]estroy [E]nthusiastic [R]ebels => [C]reative [H]umans [A]lways [O]pen [S]ource
Omnia mea mecum porto.
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7831
Location: qld

PostPosted: Mon 08 Jul 2013, 09:17    Post subject:  

SFR wrote:
In 5.5 after formatting a partiton (via Gparted) the relevant drive icon on the pinboard gets refreshed immediately after exiting Gparted.
in 5.6-alpha it doesn't get refreshed and clicking such an icon invokes pmount.
Ok, thanks. Well This might be something that be can cross checked with Raring (Barry's version and possibly pemasu's). I didn't use eudev because the most stable configuration was with the old udev-167. I did try slackware's udev-182 but it failed for me on one of my test boxes. Good, we have bugs to find! Laughing

ally wrote:
ethernet/sound and drives working OOTB
Good Smile

peebee wrote:
2. Directory naming problems when compiling /lib/modules/3.10 and 3.10.0
Known bug in my kernel build script for first versions in a series. Thanks for reminder.
peebee wrote:
1. Broadcom B43 wifi is not working - says my wifi is disabled: see below
Not that you should have to do it, but did you try rfkill unblock all ?

DaveS wrote:
Prints Smile
Smile
DaveS wrote:
I miss the little square cursor change when hovering over the window close button.
Biggest complaint by everyone else so Joe dropped it! (Personally, I like it too! I'll ask Joe for a patch, have a separate version in the repo.)

simargl wrote:
Alpha
You know me. 00 Shocked . [/jk]

zigbert wrote:
Very Happy
We'll see... Laughing
_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
OscarTalks

Joined: 05 Feb 2012
Posts: 900
Location: London, England

PostPosted: Mon 08 Jul 2013, 10:05    Post subject:  

Hello 01micko,

Thanks for your continued work on a very polished Pup.

I am curious to know if you have identified any practical operational advantages to the upgraded ffmpeg?

It does mean that Puppy apps need to be re-compiled for specific Slackos rather than being across-the-board s14.0 packages does it not?

_________________
Oscar in England

Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1459
Location: Malvern, Worcs, UK

PostPosted: Mon 08 Jul 2013, 10:42    Post subject:  

01micko wrote:

peebee wrote:
1. Broadcom B43 wifi is not working - says my wifi is disabled: see below
Not that you should have to do it, but did you try rfkill unblock all ?


Hi Mick

Yes - have just tried
Code:
rfkill unblock wlan
and put that into rc.local and that does bring b43 back to life - new feature in this kernel???

P.

_________________
LxPup-14.10 = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
SFR


Joined: 26 Oct 2011
Posts: 1077

PostPosted: Mon 08 Jul 2013, 11:56    Post subject:  

01micko wrote:
SFR wrote:
In 5.5 after formatting a partiton (via Gparted) the relevant drive icon on the pinboard gets refreshed immediately after exiting Gparted.
in 5.6-alpha it doesn't get refreshed and clicking such an icon invokes pmount.
Ok, thanks. Well This might be something that be can cross checked with Raring (Barry's version and possibly pemasu's). I didn't use eudev because the most stable configuration was with the old udev-167. I did try slackware's udev-182 but it failed for me on one of my test boxes. Good, we have bugs to find! Laughing


Raring-5.6.94.iso - the same problem with refreshing of drive icons.
Raring-3.9.8.1-SCSI (pemasu) - ditto.
(tested in VBox)
____________

Ok, played a while on real HW (Acer AO 722) and 5.6-alpha's guts seem to be more friendly for AMD-C60 (inter alia: CPU scaling works OOTB, X takes a bit less resources than in 5.5, but CPU is still hotter (~66°C) than when using proprietary ATI drivers).
Wifi works (ah, and the network tray icon changes its shape at last!), so does microphone, webcam, suspend* mode...

The problem with drive icons is reproducible on real HW as well, btw.

* suspend mode - that's a PITA on that Acer.
Both 5.5-4g and 5.5-PAE do support suspending on it, but after few suspends I've always been encountering ultimate hang, so had to disable it in the end.
We'll see how it will be with 5.6 in the long run, but so far after ~10 suspend/resume cycles nothing bad happened...
_____________

Bug? Not a bug?
PupTelly has never worked for me when I choose gnome-mplayer as a preffered player.
Removing the "--g-fatal-warnings" in this line (func):
Code:
if [ "$PLAYER" = "gnome-mplayer" ]; then OPT="--g-fatal-warnings -q" ;fi

makes it running fine, at least for me...
Is this parameter somehow crucial to be there?

Almost forgot: /root/.xbindkeysrc
PrtScr is binded to a non-existent /usr/bin/mtpaintsnapshot.sh
Maybe just 'mtpaint -s' instead..?
_____________

Quote:
suggestions? (be reasonable)

Not sure if it's reasonable enough...hope I won't cross the line..? Wink
I'm not using xarchive(r) (especially because I don't like when the whole X hangs while opening encrypted .rar or .7z (but this happens only with encrypted filenames (and yes, I know that I'm overusing brackets))), but file-roller instead.
The problem is that either files and directories have the same icons next to them, what's confusing.
This:
Code:
ln -s /usr/share/icons/gnome-fs-directory.png /usr/share/icons/folder.png

solves the problem (spied in one of Pemasu's Pups, but there was a separate icon).
The reason why I'm suggesting this, is that there might be also other apps with this problem, however, to be frank, I've never seen one.
___________

01micko wrote:
DaveS wrote:
I miss the little square cursor change when hovering over the window close button.

Biggest complaint by everyone else so Joe dropped it! (Personally, I like it too! I'll ask Joe for a patch, have a separate version in the repo.)

I, too, never had nothing against that...
___________

EDIT:
01micko wrote:
Linux-3.10 (devtmpfs, f2fs, hfs, hfs+ and usual lot of modules)

Does Gparted also supposed to handle f2fs?
It has only 'Move' and 'Copy' support for f2fs, but not 'Create'...

Greetings!

_________________
[O]bdurate [R]ules [D]estroy [E]nthusiastic [R]ebels => [C]reative [H]umans [A]lways [O]pen [S]ource
Omnia mea mecum porto.

Last edited by SFR on Mon 08 Jul 2013, 15:37; edited 1 time in total
Back to top
View user's profile Send private message 
mavrothal


Joined: 24 Aug 2009
Posts: 1684

PostPosted: Mon 08 Jul 2013, 12:35    Post subject:  

This is certainly not Alpha Very Happy Wink
Looks very solid.
Should it also update Slacko-5.5 or the new kernel my introduce driver problems?

A little problem was firefox that runs under the jwm panel.
The only other "complain" I had in a brief test was the my desktop incon configuration turned back to the original after a devx-induced aufs update.
But this is probably a desksetup bug (if not aufs)

_________________
Kids all over the world go around with an XO laptop. They deserve one puppy (or many) too Very Happy
Back to top
View user's profile Send private message 
gjuhasz


Joined: 29 Sep 2008
Posts: 161

PostPosted: Mon 08 Jul 2013, 12:47    Post subject: Kernel version  

Quote:
01micko wrote:
This will not be the final kernel. I will likely roll back to 3.4.XX (hopefully patched for f2fs) for the 4G build and keep a more recent kernel for the PAE build. (maybe 3.10 series, see what problems arise/get fixed)


Let me ask you to apply a kernel at least 3.5 to support seccomp sandbox
My 2-cent would be 3.8.3 as in pemasu's Precise 3.8.3.1 but please support SUID sandbox, too:

General setup --->
-*- Namespaces support --->
[*] PID Namespaces
[*] Network namespace

Another 2-cent: please let the user choose her/his default browser, e.g., by selecting an sfs - forcing Firefox is too insecure. A simple browser such as links2 is more than enough for viewing the Help etc.

And a kind request: Could you please support USB hard drives formatted for NTFS... this is the only reason why I rarely use Slacko(s).

FYI: I have no problem with nouveau in pemasu's precise 3.8.3.1
Back to top
View user's profile Send private message 
zigbert


Joined: 29 Mar 2006
Posts: 5753
Location: Valåmoen, Norway

PostPosted: Mon 08 Jul 2013, 14:59    Post subject:  

OscarTalks wrote:
I am curious to know if you have identified any practical operational advantages to the upgraded ffmpeg?
pMusic-4.1 is taking advantage of ffmpeg-1.2. It allows sound filtering which is not strictly necessary - but still funny. pMusic will also work on older versions of ffmpeg.


Sigmund

_________________
Stardust resources
Back to top
View user's profile Send private message Visit poster's website 
don570


Joined: 10 Mar 2010
Posts: 3331
Location: Ontario

PostPosted: Mon 08 Jul 2013, 15:43    Post subject:  

Quote:
Almost forgot: /root/.xbindkeysrc
PrtScr is binded to a non-existent /usr/bin/mtpaintsnapshot.sh
Maybe just 'mtpaint -s' instead..?



A quick way to install mtpaintsnapshot.sh is to install
psnapshot application
http://murga-linux.com/puppy/viewtopic.php?p=595913

or my right click package has it inside as well (I think)
http://murga-linux.com/puppy/viewtopic.php?p=711269#711269

____________________________________________________
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7831
Location: qld

PostPosted: Mon 08 Jul 2013, 16:45    Post subject:  

SFR wrote:
EDIT:
01micko wrote:
Linux-3.10 (devtmpfs, f2fs, hfs, hfs+ and usual lot of modules)

Does Gparted also supposed to handle f2fs?
It has only 'Move' and 'Copy' support for f2fs, but not 'Create'...

Greetings!


Dang! Missed f2fs-tools! Probably a good thing in the end because it made me get off my lazy butt and compile latest from git. The good news about that is that in June they introduce fsck.f2fs.. at last!

http://distro.ibiblio.org/puppylinux/pet_packages-slacko14/f2fs-tools-1.0.1-i486-s14.0.pet

http://distro.ibiblio.org/puppylinux/pet_packages-slacko14/f2fs-tools_DEV-1.0.1-i486-s14.0.pet
http://distro.ibiblio.org/puppylinux/pet_packages-slacko14/f2fs-tools_DOC-1.0.1-i486-s14.0.pet

BTW, hfs-tools (utils, or whatever it is) is not included but is available from PPM (slackware) and it does allow mounting rw of mac hfs and hfs+ filesystems. Tested on a late model macbook-air in ThinSlacko a while back. This enables the possibility of data recovery in macs, and I think already it helped out one forum member.

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
James C


Joined: 26 Mar 2009
Posts: 5854
Location: Kentucky

PostPosted: Mon 08 Jul 2013, 23:56    Post subject:  

Another manual frugal install. All looking good.

# report-video
VIDEO REPORT: Slacko Puppy, version 5.5.67

Chip description:
VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)

Requested by /etc/X11/xorg.conf:
Resolution (widthxheight, in pixels): 1024x768
Depth (bits, or planes): 24
Modules requested to be loaded: dbe

Probing Xorg startup log file (/var/log/Xorg.0.log):
Driver loaded (and currently in use): intel
Loaded modules: dbe dri dri2 extmod fb glx kbd mouse record

Actual rendering on monitor:
Resolution: 1024x768 pixels (270x203 millimeters)
Depth: 24 planes

...the above also recorded in /tmp/report-video
# glxgears
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
378 frames in 5.0 seconds = 75.433 FPS
376 frames in 5.0 seconds = 75.143 FPS
376 frames in 5.0 seconds = 75.143 FPS
376 frames in 5.0 seconds = 75.142 FPS
376 frames in 5.0 seconds = 75.093 FPS

-Computer-
Processor : Intel(R) Pentium(R) 4 CPU 2.80GHz
Memory : 2592MB (180MB used)
Machine Type : Physical machine
Operating System : Slacko Puppy - 5.5.67
User Name : root (root)
Date/Time : Mon 08 Jul 2013 11:03:09 PM CDT
-Display-
Resolution : 1024x768 pixels
OpenGL Renderer : Mesa DRI Intel(R) 865G x86/MMX/SSE2
X11 Vendor : The X.Org Foundation
-Audio Devices-
Audio Adapter : ICH4 - Intel ICH5


Code:
# free
             total         used         free       shared      buffers
Mem:       2592348       526876      2065472            0        64256
-/+ buffers:             462620      2129728
Swap:      4198396            0      4198396
#
Back to top
View user's profile Send private message 
sszindian


Joined: 24 Apr 2010
Posts: 607
Location: Pennsylvania U.S.

PostPosted: Tue 09 Jul 2013, 00:29    Post subject: 5.5.57  

Yes... everything loads up fine and initial tests went well however getting a little deeper...

HP Printer 1050 will not setup up in cups 1.4.8 (Slacko-5.5 uses same version and I had no problems there using hplip-11.10 version!) Tried hplip versions 11,13,12 with lots of re-plug-ins, reboots etc., etc., just wont recognize my printer?

Scanner sets up fine and works with hplip 11,12,13, no problems there.

The new version of Osmo is missing 'Contacts'... might not be important to many but very important for what I do!

Overall it is fast and preforms great... better than 5.5, Eh... hard to tell just yet?

We'll see Smile

>>>---Indian------>

_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 2124
Location: Ontario Canada

PostPosted: Tue 09 Jul 2013, 01:39    Post subject: slacko-5.6 alpha  

I've done a manual frugal install of 5567 to an 8gb SDHC card, running
on an Acer netbook.

video-info-glx 1.5.1 Tue 9 Jul 2013 on Slacko Puppy 5.5.67 Linux 3.10.0 i686
5.0 VGA compatible controller:
ATI Technologies Inc M880G [Mobility Radeon HD 4200]
oem: ATI ATOMBIOS
product: RS880M 01.00
X Server: Xorg Driver: radeon
X.Org version: 1.12.4
dimensions: 1024x768 pixels (270x203 millimeters)
depth of root window: 24 planes
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD RS880
OpenGL version string: 2.1 Mesa 8.0.4
AMD Athlon(tm) II Neo K125 Processor
Core 0: @1700 MHz
Network controller: Broadcom Corporation BCM43225 802.11b/g/n (rev 01)

My problem is that I've connected the netbook to an external monitor
with an hdmi cable and I get a display on both the netbook screen and
the external monitor but I want 1024x600 on the netbook and 1920x1080
on the external monitor.

The proprietary ati driver allows this but when I try to compile the
driver I get an error (screenshot), I have the devx and kernel source
sfs installed so I have no idea what other tools the error message
is refering to.

Do you know what is causing the error message?

Thanks.

Also, mtpaint will not save a screen capture in jpg format.

EDIT: here's the install log:

check if system has the tools required for installation.
fglrx installation requires that the system have kernel headers. /lib/modules/3.10.0/build/include/linux/version.h cannot be found on this system.
One or more tools required for installation cannot be found on the system. Install the required tools before installing the fglrx driver.
Optionally, run the installer with --force option to install without the tools.
Forcing install will disable AMD hardware acceleration and may make your system unstable. Not recommended.
capture15633.png
 Description   
 Filesize   4.35 KB
 Viewed   936 Time(s)

capture15633.png

Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 2124
Location: Ontario Canada

PostPosted: Tue 09 Jul 2013, 03:52    Post subject: slacko-5.6 alpha  

Here's a screenshot of my Slacko 5.5 install, the driver
compiled no problem in it.
I can see my SDHC card in the lower left corner in this screenshot but
it's off the screen on my netbook monitor.

I'm pretty sure that the ATI pets for 5.5 on ibiblio are corrupted, I
didn't have any luck downloading them.
slacko55screen.jpg
 Description   
 Filesize   45.51 KB
 Viewed   876 Time(s)

slacko55screen.jpg

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 31 [465 Posts]   Goto page: Previous 1, 2, 3, 4, ..., 29, 30, 31 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1304s ][ Queries: 12 (0.0063s) ][ GZIP on ]