Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 24 Apr 2014, 15:26
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
Howto make Geany execute command (F5 key) to work
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
Uten

Joined: 29 Jan 2008
Posts: 36

PostPosted: Sun 14 Jul 2013, 07:23    Post subject:  Howto make Geany execute command (F5 key) to work  

Fore some reason the Geany execute ( F5 ) does not work for me. I have tried with shell scripts and at the moment python. All I get is a flashing window.

To solve this I tried the command found in Edit->preferences->tools->terminal in a normal terminal, just replacing %c with rox.
Code:
/usr/bin/xterm -e "/bin/sh rox"

This gives the same flashing window.

Trying
Code:
/usr/bin/xterm -e /bin/sh rox

Opens rox as expected.

Now removing the "" pair from the preferences dialog in Geany solves my problem. Now I can execute my scripts from within Geany. Very handy when you do a write - unit test - write cycle.

Happy coding.
Back to top
View user's profile Send private message 
afishe2000

Joined: 29 Jan 2010
Posts: 37

PostPosted: Wed 11 Sep 2013, 10:13    Post subject:  

Tired of banging my head against the wall here...

I cant get this to work under Slacko 5.6.

Any suggestions?

Thank you
Back to top
View user's profile Send private message 
Uten

Joined: 29 Jan 2008
Posts: 36

PostPosted: Tue 17 Sep 2013, 04:47    Post subject:  

Sorry I'm late replying afishe2000.

I'm on precise 5.7 at the moment and python / shell scripts works out of the box (the terminal stays open and executes the script). This is the default executing command (edit->preferences->tools->terminal): /usr/bin/xterm -e bash -c

I remember that I used to run the scripts in the embedded terminal window with some success. but I can't recall the puppy version. Geany in precise 5.7 seems to be compiled without the embedded terminal support. CTRL+ALT+P to get the preferences window and look for the terminal flip (if memory serves me right)

I don't have slacko 5.6 so I can't test at the moment. Could you describe what happens when you try to execute a script?
Back to top
View user's profile Send private message 
cimarron

Joined: 30 May 2013
Posts: 54

PostPosted: Tue 17 Sep 2013, 09:01    Post subject:  

I use roxterm (on Lupu 5.1) and this command in Geany preferences works for me:

/usr/bin/roxterm -e bash -c
Back to top
View user's profile Send private message 
afishe2000

Joined: 29 Jan 2010
Posts: 37

PostPosted: Tue 17 Sep 2013, 12:34    Post subject:  

Thanks to all,

Will give it a try and let everyone know.
Back to top
View user's profile Send private message 
MochiMoppel


Joined: 26 Jan 2011
Posts: 205
Location: Japan

PostPosted: Tue 29 Oct 2013, 04:23    Post subject:  

afishe2000 wrote:
I cant get this to work under Slacko 5.6.
Any suggestions?

Change the command
Code:
/usr/bin/xterm -e "/bin/sh %c"

to
Code:
/usr/bin/xterm -e /bin/sh "%c"
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0459s ][ Queries: 11 (0.0050s) ][ GZIP on ]