Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 30 Jun 2015, 13:04
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
Google Earth 'Invalid HTTP Request' FIX
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message

Joined: 24 Apr 2010
Posts: 639
Location: Pennsylvania U.S.

PostPosted: Thu 18 Jul 2013, 23:45    Post_subject:  Google Earth 'Invalid HTTP Request' FIX  

Those who are running Google Earth 'Less than version 7' and are getting the Invalid HTTP request when trying to find a location...

here's the fix...

Go to: /opt/google/earth/free/libcurl.so.4 and just rename the 'libcurl.so.4' module to something like 'OLD-libcurl.so.4' so that the libcurl.so.4 module is no longer used (you could delete the module, I just renamed it until we see where Google Earth goes with this issue)!

That's it!!!! Enjoy


Cloud Computing For Every Puppy (a .pet)
Back to top
View user's profile Send_private_message 

Joined: 19 Jan 2010
Posts: 13

PostPosted: Mon 16 Sep 2013, 07:57    Post_subject:  

Thank you! Cool

I thought Google finally stopped old versions compatibility.
Back to top
View user's profile Send_private_message Visit_website 

Joined: 21 Nov 2008
Posts: 131

PostPosted: Wed 04 Dec 2013, 07:23    Post_subject:  


I thought I'd share my experience with this in case it helps someone.

I've tried installing Google Earth 6.xxx on two systems running Lupu Puppy 5.28, one a frugal install and one full.

On the frugal install it behaves as the first post in this thread describes -- thanks very much to sszindian for posting the fix.

On the full install it wouldn't start from the menu so I tried running it from the terminal and it reported libcurl.so.4 wasn't found. I then used Pfind to search for "libcurl" to see if there was any difference between the two Puppy installs, in both cases I found a copy of libcurl.so.4.1.1 in /usr/lib, presumably this is a later version than v4 installed by the Google Earth package. My problem now was why the G. Earth in the full install didn't find libcurl in /usr/lib as it presumably does under the frugal, I fixed it by making a simlink in /opt/google/earth/free pointing to /usr/lib/libcurl.so.4.1.1 naming the link libcurl.so.4 to match what G. Earth was presumably looking for.

Earth now seems to OK except the start up tip gets lost "behind" the main window -- I've just set it to no tip on start Smile. I hope I haven't broken anything else but as I didn't change anything that was there before installing earth it should be OK.

Sorry this post is rather long but this had me very puzzled so thought it might be helpful explain in full what I did to fix it.

Bye for now

Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0422s ][ Queries: 11 (0.0033s) ][ GZIP on ]