Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 16 Apr 2014, 06:28
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Virtualization
Wine - run Windows programs in Linux
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 3 [43 Posts]   Goto page: Previous 1, 2, 3 Next
Author Message
version2013

Joined: 08 Sep 2013
Posts: 47

PostPosted: Mon 25 Nov 2013, 22:11    Post subject: Wine 1.7.7  

my attempt at compiling wine-1.7.7

wine-1.7.7-i486_v1.1.pet _______ puppy 431 | stripped=true | mirrors
wine-1.7.7-i486_v1.2.pet _______ puppy 431 | stripped=false | mirrors
wine-1.7.7-i486_v2.1.pet _______ racy puppy 5.5 | stripped=true | mirrors
wine-1.7.7-i486_v2.2.pet _______ racy puppy 5.5 | stripped=false | mirrors
wine_DEV-1.7.7-i486_v1.pet ____ puppy 431 | mirrors
wine_DEV-1.7.7-i486_v2.pet ____ racy puppy 5.5 | mirrors
wine_DOC-1.7.7-i486.pet _______ mirrors
wine_extras-v2.pet ____________ menu entries | mirrors
md5.txt and hashdeep.txt ______ mirrors


Note: Click on "mirrors", then click on ">" for a download page to the respective file.

If you are not going to submit bug reports to WineHQ, I recommend packages that are 'stripped=true'
If you are going to submit bug reports to WineHQ, I recommend packages that are 'stripped=false'
When submitting bug reports to WineHQ, it appears a 'stripped=false' Wine provides more information than a 'stripped=true' Wine. [references]

The first post [>] has links to:
sfs scripts, menu entry utilities, and Wine usage tips.

----------------------------------------------------------------------------------------------------------
puppy 431 ->

I compiled using puplet: Puppies 4.31.1 by forum member 'ttuuxxx'
_________ mirrors _________
/distro/4.3__1/puppies-431.1-main-Xserver.iso
/distro/4.3__1/devx_430.sfs

This puplet uses glibc 2.6.1
The Wine files listing 'puppy 431' will possibly not work with a glibc before 2.6.1
To see what glibc your puppy has.
Code:
ldd --version


I installed these packages (as one sfs file) before compiling:
_________ mirrors _________
/fontconfig/2.7.1/fontconfig-2.7.1-i486-pup4.pet
/fontconfig/2.7.1/fontconfig_DEV-2.7.1-i486-pup4.pet
/gnutls/2.10.5/gnutls-2.10.5-i486-431.pet
/gnutls/2.10.5/gnutls_DEV-2.10.5-i486-431.pet
/lcms2/2.5/lcms2-2.5-i486_v2.pet
/lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet
/libelf/0.8.13/libelf-0.8.13-i486_v2.pet
/libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet
/libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet
/libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet
/libgpg-error/1.10/libgpg-error-1.10-i486-431.pet
/libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet
/libgphoto2/2.5.0/libgphoto2-2.5.0-i486_v2.pet
/libgphoto2/2.5.0/libgphoto2_DEV-2.5.0-i486.pet
/libtasn1/2.9/libtasn1-2.9-i486-431.pet
/libtasn1/2.9/libtasn1_DEV-2.9-i486-431.pet
/libusb/1.0.9/libusb-1.0.9-i486_v2.pet
/libusb/1.0.9/libusb_DEV-1.0.9-i486_v2.pet
/mpg123/1.12.4/mpg123-1.12.4.pet
/mpg123/1.12.4/mpg123_DEV-1.12.4.pet
/openldap/2.4.13/openldap-2.4.13-i486.pet
/openldap/2.4.13/openldap_DEV-2.4.13-i486.pet
/prelink/20130503/prelink-20130503-i486_v2.pet
/xorg/7.3/xorg_xorg_full_dri-7.3.pet
/xorg/7.3/xorg_xorg_full_dri_DEV-7.3.pet

<- puppy 431
----------------------------------------------------------------------------------------------------------
racy puppy 5.5 ->

I compiled using Racy 5.5
_________ mirrors _________
/distro/racy5.5/racy-5.5.iso
/distro/racy5.5/devx_racy_5.5.sfs

This puppy distro uses glibc 2.10.1
The Wine files listing 'racy5.5' will possibly not work with a glibc before 2.10.1
To see what glibc your puppy has.
Code:
ldd --version


I installed these packages (as one sfs file) before compiling:
_________ mirrors _________
/fontconfig/2.8.0/fontconfig-2.8.0-w5c.pet
/fontconfig/2.8.0/fontconfig_DEV-2.8.0-w5c.pet
/gnutls/2.10.5/gnutls-2.10.5-i486-431.pet
/gnutls/2.10.5/gnutls_DEV-2.10.5-i486-431.pet
/lcms2/2.5/lcms2-2.5-i486_v2.pet
/lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet
/libelf/0.8.13/libelf-0.8.13-i486_v2.pet
/libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet
/libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet
/libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet
/libgpg-error/1.10/libgpg-error-1.10-i486-431.pet
/libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet
/libtasn1/2.9/libtasn1-2.9-i486-431.pet
/libtasn1/2.9/libtasn1_DEV-2.9-i486-431.pet
/mpg123/1.12.4/mpg123-1.12.4.pet
/mpg123/1.12.4/mpg123_DEV-1.12.4.pet
/openldap/2.4.13/openldap-2.4.13-i486.pet
/openldap/2.4.13/openldap_DEV-2.4.13-i486.pet
/prelink/20130503/prelink-20130503-i486_v2.pet

<- racy puppy 5.5
----------------------------------------------------------------------------------------------------------

When compiling, I used
Code:

./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x


Menu entries, Color Setter, and other stuff I got from the file 'winegoodies.tar.gz' provided by forum member 'technosaurus'.
I only made a few changes to the contents of that file.
----------------------------------------------------------------------------------------------------------

updated links at my homepage. see below.

Last edited by version2013 on Mon 06 Jan 2014, 20:10; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
version2013

Joined: 08 Sep 2013
Posts: 47

PostPosted: Tue 10 Dec 2013, 00:29    Post subject: Wine 1.7.8  

my attempt at compiling wine-1.7.8

wine-1.7.8-i486_v1.1.pet _______ puppy 431 | stripped=true | mirrors
wine-1.7.8-i486_v1.2.pet _______ puppy 431 | stripped=false | mirrors
wine-1.7.8-i486_v2.1.pet _______ racy puppy 5.5 | stripped=true | mirrors
wine-1.7.8-i486_v2.2.pet _______ racy puppy 5.5 | stripped=false | mirrors
wine_DEV-1.7.8-i486_v1.pet ____ puppy 431 | mirrors
wine_DEV-1.7.8-i486_v2.pet ____ racy puppy 5.5 | mirrors
wine_DOC-1.7.8-i486.pet _______ mirrors
wine_extras-v2.pet ____________ menu entries | mirrors
md5.txt and hashdeep.txt ______ mirrors


Note: Click on "mirrors", then click on ">" for a download page to the respective file.

If you are not going to submit bug reports to WineHQ, I recommend packages that are 'stripped=true'
If you are going to submit bug reports to WineHQ, I recommend packages that are 'stripped=false'
When submitting bug reports to WineHQ, it appears a 'stripped=false' Wine provides more information than a 'stripped=true' Wine. [references]

The first post [>] has links to:
sfs scripts, menu entry utilities, and Wine usage tips.

----------------------------------------------------------------------------------------------------------
puppy 431 ->

I compiled using puplet: Puppies 4.31.1 by forum member 'ttuuxxx'
_________ mirrors _________
/distro/4.3__1/puppies-431.1-main-Xserver.iso
/distro/4.3__1/devx_430.sfs

This puplet uses glibc 2.6.1
The Wine files listing 'puppy 431' will possibly not work with a glibc before 2.6.1
To see what glibc your puppy has.
Code:
ldd --version


I installed these packages (as one sfs file) before compiling:
_________ mirrors _________
/fontconfig/2.7.1/fontconfig-2.7.1-i486-pup4.pet
/fontconfig/2.7.1/fontconfig_DEV-2.7.1-i486-pup4.pet
/gnutls/2.10.5/gnutls-2.10.5-i486-431.pet
/gnutls/2.10.5/gnutls_DEV-2.10.5-i486-431.pet
/lcms2/2.5/lcms2-2.5-i486_v2.pet
/lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet
/libelf/0.8.13/libelf-0.8.13-i486_v2.pet
/libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet
/libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet
/libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet
/libgpg-error/1.10/libgpg-error-1.10-i486-431.pet
/libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet
/libgphoto2/2.5.0/libgphoto2-2.5.0-i486_v2.pet
/libgphoto2/2.5.0/libgphoto2_DEV-2.5.0-i486.pet
/libtasn1/2.9/libtasn1-2.9-i486-431.pet
/libtasn1/2.9/libtasn1_DEV-2.9-i486-431.pet
/libusb/1.0.9/libusb-1.0.9-i486_v2.pet
/libusb/1.0.9/libusb_DEV-1.0.9-i486_v2.pet
/mpg123/1.12.4/mpg123-1.12.4.pet
/mpg123/1.12.4/mpg123_DEV-1.12.4.pet
/openldap/2.4.13/openldap-2.4.13-i486.pet
/openldap/2.4.13/openldap_DEV-2.4.13-i486.pet
/prelink/20130503/prelink-20130503-i486_v2.pet
/xorg/7.3/xorg_xorg_full_dri-7.3.pet
/xorg/7.3/xorg_xorg_full_dri_DEV-7.3.pet

<- puppy 431
----------------------------------------------------------------------------------------------------------
racy puppy 5.5 ->

I compiled using Racy 5.5
_________ mirrors _________
/distro/racy5.5/racy-5.5.iso
/distro/racy5.5/devx_racy_5.5.sfs

This puppy distro uses glibc 2.10.1
The Wine files listing 'racy5.5' will possibly not work with a glibc before 2.10.1
To see what glibc your puppy has.
Code:
ldd --version


I installed these packages (as one sfs file) before compiling:
_________ mirrors _________
/fontconfig/2.8.0/fontconfig-2.8.0-w5c.pet
/fontconfig/2.8.0/fontconfig_DEV-2.8.0-w5c.pet
/gnutls/2.10.5/gnutls-2.10.5-i486-431.pet
/gnutls/2.10.5/gnutls_DEV-2.10.5-i486-431.pet
/lcms2/2.5/lcms2-2.5-i486_v2.pet
/lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet
/libelf/0.8.13/libelf-0.8.13-i486_v2.pet
/libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet
/libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet
/libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet
/libgpg-error/1.10/libgpg-error-1.10-i486-431.pet
/libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet
/libtasn1/2.9/libtasn1-2.9-i486-431.pet
/libtasn1/2.9/libtasn1_DEV-2.9-i486-431.pet
/mpg123/1.12.4/mpg123-1.12.4.pet
/mpg123/1.12.4/mpg123_DEV-1.12.4.pet
/openldap/2.4.13/openldap-2.4.13-i486.pet
/openldap/2.4.13/openldap_DEV-2.4.13-i486.pet
/prelink/20130503/prelink-20130503-i486_v2.pet

<- racy puppy 5.5
----------------------------------------------------------------------------------------------------------

When compiling, I used
Code:

./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x


Menu entries, Color Setter, and other stuff I got from the file 'winegoodies.tar.gz' provided by forum member 'technosaurus'.
I only made a few changes to the contents of that file.
----------------------------------------------------------------------------------------------------------

updated links at my homepage. see below.

Last edited by version2013 on Mon 06 Jan 2014, 20:11; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
version2013

Joined: 08 Sep 2013
Posts: 47

PostPosted: Fri 13 Dec 2013, 00:06    Post subject:  

content of this post no longer relevant.
Back to top
View user's profile Send private message Visit poster's website 
ahoppin

Joined: 16 May 2011
Posts: 84

PostPosted: Sat 21 Dec 2013, 07:26    Post subject:  

I'm getting a 404 error on the weebly.com mirror link. Sad

Maybe it's me?
Back to top
View user's profile Send private message 
tommy

Joined: 04 Oct 2005
Posts: 78
Location: Italy

PostPosted: Sat 21 Dec 2013, 07:39    Post subject:  

Me too, today I got a 404 error..... server down or other problems???
Back to top
View user's profile Send private message 
version2013

Joined: 08 Sep 2013
Posts: 47

PostPosted: Sun 22 Dec 2013, 21:19    Post subject: website  

My website is backed up at
https://wuala.com/version2013/web/

A link to the current location of my website is at the bottom of my posts, next to
"Profile" "PM"

Last edited by version2013 on Mon 30 Dec 2013, 23:38; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website 
version2013

Joined: 08 Sep 2013
Posts: 47

PostPosted: Tue 24 Dec 2013, 02:27    Post subject: Wine 1.7.9  

my attempt at compiling wine-1.7.9

wine-1.7.9-i486_v1.1.pet _______ puppy 431 | stripped=true | mirrors
wine-1.7.9-i486_v1.2.pet _______ puppy 431 | stripped=false | mirrors
wine-1.7.9-i486_v2.1.pet _______ racy puppy 5.5 | stripped=true | mirrors
wine-1.7.9-i486_v2.2.pet _______ racy puppy 5.5 | stripped=false | mirrors
wine_DEV-1.7.9-i486_v1.pet ____ puppy 431 | mirrors
wine_DEV-1.7.9-i486_v2.pet ____ racy puppy 5.5 | mirrors
wine_DOC-1.7.9-i486.pet _______ mirrors
wine_extras-v2.pet ____________ menu entries | mirrors
md5.txt and hashdeep.txt ______ mirrors



If you are not going to submit bug reports to WineHQ, I recommend packages that are 'stripped=true'
If you are going to submit bug reports to WineHQ, I recommend packages that are 'stripped=false'
When submitting bug reports to WineHQ, it appears a 'stripped=false' Wine provides more information than a 'stripped=true' Wine. [references]

The first post [>] has links to:
sfs scripts, menu entry utilities, and Wine usage tips.

----------------------------------------------------------------------------------------------------------
puppy 431 ->

I compiled using puplet: Puppies 4.31.1 by forum member 'ttuuxxx'
_________ mirrors _________
/distro/4.3__1/puppies-431.1-main-Xserver.iso
/distro/4.3__1/devx_430.sfs

This puplet uses glibc 2.6.1
The Wine files listing 'puppy 431' will possibly not work with a glibc before 2.6.1
To see what glibc your puppy has.
Code:
ldd --version


I installed these packages (as one sfs file) before compiling:
_________ mirrors _________
/fontconfig/2.7.1/fontconfig-2.7.1-i486-pup4.pet
/fontconfig/2.7.1/fontconfig_DEV-2.7.1-i486-pup4.pet
/gnutls/2.10.5/gnutls-2.10.5-i486-431.pet
/gnutls/2.10.5/gnutls_DEV-2.10.5-i486-431.pet
/lcms2/2.5/lcms2-2.5-i486_v2.pet
/lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet
/libelf/0.8.13/libelf-0.8.13-i486_v2.pet
/libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet
/libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet
/libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet
/libgpg-error/1.10/libgpg-error-1.10-i486-431.pet
/libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet
/libgphoto2/2.5.0/libgphoto2-2.5.0-i486_v2.pet
/libgphoto2/2.5.0/libgphoto2_DEV-2.5.0-i486.pet
/libtasn1/2.9/libtasn1-2.9-i486-431.pet
/libtasn1/2.9/libtasn1_DEV-2.9-i486-431.pet
/libusb/1.0.9/libusb-1.0.9-i486_v2.pet
/libusb/1.0.9/libusb_DEV-1.0.9-i486_v2.pet
/mpg123/1.12.4/mpg123-1.12.4.pet
/mpg123/1.12.4/mpg123_DEV-1.12.4.pet
/openldap/2.4.13/openldap-2.4.13-i486.pet
/openldap/2.4.13/openldap_DEV-2.4.13-i486.pet
/prelink/20130503/prelink-20130503-i486_v2.pet
/xorg/7.3/xorg_xorg_full_dri-7.3.pet
/xorg/7.3/xorg_xorg_full_dri_DEV-7.3.pet

<- puppy 431
----------------------------------------------------------------------------------------------------------
racy puppy 5.5 ->

I compiled using Racy 5.5
_________ mirrors _________
/distro/racy5.5/racy-5.5.iso
/distro/racy5.5/devx_racy_5.5.sfs

This puppy distro uses glibc 2.10.1
The Wine files listing 'racy5.5' will possibly not work with a glibc before 2.10.1
To see what glibc your puppy has.
Code:
ldd --version


I installed these packages (as one sfs file) before compiling:
_________ mirrors _________
/fontconfig/2.8.0/fontconfig-2.8.0-w5c.pet
/fontconfig/2.8.0/fontconfig_DEV-2.8.0-w5c.pet
/gnutls/2.10.5/gnutls-2.10.5-i486-431.pet
/gnutls/2.10.5/gnutls_DEV-2.10.5-i486-431.pet
/lcms2/2.5/lcms2-2.5-i486_v2.pet
/lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet
/libelf/0.8.13/libelf-0.8.13-i486_v2.pet
/libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet
/libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet
/libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet
/libgpg-error/1.10/libgpg-error-1.10-i486-431.pet
/libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet
/libtasn1/2.9/libtasn1-2.9-i486-431.pet
/libtasn1/2.9/libtasn1_DEV-2.9-i486-431.pet
/mpg123/1.12.4/mpg123-1.12.4.pet
/mpg123/1.12.4/mpg123_DEV-1.12.4.pet
/openldap/2.4.13/openldap-2.4.13-i486.pet
/openldap/2.4.13/openldap_DEV-2.4.13-i486.pet
/prelink/20130503/prelink-20130503-i486_v2.pet

<- racy puppy 5.5
----------------------------------------------------------------------------------------------------------

When compiling, I used
Code:

./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x


Menu entries, Color Setter, and other stuff I got from the file 'winegoodies.tar.gz' provided by forum member 'technosaurus'.
I only made a few changes to the contents of that file.
----------------------------------------------------------------------------------------------------------

updated links at my homepage. see below.

Last edited by version2013 on Mon 30 Dec 2013, 22:03; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website 
ahoppin

Joined: 16 May 2011
Posts: 84

PostPosted: Wed 25 Dec 2013, 03:29    Post subject:  

Green_dome, many thanks for the update, and for your long-term dedication to this project!
Back to top
View user's profile Send private message 
nmlkngdm

Joined: 27 Dec 2013
Posts: 26

PostPosted: Fri 27 Dec 2013, 17:14    Post subject:  

Thank you Green_dome and keep up the good work.
Back to top
View user's profile Send private message 
Raj

Joined: 17 Dec 2013
Posts: 72

PostPosted: Mon 30 Dec 2013, 06:32    Post subject:  

Hi,

Just wanted to know if anybody has so far installed Tally6.3 software using Wing into Puppy 5.7.1 (full) install.

If yes, please can you place the instructions step-by-step & with screenshots?

Thanks,
Raj
Back to top
View user's profile Send private message 
Dingo


Joined: 11 Dec 2007
Posts: 1411
Location: somewhere at the end of rainbow...

PostPosted: Fri 03 Jan 2014, 10:17    Post subject:  

Dear Greendome (version2013)


I noted a strange thing in these years with wine builds higher than 0.9.22

with wine 0.9.22 I was able to use this free software for text to speech vocal synthesis

*Er Finestra*
- http://www.ziddu.com/download/23510925/Er_Finestra.zip.html

and to paste into text box up to 65506 characters , while, using any higher wine builds from 1.x series to current, I was able to paste only about 19.000 characters into text box (I don't remember exactly now, but the numbers of chars I can paste is sensitively lower)

has this something to do with wine clipboard? can wine be tweaked to allow as max as possible characters pasting in er finestra textbox?

I attach a 64194 chars long text for any who wants make tests
test_chars.txt.gz
Description 
gz

 Download 
Filename  test_chars.txt.gz 
Filesize  1.28 KB 
Downloaded  127 Time(s) 

_________________
replace .co.cc with .info to get access to stuff I posted in forum
dropbox 2GB free
OpenOffice for Puppy Linux
Back to top
View user's profile Send private message Visit poster's website 
Raj

Joined: 17 Dec 2013
Posts: 72

PostPosted: Sat 04 Jan 2014, 15:36    Post subject:  

Yes.
Back to top
View user's profile Send private message 
version2013

Joined: 08 Sep 2013
Posts: 47

PostPosted: Sat 04 Jan 2014, 23:52    Post subject: Wine 1.7.10  

my attempt at compiling wine-1.7.10

wine-1.7.10-i486_v1.1.pet _______ puppy 431 | stripped=true | mirrors
wine-1.7.10-i486_v1.2.pet _______ puppy 431 | stripped=false | mirrors
wine-1.7.10-i486_v2.1.pet _______ racy puppy 5.5 | stripped=true | mirrors
wine-1.7.10-i486_v2.2.pet _______ racy puppy 5.5 | stripped=false | mirrors
wine_DEV-1.7.10-i486_v1.pet ____ puppy 431 | mirrors
wine_DEV-1.7.10-i486_v2.pet ____ racy puppy 5.5 | mirrors
wine_DOC-1.7.10-i486.pet _______ mirrors
wine_extras-v2.pet ____________ menu entries | mirrors
md5.txt and hashdeep.txt ______ mirrors


If you are not going to submit bug reports to WineHQ, I recommend packages that are 'stripped=true'
If you are going to submit bug reports to WineHQ, I recommend packages that are 'stripped=false'
When submitting bug reports to WineHQ, it appears a 'stripped=false' Wine provides more information than a 'stripped=true' Wine. [references]

The first post [>] has links to:
sfs scripts, menu entry utilities, and Wine usage tips.

----------------------------------------------------------------------------------------------------------
puppy 431 ->

I compiled using puplet: Puppies 4.31.1 by forum member 'ttuuxxx'
_________ mirrors _________
/distro/4.3__1/puppies-431.1-main-Xserver.iso
/distro/4.3__1/devx_430.sfs

This puplet uses glibc 2.6.1
The Wine files listing 'puppy 431' will possibly not work with a glibc before 2.6.1
To see what glibc your puppy has.
Code:
ldd --version


I installed these packages (as one sfs file) before compiling:
_________ mirrors _________
/fontconfig/2.7.1/fontconfig-2.7.1-i486-pup4.pet
/fontconfig/2.7.1/fontconfig_DEV-2.7.1-i486-pup4.pet
/gnutls/2.10.5/gnutls-2.10.5-i486-431.pet
/gnutls/2.10.5/gnutls_DEV-2.10.5-i486-431.pet
/lcms2/2.5/lcms2-2.5-i486_v2.pet
/lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet
/libelf/0.8.13/libelf-0.8.13-i486_v2.pet
/libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet
/libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet
/libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet
/libgpg-error/1.10/libgpg-error-1.10-i486-431.pet
/libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet
/libgphoto2/2.5.0/libgphoto2-2.5.0-i486_v2.pet
/libgphoto2/2.5.0/libgphoto2_DEV-2.5.0-i486.pet
/libtasn1/2.9/libtasn1-2.9-i486-431.pet
/libtasn1/2.9/libtasn1_DEV-2.9-i486-431.pet
/libusb/1.0.9/libusb-1.0.9-i486_v2.pet
/libusb/1.0.9/libusb_DEV-1.0.9-i486_v2.pet
/mpg123/1.12.4/mpg123-1.12.4.pet
/mpg123/1.12.4/mpg123_DEV-1.12.4.pet
/openldap/2.4.13/openldap-2.4.13-i486.pet
/openldap/2.4.13/openldap_DEV-2.4.13-i486.pet
/prelink/20130503/prelink-20130503-i486_v2.pet
/xorg/7.3/xorg_xorg_full_dri-7.3.pet
/xorg/7.3/xorg_xorg_full_dri_DEV-7.3.pet


When compiling, I used
Code:

./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x --disable-tests

<- puppy 431
----------------------------------------------------------------------------------------------------------
racy puppy 5.5 ->

I compiled using Racy 5.5
_________ mirrors _________
/distro/racy5.5/racy-5.5.iso
/distro/racy5.5/devx_racy_5.5.sfs

This puppy distro uses glibc 2.10.1
The Wine files listing 'racy5.5' will possibly not work with a glibc before 2.10.1
To see what glibc your puppy has.
Code:
ldd --version


I installed these packages (as one sfs file) before compiling:
_________ mirrors _________
/fontconfig/2.8.0/fontconfig-2.8.0-w5c.pet
/fontconfig/2.8.0/fontconfig_DEV-2.8.0-w5c.pet
/gnutls/2.10.5/gnutls-2.10.5-i486-431.pet
/gnutls/2.10.5/gnutls_DEV-2.10.5-i486-431.pet
/lcms2/2.5/lcms2-2.5-i486_v2.pet
/lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet
/libelf/0.8.13/libelf-0.8.13-i486_v2.pet
/libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet
/libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet
/libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet
/libgpg-error/1.10/libgpg-error-1.10-i486-431.pet
/libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet
/libtasn1/2.9/libtasn1-2.9-i486-431.pet
/libtasn1/2.9/libtasn1_DEV-2.9-i486-431.pet
/mpg123/1.12.4/mpg123-1.12.4.pet
/mpg123/1.12.4/mpg123_DEV-1.12.4.pet
/openldap/2.4.13/openldap-2.4.13-i486.pet
/openldap/2.4.13/openldap_DEV-2.4.13-i486.pet
/prelink/20130503/prelink-20130503-i486_v2.pet


When compiling in racy puppy 5.5, I used
Code:

./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x

<- racy puppy 5.5
----------------------------------------------------------------------------------------------------------


Menu entries, Color Setter, and other stuff I got from the file 'winegoodies.tar.gz' provided by forum member 'technosaurus'.
I only made a few changes to the contents of that file.

----------------------------------------------------------------------------------------------------------

updated links at my homepage. see below.

Last edited by version2013 on Mon 06 Jan 2014, 19:57; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
nmlkngdm

Joined: 27 Dec 2013
Posts: 26

PostPosted: Sun 05 Jan 2014, 12:09    Post subject:  

Thanks version2013
mirror link for wine-1.7.10-i486_v1.1.pet _______ puppy 431 | stripped=true
http://www.mirrorcreator.com/files/PIEMWHPJ/wine-1.7.10-i486_v1.1.pet_links
Back to top
View user's profile Send private message 
version2013

Joined: 08 Sep 2013
Posts: 47

PostPosted: Sat 11 Jan 2014, 22:38    Post subject: Wine 1.6.2  

my attempt at compiling wine-1.6.2

wine-1.6.2-i486_v1.1.pet _______ puppy 431 | stripped=true | mirrors
wine-1.6.2-i486_v1.2.pet _______ puppy 431 | stripped=false | mirrors
wine-1.6.2-i486_v2.1.pet _______ racy puppy 5.5 | stripped=true | mirrors
wine-1.6.2-i486_v2.2.pet _______ racy puppy 5.5 | stripped=false | mirrors
wine_DEV-1.6.2-i486_v1.pet ____ puppy 431 | mirrors
wine_DEV-1.6.2-i486_v2.pet ____ racy puppy 5.5 | mirrors
wine_DOC-1.6.2-i486.pet _______ mirrors
wine_extras-v2.pet ____________ menu entries | mirrors
md5.txt and hashdeep.txt ______ mirrors


If you are not going to submit bug reports to WineHQ, I recommend packages that are 'stripped=true'
If you are going to submit bug reports to WineHQ, I recommend packages that are 'stripped=false'
When submitting bug reports to WineHQ, it appears a 'stripped=false' Wine provides more information than a 'stripped=true' Wine. [references]

The first post [>] has links to:
sfs scripts, menu entry utilities, and Wine usage tips.

----------------------------------------------------------------------------------------------------------
puppy 431 ->

I compiled using puplet: Puppies 4.31.1 by forum member 'ttuuxxx'
_________ mirrors _________
/distro/4.3__1/puppies-431.1-main-Xserver.iso
/distro/4.3__1/devx_430.sfs

This puplet uses glibc 2.6.1
The Wine files listing 'puppy 431' will possibly not work with a glibc before 2.6.1
To see what glibc your puppy has.
Code:
ldd --version


I installed these packages (as one sfs file) before compiling:
_________ mirrors _________
/fontconfig/2.7.1/fontconfig-2.7.1-i486-pup4.pet
/fontconfig/2.7.1/fontconfig_DEV-2.7.1-i486-pup4.pet
/gnutls/2.10.5/gnutls-2.10.5-i486-431.pet
/gnutls/2.10.5/gnutls_DEV-2.10.5-i486-431.pet
/lcms2/2.5/lcms2-2.5-i486_v2.pet
/lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet
/libelf/0.8.13/libelf-0.8.13-i486_v2.pet
/libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet
/libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet
/libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet
/libgpg-error/1.10/libgpg-error-1.10-i486-431.pet
/libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet
/libgphoto2/2.5.0/libgphoto2-2.5.0-i486_v2.pet
/libgphoto2/2.5.0/libgphoto2_DEV-2.5.0-i486.pet
/libtasn1/2.9/libtasn1-2.9-i486-431.pet
/libtasn1/2.9/libtasn1_DEV-2.9-i486-431.pet
/libusb/1.0.9/libusb-1.0.9-i486_v2.pet
/libusb/1.0.9/libusb_DEV-1.0.9-i486_v2.pet
/mpg123/1.12.4/mpg123-1.12.4.pet
/mpg123/1.12.4/mpg123_DEV-1.12.4.pet
/openldap/2.4.13/openldap-2.4.13-i486.pet
/openldap/2.4.13/openldap_DEV-2.4.13-i486.pet
/prelink/20130503/prelink-20130503-i486_v2.pet
/xorg/7.3/xorg_xorg_full_dri-7.3.pet
/xorg/7.3/xorg_xorg_full_dri_DEV-7.3.pet


When compiling, I used
Code:

./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x

<- puppy 431
----------------------------------------------------------------------------------------------------------
racy puppy 5.5 ->

I compiled using Racy 5.5
_________ mirrors _________
/distro/racy5.5/racy-5.5.iso
/distro/racy5.5/devx_racy_5.5.sfs

This puppy distro uses glibc 2.10.1
The Wine files listing 'racy5.5' will possibly not work with a glibc before 2.10.1
To see what glibc your puppy has.
Code:
ldd --version


I installed these packages (as one sfs file) before compiling:
_________ mirrors _________
/fontconfig/2.8.0/fontconfig-2.8.0-w5c.pet
/fontconfig/2.8.0/fontconfig_DEV-2.8.0-w5c.pet
/gnutls/2.10.5/gnutls-2.10.5-i486-431.pet
/gnutls/2.10.5/gnutls_DEV-2.10.5-i486-431.pet
/lcms2/2.5/lcms2-2.5-i486_v2.pet
/lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet
/libelf/0.8.13/libelf-0.8.13-i486_v2.pet
/libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet
/libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet
/libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet
/libgpg-error/1.10/libgpg-error-1.10-i486-431.pet
/libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet
/libtasn1/2.9/libtasn1-2.9-i486-431.pet
/libtasn1/2.9/libtasn1_DEV-2.9-i486-431.pet
/mpg123/1.12.4/mpg123-1.12.4.pet
/mpg123/1.12.4/mpg123_DEV-1.12.4.pet
/openldap/2.4.13/openldap-2.4.13-i486.pet
/openldap/2.4.13/openldap_DEV-2.4.13-i486.pet
/prelink/20130503/prelink-20130503-i486_v2.pet


When compiling in racy puppy 5.5, I used
Code:

./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x

<- racy puppy 5.5
----------------------------------------------------------------------------------------------------------


Menu entries, Color Setter, and other stuff I got from the file 'winegoodies.tar.gz' provided by forum member 'technosaurus'.
I only made a few changes to the contents of that file.

----------------------------------------------------------------------------------------------------------

updated links at my homepage. see below.
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 2 of 3 [43 Posts]   Goto page: Previous 1, 2, 3 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Virtualization
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1359s ][ Queries: 12 (0.0109s) ][ GZIP on ]