Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 25 Jun 2017, 00:05
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Virtualization
Wine - run Windows programs in Linux
Post new topic   Reply to topic View previous topic :: View next topic
Page 14 of 16 [229 Posts]   Goto page: Previous 1, 2, 3, ..., 12, 13, 14, 15, 16 Next
Author Message
version2013

Joined: 08 Sep 2013
Posts: 257

PostPosted: Sat 01 Oct 2016, 23:16    Post subject: Wine 1.9.19  

My attempt at compiling wine-1.9.19

[wine-1.9.19 mirrors]

wine-1.9.19_v1.1.pet ________ puppy 431 | stripped=true
wine-1.9.19_v1.2.pet ________ puppy 431 | stripped=false
wine_DEV-1.9.19_v1.1.pet ____ puppy 431 |
wine_DEV-1.9.19_v1.2.pet ____ puppy 431 |

wine-1.9.19_v2.1.pet ________ racy puppy 5.5 | stripped=true
wine-1.9.19_v2.2.pet ________ racy puppy 5.5 | stripped=false
wine_DEV-1.9.19_v2.1.pet ____ racy puppy 5.5 |
wine_DEV-1.9.19_v2.2.pet ____ racy puppy 5.5 |

wine_DOC-1.9.19.pet

wine_extras-v2.pet _____________ menu entries | mirrors
md5.txt and hashdeep.txt ________ checksums/hashes | mirrors

----------------------------------------------------------------
Notes for my webpage
http://version2013.yolasite.com/page1.php

The ">" character denotes a link to a mirror for either a directory or file.
ie. Look for the ">" adjacent to a
> directory/
> file

----------------------------------------------------------------

For general use, I recommend packages that are 'stripped=true'.
For submitting bug reports to WineHQ, I recommend packages that are 'stripped=false'.
When submitting bug reports to WineHQ, it appears a 'stripped=false' Wine provides more information than a 'stripped=true' Wine.
[references: post | page]

The first post has links to:
pet to sfs scripts, menu entry utilities, and Wine usage tips.

----------------------------------------------------------------------------------------------------------

----------------
puppy 431
----------------

I compiled using puplet: Puppies 4.31.1 by forum member 'ttuuxxx'

mirrors | /distro/4.3__1/puppies-431.1-main-Xserver.iso
mirrors | /distro/4.3__1/devx_430.sfs

This puplet uses glibc 2.6.1
The Wine files listing 'puppy 431' will possibly not work with a glibc before 2.6.1
To see what glibc your puppy has.
Code:
ldd --version

I installed the following packages, as one sfs file, before compiling;
also known as dependencies:

fontconfig/2.7.1/fontconfig-2.7.1-i486-pup4.pet [mirrors]
fontconfig/2.7.1/fontconfig_DEV-2.7.1-i486-pup4.pet

gmp/6.1.1/gmp-6.1.1-i486_v1.2.pet [mirrors]
gmp/6.1.1/gmp_DEV-6.1.1-i486_v1.2.pet

gnutls/3.5.2/gnutls-3.5.2_v1.2.pet [mirrors]
gnutls/3.5.2/gnutls_DEV-3.5.2.pet

lcms2/2.5/lcms2-2.5-i486_v2.pet [mirrors]
lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet

libelf/0.8.13/libelf-0.8.13-i486_v2.pet [mirrors]
libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet

libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet [mirrors]
libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet

libgpg-error/1.10/libgpg-error-1.10-i486-431.pet [mirrors]
libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet

libgphoto2/2.5.0/libgphoto2-2.5.0-i486_v2.pet [mirrors]
libgphoto2/2.5.0/libgphoto2_DEV-2.5.0-i486.pet

libtasn1/4.8/libtasn1-4.8-i486_v1.2.pet [mirrors]
libtasn1/4.8/libtasn1_DEV-4.8-i486_v1.2.pet

libusb/1.0.9/libusb-1.0.9-i486_v2.pet [mirrors]
libusb/1.0.9/libusb_DEV-1.0.9-i486_v2.pet

mpg123/1.12.4/mpg123-1.12.4.pet [mirrors]
mpg123/1.12.4/mpg123_DEV-1.12.4.pet

nettle/3.2/nettle-3.2_v1.2.pet [mirrors]
nettle/3.2/nettle_DEV-3.2_v1.2.pet

openal-soft/1.13/openal-soft-1.13-i486_v1.1.pet [mirrors]
openal-soft/1.13/openal-soft_DEV-1.13-i486_v1.pet

openldap/2.4.13/openldap-2.4.13-i486.pet [mirrors]
openldap/2.4.13/openldap_DEV-2.4.13-i486.pet

prelink/20130503/prelink-20130503-i486_v2.pet [mirrors]

xorg/7.3/xorg_xorg_full_dri-7.3.pet [mirrors]
xorg/7.3/xorg_xorg_full_dri_DEV-7.3.pet


------------------------------------

When compiling in puppy 431, I used:
v1.1
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-O2"

v1.2
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-g -O0 -fno-optimize-sibling-calls -fno-omit-frame-pointer -fno-inline"

----------------------------------------------------------------------------------------------------------

-----------------------
racy puppy 5.5
-----------------------

I compiled using Racy 5.5

mirrors | /distro/racy5.5/racy-5.5.iso
mirrors | /distro/racy5.5/devx_racy_5.5.sfs

This puppy distro uses glibc 2.10.1
The Wine files listing 'racy5.5' will possibly not work with a glibc before 2.10.1
To see what glibc your puppy has.
Code:
ldd --version

I installed the following packages, as one sfs file, before compiling;
also known as dependencies:

fontconfig/2.8.0/fontconfig-2.8.0-w5c.pet [mirrors]
fontconfig/2.8.0/fontconfig_DEV-2.8.0-w5c.pet

gmp/6.1.1/gmp-6.1.1-i486_v1.2.pet [mirrors]
gmp/6.1.1/gmp_DEV-6.1.1-i486_v1.2.pet

gnutls/3.5.2/gnutls-3.5.2_v1.2.pet [mirrors]
gnutls/3.5.2/gnutls_DEV-3.5.2.pet

lcms2/2.5/lcms2-2.5-i486_v2.pet [mirrors]
lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet

libelf/0.8.13/libelf-0.8.13-i486_v2.pet [mirrors]
libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet

libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet [mirrors]
libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet

libgpg-error/1.10/libgpg-error-1.10-i486-431.pet [mirrors]
libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet

libtasn1/4.8/libtasn1-4.8-i486_v1.2.pet [mirrors]
libtasn1/4.8/libtasn1_DEV-4.8-i486_v1.2.pet

mpg123/1.12.4/mpg123-1.12.4.pet [mirrors]
mpg123/1.12.4/mpg123_DEV-1.12.4.pet

nettle/3.2/nettle-3.2_v1.2.pet [mirrors]
nettle/3.2/nettle_DEV-3.2_v1.2.pet

openal-soft/1.13/openal-soft-1.13-i486_v1.1.pet [mirrors]
openal-soft/1.13/openal-soft_DEV-1.13-i486_v1.pet

openldap/2.4.13/openldap-2.4.13-i486.pet [mirrors]
openldap/2.4.13/openldap_DEV-2.4.13-i486.pet

prelink/20130503/prelink-20130503-i486_v2.pet [mirrors]

----------------------------------------

When compiling in racy puppy 5.5, I used
v2.1
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-O2"

v2.2
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-g -O0 -fno-optimize-sibling-calls -fno-omit-frame-pointer -fno-inline"

----------------------------------------------------------------------------------------------------------


Menu entries, Color Setter, and other stuff I got from the file 'winegoodies.tar.gz' [post | page] provided by forum member 'technosaurus'.
I only made a few changes to the contents of that file.

----------------------------------------------------------------------------------------------------------

updated links at my homepage. see below.

Last edited by version2013 on Fri 16 Dec 2016, 22:04; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
version2013

Joined: 08 Sep 2013
Posts: 257

PostPosted: Wed 05 Oct 2016, 07:31    Post subject: Wine 1.9.20  

My attempt at compiling wine-1.9.20

[wine-1.9.20 mirrors]

wine-1.9.20_v1.1.pet ________ puppy 431 | stripped=true
wine-1.9.20_v1.2.pet ________ puppy 431 | stripped=false
wine_DEV-1.9.20_v1.1.pet ____ puppy 431 |
wine_DEV-1.9.20_v1.2.pet ____ puppy 431 |

wine-1.9.20_v2.1.pet ________ racy puppy 5.5 | stripped=true
wine-1.9.20_v2.2.pet ________ racy puppy 5.5 | stripped=false
wine_DEV-1.9.20_v2.1.pet ____ racy puppy 5.5 |
wine_DEV-1.9.20_v2.2.pet ____ racy puppy 5.5 |

wine_DOC-1.9.20.pet

wine_extras-v2.pet _____________ menu entries | mirrors
md5.txt and hashdeep.txt ________ checksums/hashes | mirrors

----------------------------------------------------------------
Notes for my webpage
http://version2013.yolasite.com/page1.php

The ">" character denotes a link to a mirror for either a directory or file.
ie. Look for the ">" adjacent to a
> directory/
> file

----------------------------------------------------------------

For general use, I recommend packages that are 'stripped=true'.
For submitting bug reports to WineHQ, I recommend packages that are 'stripped=false'.
When submitting bug reports to WineHQ, it appears a 'stripped=false' Wine provides more information than a 'stripped=true' Wine.
[references: post | page]

The first post has links to:
pet to sfs scripts, menu entry utilities, and Wine usage tips.

----------------------------------------------------------------------------------------------------------

----------------
puppy 431
----------------

I compiled using puplet: Puppies 4.31.1 by forum member 'ttuuxxx'

mirrors | /distro/4.3__1/puppies-431.1-main-Xserver.iso
mirrors | /distro/4.3__1/devx_430.sfs

This puplet uses glibc 2.6.1
The Wine files listing 'puppy 431' will possibly not work with a glibc before 2.6.1
To see what glibc your puppy has.
Code:
ldd --version

I installed the following packages, as one sfs file, before compiling;
also known as dependencies:

fontconfig/2.7.1/fontconfig-2.7.1-i486-pup4.pet [mirrors]
fontconfig/2.7.1/fontconfig_DEV-2.7.1-i486-pup4.pet

gmp/6.1.1/gmp-6.1.1-i486_v1.2.pet [mirrors]
gmp/6.1.1/gmp_DEV-6.1.1-i486_v1.2.pet

gnutls/3.5.2/gnutls-3.5.2_v1.2.pet [mirrors]
gnutls/3.5.2/gnutls_DEV-3.5.2.pet

lcms2/2.5/lcms2-2.5-i486_v2.pet [mirrors]
lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet

libelf/0.8.13/libelf-0.8.13-i486_v2.pet [mirrors]
libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet

libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet [mirrors]
libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet

libgpg-error/1.10/libgpg-error-1.10-i486-431.pet [mirrors]
libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet

libgphoto2/2.5.0/libgphoto2-2.5.0-i486_v2.pet [mirrors]
libgphoto2/2.5.0/libgphoto2_DEV-2.5.0-i486.pet

libtasn1/4.8/libtasn1-4.8-i486_v1.2.pet [mirrors]
libtasn1/4.8/libtasn1_DEV-4.8-i486_v1.2.pet

libusb/1.0.9/libusb-1.0.9-i486_v2.pet [mirrors]
libusb/1.0.9/libusb_DEV-1.0.9-i486_v2.pet

mpg123/1.12.4/mpg123-1.12.4.pet [mirrors]
mpg123/1.12.4/mpg123_DEV-1.12.4.pet

nettle/3.2/nettle-3.2_v1.2.pet [mirrors]
nettle/3.2/nettle_DEV-3.2_v1.2.pet

openal-soft/1.13/openal-soft-1.13-i486_v1.1.pet [mirrors]
openal-soft/1.13/openal-soft_DEV-1.13-i486_v1.pet

openldap/2.4.13/openldap-2.4.13-i486.pet [mirrors]
openldap/2.4.13/openldap_DEV-2.4.13-i486.pet

prelink/20130503/prelink-20130503-i486_v2.pet [mirrors]

xorg/7.3/xorg_xorg_full_dri-7.3.pet [mirrors]
xorg/7.3/xorg_xorg_full_dri_DEV-7.3.pet


------------------------------------

When compiling in puppy 431, I used:
v1.1
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-O2"

v1.2
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-g -O0 -fno-optimize-sibling-calls -fno-omit-frame-pointer -fno-inline"

----------------------------------------------------------------------------------------------------------

-----------------------
racy puppy 5.5
-----------------------

I compiled using Racy 5.5

mirrors | /distro/racy5.5/racy-5.5.iso
mirrors | /distro/racy5.5/devx_racy_5.5.sfs

This puppy distro uses glibc 2.10.1
The Wine files listing 'racy5.5' will possibly not work with a glibc before 2.10.1
To see what glibc your puppy has.
Code:
ldd --version

I installed the following packages, as one sfs file, before compiling;
also known as dependencies:

fontconfig/2.8.0/fontconfig-2.8.0-w5c.pet [mirrors]
fontconfig/2.8.0/fontconfig_DEV-2.8.0-w5c.pet

gmp/6.1.1/gmp-6.1.1-i486_v1.2.pet [mirrors]
gmp/6.1.1/gmp_DEV-6.1.1-i486_v1.2.pet

gnutls/3.5.2/gnutls-3.5.2_v1.2.pet [mirrors]
gnutls/3.5.2/gnutls_DEV-3.5.2.pet

lcms2/2.5/lcms2-2.5-i486_v2.pet [mirrors]
lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet

libelf/0.8.13/libelf-0.8.13-i486_v2.pet [mirrors]
libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet

libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet [mirrors]
libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet

libgpg-error/1.10/libgpg-error-1.10-i486-431.pet [mirrors]
libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet

libtasn1/4.8/libtasn1-4.8-i486_v1.2.pet [mirrors]
libtasn1/4.8/libtasn1_DEV-4.8-i486_v1.2.pet

mpg123/1.12.4/mpg123-1.12.4.pet [mirrors]
mpg123/1.12.4/mpg123_DEV-1.12.4.pet

nettle/3.2/nettle-3.2_v1.2.pet [mirrors]
nettle/3.2/nettle_DEV-3.2_v1.2.pet

openal-soft/1.13/openal-soft-1.13-i486_v1.1.pet [mirrors]
openal-soft/1.13/openal-soft_DEV-1.13-i486_v1.pet

openldap/2.4.13/openldap-2.4.13-i486.pet [mirrors]
openldap/2.4.13/openldap_DEV-2.4.13-i486.pet

prelink/20130503/prelink-20130503-i486_v2.pet [mirrors]

----------------------------------------

When compiling in racy puppy 5.5, I used
v2.1
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-O2"

v2.2
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-g -O0 -fno-optimize-sibling-calls -fno-omit-frame-pointer -fno-inline"

----------------------------------------------------------------------------------------------------------


Menu entries, Color Setter, and other stuff I got from the file 'winegoodies.tar.gz' [post | page] provided by forum member 'technosaurus'.
I only made a few changes to the contents of that file.

----------------------------------------------------------------------------------------------------------

updated links at my homepage. see below.

Last edited by version2013 on Fri 16 Dec 2016, 22:05; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
version2013

Joined: 08 Sep 2013
Posts: 257

PostPosted: Fri 14 Oct 2016, 21:31    Post subject: Wine 1.8.5  

My attempt at compiling wine-1.8.5

[wine-1.8.5 mirrors]

wine-1.8.5_v1.1.pet ________ puppy 431 | stripped=true
wine-1.8.5_v1.2.pet ________ puppy 431 | stripped=false
wine_DEV-1.8.5_v1.1.pet ____ puppy 431 |
wine_DEV-1.8.5_v1.2.pet ____ puppy 431 |

wine-1.8.5_v2.1.pet ________ racy puppy 5.5 | stripped=true
wine-1.8.5_v2.2.pet ________ racy puppy 5.5 | stripped=false
wine_DEV-1.8.5_v2.1.pet ____ racy puppy 5.5 |
wine_DEV-1.8.5_v2.2.pet ____ racy puppy 5.5 |

wine_DOC-1.8.5.pet

wine_extras-v2.pet _____________ menu entries | mirrors
md5.txt and hashdeep.txt ________ checksums/hashes | mirrors

----------------------------------------------------------------
Notes for my webpage
http://version2013.yolasite.com/page1.php

The ">" character denotes a link to a mirror for either a directory or file.
ie. Look for the ">" adjacent to a
> directory/
> file

----------------------------------------------------------------

For general use, I recommend packages that are 'stripped=true'.
For submitting bug reports to WineHQ, I recommend packages that are 'stripped=false'.
When submitting bug reports to WineHQ, it appears a 'stripped=false' Wine provides more information than a 'stripped=true' Wine.
[references: post | page]

The first post has links to:
pet to sfs scripts, menu entry utilities, and Wine usage tips.

----------------------------------------------------------------------------------------------------------

----------------
puppy 431
----------------

I compiled using puplet: Puppies 4.31.1 by forum member 'ttuuxxx'

mirrors | /distro/4.3__1/puppies-431.1-main-Xserver.iso
mirrors | /distro/4.3__1/devx_430.sfs

This puplet uses glibc 2.6.1
The Wine files listing 'puppy 431' will possibly not work with a glibc before 2.6.1
To see what glibc your puppy has.
Code:
ldd --version

I installed the following packages, as one sfs file, before compiling;
also known as dependencies:

fontconfig/2.7.1/fontconfig-2.7.1-i486-pup4.pet [mirrors]
fontconfig/2.7.1/fontconfig_DEV-2.7.1-i486-pup4.pet

gmp/6.1.1/gmp-6.1.1-i486_v1.2.pet [mirrors]
gmp/6.1.1/gmp_DEV-6.1.1-i486_v1.2.pet

gnutls/3.5.2/gnutls-3.5.2_v1.2.pet [mirrors]
gnutls/3.5.2/gnutls_DEV-3.5.2.pet

lcms2/2.5/lcms2-2.5-i486_v2.pet [mirrors]
lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet

libelf/0.8.13/libelf-0.8.13-i486_v2.pet [mirrors]
libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet

libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet [mirrors]
libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet

libgpg-error/1.10/libgpg-error-1.10-i486-431.pet [mirrors]
libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet

libgphoto2/2.5.0/libgphoto2-2.5.0-i486_v2.pet [mirrors]
libgphoto2/2.5.0/libgphoto2_DEV-2.5.0-i486.pet

libtasn1/4.8/libtasn1-4.8-i486_v1.2.pet [mirrors]
libtasn1/4.8/libtasn1_DEV-4.8-i486_v1.2.pet

libusb/1.0.9/libusb-1.0.9-i486_v2.pet [mirrors]
libusb/1.0.9/libusb_DEV-1.0.9-i486_v2.pet

mpg123/1.12.4/mpg123-1.12.4.pet [mirrors]
mpg123/1.12.4/mpg123_DEV-1.12.4.pet

nettle/3.2/nettle-3.2_v1.2.pet [mirrors]
nettle/3.2/nettle_DEV-3.2_v1.2.pet

openal-soft/1.13/openal-soft-1.13-i486_v1.1.pet [mirrors]
openal-soft/1.13/openal-soft_DEV-1.13-i486_v1.pet

openldap/2.4.13/openldap-2.4.13-i486.pet [mirrors]
openldap/2.4.13/openldap_DEV-2.4.13-i486.pet

prelink/20130503/prelink-20130503-i486_v2.pet [mirrors]

xorg/7.3/xorg_xorg_full_dri-7.3.pet [mirrors]
xorg/7.3/xorg_xorg_full_dri_DEV-7.3.pet


------------------------------------

When compiling in puppy 431, I used:
v1.1
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-O2"

v1.2
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-g -O0 -fno-optimize-sibling-calls -fno-omit-frame-pointer -fno-inline"

----------------------------------------------------------------------------------------------------------

-----------------------
racy puppy 5.5
-----------------------

I compiled using Racy 5.5

mirrors | /distro/racy5.5/racy-5.5.iso
mirrors | /distro/racy5.5/devx_racy_5.5.sfs

This puppy distro uses glibc 2.10.1
The Wine files listing 'racy5.5' will possibly not work with a glibc before 2.10.1
To see what glibc your puppy has.
Code:
ldd --version

I installed the following packages, as one sfs file, before compiling;
also known as dependencies:

fontconfig/2.8.0/fontconfig-2.8.0-w5c.pet [mirrors]
fontconfig/2.8.0/fontconfig_DEV-2.8.0-w5c.pet

gmp/6.1.1/gmp-6.1.1-i486_v1.2.pet [mirrors]
gmp/6.1.1/gmp_DEV-6.1.1-i486_v1.2.pet

gnutls/3.5.2/gnutls-3.5.2_v1.2.pet [mirrors]
gnutls/3.5.2/gnutls_DEV-3.5.2.pet

lcms2/2.5/lcms2-2.5-i486_v2.pet [mirrors]
lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet

libelf/0.8.13/libelf-0.8.13-i486_v2.pet [mirrors]
libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet

libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet [mirrors]
libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet

libgpg-error/1.10/libgpg-error-1.10-i486-431.pet [mirrors]
libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet

libtasn1/4.8/libtasn1-4.8-i486_v1.2.pet [mirrors]
libtasn1/4.8/libtasn1_DEV-4.8-i486_v1.2.pet

mpg123/1.12.4/mpg123-1.12.4.pet [mirrors]
mpg123/1.12.4/mpg123_DEV-1.12.4.pet

nettle/3.2/nettle-3.2_v1.2.pet [mirrors]
nettle/3.2/nettle_DEV-3.2_v1.2.pet

openal-soft/1.13/openal-soft-1.13-i486_v1.1.pet [mirrors]
openal-soft/1.13/openal-soft_DEV-1.13-i486_v1.pet

openldap/2.4.13/openldap-2.4.13-i486.pet [mirrors]
openldap/2.4.13/openldap_DEV-2.4.13-i486.pet

prelink/20130503/prelink-20130503-i486_v2.pet [mirrors]

----------------------------------------

When compiling in racy puppy 5.5, I used
v2.1
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-O2"

v2.2
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-g -O0 -fno-optimize-sibling-calls -fno-omit-frame-pointer -fno-inline"

----------------------------------------------------------------------------------------------------------


Menu entries, Color Setter, and other stuff I got from the file 'winegoodies.tar.gz' [post | page] provided by forum member 'technosaurus'.
I only made a few changes to the contents of that file.

----------------------------------------------------------------------------------------------------------

updated links at my homepage. see below.

Last edited by version2013 on Fri 16 Dec 2016, 22:06; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
version2013

Joined: 08 Sep 2013
Posts: 257

PostPosted: Sun 23 Oct 2016, 17:49    Post subject: Wine 1.9.21  

My attempt at compiling wine-1.9.21

[wine-1.9.21 mirrors]

wine-1.9.21_v1.1.pet ________ puppy 431 | stripped=true
wine-1.9.21_v1.2.pet ________ puppy 431 | stripped=false
wine_DEV-1.9.21_v1.1.pet ____ puppy 431 |
wine_DEV-1.9.21_v1.2.pet ____ puppy 431 |

wine-1.9.21_v2.1.pet ________ racy puppy 5.5 | stripped=true
wine-1.9.21_v2.2.pet ________ racy puppy 5.5 | stripped=false
wine_DEV-1.9.21_v2.1.pet ____ racy puppy 5.5 |
wine_DEV-1.9.21_v2.2.pet ____ racy puppy 5.5 |

wine_DOC-1.9.21.pet

wine_extras-v2.pet _____________ menu entries | mirrors
md5.txt and hashdeep.txt ________ checksums/hashes | mirrors

----------------------------------------------------------------
Notes for my webpage
http://version2013.yolasite.com/page1.php

The ">" character denotes a link to a mirror for either a directory or file.
ie. Look for the ">" adjacent to a
> directory/
> file

----------------------------------------------------------------

For general use, I recommend packages that are 'stripped=true'.
For submitting bug reports to WineHQ, I recommend packages that are 'stripped=false'.
When submitting bug reports to WineHQ, it appears a 'stripped=false' Wine provides more information than a 'stripped=true' Wine.
[references: post | page]

The first post has links to:
pet to sfs scripts, menu entry utilities, and Wine usage tips.

----------------------------------------------------------------------------------------------------------

puppy431 and racy5.5 compilation error:
https://bugs.winehq.org/show_bug.cgi?id=41492
used patch to compile successfully:
https://bugs.winehq.org/attachment.cgi?id=55877


----------------
puppy 431
----------------

I compiled using puplet: Puppies 4.31.1 by forum member 'ttuuxxx'

mirrors | /distro/4.3__1/puppies-431.1-main-Xserver.iso
mirrors | /distro/4.3__1/devx_430.sfs

This puplet uses glibc 2.6.1
The Wine files listing 'puppy 431' will possibly not work with a glibc before 2.6.1
To see what glibc your puppy has.
Code:
ldd --version

I installed the following packages, as one sfs file, before compiling;
also known as dependencies:

fontconfig/2.7.1/fontconfig-2.7.1-i486-pup4.pet [mirrors]
fontconfig/2.7.1/fontconfig_DEV-2.7.1-i486-pup4.pet

gmp/6.1.1/gmp-6.1.1-i486_v1.2.pet [mirrors]
gmp/6.1.1/gmp_DEV-6.1.1-i486_v1.2.pet

gnutls/3.5.2/gnutls-3.5.2_v1.2.pet [mirrors]
gnutls/3.5.2/gnutls_DEV-3.5.2.pet

lcms2/2.5/lcms2-2.5-i486_v2.pet [mirrors]
lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet

libelf/0.8.13/libelf-0.8.13-i486_v2.pet [mirrors]
libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet

libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet [mirrors]
libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet

libgpg-error/1.10/libgpg-error-1.10-i486-431.pet [mirrors]
libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet

libgphoto2/2.5.0/libgphoto2-2.5.0-i486_v2.pet [mirrors]
libgphoto2/2.5.0/libgphoto2_DEV-2.5.0-i486.pet

libtasn1/4.8/libtasn1-4.8-i486_v1.2.pet [mirrors]
libtasn1/4.8/libtasn1_DEV-4.8-i486_v1.2.pet

libusb/1.0.9/libusb-1.0.9-i486_v2.pet [mirrors]
libusb/1.0.9/libusb_DEV-1.0.9-i486_v2.pet

mpg123/1.12.4/mpg123-1.12.4.pet [mirrors]
mpg123/1.12.4/mpg123_DEV-1.12.4.pet

nettle/3.2/nettle-3.2_v1.2.pet [mirrors]
nettle/3.2/nettle_DEV-3.2_v1.2.pet

openal-soft/1.13/openal-soft-1.13-i486_v1.1.pet [mirrors]
openal-soft/1.13/openal-soft_DEV-1.13-i486_v1.pet

openldap/2.4.13/openldap-2.4.13-i486.pet [mirrors]
openldap/2.4.13/openldap_DEV-2.4.13-i486.pet

prelink/20130503/prelink-20130503-i486_v2.pet [mirrors]

xorg/7.3/xorg_xorg_full_dri-7.3.pet [mirrors]
xorg/7.3/xorg_xorg_full_dri_DEV-7.3.pet


------------------------------------

When compiling in puppy 431, I used:
v1.1
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-O2"

v1.2
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-g -O0 -fno-optimize-sibling-calls -fno-omit-frame-pointer -fno-inline"

----------------------------------------------------------------------------------------------------------

-----------------------
racy puppy 5.5
-----------------------

I compiled using Racy 5.5

mirrors | /distro/racy5.5/racy-5.5.iso
mirrors | /distro/racy5.5/devx_racy_5.5.sfs

This puppy distro uses glibc 2.10.1
The Wine files listing 'racy5.5' will possibly not work with a glibc before 2.10.1
To see what glibc your puppy has.
Code:
ldd --version

I installed the following packages, as one sfs file, before compiling;
also known as dependencies:

fontconfig/2.8.0/fontconfig-2.8.0-w5c.pet [mirrors]
fontconfig/2.8.0/fontconfig_DEV-2.8.0-w5c.pet

gmp/6.1.1/gmp-6.1.1-i486_v1.2.pet [mirrors]
gmp/6.1.1/gmp_DEV-6.1.1-i486_v1.2.pet

gnutls/3.5.2/gnutls-3.5.2_v1.2.pet [mirrors]
gnutls/3.5.2/gnutls_DEV-3.5.2.pet

lcms2/2.5/lcms2-2.5-i486_v2.pet [mirrors]
lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet

libelf/0.8.13/libelf-0.8.13-i486_v2.pet [mirrors]
libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet

libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet [mirrors]
libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet

libgpg-error/1.10/libgpg-error-1.10-i486-431.pet [mirrors]
libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet

libtasn1/4.8/libtasn1-4.8-i486_v1.2.pet [mirrors]
libtasn1/4.8/libtasn1_DEV-4.8-i486_v1.2.pet

mpg123/1.12.4/mpg123-1.12.4.pet [mirrors]
mpg123/1.12.4/mpg123_DEV-1.12.4.pet

nettle/3.2/nettle-3.2_v1.2.pet [mirrors]
nettle/3.2/nettle_DEV-3.2_v1.2.pet

openal-soft/1.13/openal-soft-1.13-i486_v1.1.pet [mirrors]
openal-soft/1.13/openal-soft_DEV-1.13-i486_v1.pet

openldap/2.4.13/openldap-2.4.13-i486.pet [mirrors]
openldap/2.4.13/openldap_DEV-2.4.13-i486.pet

prelink/20130503/prelink-20130503-i486_v2.pet [mirrors]

----------------------------------------

When compiling in racy puppy 5.5, I used
v2.1
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-O2"

v2.2
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-g -O0 -fno-optimize-sibling-calls -fno-omit-frame-pointer -fno-inline"

----------------------------------------------------------------------------------------------------------


Menu entries, Color Setter, and other stuff I got from the file 'winegoodies.tar.gz' [post | page] provided by forum member 'technosaurus'.
I only made a few changes to the contents of that file.

----------------------------------------------------------------------------------------------------------

updated links at my homepage. see below.

Last edited by version2013 on Fri 16 Dec 2016, 22:07; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
version2013

Joined: 08 Sep 2013
Posts: 257

PostPosted: Wed 09 Nov 2016, 14:29    Post subject: Wine 1.9.22  

My attempt at compiling wine-1.9.22

[wine-1.9.22 mirrors]

wine-1.9.22_v1.1.pet ________ puppy 431 | stripped=true
wine-1.9.22_v1.2.pet ________ puppy 431 | stripped=false
wine_DEV-1.9.22_v1.1.pet ____ puppy 431 |
wine_DEV-1.9.22_v1.2.pet ____ puppy 431 |

wine-1.9.22_v2.1.pet ________ racy puppy 5.5 | stripped=true
wine-1.9.22_v2.2.pet ________ racy puppy 5.5 | stripped=false
wine_DEV-1.9.22_v2.1.pet ____ racy puppy 5.5 |
wine_DEV-1.9.22_v2.2.pet ____ racy puppy 5.5 |

wine_DOC-1.9.22.pet

wine_extras-v2.pet _____________ menu entries | mirrors
md5.txt and hashdeep.txt ________ checksums/hashes | mirrors

----------------------------------------------------------------
Notes for my webpage
http://version2013.yolasite.com/page1.php

The ">" character denotes a link to a mirror for either a directory or file.
ie. Look for the ">" adjacent to a
> directory/
> file

----------------------------------------------------------------

For general use, I recommend packages that are 'stripped=true'.
For submitting bug reports to WineHQ, I recommend packages that are 'stripped=false'.
When submitting bug reports to WineHQ, it appears a 'stripped=false' Wine provides more information than a 'stripped=true' Wine.
[references: post | page]

The first post has links to:
pet to sfs scripts, menu entry utilities, and Wine usage tips.

----------------------------------------------------------------------------------------------------------


----------------
puppy 431
----------------

I compiled using puplet: Puppies 4.31.1 by forum member 'ttuuxxx'

mirrors | /distro/4.3__1/puppies-431.1-main-Xserver.iso
mirrors | /distro/4.3__1/devx_430.sfs

This puplet uses glibc 2.6.1
The Wine files listing 'puppy 431' will possibly not work with a glibc before 2.6.1
To see what glibc your puppy has.
Code:
ldd --version

I installed the following packages, as one sfs file, before compiling;
also known as dependencies:

fontconfig/2.7.1/fontconfig-2.7.1-i486-pup4.pet [mirrors]
fontconfig/2.7.1/fontconfig_DEV-2.7.1-i486-pup4.pet

gmp/6.1.1/gmp-6.1.1-i486_v1.2.pet [mirrors]
gmp/6.1.1/gmp_DEV-6.1.1-i486_v1.2.pet

gnutls/3.5.2/gnutls-3.5.2_v1.2.pet [mirrors]
gnutls/3.5.2/gnutls_DEV-3.5.2.pet

lcms2/2.5/lcms2-2.5-i486_v2.pet [mirrors]
lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet

libelf/0.8.13/libelf-0.8.13-i486_v2.pet [mirrors]
libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet

libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet [mirrors]
libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet

libgpg-error/1.10/libgpg-error-1.10-i486-431.pet [mirrors]
libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet

libgphoto2/2.5.0/libgphoto2-2.5.0-i486_v2.pet [mirrors]
libgphoto2/2.5.0/libgphoto2_DEV-2.5.0-i486.pet

libtasn1/4.8/libtasn1-4.8-i486_v1.2.pet [mirrors]
libtasn1/4.8/libtasn1_DEV-4.8-i486_v1.2.pet

libusb/1.0.9/libusb-1.0.9-i486_v2.pet [mirrors]
libusb/1.0.9/libusb_DEV-1.0.9-i486_v2.pet

mpg123/1.12.4/mpg123-1.12.4.pet [mirrors]
mpg123/1.12.4/mpg123_DEV-1.12.4.pet

nettle/3.2/nettle-3.2_v1.2.pet [mirrors]
nettle/3.2/nettle_DEV-3.2_v1.2.pet

openal-soft/1.13/openal-soft-1.13-i486_v1.1.pet [mirrors]
openal-soft/1.13/openal-soft_DEV-1.13-i486_v1.pet

openldap/2.4.13/openldap-2.4.13-i486.pet [mirrors]
openldap/2.4.13/openldap_DEV-2.4.13-i486.pet

prelink/20130503/prelink-20130503-i486_v2.pet [mirrors]

xorg/7.3/xorg_xorg_full_dri-7.3.pet [mirrors]
xorg/7.3/xorg_xorg_full_dri_DEV-7.3.pet


------------------------------------

When compiling in puppy 431, I used:
v1.1
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-O2"

v1.2
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-g -O0 -fno-optimize-sibling-calls -fno-omit-frame-pointer -fno-inline"

----------------------------------------------------------------------------------------------------------

-----------------------
racy puppy 5.5
-----------------------

I compiled using Racy 5.5

mirrors | /distro/racy5.5/racy-5.5.iso
mirrors | /distro/racy5.5/devx_racy_5.5.sfs

This puppy distro uses glibc 2.10.1
The Wine files listing 'racy5.5' will possibly not work with a glibc before 2.10.1
To see what glibc your puppy has.
Code:
ldd --version

I installed the following packages, as one sfs file, before compiling;
also known as dependencies:

fontconfig/2.8.0/fontconfig-2.8.0-w5c.pet [mirrors]
fontconfig/2.8.0/fontconfig_DEV-2.8.0-w5c.pet

gmp/6.1.1/gmp-6.1.1-i486_v1.2.pet [mirrors]
gmp/6.1.1/gmp_DEV-6.1.1-i486_v1.2.pet

gnutls/3.5.2/gnutls-3.5.2_v1.2.pet [mirrors]
gnutls/3.5.2/gnutls_DEV-3.5.2.pet

lcms2/2.5/lcms2-2.5-i486_v2.pet [mirrors]
lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet

libelf/0.8.13/libelf-0.8.13-i486_v2.pet [mirrors]
libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet

libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet [mirrors]
libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet

libgpg-error/1.10/libgpg-error-1.10-i486-431.pet [mirrors]
libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet

libtasn1/4.8/libtasn1-4.8-i486_v1.2.pet [mirrors]
libtasn1/4.8/libtasn1_DEV-4.8-i486_v1.2.pet

mpg123/1.12.4/mpg123-1.12.4.pet [mirrors]
mpg123/1.12.4/mpg123_DEV-1.12.4.pet

nettle/3.2/nettle-3.2_v1.2.pet [mirrors]
nettle/3.2/nettle_DEV-3.2_v1.2.pet

openal-soft/1.13/openal-soft-1.13-i486_v1.1.pet [mirrors]
openal-soft/1.13/openal-soft_DEV-1.13-i486_v1.pet

openldap/2.4.13/openldap-2.4.13-i486.pet [mirrors]
openldap/2.4.13/openldap_DEV-2.4.13-i486.pet

prelink/20130503/prelink-20130503-i486_v2.pet [mirrors]

----------------------------------------

When compiling in racy puppy 5.5, I used
v2.1
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-O2"

v2.2
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-g -O0 -fno-optimize-sibling-calls -fno-omit-frame-pointer -fno-inline"

----------------------------------------------------------------------------------------------------------


Menu entries, Color Setter, and other stuff I got from the file 'winegoodies.tar.gz' [post | page] provided by forum member 'technosaurus'.
I only made a few changes to the contents of that file.

----------------------------------------------------------------------------------------------------------

updated links at my homepage. see below.

Last edited by version2013 on Fri 16 Dec 2016, 22:08; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
version2013

Joined: 08 Sep 2013
Posts: 257

PostPosted: Fri 18 Nov 2016, 20:35    Post subject:  

No packages for wine 1.9.23.
Build fails when trying to compile with puppy431 and racy5.5.
https://bugs.winehq.org/show_bug.cgi?id=41705
The patch is in a different format than what I used in the past.
I am going to wait for 1.9.24.
Back to top
View user's profile Send private message Visit poster's website 
Marv


Joined: 04 May 2005
Posts: 816
Location: SW Wisconsin

PostPosted: Sat 26 Nov 2016, 13:37    Post subject: Wine 1.9.22 run as SFS  

I just shut down my last Windows machine. I had a few financial and quilt design programs that were only available under windows so I downloaded your version 1.9.22_v2.1 pet and it does exactly what is needed. Run on X-slacko 4.2 and LxPupSc 16.11.2 so far. I use it seldom so I didn't want to install it permanently so I tried the following and it worked well. Only a small (<2Mb) /root/.wine file remains on the OS it is run on after unloading. I'm sure there are other more elegant ways to do this but this works for my light occasional use. In the preliminary stages of this, I just ran the non-customized SFS and moved the .wine folder from /root to my EXT2 data partition and made a symlink to it in /root. That worked also.


Downloaded the pet, both extracted it to a dir and converted it to a SFS (in my EXT2 workdir).

Loaded that SFS, ran winecfg and added my programs to /root/.wine/drive_c/Program Files. Tested the programs.

Then moved /root/.wine into the extracted pet directory and converted that into an SFS (now has mono, gecko, and my programs on board).

That SFS loads and unloads cleanly in the two pups above, leaves only a small .wine file behind when unloaded, and is perfect for my occasional use.

Thanks for the pet and guidance. This was MUCH smoother than my previous wine tastings.

Edit: Also tested in X-tahr 2.0. Works fine on my progs.

_________________
Pups currently in kennel Very Happy X-slacko 4.2 and X-tahr 2.0 for my users; LxPupSc and LxPupXenial for me. All good pups indeed, and all running browsers, office etc. solely from SFS.
Back to top
View user's profile Send private message 
version2013

Joined: 08 Sep 2013
Posts: 257

PostPosted: Wed 30 Nov 2016, 22:15    Post subject: Wine 1.9.24  

My attempt at compiling wine-1.9.24

[wine-1.9.24 mirrors]

wine-1.9.24_v1.1.pet ________ puppy 431 | stripped=true
wine-1.9.24_v1.2.pet ________ puppy 431 | stripped=false
wine_DEV-1.9.24_v1.1.pet ____ puppy 431 |
wine_DEV-1.9.24_v1.2.pet ____ puppy 431 |

wine-1.9.24_v2.1.pet ________ racy puppy 5.5 | stripped=true
wine-1.9.24_v2.2.pet ________ racy puppy 5.5 | stripped=false
wine_DEV-1.9.24_v2.1.pet ____ racy puppy 5.5 |
wine_DEV-1.9.24_v2.2.pet ____ racy puppy 5.5 |

wine_DOC-1.9.24.pet

wine_extras-v2.pet _____________ menu entries | mirrors
md5.txt and hashdeep.txt ________ checksums/hashes | mirrors

----------------------------------------------------------------
Notes for my webpage
http://version2013.yolasite.com/page1.php

The ">" character denotes a link to a mirror for either a directory or file.
ie. Look for the ">" adjacent to a
> directory/
> file

----------------------------------------------------------------

For general use, I recommend packages that are 'stripped=true'.
For submitting bug reports to WineHQ, I recommend packages that are 'stripped=false'.
When submitting bug reports to WineHQ, it appears a 'stripped=false' Wine provides more information than a 'stripped=true' Wine.
[references: post | page]

The first post has links to:
pet to sfs scripts, menu entry utilities, and Wine usage tips.

----------------------------------------------------------------------------------------------------------


----------------
puppy 431
----------------

I compiled using puplet: Puppies 4.31.1 by forum member 'ttuuxxx'

mirrors | /distro/4.3__1/puppies-431.1-main-Xserver.iso
mirrors | /distro/4.3__1/devx_430.sfs

This puplet uses glibc 2.6.1
The Wine files listing 'puppy 431' will possibly not work with a glibc before 2.6.1
To see what glibc your puppy has.
Code:
ldd --version

I installed the following packages, as one sfs file, before compiling;
also known as dependencies:

fontconfig/2.7.1/fontconfig-2.7.1-i486-pup4.pet [mirrors]
fontconfig/2.7.1/fontconfig_DEV-2.7.1-i486-pup4.pet

gmp/6.1.1/gmp-6.1.1-i486_v1.2.pet [mirrors]
gmp/6.1.1/gmp_DEV-6.1.1-i486_v1.2.pet

gnutls/3.5.2/gnutls-3.5.2_v1.2.pet [mirrors]
gnutls/3.5.2/gnutls_DEV-3.5.2.pet

lcms2/2.5/lcms2-2.5-i486_v2.pet [mirrors]
lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet

libelf/0.8.13/libelf-0.8.13-i486_v2.pet [mirrors]
libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet

libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet [mirrors]
libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet

libgpg-error/1.10/libgpg-error-1.10-i486-431.pet [mirrors]
libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet

libgphoto2/2.5.0/libgphoto2-2.5.0-i486_v2.pet [mirrors]
libgphoto2/2.5.0/libgphoto2_DEV-2.5.0-i486.pet

libtasn1/4.8/libtasn1-4.8-i486_v1.2.pet [mirrors]
libtasn1/4.8/libtasn1_DEV-4.8-i486_v1.2.pet

libusb/1.0.9/libusb-1.0.9-i486_v2.pet [mirrors]
libusb/1.0.9/libusb_DEV-1.0.9-i486_v2.pet

mpg123/1.12.4/mpg123-1.12.4.pet [mirrors]
mpg123/1.12.4/mpg123_DEV-1.12.4.pet

nettle/3.2/nettle-3.2_v1.2.pet [mirrors]
nettle/3.2/nettle_DEV-3.2_v1.2.pet

openal-soft/1.13/openal-soft-1.13-i486_v1.1.pet [mirrors]
openal-soft/1.13/openal-soft_DEV-1.13-i486_v1.pet

openldap/2.4.13/openldap-2.4.13-i486.pet [mirrors]
openldap/2.4.13/openldap_DEV-2.4.13-i486.pet

prelink/20130503/prelink-20130503-i486_v2.pet [mirrors]

xorg/7.3/xorg_xorg_full_dri-7.3.pet [mirrors]
xorg/7.3/xorg_xorg_full_dri_DEV-7.3.pet


------------------------------------

When compiling in puppy 431, I used:
v1.1
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-O2"

v1.2
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-g -O0 -fno-optimize-sibling-calls -fno-omit-frame-pointer -fno-inline"

----------------------------------------------------------------------------------------------------------

-----------------------
racy puppy 5.5
-----------------------

I compiled using Racy 5.5

mirrors | /distro/racy5.5/racy-5.5.iso
mirrors | /distro/racy5.5/devx_racy_5.5.sfs

This puppy distro uses glibc 2.10.1
The Wine files listing 'racy5.5' will possibly not work with a glibc before 2.10.1
To see what glibc your puppy has.
Code:
ldd --version

I installed the following packages, as one sfs file, before compiling;
also known as dependencies:

fontconfig/2.8.0/fontconfig-2.8.0-w5c.pet [mirrors]
fontconfig/2.8.0/fontconfig_DEV-2.8.0-w5c.pet

gmp/6.1.1/gmp-6.1.1-i486_v1.2.pet [mirrors]
gmp/6.1.1/gmp_DEV-6.1.1-i486_v1.2.pet

gnutls/3.5.2/gnutls-3.5.2_v1.2.pet [mirrors]
gnutls/3.5.2/gnutls_DEV-3.5.2.pet

lcms2/2.5/lcms2-2.5-i486_v2.pet [mirrors]
lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet

libelf/0.8.13/libelf-0.8.13-i486_v2.pet [mirrors]
libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet

libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet [mirrors]
libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet

libgpg-error/1.10/libgpg-error-1.10-i486-431.pet [mirrors]
libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet

libtasn1/4.8/libtasn1-4.8-i486_v1.2.pet [mirrors]
libtasn1/4.8/libtasn1_DEV-4.8-i486_v1.2.pet

mpg123/1.12.4/mpg123-1.12.4.pet [mirrors]
mpg123/1.12.4/mpg123_DEV-1.12.4.pet

nettle/3.2/nettle-3.2_v1.2.pet [mirrors]
nettle/3.2/nettle_DEV-3.2_v1.2.pet

openal-soft/1.13/openal-soft-1.13-i486_v1.1.pet [mirrors]
openal-soft/1.13/openal-soft_DEV-1.13-i486_v1.pet

openldap/2.4.13/openldap-2.4.13-i486.pet [mirrors]
openldap/2.4.13/openldap_DEV-2.4.13-i486.pet

prelink/20130503/prelink-20130503-i486_v2.pet [mirrors]

----------------------------------------

https://bugs.winehq.org/show_bug.cgi?id=41869
https://bugs.winehq.org/attachment.cgi?id=56274
This patch is only applied to Racy5.5
Puppy431 build completed without a need for this patch.

----------------------------------------

When compiling in racy puppy 5.5, I used
v2.1
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-O2"

v2.2
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-g -O0 -fno-optimize-sibling-calls -fno-omit-frame-pointer -fno-inline"

----------------------------------------------------------------------------------------------------------


Menu entries, Color Setter, and other stuff I got from the file 'winegoodies.tar.gz' [post | page] provided by forum member 'technosaurus'.
I only made a few changes to the contents of that file.

----------------------------------------------------------------------------------------------------------

updated links at my homepage. see below.

Last edited by version2013 on Fri 16 Dec 2016, 22:09; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
trlkly

Joined: 11 Oct 2010
Posts: 23

PostPosted: Thu 15 Dec 2016, 18:54    Post subject:  

Any chance of getting the latest stable version with OSMesa support compiled in? I apparently have OSMesa6 10.1.0, if that matters.

I'm trying to get certain programs running that try to use OpenGL, and the error I get is that OSMesa is not compiled in.
Back to top
View user's profile Send private message 
version2013

Joined: 08 Sep 2013
Posts: 257

PostPosted: Fri 16 Dec 2016, 19:31    Post subject:  

trlkly wrote:
Any chance of getting the latest stable version with OSMesa support compiled in? I apparently have OSMesa6 10.1.0, if that matters.

I'm trying to get certain programs running that try to use OpenGL, and the error I get is that OSMesa is not compiled in.


If I can find the time, I will try to figure how to compile OSMesa and it's dependencies and have them compiled into a future build of Wine.

Does anyone know if this Mesa file [1] has the development headers for compiling?


[1] http://murga-linux.com/puppy/viewtopic.php?p=866944#866944
Back to top
View user's profile Send private message Visit poster's website 
version2013

Joined: 08 Sep 2013
Posts: 257

PostPosted: Fri 16 Dec 2016, 20:58    Post subject: Wine 2.0-rc1  

My attempt at compiling wine-2.0-rc1

[wine-2.0-rc1 mirrors]

wine-2.0-rc1_v1.1.pet ________ puppy 431 | stripped=true
wine-2.0-rc1_v1.2.pet ________ puppy 431 | stripped=false
wine_DEV-2.0-rc1_v1.1.pet ____ puppy 431 |
wine_DEV-2.0-rc1_v1.2.pet ____ puppy 431 |

wine-2.0-rc1_v2.1.pet ________ racy puppy 5.5 | stripped=true
wine-2.0-rc1_v2.2.pet ________ racy puppy 5.5 | stripped=false
wine_DEV-2.0-rc1_v2.1.pet ____ racy puppy 5.5 |
wine_DEV-2.0-rc1_v2.2.pet ____ racy puppy 5.5 |

wine_DOC-2.0-rc1.pet

wine_extras-v2.pet _____________ menu entries | mirrors
md5.txt and hashdeep.txt ________ checksums/hashes | mirrors

----------------------------------------------------------------
Notes for my webpage
http://version2013.yolasite.com/page1.php

The ">" character denotes a link to a mirror for either a directory or file.
ie. Look for the ">" adjacent to a
> directory/
> file

----------------------------------------------------------------

For general use, I recommend packages that are 'stripped=true'.
For submitting bug reports to WineHQ, I recommend packages that are 'stripped=false'.
When submitting bug reports to WineHQ, it appears a 'stripped=false' Wine provides more information than a 'stripped=true' Wine.
[references: post | page]

The first post has links to:
pet to sfs scripts, menu entry utilities, and Wine usage tips.

----------------------------------------------------------------------------------------------------------


----------------
puppy 431
----------------

I compiled using puplet: Puppies 4.31.1 by forum member 'ttuuxxx'

mirrors | /distro/4.3__1/puppies-431.1-main-Xserver.iso
mirrors | /distro/4.3__1/devx_430.sfs

This puplet uses glibc 2.6.1
The Wine files listing 'puppy 431' will possibly not work with a glibc before 2.6.1
To see what glibc your puppy has.
Code:
ldd --version

I installed the following packages, as one sfs file, before compiling;
also known as dependencies:

fontconfig/2.7.1/fontconfig-2.7.1-i486-pup4.pet [mirrors]
fontconfig/2.7.1/fontconfig_DEV-2.7.1-i486-pup4.pet

gmp/6.1.1/gmp-6.1.1-i486_v1.2.pet [mirrors]
gmp/6.1.1/gmp_DEV-6.1.1-i486_v1.2.pet

gnutls/3.5.2/gnutls-3.5.2_v1.2.pet [mirrors]
gnutls/3.5.2/gnutls_DEV-3.5.2.pet

lcms2/2.5/lcms2-2.5-i486_v2.pet [mirrors]
lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet

libelf/0.8.13/libelf-0.8.13-i486_v2.pet [mirrors]
libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet

libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet [mirrors]
libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet

libgpg-error/1.10/libgpg-error-1.10-i486-431.pet [mirrors]
libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet

libgphoto2/2.5.0/libgphoto2-2.5.0-i486_v2.pet [mirrors]
libgphoto2/2.5.0/libgphoto2_DEV-2.5.0-i486.pet

libtasn1/4.8/libtasn1-4.8-i486_v1.2.pet [mirrors]
libtasn1/4.8/libtasn1_DEV-4.8-i486_v1.2.pet

libusb/1.0.9/libusb-1.0.9-i486_v2.pet [mirrors]
libusb/1.0.9/libusb_DEV-1.0.9-i486_v2.pet

mpg123/1.12.4/mpg123-1.12.4.pet [mirrors]
mpg123/1.12.4/mpg123_DEV-1.12.4.pet

nettle/3.2/nettle-3.2_v1.2.pet [mirrors]
nettle/3.2/nettle_DEV-3.2_v1.2.pet

openal-soft/1.13/openal-soft-1.13-i486_v1.1.pet [mirrors]
openal-soft/1.13/openal-soft_DEV-1.13-i486_v1.pet

openldap/2.4.13/openldap-2.4.13-i486.pet [mirrors]
openldap/2.4.13/openldap_DEV-2.4.13-i486.pet

prelink/20130503/prelink-20130503-i486_v2.pet [mirrors]

xorg/7.3/xorg_xorg_full_dri-7.3.pet [mirrors]
xorg/7.3/xorg_xorg_full_dri_DEV-7.3.pet


------------------------------------

When compiling in puppy 431, I used:
v1.1
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-O2"

v1.2
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-g -O0 -fno-optimize-sibling-calls -fno-omit-frame-pointer -fno-inline"

----------------------------------------------------------------------------------------------------------

-----------------------
racy puppy 5.5
-----------------------

I compiled using Racy 5.5

mirrors | /distro/racy5.5/racy-5.5.iso
mirrors | /distro/racy5.5/devx_racy_5.5.sfs

This puppy distro uses glibc 2.10.1
The Wine files listing 'racy5.5' will possibly not work with a glibc before 2.10.1
To see what glibc your puppy has.
Code:
ldd --version

I installed the following packages, as one sfs file, before compiling;
also known as dependencies:

fontconfig/2.8.0/fontconfig-2.8.0-w5c.pet [mirrors]
fontconfig/2.8.0/fontconfig_DEV-2.8.0-w5c.pet

gmp/6.1.1/gmp-6.1.1-i486_v1.2.pet [mirrors]
gmp/6.1.1/gmp_DEV-6.1.1-i486_v1.2.pet

gnutls/3.5.2/gnutls-3.5.2_v1.2.pet [mirrors]
gnutls/3.5.2/gnutls_DEV-3.5.2.pet

lcms2/2.5/lcms2-2.5-i486_v2.pet [mirrors]
lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet

libelf/0.8.13/libelf-0.8.13-i486_v2.pet [mirrors]
libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet

libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet [mirrors]
libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet

libgpg-error/1.10/libgpg-error-1.10-i486-431.pet [mirrors]
libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet

libtasn1/4.8/libtasn1-4.8-i486_v1.2.pet [mirrors]
libtasn1/4.8/libtasn1_DEV-4.8-i486_v1.2.pet

mpg123/1.12.4/mpg123-1.12.4.pet [mirrors]
mpg123/1.12.4/mpg123_DEV-1.12.4.pet

nettle/3.2/nettle-3.2_v1.2.pet [mirrors]
nettle/3.2/nettle_DEV-3.2_v1.2.pet

openal-soft/1.13/openal-soft-1.13-i486_v1.1.pet [mirrors]
openal-soft/1.13/openal-soft_DEV-1.13-i486_v1.pet

openldap/2.4.13/openldap-2.4.13-i486.pet [mirrors]
openldap/2.4.13/openldap_DEV-2.4.13-i486.pet

prelink/20130503/prelink-20130503-i486_v2.pet [mirrors]

----------------------------------------


When compiling in racy puppy 5.5, I used
v2.1
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-O2"

v2.2
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-g -O0 -fno-optimize-sibling-calls -fno-omit-frame-pointer -fno-inline"

----------------------------------------------------------------------------------------------------------


Menu entries, Color Setter, and other stuff I got from the file 'winegoodies.tar.gz' [post | page] provided by forum member 'technosaurus'.
I only made a few changes to the contents of that file.

----------------------------------------------------------------------------------------------------------

updated links at my homepage. see below.
Back to top
View user's profile Send private message Visit poster's website 
version2013

Joined: 08 Sep 2013
Posts: 257

PostPosted: Tue 20 Dec 2016, 22:02    Post subject: Wine 2.0-rc2  

My attempt at compiling wine-2.0-rc2

[wine-2.0-rc2 mirrors]

wine-2.0-rc2_v1.1.pet ________ puppy 431 | stripped=true
wine-2.0-rc2_v1.2.pet ________ puppy 431 | stripped=false
wine_DEV-2.0-rc2_v1.1.pet ____ puppy 431 |
wine_DEV-2.0-rc2_v1.2.pet ____ puppy 431 |

wine-2.0-rc2_v2.1.pet ________ racy puppy 5.5 | stripped=true
wine-2.0-rc2_v2.2.pet ________ racy puppy 5.5 | stripped=false
wine_DEV-2.0-rc2_v2.1.pet ____ racy puppy 5.5 |
wine_DEV-2.0-rc2_v2.2.pet ____ racy puppy 5.5 |

wine_DOC-2.0-rc2.pet

wine_extras-v2.pet _____________ menu entries | mirrors
md5.txt and hashdeep.txt ________ checksums/hashes | mirrors

----------------------------------------------------------------
Notes for my webpage
http://version2013.yolasite.com/page1.php

The ">" character denotes a link to a mirror for either a directory or file.
ie. Look for the ">" adjacent to a
> directory/
> file

----------------------------------------------------------------

For general use, I recommend packages that are 'stripped=true'.
For submitting bug reports to WineHQ, I recommend packages that are 'stripped=false'.
When submitting bug reports to WineHQ, it appears a 'stripped=false' Wine provides more information than a 'stripped=true' Wine.
[references: post | page]

The first post has links to:
pet to sfs scripts, menu entry utilities, and Wine usage tips.

----------------------------------------------------------------------------------------------------------


----------------
puppy 431
----------------

I compiled using puplet: Puppies 4.31.1 by forum member 'ttuuxxx'

mirrors | /distro/4.3__1/puppies-431.1-main-Xserver.iso
mirrors | /distro/4.3__1/devx_430.sfs

This puplet uses glibc 2.6.1
The Wine files listing 'puppy 431' will possibly not work with a glibc before 2.6.1
To see what glibc your puppy has.
Code:
ldd --version

I installed the following packages, as one sfs file, before compiling;
also known as dependencies:

fontconfig/2.7.1/fontconfig-2.7.1-i486-pup4.pet [mirrors]
fontconfig/2.7.1/fontconfig_DEV-2.7.1-i486-pup4.pet

gmp/6.1.1/gmp-6.1.1-i486_v1.2.pet [mirrors]
gmp/6.1.1/gmp_DEV-6.1.1-i486_v1.2.pet

gnutls/3.5.2/gnutls-3.5.2_v1.2.pet [mirrors]
gnutls/3.5.2/gnutls_DEV-3.5.2.pet

lcms2/2.5/lcms2-2.5-i486_v2.pet [mirrors]
lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet

libelf/0.8.13/libelf-0.8.13-i486_v2.pet [mirrors]
libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet

libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet [mirrors]
libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet

libgpg-error/1.10/libgpg-error-1.10-i486-431.pet [mirrors]
libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet

libgphoto2/2.5.0/libgphoto2-2.5.0-i486_v2.pet [mirrors]
libgphoto2/2.5.0/libgphoto2_DEV-2.5.0-i486.pet

libtasn1/4.8/libtasn1-4.8-i486_v1.2.pet [mirrors]
libtasn1/4.8/libtasn1_DEV-4.8-i486_v1.2.pet

libusb/1.0.9/libusb-1.0.9-i486_v2.pet [mirrors]
libusb/1.0.9/libusb_DEV-1.0.9-i486_v2.pet

mpg123/1.12.4/mpg123-1.12.4.pet [mirrors]
mpg123/1.12.4/mpg123_DEV-1.12.4.pet

nettle/3.2/nettle-3.2_v1.2.pet [mirrors]
nettle/3.2/nettle_DEV-3.2_v1.2.pet

openal-soft/1.13/openal-soft-1.13-i486_v1.1.pet [mirrors]
openal-soft/1.13/openal-soft_DEV-1.13-i486_v1.pet

openldap/2.4.13/openldap-2.4.13-i486.pet [mirrors]
openldap/2.4.13/openldap_DEV-2.4.13-i486.pet

prelink/20130503/prelink-20130503-i486_v2.pet [mirrors]

xorg/7.3/xorg_xorg_full_dri-7.3.pet [mirrors]
xorg/7.3/xorg_xorg_full_dri_DEV-7.3.pet


------------------------------------

When compiling in puppy 431, I used:
v1.1
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-O2"

v1.2
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-g -O0 -fno-optimize-sibling-calls -fno-omit-frame-pointer -fno-inline"

----------------------------------------------------------------------------------------------------------

-----------------------
racy puppy 5.5
-----------------------

I compiled using Racy 5.5

mirrors | /distro/racy5.5/racy-5.5.iso
mirrors | /distro/racy5.5/devx_racy_5.5.sfs

This puppy distro uses glibc 2.10.1
The Wine files listing 'racy5.5' will possibly not work with a glibc before 2.10.1
To see what glibc your puppy has.
Code:
ldd --version

I installed the following packages, as one sfs file, before compiling;
also known as dependencies:

fontconfig/2.8.0/fontconfig-2.8.0-w5c.pet [mirrors]
fontconfig/2.8.0/fontconfig_DEV-2.8.0-w5c.pet

gmp/6.1.1/gmp-6.1.1-i486_v1.2.pet [mirrors]
gmp/6.1.1/gmp_DEV-6.1.1-i486_v1.2.pet

gnutls/3.5.2/gnutls-3.5.2_v1.2.pet [mirrors]
gnutls/3.5.2/gnutls_DEV-3.5.2.pet

lcms2/2.5/lcms2-2.5-i486_v2.pet [mirrors]
lcms2/2.5/lcms2_DEV-2.5-i486_v2.pet

libelf/0.8.13/libelf-0.8.13-i486_v2.pet [mirrors]
libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet

libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet [mirrors]
libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet

libgpg-error/1.10/libgpg-error-1.10-i486-431.pet [mirrors]
libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet

libtasn1/4.8/libtasn1-4.8-i486_v1.2.pet [mirrors]
libtasn1/4.8/libtasn1_DEV-4.8-i486_v1.2.pet

mpg123/1.12.4/mpg123-1.12.4.pet [mirrors]
mpg123/1.12.4/mpg123_DEV-1.12.4.pet

nettle/3.2/nettle-3.2_v1.2.pet [mirrors]
nettle/3.2/nettle_DEV-3.2_v1.2.pet

openal-soft/1.13/openal-soft-1.13-i486_v1.1.pet [mirrors]
openal-soft/1.13/openal-soft_DEV-1.13-i486_v1.pet

openldap/2.4.13/openldap-2.4.13-i486.pet [mirrors]
openldap/2.4.13/openldap_DEV-2.4.13-i486.pet

prelink/20130503/prelink-20130503-i486_v2.pet [mirrors]

----------------------------------------


When compiling in racy puppy 5.5, I used
v2.1
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-O2"

v2.2
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-g -O0 -fno-optimize-sibling-calls -fno-omit-frame-pointer -fno-inline"

----------------------------------------------------------------------------------------------------------


Menu entries, Color Setter, and other stuff I got from the file 'winegoodies.tar.gz' [post | page] provided by forum member 'technosaurus'.
I only made a few changes to the contents of that file.

----------------------------------------------------------------------------------------------------------

updated links at my homepage. see below.
Back to top
View user's profile Send private message Visit poster's website 
version2013

Joined: 08 Sep 2013
Posts: 257

PostPosted: Thu 19 Jan 2017, 00:34    Post subject: Wine 2.0-rc5  

My attempt at compiling wine-2.0-rc5

[wine-2.0-rc5 mirrors]

wine-2.0-rc5_v1.1.pet ________ puppy 431 | stripped=true
wine-2.0-rc5_v1.2.pet ________ puppy 431 | stripped=false
wine_DEV-2.0-rc5_v1.1.pet ____ puppy 431 |
wine_DEV-2.0-rc5_v1.2.pet ____ puppy 431 |

wine-2.0-rc5_v2.1.pet ________ racy puppy 5.5 | stripped=true
wine-2.0-rc5_v2.2.pet ________ racy puppy 5.5 | stripped=false
wine_DEV-2.0-rc5_v2.1.pet ____ racy puppy 5.5 |
wine_DEV-2.0-rc5_v2.2.pet ____ racy puppy 5.5 |

wine_DOC-2.0-rc5.pet

wine_extras-v2.pet _____________ menu entries | mirrors
md5.txt and hashdeep.txt ________ checksums/hashes | mirrors

----------------------------------------------------------------
Notes for my webpage
http://version2013.yolasite.com/page1.php

The ">" character denotes a link to a mirror for either a directory or file.
ie. Look for the ">" adjacent to a
> directory/
> file

----------------------------------------------------------------

For general use, I recommend packages that are 'stripped=true'.
For submitting bug reports to WineHQ, I recommend packages that are 'stripped=false'.
When submitting bug reports to WineHQ, it appears a 'stripped=false' Wine provides more information than a 'stripped=true' Wine.
[references: post | page]

The first post has links to:
pet to sfs scripts, menu entry utilities, and Wine usage tips.

----------------------------------------------------------------------------------------------------------

https://bugs.winehq.org/show_bug.cgi?id=42211
http://source.winehq.org/git/wine.git/commit/d7951abc72254eacaa8cbbeb8ff43c7b011f25e3
I applied this patch to both puppy 431 and Racy 5.5

----------------
puppy 431
----------------

I compiled using puplet: Puppies 4.31.1 by forum member 'ttuuxxx'

mirrors | /distro/4.3__1/puppies-431.1-main-Xserver.iso
mirrors | /distro/4.3__1/devx_430.sfs

This puplet uses glibc 2.6.1
The Wine files listing 'puppy 431' will possibly not work with a glibc before 2.6.1
To see what glibc your puppy has.
Code:
ldd --version

I installed the following packages, as one sfs file, before compiling;
also known as dependencies:

fontconfig/2.7.1/fontconfig-2.7.1-i486-pup4.pet [mirrors]
fontconfig/2.7.1/fontconfig_DEV-2.7.1-i486-pup4.pet

gmp/6.1.1/gmp-6.1.1-i486_v1.2.pet [mirrors]
gmp/6.1.1/gmp_DEV-6.1.1-i486_v1.2.pet

gnutls/3.5.2/gnutls-3.5.2_v1.2.pet [mirrors]
gnutls/3.5.2/gnutls_DEV-3.5.2.pet

lcms2/2.8/lcms2-2.8_v2.pet [mirrors]
lcms2/2.8/lcms2_DEV-2.8_v2.pet

libelf/0.8.13/libelf-0.8.13-i486_v2.pet [mirrors]
libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet

libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet [mirrors]
libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet

libgpg-error/1.10/libgpg-error-1.10-i486-431.pet [mirrors]
libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet

libgphoto2/2.5.0/libgphoto2-2.5.0-i486_v2.pet [mirrors]
libgphoto2/2.5.0/libgphoto2_DEV-2.5.0-i486.pet

libtasn1/4.8/libtasn1-4.8-i486_v1.2.pet [mirrors]
libtasn1/4.8/libtasn1_DEV-4.8-i486_v1.2.pet

libusb/1.0.9/libusb-1.0.9-i486_v2.pet [mirrors]
libusb/1.0.9/libusb_DEV-1.0.9-i486_v2.pet

mpg123/1.12.4/mpg123-1.12.4.pet [mirrors]
mpg123/1.12.4/mpg123_DEV-1.12.4.pet

nettle/3.2/nettle-3.2_v1.2.pet [mirrors]
nettle/3.2/nettle_DEV-3.2_v1.2.pet

openal-soft/1.13/openal-soft-1.13-i486_v1.1.pet [mirrors]
openal-soft/1.13/openal-soft_DEV-1.13-i486_v1.pet

openldap/2.4.13/openldap-2.4.13-i486.pet [mirrors]
openldap/2.4.13/openldap_DEV-2.4.13-i486.pet

prelink/20130503/prelink-20130503-i486_v2.pet [mirrors]

xorg/7.3/xorg_xorg_full_dri-7.3.pet [mirrors]
xorg/7.3/xorg_xorg_full_dri_DEV-7.3.pet


------------------------------------

When compiling in puppy 431, I used:
v1.1
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-O2"

v1.2
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-g -O0 -fno-optimize-sibling-calls -fno-omit-frame-pointer -fno-inline"

----------------------------------------------------------------------------------------------------------

-----------------------
racy puppy 5.5
-----------------------

I compiled using Racy 5.5

mirrors | /distro/racy5.5/racy-5.5.iso
mirrors | /distro/racy5.5/devx_racy_5.5.sfs

This puppy distro uses glibc 2.10.1
The Wine files listing 'racy5.5' will possibly not work with a glibc before 2.10.1
To see what glibc your puppy has.
Code:
ldd --version

I installed the following packages, as one sfs file, before compiling;
also known as dependencies:

fontconfig/2.8.0/fontconfig-2.8.0-w5c.pet [mirrors]
fontconfig/2.8.0/fontconfig_DEV-2.8.0-w5c.pet

gmp/6.1.1/gmp-6.1.1-i486_v1.2.pet [mirrors]
gmp/6.1.1/gmp_DEV-6.1.1-i486_v1.2.pet

gnutls/3.5.2/gnutls-3.5.2_v1.2.pet [mirrors]
gnutls/3.5.2/gnutls_DEV-3.5.2.pet

lcms2/2.8/lcms2-2.8_v2.pet [mirrors]
lcms2/2.8/lcms2_DEV-2.8_v2.pet

libelf/0.8.13/libelf-0.8.13-i486_v2.pet [mirrors]
libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet

libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet [mirrors]
libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet

libgpg-error/1.10/libgpg-error-1.10-i486-431.pet [mirrors]
libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet

libtasn1/4.8/libtasn1-4.8-i486_v1.2.pet [mirrors]
libtasn1/4.8/libtasn1_DEV-4.8-i486_v1.2.pet

mpg123/1.12.4/mpg123-1.12.4.pet [mirrors]
mpg123/1.12.4/mpg123_DEV-1.12.4.pet

nettle/3.2/nettle-3.2_v1.2.pet [mirrors]
nettle/3.2/nettle_DEV-3.2_v1.2.pet

openal-soft/1.13/openal-soft-1.13-i486_v1.1.pet [mirrors]
openal-soft/1.13/openal-soft_DEV-1.13-i486_v1.pet

openldap/2.4.13/openldap-2.4.13-i486.pet [mirrors]
openldap/2.4.13/openldap_DEV-2.4.13-i486.pet

prelink/20130503/prelink-20130503-i486_v2.pet [mirrors]

----------------------------------------


When compiling in racy puppy 5.5, I used
v2.1
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-O2"

v2.2
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-g -O0 -fno-optimize-sibling-calls -fno-omit-frame-pointer -fno-inline"

----------------------------------------------------------------------------------------------------------


Menu entries, Color Setter, and other stuff I got from the file 'winegoodies.tar.gz' [post | page] provided by forum member 'technosaurus'.
I only made a few changes to the contents of that file.

----------------------------------------------------------------------------------------------------------

updated links at my homepage. see below.
Back to top
View user's profile Send private message Visit poster's website 
version2013

Joined: 08 Sep 2013
Posts: 257

PostPosted: Tue 24 Jan 2017, 21:43    Post subject: Wine 2.0-rc6  

My attempt at compiling wine-2.0-rc6

[wine-2.0-rc6 mirrors]

wine-2.0-rc6_v1.1.pet ________ puppy 431 | stripped=true
wine-2.0-rc6_v1.2.pet ________ puppy 431 | stripped=false
wine_DEV-2.0-rc6_v1.1.pet ____ puppy 431 |
wine_DEV-2.0-rc6_v1.2.pet ____ puppy 431 |

wine-2.0-rc6_v2.1.pet ________ racy puppy 5.5 | stripped=true
wine-2.0-rc6_v2.2.pet ________ racy puppy 5.5 | stripped=false
wine_DEV-2.0-rc6_v2.1.pet ____ racy puppy 5.5 |
wine_DEV-2.0-rc6_v2.2.pet ____ racy puppy 5.5 |

wine_DOC-2.0-rc6.pet

wine_extras-v2.pet _____________ menu entries | mirrors
md5.txt and hashdeep.txt ________ checksums/hashes | mirrors

----------------------------------------------------------------
Notes for my webpage
http://version2013.yolasite.com/page1.php

The ">" character denotes a link to a mirror for either a directory or file.
ie. Look for the ">" adjacent to a
> directory/
> file

----------------------------------------------------------------

For general use, I recommend packages that are 'stripped=true'.
For submitting bug reports to WineHQ, I recommend packages that are 'stripped=false'.
When submitting bug reports to WineHQ, it appears a 'stripped=false' Wine provides more information than a 'stripped=true' Wine.
[references: post | page]

The first post has links to:
pet to sfs scripts, menu entry utilities, and Wine usage tips.

----------------------------------------------------------------------------------------------------------


----------------
puppy 431
----------------

I compiled using puplet: Puppies 4.31.1 by forum member 'ttuuxxx'

mirrors | /distro/4.3__1/puppies-431.1-main-Xserver.iso
mirrors | /distro/4.3__1/devx_430.sfs

This puplet uses glibc 2.6.1
The Wine files listing 'puppy 431' will possibly not work with a glibc before 2.6.1
To see what glibc your puppy has.
Code:
ldd --version

I installed the following packages, as one sfs file, before compiling;
also known as dependencies:

fontconfig/2.7.1/fontconfig-2.7.1-i486-pup4.pet [mirrors]
fontconfig/2.7.1/fontconfig_DEV-2.7.1-i486-pup4.pet

gmp/6.1.1/gmp-6.1.1-i486_v1.2.pet [mirrors]
gmp/6.1.1/gmp_DEV-6.1.1-i486_v1.2.pet

gnutls/3.5.2/gnutls-3.5.2_v1.2.pet [mirrors]
gnutls/3.5.2/gnutls_DEV-3.5.2.pet

lcms2/2.8/lcms2-2.8_v2.pet [mirrors]
lcms2/2.8/lcms2_DEV-2.8_v2.pet

libelf/0.8.13/libelf-0.8.13-i486_v2.pet [mirrors]
libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet

libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet [mirrors]
libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet

libgpg-error/1.10/libgpg-error-1.10-i486-431.pet [mirrors]
libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet

libgphoto2/2.5.0/libgphoto2-2.5.0-i486_v2.pet [mirrors]
libgphoto2/2.5.0/libgphoto2_DEV-2.5.0-i486.pet

libtasn1/4.8/libtasn1-4.8-i486_v1.2.pet [mirrors]
libtasn1/4.8/libtasn1_DEV-4.8-i486_v1.2.pet

libusb/1.0.9/libusb-1.0.9-i486_v2.pet [mirrors]
libusb/1.0.9/libusb_DEV-1.0.9-i486_v2.pet

mpg123/1.12.4/mpg123-1.12.4.pet [mirrors]
mpg123/1.12.4/mpg123_DEV-1.12.4.pet

nettle/3.2/nettle-3.2_v1.2.pet [mirrors]
nettle/3.2/nettle_DEV-3.2_v1.2.pet

openal-soft/1.13/openal-soft-1.13-i486_v1.1.pet [mirrors]
openal-soft/1.13/openal-soft_DEV-1.13-i486_v1.pet

openldap/2.4.13/openldap-2.4.13-i486.pet [mirrors]
openldap/2.4.13/openldap_DEV-2.4.13-i486.pet

prelink/20130503/prelink-20130503-i486_v2.pet [mirrors]

xorg/7.3/xorg_xorg_full_dri-7.3.pet [mirrors]
xorg/7.3/xorg_xorg_full_dri_DEV-7.3.pet


------------------------------------

When compiling in puppy 431, I used:
v1.1
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-O2"

v1.2
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-g -O0 -fno-optimize-sibling-calls -fno-omit-frame-pointer -fno-inline"

----------------------------------------------------------------------------------------------------------

-----------------------
racy puppy 5.5
-----------------------

I compiled using Racy 5.5

mirrors | /distro/racy5.5/racy-5.5.iso
mirrors | /distro/racy5.5/devx_racy_5.5.sfs

This puppy distro uses glibc 2.10.1
The Wine files listing 'racy5.5' will possibly not work with a glibc before 2.10.1
To see what glibc your puppy has.
Code:
ldd --version

I installed the following packages, as one sfs file, before compiling;
also known as dependencies:

fontconfig/2.8.0/fontconfig-2.8.0-w5c.pet [mirrors]
fontconfig/2.8.0/fontconfig_DEV-2.8.0-w5c.pet

gmp/6.1.1/gmp-6.1.1-i486_v1.2.pet [mirrors]
gmp/6.1.1/gmp_DEV-6.1.1-i486_v1.2.pet

gnutls/3.5.2/gnutls-3.5.2_v1.2.pet [mirrors]
gnutls/3.5.2/gnutls_DEV-3.5.2.pet

lcms2/2.8/lcms2-2.8_v2.pet [mirrors]
lcms2/2.8/lcms2_DEV-2.8_v2.pet

libelf/0.8.13/libelf-0.8.13-i486_v2.pet [mirrors]
libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet

libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet [mirrors]
libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet

libgpg-error/1.10/libgpg-error-1.10-i486-431.pet [mirrors]
libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet

libtasn1/4.8/libtasn1-4.8-i486_v1.2.pet [mirrors]
libtasn1/4.8/libtasn1_DEV-4.8-i486_v1.2.pet

mpg123/1.12.4/mpg123-1.12.4.pet [mirrors]
mpg123/1.12.4/mpg123_DEV-1.12.4.pet

nettle/3.2/nettle-3.2_v1.2.pet [mirrors]
nettle/3.2/nettle_DEV-3.2_v1.2.pet

openal-soft/1.13/openal-soft-1.13-i486_v1.1.pet [mirrors]
openal-soft/1.13/openal-soft_DEV-1.13-i486_v1.pet

openldap/2.4.13/openldap-2.4.13-i486.pet [mirrors]
openldap/2.4.13/openldap_DEV-2.4.13-i486.pet

prelink/20130503/prelink-20130503-i486_v2.pet [mirrors]

----------------------------------------


When compiling in racy puppy 5.5, I used
v2.1
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-O2"

v2.2
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-g -O0 -fno-optimize-sibling-calls -fno-omit-frame-pointer -fno-inline"

----------------------------------------------------------------------------------------------------------


Menu entries, Color Setter, and other stuff I got from the file 'winegoodies.tar.gz' [post | page] provided by forum member 'technosaurus'.
I only made a few changes to the contents of that file.

----------------------------------------------------------------------------------------------------------

updated links at my homepage. see below.
Back to top
View user's profile Send private message Visit poster's website 
version2013

Joined: 08 Sep 2013
Posts: 257

PostPosted: Tue 31 Jan 2017, 14:56    Post subject: Wine 2.0  

My attempt at compiling wine-2.0

[wine-2.0 mirrors]

wine-2.0_v1.1.pet ________ puppy 431 | stripped=true
wine-2.0_v1.2.pet ________ puppy 431 | stripped=false
wine_DEV-2.0_v1.1.pet ____ puppy 431 |
wine_DEV-2.0_v1.2.pet ____ puppy 431 |

wine-2.0_v2.1.pet ________ racy puppy 5.5 | stripped=true
wine-2.0_v2.2.pet ________ racy puppy 5.5 | stripped=false
wine_DEV-2.0_v2.1.pet ____ racy puppy 5.5 |
wine_DEV-2.0_v2.2.pet ____ racy puppy 5.5 |

wine_DOC-2.0.pet

wine_extras-v2.pet _____________ menu entries | mirrors
md5.txt and hashdeep.txt ________ checksums/hashes | mirrors

----------------------------------------------------------------
Notes for my webpage
http://version2013.yolasite.com/page1.php

The ">" character denotes a link to a mirror for either a directory or file.
ie. Look for the ">" adjacent to a
> directory/
> file

----------------------------------------------------------------

For general use, I recommend packages that are 'stripped=true'.
For submitting bug reports to WineHQ, I recommend packages that are 'stripped=false'.
When submitting bug reports to WineHQ, it appears a 'stripped=false' Wine provides more information than a 'stripped=true' Wine.
[references: post | page]

The first post has links to:
pet to sfs scripts, menu entry utilities, and Wine usage tips.

----------------------------------------------------------------------------------------------------------


----------------
puppy 431
----------------

I compiled using puplet: Puppies 4.31.1 by forum member 'ttuuxxx'

mirrors | /distro/4.3__1/puppies-431.1-main-Xserver.iso
mirrors | /distro/4.3__1/devx_430.sfs

This puplet uses glibc 2.6.1
The Wine files listing 'puppy 431' will possibly not work with a glibc before 2.6.1
To see what glibc your puppy has.
Code:
ldd --version

I installed the following packages, as one sfs file, before compiling;
also known as dependencies:

fontconfig/2.7.1/fontconfig-2.7.1-i486-pup4.pet [mirrors]
fontconfig/2.7.1/fontconfig_DEV-2.7.1-i486-pup4.pet

gmp/6.1.1/gmp-6.1.1-i486_v1.2.pet [mirrors]
gmp/6.1.1/gmp_DEV-6.1.1-i486_v1.2.pet

gnutls/3.5.2/gnutls-3.5.2_v1.2.pet [mirrors]
gnutls/3.5.2/gnutls_DEV-3.5.2.pet

lcms2/2.8/lcms2-2.8_v2.pet [mirrors]
lcms2/2.8/lcms2_DEV-2.8_v2.pet

libelf/0.8.13/libelf-0.8.13-i486_v2.pet [mirrors]
libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet

libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet [mirrors]
libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet

libgpg-error/1.10/libgpg-error-1.10-i486-431.pet [mirrors]
libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet

libgphoto2/2.5.0/libgphoto2-2.5.0-i486_v2.pet [mirrors]
libgphoto2/2.5.0/libgphoto2_DEV-2.5.0-i486.pet

libtasn1/4.8/libtasn1-4.8-i486_v1.2.pet [mirrors]
libtasn1/4.8/libtasn1_DEV-4.8-i486_v1.2.pet

libusb/1.0.9/libusb-1.0.9-i486_v2.pet [mirrors]
libusb/1.0.9/libusb_DEV-1.0.9-i486_v2.pet

mpg123/1.12.4/mpg123-1.12.4.pet [mirrors]
mpg123/1.12.4/mpg123_DEV-1.12.4.pet

nettle/3.2/nettle-3.2_v1.2.pet [mirrors]
nettle/3.2/nettle_DEV-3.2_v1.2.pet

openal-soft/1.13/openal-soft-1.13-i486_v1.1.pet [mirrors]
openal-soft/1.13/openal-soft_DEV-1.13-i486_v1.pet

openldap/2.4.13/openldap-2.4.13-i486.pet [mirrors]
openldap/2.4.13/openldap_DEV-2.4.13-i486.pet

prelink/20130503/prelink-20130503-i486_v2.pet [mirrors]

xorg/7.3/xorg_xorg_full_dri-7.3.pet [mirrors]
xorg/7.3/xorg_xorg_full_dri_DEV-7.3.pet


------------------------------------

When compiling in puppy 431, I used:
v1.1
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-O2"

v1.2
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-g -O0 -fno-optimize-sibling-calls -fno-omit-frame-pointer -fno-inline"

----------------------------------------------------------------------------------------------------------

-----------------------
racy puppy 5.5
-----------------------

I compiled using Racy 5.5

mirrors | /distro/racy5.5/racy-5.5.iso
mirrors | /distro/racy5.5/devx_racy_5.5.sfs

This puppy distro uses glibc 2.10.1
The Wine files listing 'racy5.5' will possibly not work with a glibc before 2.10.1
To see what glibc your puppy has.
Code:
ldd --version

I installed the following packages, as one sfs file, before compiling;
also known as dependencies:

fontconfig/2.8.0/fontconfig-2.8.0-w5c.pet [mirrors]
fontconfig/2.8.0/fontconfig_DEV-2.8.0-w5c.pet

gmp/6.1.1/gmp-6.1.1-i486_v1.2.pet [mirrors]
gmp/6.1.1/gmp_DEV-6.1.1-i486_v1.2.pet

gnutls/3.5.2/gnutls-3.5.2_v1.2.pet [mirrors]
gnutls/3.5.2/gnutls_DEV-3.5.2.pet

lcms2/2.8/lcms2-2.8_v2.pet [mirrors]
lcms2/2.8/lcms2_DEV-2.8_v2.pet

libelf/0.8.13/libelf-0.8.13-i486_v2.pet [mirrors]
libelf/0.8.13/libelf_DEV-0.8.13-i486_v2.pet

libgcrypt/1.4.6/libgcrypt-1.4.6-i486-431.pet [mirrors]
libgcrypt/1.4.6/libgcrypt_DEV-1.4.6-i486-431.pet

libgpg-error/1.10/libgpg-error-1.10-i486-431.pet [mirrors]
libgpg-error/1.10/libgpg_DEV-error-1.10-i486-431.pet

libtasn1/4.8/libtasn1-4.8-i486_v1.2.pet [mirrors]
libtasn1/4.8/libtasn1_DEV-4.8-i486_v1.2.pet

mpg123/1.12.4/mpg123-1.12.4.pet [mirrors]
mpg123/1.12.4/mpg123_DEV-1.12.4.pet

nettle/3.2/nettle-3.2_v1.2.pet [mirrors]
nettle/3.2/nettle_DEV-3.2_v1.2.pet

openal-soft/1.13/openal-soft-1.13-i486_v1.1.pet [mirrors]
openal-soft/1.13/openal-soft_DEV-1.13-i486_v1.pet

openldap/2.4.13/openldap-2.4.13-i486.pet [mirrors]
openldap/2.4.13/openldap_DEV-2.4.13-i486.pet

prelink/20130503/prelink-20130503-i486_v2.pet [mirrors]

----------------------------------------


When compiling in racy puppy 5.5, I used
v2.1
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-O2"

v2.2
Code:
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --build=i486-pc-linux-gnu --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib --with-x CFLAGS="-g -O0 -fno-optimize-sibling-calls -fno-omit-frame-pointer -fno-inline"

----------------------------------------------------------------------------------------------------------


Menu entries, Color Setter, and other stuff I got from the file 'winegoodies.tar.gz' [post | page] provided by forum member 'technosaurus'.
I only made a few changes to the contents of that file.

----------------------------------------------------------------------------------------------------------

updated links at my homepage. see below.
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 14 of 16 [229 Posts]   Goto page: Previous 1, 2, 3, ..., 12, 13, 14, 15, 16 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Virtualization
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.2788s ][ Queries: 14 (0.0193s) ][ GZIP on ]