Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 19 Nov 2019, 05:47
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
LxPup : a Puppy with LXDE as its desktop environment
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 48 of 68 [1012 Posts]   Goto page: Previous 1, 2, 3, ..., 46, 47, 48, 49, 50, ..., 66, 67, 68 Next
Author Message
riedzig

Joined: 01 Oct 2015
Posts: 36

PostPosted: Thu 01 Oct 2015, 03:23    Post subject: LXPupTahr with occasional boot failures  

I use LxPupTahr-15.05.2 with nVIDIA propreitary driver 304.125, frugal install. Whereas the standard TahrPup 6.0.2 with the same nVIDIA driver has never shown any boot failures, LxPupTahr sometimes (cca 1 among 20) starts with frozen mouse and message "The nVIDIA X driver is found, but lacking the module for the current kernel 3.14.20". However, I can still navigate using arrow keys and keybindings and so get to reboot. After this it often starts correctly saying "nVIDIA driver is now running".

I read about conflicts with nouveau, blacklisted it, deleted parts of nouveau from /usr/lib/xorg/modules/drivers, nothing helped so far. Any advice would be appreciated.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 4053
Location: Worcestershire, UK

PostPosted: Thu 01 Oct 2015, 12:49    Post subject: Re: LXPupTahr with occasional boot failures  

riedzig wrote:
I use LxPupTahr-15.05.2 with nVIDIA propreitary driver 304.125, frugal install. Whereas the standard TahrPup 6.0.2 with the same nVIDIA driver has never shown any boot failures, LxPupTahr sometimes (cca 1 among 20) starts with frozen mouse and message "The nVIDIA X driver is found, but lacking the module for the current kernel 3.14.20". However, I can still navigate using arrow keys and keybindings and so get to reboot. After this it often starts correctly saying "nVIDIA driver is now running".

I read about conflicts with nouveau, blacklisted it, deleted parts of nouveau from /usr/lib/xorg/modules/drivers, nothing helped so far. Any advice would be appreciated.
Hi riedzig

That sounds very odd... What is the boot media? Is it pae or no-pae? Are you on a laptop or a desktop?

What is the md5 of your iso? You can check the correct value at: http://sourceforge.net/projects/lxpup/files/LxPup15.05/

How have you installed the nvidia driver? by .pet or by .sfs? Where did you obtain the driver?

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPups, ScPup & ScPup64, LxPup, LxPupSc & LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
riedzig

Joined: 01 Oct 2015
Posts: 36

PostPosted: Fri 02 Oct 2015, 02:32    Post subject:  

Hi peebee, thanks for your interest
I'm on a desktop, motherboard GA-M68MT-D3P

It's LxPupTahr-15.05.2-pae, to be sure I downloaded the iso again, both have

6b11b68d795d9d22a95f55ca76b2360b

I installed the nVIDIA driver via Quickpet Tahr - Drivers - video upgrade wizard and selected 6.0.2.iso - nvidia 304.125 (I believe also PAE, I canˇt check it, though). The rest went automatically.
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 4053
Location: Worcestershire, UK

PostPosted: Fri 02 Oct 2015, 05:30    Post subject:  

riedzig wrote:
Hi peebee, thanks for your interest
I'm on a desktop, motherboard GA-M68MT-D3P

It's LxPupTahr-15.05.2-pae, to be sure I downloaded the iso again, both have

6b11b68d795d9d22a95f55ca76b2360b

I installed the nVIDIA driver via Quickpet Tahr - Drivers - video upgrade wizard and selected 6.0.2.iso - nvidia 304.125 (I believe also PAE, I canˇt check it, though). The rest went automatically.
Hi riedzig

It just so happens that my desktop also has an nvidia board requiring the 304.* driver....

I went through all the steps you took and rebooted a few times with no problems....

The only thing I can suggest is that the 304.128 version of the driver is now available - but you would have to build it yourself using getnvidia-1.0.pet to build either a .pet or .sfs from the .run file: ftp://download.nvidia.com/XFree86/Linux-x86/304.128/NVIDIA-Linux-x86-304.128.run

This would need a compiling environment with the devx installed....

You could try posting on the nvidia thread to see if anybody else has the same problems - give as much info as you can - for instance can you capture the output from dmesg and lsmod when a problem boot occurs??

Sorry I can't help any more
Cheers
peebee

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPups, ScPup & ScPup64, LxPup, LxPupSc & LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
riedzig

Joined: 01 Oct 2015
Posts: 36

PostPosted: Fri 02 Oct 2015, 08:48    Post subject:  

Thanks peebee, I´ll first try to make one or more parallel frugal installs, possibly with the driver assigned to 6.0.0 and let you know whether the issue persists.

Please one more thing: I wish to exclude "Recent documents" from the main menu, but find no option in configuration files (in /root/.config or /etc/xdg). Where can this be done?

Anyway Puppy with lxde is great!
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 4053
Location: Worcestershire, UK

PostPosted: Fri 02 Oct 2015, 11:51    Post subject:  

riedzig wrote:
I wish to exclude "Recent documents" from the main menu, but find no option in configuration files (in /root/.config or /etc/xdg). Where can this be done?

Anyway Puppy with lxde is great!


Thanks!

You need to edit:
/root/.config/lxpanel/LXDE/panels/panel

and remove around line 40 the section:
recentdocuments { ..................... }

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPups, ScPup & ScPup64, LxPup, LxPupSc & LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
riedzig

Joined: 01 Oct 2015
Posts: 36

PostPosted: Tue 13 Oct 2015, 02:37    Post subject:  

Hi peebee,

I made a new frugal install nopae, did dozens of reboots and the nvidia problem didn't occur any more.

I also managed to implement the option save/not save at shutdown discussed in
http://murga-linux.com/puppy/viewtopic.php?t=81911

Only one issue remains - PCmanFM sometimes begins to strike and refuses to copy and paste between two locations or drives. After a reboot it's OK again. I found related threads on the web, but no easy solution.

Thanks for all your hints!
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 4053
Location: Worcestershire, UK

PostPosted: Fri 16 Oct 2015, 09:41    Post subject:  

see later post for LxPup-15.10
_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPups, ScPup & ScPup64, LxPup, LxPupSc & LxPupSc64

Last edited by peebee on Wed 21 Oct 2015, 14:36; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Sat 17 Oct 2015, 01:57    Post subject: lxpup cannot read french accents  

puppylinux quand y'a un accent "é" par exemple, ça remplace par un "?" et du coup je peux pas compresser avec PackIt en Zip car le chemin n'est pas reconnu.
External disk drive : lxpup cannot read french accents . Have you an idea how to solve it ?

_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
peebee


Joined: 21 Sep 2008
Posts: 4053
Location: Worcestershire, UK

PostPosted: Wed 21 Oct 2015, 14:35    Post subject: LxPup-15.10 for testing  

see below
_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPups, ScPup & ScPup64, LxPup, LxPupSc & LxPupSc64

Last edited by peebee on Tue 27 Oct 2015, 05:08; edited 5 times in total
Back to top
View user's profile Send private message Visit poster's website 
Billtoo


Joined: 07 Apr 2009
Posts: 3680
Location: Ontario Canada

PostPosted: Wed 21 Oct 2015, 15:59    Post subject: LxPup : a Puppy with LXDE as its desktop environment  

I did a manual frugal install to a usb-3.0 hard drive, pc is a macmini.

Added some apps from PPM and some other stuff.

It's working well, no problems yet.

Video-Info 1.5.1 - Wed 21 Oct 2015 on Slacko Puppy 6.0.7.4 - Linux 4.1.6-EmSee-32-pae i686

Chip description:
[ 2228.605] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics 4000

X Server: Xorg Driver used: intel

X.Org version: 1.14.3
dimensions: 1920x1080 pixels (507x285 millimeters)
depth of root window: 24 planes
Screenshot.jpg
 Description   
 Filesize   34.89 KB
 Viewed   1543 Time(s)

Screenshot.jpg

Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 6730
Location: Earth

PostPosted: Thu 22 Oct 2015, 01:18    Post subject:  

Startup goes OK.


Added Chromium46 PET

Thought you would want to review this save-session naming to avoid problems.


Continuing to test...

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engines or use DogPile
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 4053
Location: Worcestershire, UK

PostPosted: Thu 22 Oct 2015, 01:59    Post subject:  

gcmartin wrote:
Thought you would want to review this save-session naming to avoid problems.

NO! it's correct - see my warning above "Won't currently update a previous LxPup as it identifies as Slacko 6.0.7.4 for ease of construction."

_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPups, ScPup & ScPup64, LxPup, LxPupSc & LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
gcmartin

Joined: 14 Oct 2005
Posts: 6730
Location: Earth

PostPosted: Thu 22 Oct 2015, 04:07    Post subject:  

OK, I understand
_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engines or use DogPile
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 4053
Location: Worcestershire, UK

PostPosted: Tue 27 Oct 2015, 05:05    Post subject:  

LxPup-15.10.4-s-pae for testing

- based on 01micko's new Slacko 6.0.8.1 32-bit iso built with woof-ce
- Slackware 14.1 compatible
- 32-bit kernel 4.1.11-pae also from 01micko

md5 = 8b567eddd1f7f502c805950f2b27fac0

Won't currently update a previous LxPup as it identifies as Slacko 6.0.8.1 for ease of construction.

Cheers
peebee
lxpup-15.10.png
 Description   
 Filesize   8.53 KB
 Viewed   1293 Time(s)

lxpup-15.10.png


_________________
LxPup = Puppy + LXDE
Main version used daily: LxPupSc; Assembler of UPups, ScPup & ScPup64, LxPup, LxPupSc & LxPupSc64
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 48 of 68 [1012 Posts]   Goto page: Previous 1, 2, 3, ..., 46, 47, 48, 49, 50, ..., 66, 67, 68 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0803s ][ Queries: 12 (0.0325s) ][ GZIP on ]