Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 18 Apr 2014, 04:12
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Slacko 5.7 final
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 38 [569 Posts]   Goto page: Previous 1, 2, 3, 4, ..., 36, 37, 38 Next
Author Message
01micko


Joined: 11 Oct 2008
Posts: 7547
Location: qld

PostPosted: Wed 27 Nov 2013, 20:56    Post subject: Re: Slacko testing (for 5.7)
Subject description: woof-CE be2d186462e281c1c42035dd5d9ee0b08b9ed686
 

peebee wrote:

- is k3.10.19 the likely final pae kernel version? If it is, do you want the Broadcom-STA pet for k3.10.19?

No, what I should do is see if I can automate the process in kernel-kit.
peebee wrote:

- is the Slackware base 14.0 or 14.1? Distrospecs shows 14.0. Will we be moving to 14.1 during the update process?

No, staying with 14.0 for a little while. When we add 64 bit support it will be logical to support 14.1 then, however, I think salix is suffering from the lack of dev syndrome too as I don't think they have the human resources to build 14.1 packages or a 14.1 based distro.

SFR wrote:
If the first $1 isn't wrapped, an arg with spaces willl cause "too many arguments" error and empty ARGS var.

got it, thanks.
SFR wrote:
Somehow have survived my previous hunting - fixed broken icons in xlock & firewallgtk (attached).

Ok, firewallstate is in slacko repo, easy fix, xlock_gui is in common, I don't have access so I will throw it in the z_base_hacks pet.

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
James C


Joined: 26 Mar 2009
Posts: 5440
Location: Kentucky

PostPosted: Wed 27 Nov 2013, 23:49    Post subject:  

Upgraded frugal from 5.6.1 to 5.6.3....... no troubles.

# report-video
VIDEO REPORT: Slacko Puppy, version 5.6.3

Chip description:
VGA compatible controller: nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] (rev c1)

Requested by /etc/X11/xorg.conf:
Resolution (widthxheight, in pixels): 1440x900
Depth (bits, or planes): 24
Modules requested to be loaded: dbe

Probing Xorg startup log file (/var/log/Xorg.0.log):
Driver loaded (and currently in use): nouveau
Loaded modules: dbe dri dri2 exa extmod fb glx kbd mouse record shadowfb

Actual rendering on monitor:
Resolution: 1440x900 pixels (380x238 millimeters)
Depth: 24 planes

...the above also recorded in /tmp/report-video
# glxgears
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
1795 frames in 5.0 seconds = 358.573 FPS
1762 frames in 5.0 seconds = 352.379 FPS
1806 frames in 5.0 seconds = 360.741 FPS
1814 frames in 5.0 seconds = 362.755 FPS
1845 frames in 5.0 seconds = 368.903 FPS

-Computer-
Processor : AMD Athlon(tm) XP 2400+
Memory : 1033MB (215MB used)
Machine Type : Physical machine
Operating System : Slacko Puppy - 5.6.3
User Name : root (root)
Date/Time : Wed 27 Nov 2013 10:03:42 PM CST
-Display-
Resolution : 1440x900 pixels
OpenGL Renderer : Mesa DRI nv18 x86/MMX+/3DNow!+/SSE
X11 Vendor : The X.Org Foundation
-Audio Devices-
Audio Adapter : VIA8233 - VIA 8235
Back to top
View user's profile Send private message 
sszindian


Joined: 24 Apr 2010
Posts: 578
Location: Pennsylvania U.S.

PostPosted: Thu 28 Nov 2013, 01:25    Post subject: 5.6.3  

Upgrade from 5.6.1 to 5.6.3 (w/Delta file) went smooth, just had to replace desktop background and remove desktop icons... wbar icons came through without a hitch.

I really couldn't find any major faults with 5.6.1

This build with the 3.10.19 Kernel is without doubt, the best yet at least for my P-4 Dell 3000. Most responsive and very very fast.

About the only issue I could find is with xscreensaver. The program functions well with all the standard screensaver modules included but... that darn old GLslideshow, Carousel, or others that require pictures or graphics to display... just won't work! Sure would be nice to see that little thing 'fixed' (or explain how we can fix it ourselves) before the 5.7 release? You're probably the only one capible of correcting that!

Otherwise... very nice piece of work!

>>>---Indian------>
Desktop-5.6.3.png
 Description   
 Filesize   162.43 KB
 Viewed   1143 Time(s)

Desktop-5.6.3.png


_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192
Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 3623
Location: Earth

PostPosted: Thu 28 Nov 2013, 03:48    Post subject: SAMBA 4.1+ in upcoming 64bit Slacko, OOTB?  

@Iguleder is working along with several others on fashioning this offering. Collaboration is a beautiful thing as everyone is assisting to test and help where possible. A 64bit Slacko to accompany the 32bit Slacko is another version which will cover most, if not all of the x86 architectures with a consistent framework for the user community. An enormous feat and a great demonstration in how we CAN work together for a common good!

The 2 flagship 64bit PUPs, up until now, were built with the knowledge of a PC that is of the 2007 design and up. That is to say, there is enough RAM on the MB to accomodate a RAM-centric 64bit distro with applications which mirror 32bit PUPs. Both of these, FATDOG and LightHouse64 also acknowledged that they could ship a distro which eliminated the need and stress of installing-setup SMB sharing. This sharing is essential to provide Linux with the same kind of sharing on the LAN that Windows and Apple have had for over a decade (in fact, in 2015 it will be 2 decades). 01Micko assisted LightHouse64 with his SAMBA Simple Management (SSM) which is an all-in-one visual utility for SAMBA operations and LAN sharing for those who would struggle to launch OOTB. He provides the same with his built-in SAMBA in his PhatSlacko, as well.

I want to make a 64bit system request and ask that you evaluate/consider
Since FATDOG and LH64 has provides a very good pattern of including SAMBA technology in 64bit implementations with little to no impact on system operations, would you also package 01Micko's or TaZoC's SAMBA as they embrace current IEEE standards for LAN operations across all platforms in an OOTB distro? (This would provide consistent LAN sharing, OOTB, from all of PUPs mainline 64bit distros whereas consistent and equivalent functionality is provide the user.) In testing, I have NOT observe any negative behavior from either of these 2 systems in the 3 years of their use. RAM impact is less than 10MB and system or application performance is not impacted because of a running SAMBA service. Latest SAMBA 4.10 from 01Micko has already been tested in this 32bit Slacko and as it was in PhatSlacko, there is no observable impact that comes with its functionality. They have a painless implementation that is built-in/OOTB.

I know that this is going to bring a very fast high-octane distro just as we've seen in the Puppy past. 64bit offers good channeling and services to applications and ultimately to the user's desktop.

Hope this helps

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send private message 
SFR


Joined: 26 Oct 2011
Posts: 879

PostPosted: Thu 28 Nov 2013, 08:10    Post subject:  

sszindian wrote:
About the only issue I could find is with xscreensaver. The program functions well with all the standard screensaver modules included but... that darn old GLslideshow, Carousel, or others that require pictures or graphics to display... just won't work

Hey Sszindian

It's enough to always run xscreensaver and xscreensaver-demo as user spot, e.g.:
Code:
su spot -c xscreensaver-demo

Carousel works fine, but GLSlideshow segfaults (probably due to missing Helvetica font).

Additionaly, if you also want to use 'screen-lock' feature, set 'suid' bit for /usr/bin/xscreensaver:
Code:
chmod +s /usr/bin/xscreensaver

And make sure that password for spot is set!
Then restart xscreensaver daemon (as spot).
Screen can be unlocked using both root and spot passwords.

The only downside I've noticed is that if one of GL screensavers is running, the box with password prompt may not be displayed and password has to be entered "blindly" then.
But this can be overridden by setting 'Settings -> Advanced -> Visual' to be "TrueColor", which is unfortunately slower than GL.

HTH
Greetings!
Screenshot.jpg
 Description   
 Filesize   56.02 KB
 Viewed   1043 Time(s)

Screenshot.jpg


_________________
[O]bdurate [R]ules [D]estroy [E]nthusiastic [R]ebels => [C]reative [H]umans [A]lways [O]pen [S]ource
Omnia mea mecum porto.
Back to top
View user's profile Send private message 
sszindian


Joined: 24 Apr 2010
Posts: 578
Location: Pennsylvania U.S.

PostPosted: Thu 28 Nov 2013, 09:36    Post subject: xscreensaver  

SFR

'Thanks for that info on xscreensaver, I'll give it a try this weekend and see if I can accomplish what you wrote here Smile' That said, this should be the perfect puppy for those wanting to display all those family pictures.

-----------------------------

Also:
If anyone's looking for a Google Earth that runs very well in Slacko...

google_earth-6.0.3.2197.sfs

but since this is a 'Less than version 7' you will get the 'Invalid HTTP request dialog box' when trying to find a location with the search function so...

here's the fix...

Go to: /opt/google/earth/free/libcurl.so.4 and just rename the 'libcurl.so.4' module to something like 'OLD-libcurl.so.4' so that the libcurl.so.4 module is no longer used (you could delete the module, I just renamed it)! (This is also posted in the How To section on this forum.)

>>>---Indian------->

_________________
Cloud Computing For Every Puppy (a .pet)
http://murga-linux.com/puppy/viewtopic.php?t=69192
Back to top
View user's profile Send private message 
Ted Dog


Joined: 13 Sep 2005
Posts: 2051
Location: Heart of Texas

PostPosted: Thu 28 Nov 2013, 09:46    Post subject:  

are there other run as spot type issues with slacko like the screen saver topic addressed above. The one thing I eztremely DISLIKE about fatdog64 is its dumb hybrid mode of run as spot. It only serves as a bug magnet. seemingly normal tasks are bungled by its non standard implentation. Either go multiuser in a clean standard linux mode or back to everthing as root like with only outgoing web and ftp stuff as run as non root.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8554
Location: Stratford, Ontario

PostPosted: Thu 28 Nov 2013, 10:06    Post subject:  

Mick: It looks good. Other than being built with woof-CE, are there any other changes from 5.6 that we should be testing?
Back to top
View user's profile Send private message 
musher0


Joined: 04 Jan 2009
Posts: 3789
Location: Gatineau (Qc), Canada

PostPosted: Thu 28 Nov 2013, 13:55    Post subject:  

Edit, Nov. 30, 2013
~~~~~~~~~~~~~
Hello, Mick and all.

The pupsave-creation bug has decided it was not done with me. (hehe) Rolling Eyes

@Mick: Which blkid version did you use ?

BFN.

musher0

~~~~~~~~~~~~~~~

To the users:
For suggested workarounds, please see
http://murga-linux.com/puppy/viewtopic.php?p=740525&sort=lastpost#740525
and
http://murga-linux.com/puppy/viewtopic.php?p=740519&sort=lastpost#740519
24.jpg
 Description   
 Filesize   26.06 KB
 Viewed   936 Time(s)

24.jpg


_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)

Last edited by musher0 on Sat 30 Nov 2013, 04:16; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
playdayz


Joined: 25 Apr 2008
Posts: 3788

PostPosted: Thu 28 Nov 2013, 15:46    Post subject:  

The screen does not come back from standby.

Slacko 5.6.0 and 1 also have this problem. It is on the ex-windows 8 Lenovo 580, Intel 4000 graphics, which are becoming very widespread I believe, so it is worth reporting. 5.5 had this problem very infrequently, maybe 1 in 10 times, but 5.6+ have it every time. ACPI is working so if I close the lid, the computer goes to standby but when I open the lid, the screen stays black (no backlight in other words).

Add: This might help--the problem is not acpi. If I disable acpi and reboot the same problem happens when the screen blanks itself after 5 minutes or however long. It will not unblank.

Graphics work fine otherwise. Intel driver is found, and i915 kernel model is loaded, and modeset takes effect. Just let me know what other info to post. Thanks.
video-info-glx 1.5.1 Thu 28 Nov 2013 on Slacko Puppy 5.6.3 Linux 3.10.19 i686
2.0 VGA compatible controller: Intel Corporation Device 0166 (rev 09)
oem: Intel(R) Sandybridge/Ivybridge Graphics Chipset Accelerated VGA BIOS
product: Intel(R) Sandybridge/Ivybridge Graphics Controller Hardware Version 0.0

X Server: Xorg Driver: intel
X.Org version: 1.12.4
dimensions: 1366x768 pixels (361x203 millimeters)
depth of root window: 24 planes

direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) Ivybridge Mobile x86/MMX/SSE2
OpenGL version string: 2.1 Mesa 8.0.4

Intel(R) Core(TM) i3-3120M CPU @ 2.50GHz
Core 0: @1200 1: @1200 2: @1200 3: @1200 MHz

---------------------------------------------------------------------------------------------

Might as well also report 1) frisbee (rather than SNS) is necessary for connection to come back from standby, but it works perfectly; 2) touch pad with two finger scrolling works perfectly ootb.

Also, Firefox 24 ESR is released and is running fine in 5.6.3 So is that nasty gnome-mplayer 1.08 also released.

More success: All of the test videos play in gnome-mplayer in the suite I used for Lucid. Even better, gnome-mplayer orrectly handles DVD menus.

Another glitch: On my desktop the Microsoft Wireless mouse scroll wheel does not work--no scrolling happens. I have looked for a setup option for that but found none.

Has anyone else had trouble with mirror repos. The google-chrome 30 stable in Puppy Slacko 14 Official, was not found or otherwise a problem in several of the repos, nllug, vcu, and aarnet. I have seen this putting some new browsers in the lucid repos also. The Slackware google chrome did run after installing polkit and gconf. ibiblio seems reliable but it is so slow as to be unusable imho--not a good impression on new users..
Back to top
View user's profile Send private message 
bark_bark_bark

Joined: 05 Jun 2012
Posts: 702
Location: USA

PostPosted: Thu 28 Nov 2013, 21:02    Post subject:  

playdayz wrote:
The screen does not come back from standby.

Slacko 5.6.0 and 1 also have this problem. It is on the ex-windows 8 Lenovo 580, Intel 4000 graphics, which are becoming very widespread I believe, so it is worth reporting. 5.5 had this problem very infrequently, maybe 1 in 10 times, but 5.6+ have it every time. ...

...Graphics work fine otherwise. Intel driver is found, and i915 kernel model is loaded, and modeset takes effect. Just let me know what other info to post. Thanks.


I have the same problem with my Acer Aspire One since 5.5. It seems that there is no solution to it.

_________________
Desktop: Intel 945PSN Board, 3.2Ghz P-IV "Prescott 2M", 2GB RAM, 160GB WD HDD, Windows 7
Netbook: Acer AOD257 with 2GB upgrade, No OS
Back to top
View user's profile Send private message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3860
Location: Kiel,Germany

PostPosted: Thu 28 Nov 2013, 22:49    Post subject:  

musher0 wrote:
Hello, Mick and all.
The pupsave-creation bug has decided it was not done with me. (hehe) Rolling Eyes
@Mick: Which blkid version did you use ?
Edit, 14h10, my time:
For the time being, as a work-around, here are a couple of antidotes. Use
one OR the other. BFN.
musher0


Musher, please do not scatter your workarounds everywhere again .

You had said that it was solved because of blkid .

I was able to reproduce your bug slightly by playing with the code :


We need you to run it in urxvt terminal an post the content of /tmp/schoices.txt in [ code ] tags .

Many thanks !
Back to top
View user's profile Send private message Visit poster's website 
James C


Joined: 26 Mar 2009
Posts: 5440
Location: Kentucky

PostPosted: Thu 28 Nov 2013, 23:30    Post subject:  

Another fresh frugal install on yet another old test box.All good so far.

VIDEO REPORT: Slacko Puppy, version 5.6.3

Chip description:
VGA compatible controller: Intel Corporation 82865G Integrated Graphics Controller (rev 02)

Requested by /etc/X11/xorg.conf:
Resolution (widthxheight, in pixels): 1024x768
Depth (bits, or planes): 24
Modules requested to be loaded: dbe

Probing Xorg startup log file (/var/log/Xorg.0.log):
Driver loaded (and currently in use): intel
Loaded modules: dbe dri dri2 extmod fb glx kbd mouse record

Actual rendering on monitor:
Resolution: 1024x768 pixels (270x203 millimeters)
Depth: 24 planes

...the above also recorded in /tmp/report-video
# glxgears
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
365 frames in 5.0 seconds = 72.973 FPS
367 frames in 5.0 seconds = 73.378 FPS
369 frames in 5.0 seconds = 73.747 FPS
358 frames in 5.0 seconds = 71.545 FPS

-Computer-
Processor : Intel(R) Celeron(R) CPU 2.40GHz
Memory : 1025MB (143MB used)
Machine Type : Physical machine
Operating System : Slacko Puppy - 5.6.3
User Name : root (root)
Date/Time : Thu 28 Nov 2013 09:36:53 PM CST
-Display-
Resolution : 1024x768 pixels
OpenGL Renderer : Mesa DRI Intel(R) 865G x86/MMX/SSE2
X11 Vendor : The X.Org Foundation
-Audio Devices-
Audio Adapter : ICH4 - Intel ICH5


Code:
# free
             total         used         free       shared      buffers
Mem:       1025232       656772       368460            0        43292
-/+ buffers:             613480       411752
Swap:      2150396            0      2150396
#
Back to top
View user's profile Send private message 
oldyeller


Joined: 15 Nov 2011
Posts: 721
Location: Mishawaka IN

PostPosted: Thu 28 Nov 2013, 23:42    Post subject:  

I am downloading now. Will test some tomorrow Very Happy Very Happy

Cheers
Back to top
View user's profile Send private message 
mavrothal


Joined: 24 Aug 2009
Posts: 1384

PostPosted: Fri 29 Nov 2013, 01:00    Post subject:  

playdayz wrote:
The screen does not come back from standby.

Slacko 5.6.0 and 1 also have this problem. It is on the ex-windows 8 Lenovo 580, Intel 4000 graphics, which are becoming very widespread I believe, so it is worth reporting. 5.5 had this problem very infrequently, maybe 1 in 10 times, but 5.6+ have it every time.


Sounds a lot like this kernel 3.10-specific issue but should have been fixed in late 3.10 versions.

_________________
Kids all over the world go around with an XO laptop. They deserve one puppy (or many) too Very Happy
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 38 [569 Posts]   Goto page: Previous 1, 2, 3, 4, ..., 36, 37, 38 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1082s ][ Queries: 12 (0.0068s) ][ GZIP on ]