Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 21 Aug 2018, 11:34
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
My report on Quirky 6.0
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 64 of 64 [956 Posts]   Goto page: Previous 1, 2, 3, ..., 62, 63, 64
Author Message
fw190

Joined: 03 Feb 2015
Posts: 4

PostPosted: Tue 03 Feb 2015, 16:27    Post subject:  

Hello,

I have tried to install but ended up wit an epick fail. My system is latest linux Mint. I have tried to format, and do it again but no luck:
Code:
fw190@wurger ~ $ cd /home/fw190/Pobrane
fw190@wurger ~/Pobrane $ sudo sh ./install-quirky-to-drive.sh
[sudo] password for fw190:

This script will install Quirky to an entire drive, and make it bootable
with the Syslinux boot manager, for any x86 PC.
The intention is to install to pluggable memory drives such as USB Flash
sticks and SD-cards. The entire drive is erased, so take off any files that
you want to keep.
The script will ask questions at each step, and will offer a choice of
drives to install to, but of course it comes down to you to make an intelligent
choice and not erase your PCs internal hard drive!
This script should work when running any Linux distribution, however, it
works best when running a Puppy Linux or Puppy Linux-derivative, as Puppy has,
in my opinion, many superior utilities. However, this script will check for
existence or otherwise of those utilities and downgrade appropriately, or
abort if a missing utility is essential.

Press ENTER key to continue (CTRL-C to abort):

1 unicorn-6.2.usfs.xz

Type a number from the left column: 1
...ok, have chosen unicorn-6.2.usfs.xz

Testing integrity of compressed file, please wait...

Plug in a USB Flash drive, 2GB size, or greater, right now.
Also, please be sure that it is unmounted.
Note, 2GB is sufficient, however for a satisfactory ongoing experience
using Quirky, it is recommended to use a 4GB or greater drive. If you intend
to keep using this installation on a daily basis, to allow for plenty of
package installations, upgrades, downloads, etc., a much bigger drive is
recommended, at least 8GB.

WARNING: Many Linux distros will auto-mount a drive when it is plugged
         in. You will have to unmount it BEFORE CONTINUING!!!
         (if you are unsure about this, don't worry, the script will
          check again later, after you have chosen the drive)

Have you plugged in the drive? Then press ENTER key:

As you are not using a Puppy-derivative, you do not have the excellent
'probedisk' utility, which reports all drives. So, falling back to giving you
a simple list:

These are all of the drives found in your PC:
sda sdb

Choose the drive to install to...
1 sda
2 sdb

Type a number from left column: 2
...ok, have chosen sdb


Uncompressing unicorn-6.2.usfs.xz to unicorn-6.2.usfs...

Final sanity check: 'sdb' is correct? (ENTER if OK, CTRL-C abort):

Some preliminaries on the sdb...
Size of drive=7681MB

Would you like to zeroize the entire drive before installation?
You should answer 'yes' to this if you choose to make a image-file
of the drive immediately after installation (this script will later offer
to do that) -- an image-file is useful for writing to other drives, or
to give to others. Zeroizing beforehand will make the image-file smaller.
NOTE: zeroizing may take over 30 minutes, depending on size of drive.
NOTE: Do not do this with a USB1 interface or via a USB-hub (too slow).
NOTE: Unless you really need to do this, recommend press ENTER to decline.
ENTER only to decline, (any other char to zeroize drive):

It is necessary to zeroize a small part of the drive, the beginning
and the end. The end, because if the drive previously had a GPT secondary
partition on it, this has to be wiped.
Zeroizing only first 20MB and last 20MB of drive...
5+0 records in
5+0 records out
20971520 bytes (21 MB) copied, 3.87186 s, 5.4 MB/s
...done

Creating 16MB FAT-16 first partition...
1+0 records in
1+0 records out
440 bytes (440 B) copied, 0.014434 s, 30.5 kB/s
mkfs.fat 3.0.26 (2014-03-07)
mkfs.fat: warning - lowercase labels might not work properly with DOS or Windows
/dev/sdb1: No such file or directory
Installing syslinux in 1st partition, sdb1...
syslinux: /dev/sdb1: No such file or directory
Creating 2nd partition, size 7360MB...

Please choose whether to create a ext2, ext4, of f2fs filesystem in the
second partition. For Flash media, f2fs is very highly recommended.

1 f2fs (best choice for Flash)
2 ext4-without-journal (2nd best choice for Flash)
3 ext2
4 ext4 with journal (recommended for hard drives)

Type a number from left column: 1
...ok, have chosen f2fs

Creating f2fs in 2nd partition...

   F2FS-tools: mkfs.f2fs Ver: 1.2.0 (2013-10-25)

Info: Label = quirky2
   Error: Failed to open the device!
...done

Creating unicorn-6.2.sfs
This will be copied to /audit/reference in the target drive, and
may be used in future for recovery purposes. Creating now...
./install-quirky-to-drive.sh: 417: ./install-quirky-to-drive.sh: mksquashfs: not found

Populating 1st partition, sdb1...
mount: special device /dev/sdb1 does not exist

Error, failed to mount first partition, sdb1. Aborting
fw190@wurger ~/Pobrane $
Back to top
View user's profile Send private message 
ETP


Joined: 19 Oct 2010
Posts: 1085
Location: UK

PostPosted: Wed 04 Feb 2015, 09:43    Post subject:  

Hi fw190 & welcome to the kennels.

The instructions for installation can be found here:
http://distro.ibiblio.org/quirky/quirky6/amd64/april-6.89/install-quirky.htm

The output from the script indicates failure to make the first partition bootable due to syslinux not being present or found in Mint followed by failure to create the f2fs partition due to the absence of the needed tools in Mint.
Perhaps the most relevant part of the notes is:

Quote:
Some people found the script to be troublesome in certain Linux distributions -- this may just be a matter of installing needed packages, for example with Ubuntu you might need to install 'mtools', 'syslinux' and 'f2fs-tools' -- if the latter is not in the repo, then the distro is too old!). If you encounter a problem that you can't solve, go to the Forum to discuss it, or try Method B or D.


Note also that it would fail if you did not start by un-mounting the target stick. You were correct in using an 8GB stick.

Your best bet is to use a live ISO of a Pup such as Precise 5.7.1 which contains everything that is needed to run the script.

_________________
Regards ETP

Kennels
Back to top
View user's profile Send private message 
fw190

Joined: 03 Feb 2015
Posts: 4

PostPosted: Wed 04 Feb 2015, 15:36    Post subject:  

Thank you for your reply.

Actually I did read the instruciotns, and checked for the presence of those packages. They were there except of one which I have installed but it didn't help. Then I have tried various things - even changing the language of my system which helped a bit excluding one error but when I got to a point in which I had no clue what to do I just posted the output here.

Then I thought that this might not be the suitable topic for noob problems like mine and I reposted it here http://murga-linux.com/puppy/viewtopic.php?p=825993#825993 where a friendly soule pointed me to method D which in the end worked ok with the 8GB file which I plan to test a bit.

Once again thank you Wink

E. spelling
Back to top
View user's profile Send private message 
Yelisey

Joined: 09 Feb 2015
Posts: 6

PostPosted: Mon 09 Feb 2015, 15:22    Post subject: f2fs for partition in internal ssd drive
Subject description: Grub4dos don`t see that file system
 

How can I do bootable Puppy with f2fs in internal ssd drive?
Back to top
View user's profile Send private message 
slavvo67

Joined: 12 Oct 2012
Posts: 1567
Location: The other Mr. 305

PostPosted: Tue 10 Feb 2015, 23:27    Post subject:  

It appears the Quirky Unicorn upgrade from 6.2 to 6.2.1 breaks my internet connection (eth0 in my case, unsure about wlan0). For now, I have chosen not to upgrade to the 6.2.1 version, though I am not sure how important that 6.2.1 upgrade really is.
Back to top
View user's profile Send private message 
Rodney Byne

Joined: 31 Jan 2014
Posts: 181

PostPosted: Sun 15 Feb 2015, 07:30    Post subject: Screenshot status box?  

Hi,

In many desktop screenshots, there is shown
a black box with white text which looks like
pc status information.

I can't find anything about it in Menu, what's the
secret, how do I make that box appear please?

Regards.
Back to top
View user's profile Send private message 
Moat


Joined: 16 Jul 2013
Posts: 860
Location: Mid-mitten, USA

PostPosted: Sun 15 Feb 2015, 20:09    Post subject:  

Hi Rodney - that's a Linux desktop widget engine called "conky" - you might have it available in your PPM, or search the forum for .pets.

The "Pwidgets" app for Puppy is actually based on a Puppy-specific optimized conky engine - the particular configuration you mention (black box with white text) might even run fine if copied to Pwidgets' /usr/local/pwidgets/widgets/configs directory, if you so happen to install or have installed Pwidgets already.

Aside from actually being useful, conky can be a lot of fun to play with/customize/config!

http://conky.sourceforge.net/

Bob
Back to top
View user's profile Send private message 
Ibidem

Joined: 25 May 2010
Posts: 553
Location: State of Jefferson

PostPosted: Fri 27 Mar 2015, 17:38    Post subject:  

A late comment or two on http://bkhome.org/news/?viewDetailed=00114.

* Alpine Linux also has an ARM flavor, built for the Raspberry Pi (not sure if it's armv6-hf or something lesser).
* I'd be very interested in seeing an "Alpine Puppy"; if it would be helpful, I could package some of the standard Puppy programs like mhwaveedit and mtpaint, though I'd like to hear a request before I do that. (I already maintain a few packages for Alpine.)

Feel free to respond or PM me, as appropriate, if you have questions related to Alpine.
Big caveat: There isn't a Seamonkey package, the stock Linux binary won't be compatible, and I'm not ready to maintain Seamonkey.
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 3516
Location: Ontario Canada

PostPosted: Sun 31 May 2015, 12:30    Post subject: My report on Quirky 6.0  

New install of Quirky-6.2.1 to a 32gb flash drive.

Operating System
Version
Kernel Linux 3.16.6 (i686)
Version #1 SMP Sun Oct 19 00:35:00 GMT-8 2014
C Library Unknown
Distribution Quirky Unicorn
Current Session
Computer Name puppypc31899
User Name root (root)
Home Directory /root
Desktop Environment XFCE 4

OpenGL
Vendor Advanced Micro Devices, Inc.
Renderer AMD Radeon HD 5570
Version 4.4.13283 Compatibility Profile Context 14.501.1003
Direct Rendering Yes

I installed xfce-4.12_tahr.pet (thanks 666philb) and added some plugins.
Added some applications with PPM.

It's working fine so far.
Screenshot.jpg
 Description   
 Filesize   13.8 KB
 Viewed   683 Time(s)

Screenshot.jpg

Back to top
View user's profile Send private message 
eowens2

Joined: 27 Aug 2008
Posts: 172

PostPosted: Wed 29 Jul 2015, 21:28    Post subject:  

I would like some advice on how to get my new Brother MFC-L2700DW printer working on Quirky Tahr.

I am using Quirky Tahr 6.0.5 (CUPS 1.7.1) on an Acer c710 laptop. The md5sums for tahr-6.0.5.usfs.xz and
install-quirky-to-partition.sh were both correct.

Brother printer drivers are created by downloading a "xxxlpr.deb" file and a "xxxcuppswrapper.deb" file from the Brother web site (http://support.brother.com/g/b/downloadtop.aspx?c=eu_ot&lang=en&prod=mfcl2700dw_us_eu_as), and installing them with "dpkg" or "debbi" from debbi-1.x.pet.

I used debbi from debbi-1.2.pet (found at http://www.murga-linux.com/puppy/viewtopic.php?t=42533) for my installation.

Here is my attempt at lpr install and the response:

Code:

# debbi mfcl2700dwlpr-3.2.0-1.i386.deb
chown: unknown user lp
Post-install script completed!
Done!
#

And here is my attempt at cupswrapper install and the response:
Code:

# debbi mfcl2700dwcupswrapper-3.2.0-1.i386.deb
lpadmin -p MFCL2700DW -E -v usb://dev/usb/lp0 -P /usr/share/ppd/brother/brother-MFCL2700DW-cups-en.ppd
lpadmin: Request Entity Too Large
Post-install script completed!
Done!
#

The process created PPD files in /opt/brother/Printers, /usr/share/cups/model, and /usr/share/ppd, but when I then open CUPS and click on "Adding Printers and Classes" to add the MFC-L2700DW I get "Internal Server Error" and the process halts!

BK's blog says that early versions of Quirky had printing problems due to the non-inclusion of the packages "cups-core-drivers" and "cups-filters-core-drivers" by Ubuntu, but these packages were present in my copy of Quirky Tahr-6.0.5.


Has anyone else encountered this? Any suggestions as to how to get the Brother MFC-L2700DW working?

I should add that I used the same process as described above to install the drivers in Tahrpup 6.0.5 [CUPS 1.4.8] and the printer works fine.

Any help would be appreciated.
Back to top
View user's profile Send private message 
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Mon 16 May 2016, 01:40    Post subject: 64 pages ! in english !  

64 pages ! in english ! i come back once i translated them, unless a french guy made a resume
b14.jpg
 Description   Version 6 seems enough for my home needs
 Filesize   58.72 KB
 Viewed   234 Time(s)

b14.jpg


_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
Display posts from previous:   Sort by:   
Page 64 of 64 [956 Posts]   Goto page: Previous 1, 2, 3, ..., 62, 63, 64
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1965s ][ Queries: 12 (0.1424s) ][ GZIP on ]