Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 19 Jul 2019, 04:50
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Software Installation Problem - Electrum.
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [7 Posts]  
Author Message
arseh2

Joined: 30 Aug 2013
Posts: 45

PostPosted: Wed 25 Dec 2013, 05:22    Post subject:  Software Installation Problem - Electrum.  

I tried to implement the tutorial here:

http://www.musicresolutions.com/portfolio/portable-encrypted-usb-bitcoin-wallet-puppy-linux-electrum/

However, I have Slacko 5.6 and I already seem to have the python installed? In any case I attempted to do what has been instructed there but these files do not appear in package manager:

------------------------
python-pip-1.0

python-setuptools
python-sip
python-qt4_4.9.1
libqtwebkit4_2.2.1
python3-pyqt4_4.9.1
------------------------

Only a pip file for a later version. I installed it.

And - on the installation instruction of Electrum, I directly downloaded it and extracted - is it the same way as on the above link instruction which tells me to do with console?

I did not say on the console:

pip install https://download.electrum.org/Electrum-1.9.6.tar.gz#md5=0d92d137ba26136f3908f2bf50271fe3

Which it gives error.


But I just downloaded and clicked, then extracted:

https://download.electrum.org/Electrum-1.9.6.tar.gz#md5=0d92d137ba26136f3908f2bf50271fe3

Are both of these the same?

And when I look at the Electrum folder I see some files. Nothing happens when I click on them. There are some "python" icons.

How can I have these get to work? What should I do to make Electrum work? Both in terms of Electrum and Python?
Back to top
View user's profile Send private message 
mikeb


Joined: 23 Nov 2006
Posts: 11266

PostPosted: Wed 25 Dec 2013, 08:14    Post subject:  

Quote:
However, I have Slacko 5.6 and I already seem to have the python installed?

you type python and something happens?... did not know that any puppies that have it by default and usually the devx is cited to get it which to me is a little silly...but regardless you might still be lacking python core.

mike
Back to top
View user's profile Send private message 
arseh2

Joined: 30 Aug 2013
Posts: 45

PostPosted: Wed 25 Dec 2013, 09:16    Post subject:  

No - nothing happens when I type Python.

I only guessed Python is installed because in the package manager when I type "Python" and search for all repositories, the last 2 items are Python 2.7.3 and Python 2.7.3-i686-s and there is a checkmark near them, plus it writes (Already Installed). It is a live CD Finalized - so I guess these are default installed - I can not have added later.

I manually installed Python later - again Electrum does not work.

Does the Python snake icon in the Electrum software files mean that there is a Python software installed and is associated? Or Electrum puts the Python icons in the files although there is no Python yet?

I just need to install this Electrum thing - but do not know what to do!....
Back to top
View user's profile Send private message 
mikeb


Joined: 23 Nov 2006
Posts: 11266

PostPosted: Wed 25 Dec 2013, 09:35    Post subject:  

hmm ok though I would expect 'python' to do something.

Quote:
python3-pyqt4_4.9.1

this suggests python 3 also so even if python 2.7 was installed they are not compatible...not backward or forward so you have to have python 3 for python 3 software (yes foss strikes again Very Happy )

mike
Back to top
View user's profile Send private message 
arseh2

Joined: 30 Aug 2013
Posts: 45

PostPosted: Wed 25 Dec 2013, 14:44    Post subject:  

I have been trying to install several versions of Pyhton - however, at the final stage it writes : "checking ptyhon3-3-3.0 for missing shared libraryfiles" and it stays this way for an hour. Should I wait for more - is that normal? At first I thought it has frozen after 10 minutes and killed it.

Now I wanted to give a chance and waited for almost an hour it remains. So I killed again.

What would be wrong? This is a live CD with a 1.25 GB Ram laptop with Intel Centrino Sonoma. Not a very ancient computer.

What would you suggest me to do?
Back to top
View user's profile Send private message 
arseh2

Joined: 30 Aug 2013
Posts: 45

PostPosted: Wed 25 Dec 2013, 15:06    Post subject:  

With some trial and error I managed to install Python. Now will see what happens with Electrum. Anything happens - will write here.
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 12329
Location: S.C. USA

PostPosted: Wed 25 Dec 2013, 15:30    Post subject:  

Electrum

The web site in your first post gives you specific information on how you will have to run Electrum.
Follow that advice.
Electrum package, not being compiled specifically for Puppy, will require some manual setting up. That web site tells you how.

_________________
The things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
YaPI(any iso installer) http://www.murga-linux.com/puppy/viewtopic.php?t=107601
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [7 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0501s ][ Queries: 11 (0.0091s) ][ GZIP on ]