Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 02 Sep 2014, 22:47
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Slacko64 - 64 bit Puppy - 6 Feb 2014
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 16 of 18 [262 Posts]   Goto page: Previous 1, 2, 3, ..., 14, 15, 16, 17, 18 Next
Author Message
mini-jaguar

Joined: 13 Nov 2008
Posts: 462

PostPosted: Mon 10 Mar 2014, 10:15    Post subject:  

Works, but it would be much cooler if there was a .pet or .sfs which had the 32-bit libraries (like for FatDog) so you could run 32-bit software.

Actually, never mind, I'll probably try that one to see if it works. It'll take a few days to get around to it though.
Back to top
View user's profile Send private message 
smokey01


Joined: 30 Dec 2006
Posts: 1806
Location: South Australia

PostPosted: Tue 11 Mar 2014, 01:28    Post subject:  

I think you will find the 32bit libraries that FatDog uses are actually slacko binaries.
_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send private message Visit poster's website 
James C


Joined: 26 Mar 2009
Posts: 5726
Location: Kentucky

PostPosted: Wed 12 Mar 2014, 02:33    Post subject:  

Successfully updated a frugal install from 5.8.7 to 5.8.8 ........no problems.

Report Video 1.3 - Wed 12 Mar 2014 on Slacko64 Puppy 5.8.8 - Linux 3.13.1 x86_64

Chip description:
d.0 VGA compatible controller: NVIDIA Corporation C61 [GeForce 7025 / nForce 630a] (rev a2)
oem: NVIDIA
product: MCP61 - mcp61-86 Chip Rev

X Server: Xorg Driver used: nouveau

X.Org version: 1.12.4
dimensions: 1440x900 pixels (381x238 millimeters)
depth of root window: 24 planes


...the above also recorded in /tmp/root/ as report-video,
and archived with xorg.conf and Xorg.0.log as report-video-full.gz
# glxgears
1411 frames in 5.0 seconds = 282.032 FPS
1730 frames in 5.0 seconds = 345.781 FPS
1760 frames in 5.0 seconds = 351.906 FPS
1754 frames in 5.0 seconds = 350.670 FPS
1750 frames in 5.0 seconds = 349.853 FPS

-Computer-
Processor : 2x AMD Athlon(tm) 64 X2 Dual Core Processor 5200+
Memory : 3796MB (437MB used)
Machine Type : Physical machine
Operating System : Slacko64 Puppy - 5.8.8
User Name : root (root)
Date/Time : Wed 12 Mar 2014 01:49:16 AM CDT
-Display-
Resolution : 1440x900 pixels
OpenGL Renderer : Gallium 0.4 on llvmpipe (LLVM 0x300)
X11 Vendor : The X.Org Foundation
-Audio Devices-
Audio Adapter : HDA-Intel - HDA NVidia

Code:
# free
             total         used         free       shared      buffers
Mem:       3796788      1703796      2092992            0        83404
-/+ buffers:            1620392      2176396
Swap:      8294396            0      8294396
#
Back to top
View user's profile Send private message 
01micko


Joined: 11 Oct 2008
Posts: 7797
Location: qld

PostPosted: Wed 12 Mar 2014, 23:12    Post subject:  

01micko wrote:
As for data corruption/issues.. this clearly stated as alpha software. I have mounted ntfs with no issues. I would never install linux on ntfs. That said, Barry decided to support that for "ease of use". At the moment it is still supported, but with considerations for the direction MS is going then that support will probably have to be revoked.

I really wish hardware companies would grow some balls. MS is not about standards, its about self preservation and competition annihilation. That way usb installs could be simple, eliminating need for NTFS installs. </rant>

As for the full install bug, its a lib64 issue that will be addressed in the next alpha. You can use the f2fs full installer (makes a full install to USB stick) and copy (don't dd, else you use f2fs on a hard drive, not recommended) that to a partition and it would probably work.


Just referencing this previous post of mine. (5th March, previous page, this thread in answer to James C and Jades).

A while ago I did do a Slacko64 full install along side Vista on the lappy on which I'm typing. It went well but I never booted it. I was experimenting with grub2. Grub2 did not see the install and of course did not boot it, however Vista did boot and remained intact. I did realise that the /usr/lib64 directory failed to copy because the grub2 install was called from a chroot and failed. Once I manually copied over all of /usr/lib64 the chroot worked fine to install grub2 which indicated to me that that installation of Slacko64 (previous version, 5.8.7, k3.12.8.) was pretty much fully functional.

Fast Forward >> Today. As part of my course (WRT my uni stuff) we are optionally allowed to use Linux! (Yay... I hate windows!). It's fedora; which I'm going to have to learn anyway, being closely related to RHEL, I forget how to use yum and such but it will come back. I'm more used to urpmi being of Mandrake stock myself. Slackware came much later (around 12.0).

I installed fedora-20.0 from usb stick. The installer is a bit stupid, even though it recognised my 35GB partition, ext4, at /dev/sda5, I had to mark it for formatting..then again, recognised my 2.5GB swap partition at sda7 but still had to mark it for formatting! Rolling Eyes . It wasn't obvious so I'll be making a bug report about that, as well as the stupid "live-usb-installer" .. total fail, and IIRC it was too when I installed SOAS for the young bloke about 6 months ago. Had to hack that one in slackware to get it to work. On a brighter note, the "old" full install was recognised as "Unknown Linux". Cool.

So, I let the installer do it's thing and promptly rebooted, choosing "Unknown Linux" from the menu. Now I sit typing this! Beauty!

Two fantastic things to come out of this for Slacko64.
    1. Grub2 I built works just fine; will work even better once I tweak (and you people test) the scripts.
    2. Slacko64 full install isn't very much broken.


Cheers! (Back to work now!)

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
gcmartin

Joined: 14 Oct 2005
Posts: 4238
Location: Earth

PostPosted: Thu 13 Mar 2014, 06:09    Post subject:  

01micko wrote:
... Two fantastic things to come out of this for Slacko64.
    1. Grub2 I built works just fine; will work even better once I tweak (and you people test) the scripts.
    2. Slacko64 full install isn't very much broken.
Request
Would it be appropriate to have the ISO be a GRUB2 based ISO? Or, Is the learning curve too large for doing such for CD/DVD boot?

Both @Ted Dog and @Rcrsn51 , each has done some work with GRUB2 and wonder if there is some contribution(s) from them that would assist a migration in the 64bit Slacko to a GRUB2 base across the board. Maybe there exist some reference here in Puppyland for such setup for DVD bootmanager use.

Thus, Slacko64 would have GRUB2 as the base bootmanager for DVD, frugal, full or remaster, each creating reference in setup, configuration, and utility use.

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send private message 
jdavid

Joined: 13 Mar 2014
Posts: 1

PostPosted: Thu 13 Mar 2014, 22:40    Post subject: dialup in slacko64
Subject description: can"t use usb modem
 

Hello, I have a problem with dialup. I am using a zoom usb modem that has always worked in puppies from 4.31 and up. It works in all the fatdogs too. I get the message: wvdial: utils/wvtask.cc:409: static void WvTaskMan::_stackmaster(): Assertion `magic_number == -0x123678' failed. I have searched but cannot fine a solution. I just cannot get pupdial to work in slacko64 and have tried both downloads. Any ideas?

jdavid

Solved: Dialup with usb modem in Slacko64. I put the three "libwvbase" files/links from fatdog621 (folder /user/lib64) into Slacko64. I also used my working wvdial.conf from fatdog621. Pupdial/Wvdial now works fine in Slacko64.
01micko, thanks for your puppy slacko systems, very nice.

jdavid

Last edited by jdavid on Tue 01 Apr 2014, 15:53; edited 1 time in total
Back to top
View user's profile Send private message 
mini-jaguar

Joined: 13 Nov 2008
Posts: 462

PostPosted: Fri 14 Mar 2014, 07:20    Post subject:  

smokey01 wrote:
I think you will find the 32bit libraries that FatDog uses are actually slacko binaries.
Yes, but I tried that .sfs and it doesn't make the software compatible in any way, unfortunately.

Even a lowly Tetris for Puppy 4.3.1 or lower, which works fine on FatDog64 with the libs loaded, doesn't work here.
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2455
Location: Texas, USA

PostPosted: Wed 26 Mar 2014, 11:06    Post subject: Bibletime 2.10.0  

Hi Mick,

Fatdog64's latest Bibletime 2.10.0 works great on your Slacko64.

Regards,
Jim
Screenshot_2014-03-26_102330.jpg
Description 
jpg

 Download 
Filename  Screenshot_2014-03-26_102330.jpg 
Filesize  242.77 KB 
Downloaded  98 Time(s) 
Back to top
View user's profile Send private message 
radky

Joined: 02 May 2010
Posts: 448

PostPosted: Thu 03 Apr 2014, 18:18    Post subject:
Subject description: FbBox
 

FbBox desktop environment

Supports Slacko and Slacko64

http://murga-linux.com/puppy/viewtopic.php?t=92982

_________________
PupMates
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1663
Location: wales

PostPosted: Sat 05 Apr 2014, 13:21    Post subject:  

hi 01micko,

flsynclient is not retaining it's settings for me

_________________
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
LÖVE2d, a collection of 27 lua gameshttp://www.murga-linux.com/puppy/viewtopic.php?t=76739
Back to top
View user's profile Send private message 
IlluminatiPL

Joined: 16 Feb 2014
Posts: 27

PostPosted: Sun 06 Apr 2014, 10:35    Post subject: FFMpeg Compile Problem  

I have with a problem with Compile FFMpeg [Little MB's of Snapshot]... (with Opus)

Commands:

./configure --prefix=/usr --libdir=/usr/lib64 --enable-libmp3lame --enable-libx264 --enable-libfaac --enable-pthreads --enable-small --enable-postproc --enable-libvorbis --enable-libopus --enable-gpl --enable-shared --enable-nonfree --enable-libopencore-amrnb --enable-libopencore-amrwb --disable-debug --enable-bzlib --enable-zlib --enable-libspeex --enable-version3 --enable-runtime-cpudetect --enable-x11grab --enable-libschroedinger --enable-libtheora --enable-libxvid --enable-swscale --enable-libvpx --arch=x86_64

Results:

Compile is done,But "AvFilter" it's doesn't works... (Screenshot capture it's doesn't works too...)

Last edited by IlluminatiPL on Sun 06 Apr 2014, 10:36; edited 1 time in total
Back to top
View user's profile Send private message 
IlluminatiPL

Joined: 16 Feb 2014
Posts: 27

PostPosted: Sun 06 Apr 2014, 10:35    Post subject:  

Double post.
URL: http://murga-linux.com/puppy/viewtopic.php?p=769571#769571
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2455
Location: Texas, USA

PostPosted: Sun 06 Apr 2014, 13:35    Post subject:    

Hi Mick,

Radky's FbBox, discussed above, is working great on my hardware.

Regards, Very Happy
Jim
image-3.jpg
 Description   
 Filesize   16.99 KB
 Viewed   776 Time(s)

image-3.jpg

Back to top
View user's profile Send private message 
Jades

Joined: 07 Aug 2010
Posts: 440
Location: Somewhere in Blighty.

PostPosted: Mon 21 Apr 2014, 09:08    Post subject: OpenSSL  

Just updated and checked PPM and version 1.0.1g of OpenSSL is available for download on the slackware64-14.0-patches repo. Slacko64's bundled version is 1.0.1f, which is one of the vulnerable ones which have had press coverage recently.
_________________
Zhaan - AMD K6 2 500, 512MB RAM, ATI Rage 128 VR. Full install Wary 5.5 HardInfo Report
Merlin - Pentium D 3.4GHz, 2GB RAM, Radeon X1650 Pro AGP. Slacko 5.7.0 HardInfo Report
Back to top
View user's profile Send private message Visit poster's website 
Doglover

Joined: 24 Jun 2006
Posts: 179

PostPosted: Sun 25 May 2014, 21:40    Post subject:  

Hi... running an HP 15-n228us with ati graphics.

X will not start.

output from sys info...

-Computer-
Processor : 4x AMD A6-5200 APU with Radeon(TM) HD Graphics
Memory : 5680MB (308MB used)
Machine Type : Physical machine
Operating System : Slacko Puppy - 5.7.0
User Name : root (root)
Date/Time : Mon 26 May 2014 02:38:15 AM GMT-8
-Display-
Resolution : 1368x768 pixels
OpenGL Renderer : Gallium 0.4 on llvmpipe (LLVM 0x300)
X11 Vendor : The X.Org Foundation
-Audio Devices-
Audio Adapter : HDA-Intel - HD-Audio Generic
Audio Adapter : HDA-Intel - HD-Audio Generic
-Input Devices-
AT Translated Set 2 keyboard
Logitech USB Optical Mouse
SynPS/2 Synaptics TouchPad
ST LIS3LV02DL Accelerometer
Power Button
Lid Switch
Power Button
Video Bus
HP WMI hotkeys
HD-Audio Generic HDMI/DP,pcm : 3=
HD-Audio Generic Headphone
HD-Audio Generic Mic
PC Speaker
HP Truevision HD
-Printers-
No printers found
-SCSI Disks-
ATA HGST HTS541075A9
hp DVDRAM GU70N
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 16 of 18 [262 Posts]   Goto page: Previous 1, 2, 3, ..., 14, 15, 16, 17, 18 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1043s ][ Queries: 12 (0.0101s) ][ GZIP on ]