Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 23 Nov 2017, 22:28
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars ) » Für deutschsprachige Anhänger
avidemux 2.5.5
Moderators: MU
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [7 Posts]  
Author Message
alibaber

Joined: 19 Jan 2014
Posts: 3
Location: Germany - Niedersachsen

PostPosted: Thu 23 Jan 2014, 16:32    Post subject:  avidemux 2.5.5
Subject description: Fehlermeldung bei Installation
 

Hallo liebe Forengemeinde,

ich bin (aus etlichen Gründen) vor einiger Zeit auf dieses Linux umgestiegen:
Lucid puppy 528
Es ist auf USB-Stick installiert.
Benutzte Hardware:
Celeron 440 mit 2,0 GHz auf Gigabyte G33M-DS2R mit 4 GB DDR2 Corasair

Anfang letzten Jahres hatte ich AVIdemux 2.5.5 installiert und erhielt nach der Installation eine PPM-Fehler-Meldung, wovon ich einen Screenshot machte (s. 1. Bild); meine Programmierkenntnisse sind übrigends = 0 Sad.

Die 2.6-er Version hatte ich nirgends als .pet o.ä. gefunden, mit der verfügbaren Anleitung zur Installation bin ich nicht klargekommen - endete mit Fehlermeldung.

Da die 2.5-er Version aber (bis auf den Fehler) lief, habe ich ich sie auch benutzt.

Am Wochenende wollte ich eine CAM-Aufnahme meines Bruders schneiden - dazu bräuchte ich aber den H264/x264-Codec, TV-HD-Aufnahmen im TS-Format lassen sich mit der 2.5-er nicht einmal öffnen; am Ende der Indizierung gibt's eine Fehlermeldung
(s. 2. Bild).

Probeweise hatte ich nun Vers. 2.6.7 unter wine installiert - das geht ja auch - und läuft schonmal. Dabei habe ich festgestellt, daß die erste Audiospur der TV-HD-Aufnahmen (audio Track 0) irgendwie kein Audio ist

Da ich jedoch die Linux-Version nutzen will, habe ich mich nochmal an der 2.6.7-er Version versucht - das mit der bei 'avidemux.org' gefundenen Compilier-Anleitung krieg ich nicht hin:
"cmake: command not found".
Code:

sh-4.1# bash bootStrap.bash --deb --without-qt4 --with-gtk
bootStrap.bash: line 93: cmake: command not found
CMAKE Version :
Build configuration :
******************* :
Build type :
Release build
    Core will be built
    Gtk will be built
     Qt4 will be skipped
     Cli will be skipped
    Plugins will be built
**BootStrapping avidemux **
Top dir : /root/Compile/avidemux_2.6.7
Fake installation directory=/root/Compile/avidemux_2.6.7/install
** CORE **
Building buildCore from ../avidemux_core with EXTRA=<>, DEBUG=<>
bootStrap.bash: line 36: cmake: command not found
** Failed at cmakeZ**
sh-4.1#

Ich denke mal, ich brauche noch irgendwelche Programmier-Software oder sowas; cmake habe ich in meinem puppy jedenfalls nicht gefunden.

Ich habe das Gefühl, AVIdemux hat irgend etwas gegen mich Evil or Very Mad

Gibt es irgend eine Möglichkeit für Leute wie mich, die 2.6-er Version unter meinem puppy zum Laufen zu bringen - ausser unter wine?

Grüsse, Ulrich
Fehler_Install_AVIDEMUX_2-5-5.png
 Description   
 Filesize   26.54 KB
 Viewed   460 Time(s)

Fehler_Install_AVIDEMUX_2-5-5.png

Fehler_crash_AVIDEMUX_2-5-5.png
 Description   
 Filesize   34.04 KB
 Viewed   458 Time(s)

Fehler_crash_AVIDEMUX_2-5-5.png

Back to top
View user's profile Send private message 
antilet

Joined: 17 Aug 2012
Posts: 217

PostPosted: Fri 24 Jan 2014, 04:45    Post subject:  

Schon mal hier geschaut: http://murga-linux.com/puppy/viewtopic.php?t=74380

Übrigens die Entwickler-Tools (cmake) findest du hier:
http://distro.ibiblio.org/puppylinux/puppy-5.2.8/
Es ist die Datei lupu_devx_528-4.sfs
(Die hoffentlich zu deinem 528 passt, es gibt davon verschiedene Versionen)

Auf deinem Rechner läuft aber sicher auch Precise, vielleicht auch einen Versuch wert...

Oder du versuchst es mit dem SFS- von Lazy, sollte auch gehen, hier sind idR. alle Abhängigkeiten mit enthalten:
http://smokey01.com/RSH/LazY-Puppy-201/lp201-sfs/single-apps/
LP2_Avidemux255.sfs

_________________
Toshiba Satallite M30X-124 | ATI Mobility Radeon 9700 | Intel PRO/Wireless 2200BG
Most Linux need special boot options to boot on this laptop: i8042.nomux=1 highres=off nohz=off irqpoll

Back to top
View user's profile Send private message 
alibaber

Joined: 19 Jan 2014
Posts: 3
Location: Germany - Niedersachsen

PostPosted: Thu 30 Jan 2014, 15:02    Post subject:  

Hallo 'antilet',

erstmal danke für die Hinweise!
Ich hatte mich - bevor ich im Forum wild drauf los frage - vorher schon hier umgesehen, aber offensichtlich nicht das richtige gefunden.

Den englischsprachigen Thread 'Schon mal hier geschaut:' hatte ich dabei auch gefunden.
Ich konnte nicht glauben, das Entwicklungstools (o.s.ä.) so groß sind!
Mein ursprüngliches puppy-sfs hatte ca. 130 MB und das bei den ganzen enthaltenen Programmen und co.

Das 'lupu_devx_528-4.sfs' habe ich runtergeladen und per 'load sfs on the fly' geladen.
cmake Vers. 2.8.3 läuft (S. Bild), habe also Hoffnung Very Happy

Precise hatte ich mir (neben wary und racy) als Vers. 5.4.3 schonmal angesehen. Die aktuelle gefällt mir optisch erheblich besser.
Ich hab Vers. 5.7.1 erstmal eingedeutscht und musste feststellen, daß das Erstellen einer neuen live-CD fast 20 Min. dauerte - bei minem lupu nicht einmal 5 - und das bei mittlerweile ca. 240 MB Größe!

Ich werde jetzt aber erstmal AVIdemux 2.6.7 versuchen zum Laufen zu bringen. Mal sehen, ob ich's gebacken krieg ...
Das Ergebnis wird hier dann mitgeteilt.


Grüsse, Ulrich
cmake-screen.jpg
 Description   
 Filesize   52.62 KB
 Viewed   391 Time(s)

cmake-screen.jpg

Back to top
View user's profile Send private message 
alibaber

Joined: 19 Jan 2014
Posts: 3
Location: Germany - Niedersachsen

PostPosted: Fri 31 Jan 2014, 10:08    Post subject:  

Habe festgestelt, daß anscheinend noch yasm benötigt wird.

Nach Entpacken de Archives 'avidemux_2.6.7.tar.gz' im erstellten Verzeichnis Konsole geöffnet und die 'bootStrap.bash' ausgeführt.
Nach ca. 15 sec. Ende mit Fehler
Code:
-- Configuring FFmpeg
ERRORconfigure returned <1>
ERRORconfigure output is <yasm not found, use --disable-yasm for a crippled build
.
.
CMake Error at /AVIDEMUX_2.6.7/cmake/admFFmpegBuild.cmake:238 (MESSAGE):
  An error occured
Call Stack (most recent call first):
  CMakeLists.txt:77 (include)

-- Configuring incomplete, errors occurred!
** Failed at cmakeZ**


Als 'Nicht-Programmierer' nun erstmal in's Verz. '/avidemux_2.6.7/buildCore/ffmpeg/source' gewechselt und die ffmpeg_configure.sh editiert: die Option '--disable-yasm' hinzugefügt, gespeichert und ausgeführt. Script läuft bis zum Ende durch, bis auf folgende Warnungen:
Code:
WARNING: Option --enable-decoder=mp2_float did not match anything
WARNING: Option --enable-decoder=mp3_float did not match anything
WARNING: Option --enable-decoder=h264_vaapi did not match anything
WARNING: Option --enable-encoder=ac3_float did not match anything
WARNING: Please upgrade to VA-API >= 0.32 if you would like full VA-API support.

Voller Hoffnung nun die '/AVIDEMUX_2.6.7/cmake/admFFmpegBuild.cmake' editiert und in Zeile 30 die Option '--disable-yasm' hinzugefügt.
Das beim 1. Fehlversuch erstellte Verzeichnis '/AVIDEMUX_2.6.7/buildCore' (vorsichtshalber) gelöscht und 2. Versuch gestartet.
FFmpeg-configuration läuft durch aber wieder Abbruch mit Fehler, denn yasm wird in der 'admFFmpegBuild.cmake' anscheinend nochmal gebraucht:

Code:
   if (ADM_CPU_X86)
      file(READ ${FFMPEG_BINARY_DIR}/config.h FF_CONFIG_H)
      string(REGEX MATCH "#define[ ]+HAVE_YASM[ ]0" FF_YASM "${FF_CONFIG_H}")

      if (NOT FF_YASM)
         message(FATAL_ERROR "Yasm was not found.")
      endif (NOT FF_YASM)
   endif (ADM_CPU_X86)

Also nochmal das 'buildCore'-Verzeichnis gelöscht, die ''admFFmpegBuild.cmake'' nochmal editiert, entsprechenden Part 'raus-kommentiert' und 3. Vers. gestartet.
Diesmal hat's ca. 15 Min gedauert bis zum Ende - wieder Abbruch mit Fehlern wie z.B.:
Code:

error: ‘VACodedBufferSegment’ was not declared in this scope
error: ‘buf_list’ was not declared in this scope
error: expected primary-expression before ‘)’ token
error: expected ‘;’ before ‘buf_list’
usw.

Ein Weitermachen scheint mir sinnlos, zumal ich nicht einmal weiß, worum es bei den Fehlern geht.
Ob's nur an meinem 'Raus-kommentierren' liegt?
Ob yasm zwingend erforderlich ist (habe ich als source-code gefunden; aber wie krieg ich's instaliert??)
In vielen Threads wird aber zumindest ffmpeg mit der disable-yasm-Funktion configuriet und läuft dann auch...

Hat überhaupt schon jemand AVIdemux 2.6.7 unter puppy am laufen?
Meistends lese ich, daß die 2.6-er Vers. nur unter wine genutzt wird.
Da mein Rechner zum Video-Konvertiern eh schon 'stärker' sein könnte, befürchte ich durch den wine-Umweg zusätzliche (und eigentlich doch unnötige) Leistungs-Einbußen. AVIdemux ist ja schließlich ein Linux-Programm.

Falls Möglichkeit für mich besteht, bitte ruhig mitteilen, was zu tun ist.
Wenn's zu hoch für mich ist ebenfalls mitteilen
Noch habe ich nicht ganz aufgegeben, aber irgendwann ist auch Schluß.

Grüße, Ulrich
Back to top
View user's profile Send private message 
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Mon 30 Mar 2015, 05:54    Post subject: Avidemux 2.5.5  

Avidemux 2.5.5 Lucid use with Precise 5.7.1 (Triton France)
Libx264.so.118 symlinked to 120
SDL package
I absolutely don't understand what you are speaking, unless it's about Avidemux 2.5.5 Lucid. If my data help ... well.
symlink.png
 Description   
 Filesize   17.65 KB
 Viewed   243 Time(s)

symlink.png


_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Sat 21 May 2016, 13:47    Post subject: avidemux 2.5.5 simlink libvpx and it will run.  

Pupjibaro Jessie :
avidemux 2.5.5 simlink libvpx and it will run.
avidemux.2.5.5.jpg
 Description   Pupjibaro Jessie has not FFmpeg, as Tahrpup !
 Filesize   74.02 KB
 Viewed   156 Time(s)

avidemux.2.5.5.jpg


_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Wed 26 Jul 2017, 14:53    Post subject: ok puppy 5.7.1 russian  

ok puppy 5.7.1 russian
avidemux.jpg
 Description   Da !
 Filesize   44.27 KB
 Viewed   42 Time(s)

avidemux.jpg


_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
Display posts from previous:   Sort by:   
Page 1 of 1 [7 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars ) » Für deutschsprachige Anhänger
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0477s ][ Queries: 12 (0.0063s) ][ GZIP on ]