Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 23 Sep 2014, 16:37
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
native linux 3d games crashing after a few minutes
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [9 Posts]  
Author Message
jangelelcangry

Joined: 28 May 2013
Posts: 23

PostPosted: Sat 29 Mar 2014, 19:02    Post subject:  native linux 3d games crashing after a few minutes  

hi. I would like to know why 3d games are crashing and freezing my computer after a few minutes of gameplay.
Games;
sauerbraten: crashes after 5-10 minutes in coop edit mode, freezes computer after a few seconds.
Source games (l4d & portal) crashes between 30 seconds-1 minute) sometimes steam crashes and computer freezes.
Sauerbraten (running through wine): same as linux version.
The only game that hasn't crashed puppy is Need for speed underground 2 which is an almost perfect replica compared to windows minus the frame rate which is lower.
system:
os: slacko puppy 5.7 full install ext4 partition
cpu: intel core i5 2500 @ 3.7 ghz
gpu: sapphire radeon hd 6870 1gb stock clocks
ram: gskill 4GB 1333
cpu cooler: rocketfish universal cpu cooler (a re-branded CM hyper tx3)
Motherboard: asrock h61m u3s3
driver: fglrx driver from the video upgrade wizard (any other version besides the barts, vesa or modesetting won't work).
another symptom is that when i press power button you can hear the woof sound and after 30 seconds the system will shutdown. cannot see command prompt its like the graphics server crashed.
Any other info you need? Let me know
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 5144
Location: Charleston S.C. USA

PostPosted: Sun 30 Mar 2014, 16:24    Post subject:  

I would do a Google search for sauerbraten crashes.

One idea:
Make sure Puppy screen saver is turned off.
menu->Desktop->pupX set properties of X->screensaver

Maybe check settings in the AMD Catalyst control program.

What specific AMD driver are you using?

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
jangelelcangry

Joined: 28 May 2013
Posts: 23

PostPosted: Sun 30 Mar 2014, 22:11    Post subject:  

the driver version is 13.9.
almost forgot: im using slacko puppy 5.7 pae.
i have disabled the screensaver and still shutting off.
if i try to re-open portal right after the crash, steam shuts down and htop shows that memory usage is around 900MB.
is there any other driver version i can try?
i tried other catalyst versions but those seems to be incompatible with slacko puppy.
the only driver i can use is the 13.9, other than that one won't start.
i'll keep searching why sauerbraten crashes.
thanks for your response Smile
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 5144
Location: Charleston S.C. USA

PostPosted: Mon 31 Mar 2014, 02:30    Post subject:  

Found this on AMD support site.

Steam crashes and games hang on a black screen when Force AA is on

There is a newer driver at AMD support. V13.12
However, I do not think anyone has made a Slacko 5.7.0 pet of it yet.

One thing about graphic drivers. They need to be compiled for the specific Linux kernel that is being used in the version of Puppy.
Slacko 5.7 non-pae uses the 3.4.82 kernel
Slacko 5.7.0 pae uses 3.10.32 kernel

That is why there are several version of the driver in the Puppy Package Manager.

The Video Upgrade Wizard should figure out which one matches the kernel you are using.

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
jangelelcangry

Joined: 28 May 2013
Posts: 23

PostPosted: Tue 01 Apr 2014, 13:15    Post subject:  

well
1) the aa is not an issue because i always make sure that aa is off.
2) my screen never black out just freezes like if you were looking at a screenshot.
3) also this problem you described occured with the gtx 560 i think. just in case.
btw. the kernel thing sounds like if slacko 5.6 is windows 7 and 5.7 is w8 (just an example) which i think that both have a different kernel. am i right?
thank you.
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 5144
Location: Charleston S.C. USA

PostPosted: Wed 02 Apr 2014, 03:00    Post subject:  

Quote:
btw. the kernel thing sounds like if slacko 5.6 is windows 7 and 5.7 is w8 (just an example) which i think that both have a different kernel. am i right?

Yes Slacko versions are using different Linux Kernels.

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
jangelelcangry

Joined: 28 May 2013
Posts: 23

PostPosted: Wed 02 Apr 2014, 22:52    Post subject:  

i noticed something else. it seems when i manually close portal it suppose to clear up ram but it wont clear up and seems to be a possible memory leak.
Back to top
View user's profile Send private message 
jangelelcangry

Joined: 28 May 2013
Posts: 23

PostPosted: Thu 10 Apr 2014, 14:24    Post subject:  

i bought an used radeon hd 4850 and the crashing disappeared on portal and sauerbraten ATM
now l4d is next.
and then:
look for a workaround for the default audio device bug and wait for a newer radeon driver to come to see if the radeon hd 6870 finally works.
Back to top
View user's profile Send private message 
jangelelcangry

Joined: 28 May 2013
Posts: 23

PostPosted: Sun 31 Aug 2014, 10:27    Post subject:  

It seems that the problem was the fglrx driver version itself.
changed kernel and driver and my puppy stop crashing games.now i can play source games for hours without crashes.
conclusion AMD Catalyst 13-9 =BAD.
Now it seems pretty much solved for now.
and thanks to bigpup for helping me Very Happy
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [9 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0558s ][ Queries: 11 (0.0038s) ][ GZIP on ]