Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 20 Oct 2014, 22:48
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Dpup 487
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 6 [87 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Author Message
dejan555


Joined: 30 Nov 2008
Posts: 2681
Location: Montenegro

PostPosted: Wed 23 Apr 2014, 07:58    Post subject:  

Yes, they should but I might recompile some of them.
_________________


Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
ally


Joined: 19 May 2012
Posts: 851
Location: lincoln

PostPosted: Wed 23 Apr 2014, 10:32    Post subject:  

ok, I'll wait then, the '487' packages are up on the archive already

Smile
Back to top
View user's profile Send private message Visit poster's website 
ally


Joined: 19 May 2012
Posts: 851
Location: lincoln

PostPosted: Wed 23 Apr 2014, 10:34    Post subject:  

ok, I'll wait then, the '487' packages are up on the archive already

Smile
Back to top
View user's profile Send private message Visit poster's website 
dejan555


Joined: 30 Nov 2008
Posts: 2681
Location: Montenegro

PostPosted: Wed 23 Apr 2014, 16:57    Post subject:  

wine repackaged as sfs too and verified that it works on my install too
latest jre sfs by shinobar also works and mirrored on dpup additional pkgs
static precompiled deadbeef music player repackaged as pet
Get here
md5sums are here

_________________


Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
musher0


Joined: 04 Jan 2009
Posts: 4254
Location: Gatineau (Qc), Canada

PostPosted: Fri 25 Apr 2014, 10:08    Post subject:  

Hello, dejan555.

I hope you are well.

What would be the best urxvt (rxvt-unicode) to run on dpup-4.87, if we do not like or
need a tabbed terminal ? Something supple, that can open another window of itself
without making a fuss or issuing font (-fnt parameter) errors.

I tried compiling the latest rxvt-unicode-9.19, it didn't work in dpup-4.87 -- some
image lib was missing. * (see note)

Then, I tried installing the rxvt-unicode-ml_9.07-2+b1_i386.deb and then the
rxvt-unicode-lite_9.07-2+b1_i386.deb from the Debian Squeeze listing at pkgs.org,
without success. These ones seem to be allergic to any TTF mono fonts -- even if the
fonts are present in the dpup.

I ask because I have written many information scripts based on less. In UpupRaring
3.9.9.2 or most other Puppies, it is easy to issue a command in the form
Code:
urxvt -some_urxvt_parameters -e less -some_less_parameters SomeInformationFile.txt

and it opens a separate urxvt window showing the info.

It seems I cannot do the same with mrxvt: the info shows in the same tab -- but not
always. mrxvt cannot spawn itself without the tabs, right?

Many thanks in advance for any reply.

musher0
~~~~~~~~~~
PS * I was able to compile this latest urxvt 9.19-full in UpupRaring 3.9.9.2 yesterday
and it works beautifully there.

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send private message Visit poster's website 
dejan555


Joined: 30 Nov 2008
Posts: 2681
Location: Montenegro

PostPosted: Fri 25 Apr 2014, 11:20    Post subject:  

I'll try some emulators and reply again.
These days I'm trying to update gtk2 and dependent libs and compile latest gimp with python support and some plugins
EDIT: If you run it with
Code:
mrxvt-full -e less...

then it works, mrxvt is script to launch actual executable which is mrxvt-full
EDIT2: you can also fix it like this if you want to use just "mrxvt"
Overwrite mrxvt script with symlink to mrxvt-full
Code:
ln -sf /usr/bin/mrxvt-full /usr/bin/mrxvt


Or fix script to run with any given parameters:
Code:
sed -i 's/$1/"$@"/' /usr/bin/mrxvt

_________________


Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
Billtoo


Joined: 07 Apr 2009
Posts: 2126
Location: Ontario Canada

PostPosted: Fri 25 Apr 2014, 19:45    Post subject: Dpup 487  

New manual frugal install to a flash drive running on 10 year old
compaq Presario S6700NX desktop.
video-info-glx 1.5.3 Fri 25 Apr 2014 on Lenny Puppy 487 Linux 2.6.30.5 i686
0.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200] (rev 01)
oem: ATI RADEON 9200
X Server: Xorg Driver: radeon
X.Org version: 1.4.2
dimensions: 1920x1080 pixels (521x293 millimeters)
depth of root window: 24 planes
Intel(R) Pentium(R) 4 CPU 2.80GHz
Core 0: @2800 1: @2800 MHz

The wine pet works but xbmc won't run on this pc, nexuiz does though.
Dpup487 is working well on this pc.

EDIT:
After installing a qt-everywhere-opensource-src-4.7.4-lupu-i686.pet
that I have smplayer-14.3.0.tar.bz2 compiled and works well.
smplayer.jpg
 Description   
 Filesize   50.31 KB
 Viewed   412 Time(s)

smplayer.jpg

screenshot.jpg
 Description   
 Filesize   49.38 KB
 Viewed   485 Time(s)

screenshot.jpg


Last edited by Billtoo on Sat 26 Apr 2014, 07:59; edited 1 time in total
Back to top
View user's profile Send private message 
tubeguy


Joined: 28 Aug 2009
Posts: 1326
Location: Park Ridge IL USA

PostPosted: Fri 25 Apr 2014, 20:08    Post subject:  

Billtoo I have had MJWIN on every machine I've ever owned and my mom has been hooked on it since 2000. When she finally got a Win7 box I created an XP VM just so she could play it. Very Happy
_________________
Toshiba M115-S1061: PupServer |HP/Compaq D330ST: Dpup 486
Back to top
View user's profile Send private message Visit poster's website 
musher0


Joined: 04 Jan 2009
Posts: 4254
Location: Gatineau (Qc), Canada

PostPosted: Fri 25 Apr 2014, 20:53    Post subject:  

dejan555 wrote:
I'll try some emulators and reply again.
These days I'm trying to update gtk2 and dependent libs and compile latest gimp with python support and some plugins
EDIT: If you run it with
Code:
mrxvt-full -e less...

then it works, mrxvt is script to launch actual executable which is mrxvt-full
EDIT2: you can also fix it like this if you want to use just "mrxvt"
Overwrite mrxvt script with symlink to mrxvt-full
Code:
ln -sf /usr/bin/mrxvt-full /usr/bin/mrxvt


Or fix script to run with any given parameters:
Code:
sed -i 's/$1/"$@"/' /usr/bin/mrxvt


Ok, I'll try that. Many thanks, dejan.

BFN.

musher0

_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send private message Visit poster's website 
musher0


Joined: 04 Jan 2009
Posts: 4254
Location: Gatineau (Qc), Canada

PostPosted: Fri 25 Apr 2014, 22:15    Post subject:  

Got it! Thanks, dejan.

As you suggested, I simply made a link from mrxvt-full to mrxvt, and now something
like this:
Code:
#!/bin/sh
# nice-mrxvt.sh
####
mrxvt -aht -tr -tint grey50 -shade %3 +showmenu -e less --help

looks something like that (see pic).
mrxvt's syntax is a bit different, that's all. The urxvt contraction -sh has to be spelled out
in full in mrxvt, and the percentage of shading stated with the % sign (e.g. -shade %5).
Also, in mrxvt the shading indication is the reverse of what it is in urxvt. In urxvt the
above would be stated "-sh 95".

Now to resaving the scripts in a language code that mrxvt can understand
(ISO-8859-1, not UTF8)! Smile

Again, thanks. BFN.

musher0
mrxvt_transparent-with-less.jpg
 Description   
 Filesize   55.11 KB
 Viewed   457 Time(s)

mrxvt_transparent-with-less.jpg


_________________
"Logical entities must not be multiplied needlessly." / "Il ne faut pas multiplier les êtres logiques inutilement." (Ockham)
Back to top
View user's profile Send private message Visit poster's website 
dejan555


Joined: 30 Nov 2008
Posts: 2681
Location: Montenegro

PostPosted: Sat 26 Apr 2014, 06:07    Post subject:  

Looks cool musher0, I have a transparent/tabless/scrollbarless mrxvt for weechat too. (0.4.4-dev version, it's in dpup486 pets)
Earlier version of urxvt (I think 9.15) compiles on dpup but something doesn't work right.

I always loved Xmahjongg, it's simple but has many layouts and themes to choose from I even made that little gui to choose which ones to load, my favorite combo is boar-dorothys-green Smile

_________________


Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
dejan555


Joined: 30 Nov 2008
Posts: 2681
Location: Montenegro

PostPosted: Sat 26 Apr 2014, 18:46    Post subject:  

Gimp 2.8.10 is finally compiled, but before it installs we'll have to do an update of gtk and some libraries. I was thinking easiest way would be to apply a delta file to main sfs instead doing a full iso, it's 13 MB and easy to apply.
For gimp, I'm thinking of making sfs with python+other extra scripts and plugins (GMIC is also compiled and working nicely Cool )
I'll upload update and files tomorrow.


_________________


Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
dejan555


Joined: 30 Nov 2008
Posts: 2681
Location: Montenegro

PostPosted: Sun 27 Apr 2014, 06:18    Post subject:  

Dpup 487 Update 1
EDIT: After you apply this update you can proceede to Update 2

Attached is a script to download delta files and update main dpup sfs or devx. (assuming you use frugal install)
Download it, unpack and make executable, move in executable path

Code:
gunzip update.sh.gz
chmod +x update.sh
mv update.sh /root/my-applications/bin


Then open console in directory containing dpup-487.sfs or dpup-devx_487.sfs and run one of these commnads:
Code:
#Run this to update dpup-487.sfs:
update.sh main

#Run this to update devx:
update.sh devx


What's updated?
gtk2 is updated to latest with pango/cairo/pixbuf/libpng and other needed libs
mtpaint and geany updates are included
Also gimp 2.8.10 is added to repo but it will not run without these updates.

Note: After this update I had some apps output glib warnings in console but I had not experienced any problems.

Gimp packages:
There's a full sfs here: Gimp-2.8.10-dpup487_487.sfs 28.2 MB

Contents:
Python 2.8.10 (for python-fu scripts support)
Gimp 2.8.10 with babl/gegl dependencies
Plugins: gmic, david's batch processor and wavelet-decompose
Script packs: FxFoundry pack, Elsamuko scripts, Silicosaur effects and kaleidoscope script

Individual pets used for update and separate gimp packs are also uploaded to repo.
update.sh.gz
Description  Update script for dpup 487
gz

 Download 
Filename  update.sh.gz 
Filesize  800 Bytes 
Downloaded  53 Time(s) 

_________________



Last edited by dejan555 on Mon 06 Oct 2014, 20:05; edited 2 times in total
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
Billtoo


Joined: 07 Apr 2009
Posts: 2126
Location: Ontario Canada

PostPosted: Sun 27 Apr 2014, 06:49    Post subject: Dpup 487  

I applied the updates and everything is working fine so far, conky is
taking a little more screen space after the update.
Thanks
updated+gimp.jpg
 Description   
 Filesize   55.72 KB
 Viewed   322 Time(s)

updated+gimp.jpg

Back to top
View user's profile Send private message 
dejan555


Joined: 30 Nov 2008
Posts: 2681
Location: Montenegro

PostPosted: Sun 27 Apr 2014, 07:29    Post subject:  

Hmm, are the fonts bigger?
freetype and fontconfig are also updated, maybe that's why conky takes more space, something might have changed there.
Didn't notice any change in fonts in gtk apps.

_________________


Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
Display posts from previous:   Sort by:   
Page 3 of 6 [87 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0910s ][ Queries: 12 (0.0058s) ][ GZIP on ]