Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 22:59
All times are UTC - 4
 Forum index » Off-Topic Area » Programming
InkscapeLite compilation problems.
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
johnfound

Joined: 21 Apr 2014
Posts: 2
Location: Bulgaria

PostPosted: Mon 21 Apr 2014, 12:41    Post_subject:  InkscapeLite compilation problems.
Sub_title: Missing icons and not recognized option error.
 

Hi all. I have a problem compiling InkscapeLite on Linux Mint. I downloaded the sources (inkscapelite-0.36.3.tar.gz) and tried to compile it. At first there was an error: gcc: error: unrecognized option '--export-dynamic'. I fixed (?) it by replacing --export-dynamic with -rdynamic option, according to an answer on StackOverflow.

After compilation, the program works actually, but most of the toolbar and menu icons are missing (replaced by black/random rectangles).

What I am missing?
inkscape.png
 Description   
 Filesize   13.77 KB
 Viewed   269 Time(s)

inkscape.png

Back to top
View user's profile Send_private_message Visit_website 
johnfound

Joined: 21 Apr 2014
Posts: 2
Location: Bulgaria

PostPosted: Mon 21 Apr 2014, 16:12    Post_subject:  

BTW, after installing Lucid Puppy 5.28, I noticed, that one of the icons (the lower icon on the tool palette - IIRC it is the color picker tool) is wrong as well - it was the same as the text tool (the previous icon).
Back to top
View user's profile Send_private_message Visit_website 
MochiMoppel


Joined: 26 Jan 2011
Posts: 433
Location: Japan

PostPosted: Wed 23 Apr 2014, 01:59    Post_subject:  

johnfound wrote:
BTW, after installing Lucid Puppy 5.28, I noticed, that one of the icons (the lower icon on the tool palette - IIRC it is the color picker tool) is wrong as well - it was the same as the text tool (the previous icon).
I hope it doesn't come as a surprise that this necro SW has problems in other Puppies as well.
Precise 5.7: The color picker button can magically assume any icon image, including your not appreciated black. The zoom icon (bottom left) can assume funny patterns. All icons appear unsharp.
Slacko 5.7: Icons are sharp and don't change their appearance, but as in Precise the X-scale at the top fills with artifacts with every mouse movement, so does the Y-scale at the left, which is almost invisible, so it doesn't matter anyway.
Puppy 4.2: Perfect. Bottomline: ancient SW runs best on an ancient OS. Which makes me wonder why you try so hard to revive this dead horse. The current version and the old lite version are worlds apart in functionality and usability.
ink_precise5.7_black.png
 Description   
 Filesize   27.19 KB
 Viewed   192 Time(s)

ink_precise5.7_black.png

ink_precise5.7.png
 Description   
 Filesize   33.1 KB
 Viewed   213 Time(s)

ink_precise5.7.png

ink_slacko5.7.png
 Description   
 Filesize   22.73 KB
 Viewed   209 Time(s)

ink_slacko5.7.png

ink_puppy4.2.png
 Description   
 Filesize   27.51 KB
 Viewed   213 Time(s)

ink_puppy4.2.png

Back to top
View user's profile Send_private_message 
greengeek

Joined: 20 Jul 2010
Posts: 2596
Location: New Zealand

PostPosted: Thu 24 Apr 2014, 03:12    Post_subject:  

MochiMoppel wrote:
. The current version and the old lite version are worlds apart in functionality and usability.
Which current version is the best one to get - do you mean Inkscape full, or just a newer version of Inkscapelite?
Back to top
View user's profile Send_private_message 
MochiMoppel


Joined: 26 Jan 2011
Posts: 433
Location: Japan

PostPosted: Thu 24 Apr 2014, 05:30    Post_subject:  

There is no newer version of InkscapeLite. It was a one-time-only project. The current stable version is 0.48.4. (full version). PETs are available for most Puppy flavors. I use 0.48.3 for Slacko.
Back to top
View user's profile Send_private_message 
greengeek

Joined: 20 Jul 2010
Posts: 2596
Location: New Zealand

PostPosted: Thu 24 Apr 2014, 05:41    Post_subject:  

Thanks for explaining this. I always wondered what caused the edge artifacts when you moved the mouse across the page. Never had much success with Lite so I will give the full version a go.
Back to top
View user's profile Send_private_message 
amigo

Joined: 02 Apr 2007
Posts: 2261

PostPosted: Thu 24 Apr 2014, 09:02    Post_subject:  

The reason for using the old version was because it has *way* less dependencies than the newer versions. However, BK's hack of the original sources was really poor -and that's why things work so weird or not at all. The original (old) sources work much better.
Back to top
View user's profile Send_private_message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3972
Location: Kiel,Germany

PostPosted: Thu 24 Apr 2014, 10:03    Post_subject:  

For the icons :
Code:
strace inkscapelite 2>inkscpelite.strace
geany inkscpelite.strace

should open a huge file which should show look ups for icons like
access("/usr/share/inkscape/join_miter.xpm", F_OK) = 0

So the icons are in /usr/share/inkscape/ directory .
Of course, check if they are there or in /usr/local/share/inkscape .


Other than this, your libxpm* might not work as it should .
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Off-Topic Area » Programming
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0964s ][ Queries: 12 (0.0412s) ][ GZIP on ]