Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Dec 2014, 16:12
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
qt-4.8.6-w5.sfs
Moderators: deshlab, Flash, GuestToo, Ian, JohnMurga, Lobster
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
watchdog

Joined: 28 Sep 2012
Posts: 676

PostPosted: Wed 07 May 2014, 05:30    Post_subject:  qt-4.8.6-w5.sfs
Sub_title: qt4 libraries for old puppies
 

I have spent a lot of time on it and I don't know if my work is worth an upload. I have done it. Use at your own risk. It works for me in wary and puppy 4.3.2. Some problems in slacko; read:

http://www.murga-linux.com/puppy/viewtopic.php?p=775707#775707

I used in wary 5.3 the following configure command:

https://copy.com/R4e14XacjkIB

My wary did not compile webkit and so I took it from pemasu (thanks) version 4.8.2:

http://smokey01.com/pemasu/pet_packages-upup/

My sfs should substitute in old puppies the old but still working qt-4.7.1.sfs:

http://www.4shared.com/file/Fs1zcssq/qt-471.html


Test and enjoy qt-4.8.6-w5.sfs:

https://copy.com/zWJ4oZmv4f77
Back to top
View user's profile Send_private_message 
watchdog

Joined: 28 Sep 2012
Posts: 676

PostPosted: Wed 07 May 2014, 06:10    Post_subject: qt-4.8.6-w5-1.sfs
Sub_title: qt libraries for qupzilla
 

If you want to use qupzilla in old puppies you must use the following sfs:

https://copy.com/dQ4cEGBAbQgU

My wary 5.3's compiler refused to build webkit and libQtScript and so the trick is to take the missing lib from pemasu's work.

EDIT: the above qt build is missing libqtsqlite.so so if you run qupzilla in console than you'll see sql database errors and you'll cannot import bookmarks from other browsers. I have added the missing plugin and qupzilla is working in lucid with the following qt-4.8.6-w5-5.sfs download:

https://copy.com/SkPK7jHmdRPg

Edited_time_total
Back to top
View user's profile Send_private_message 
jlst

Joined: 23 Nov 2012
Posts: 26

PostPosted: Sun 15 Jun 2014, 22:54    Post_subject:  

Nice thank you
Back to top
View user's profile Send_private_message 
666philb


Joined: 07 Feb 2010
Posts: 1962
Location: wales

PostPosted: Sun 14 Dec 2014, 13:10    Post_subject:  

hi watchdog

have you got the .dev files for this?

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send_private_message 
watchdog

Joined: 28 Sep 2012
Posts: 676

PostPosted: Sun 14 Dec 2014, 14:40    Post_subject:  

666philb wrote:
hi watchdog

have you got the .dev files for this?


No. I have not saved the development files. In old puppies I realized that the qt 4.8.0 by pemasu (http://smokey01.com/pemasu/QT-4.8.0-dpup/libs/qt-4.8.0-basic-with-qtwebkit-dpup.pet) is a better choice to use. I have also the sfs of pemasu's work. If you need the dev files of qt 4.8.0 they are here:

http://smokey01.com/pemasu/QT-4.8.0-dpup/libs/qt_DEV-4.8.0-basic-with-qtwebkit-dpup.pet
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Unsorted
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0491s ][ Queries: 11 (0.0056s) ][ GZIP on ]