Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 21 Oct 2017, 06:26
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
palemoon browser
Post new topic   Reply to topic View previous topic :: View next topic
Page 30 of 33 [483 Posts]   Goto page: Previous 1, 2, 3, ..., 28, 29, 30, 31, 32, 33 Next
Author Message
watchdog

Joined: 28 Sep 2012
Posts: 1455
Location: Italy

PostPosted: Thu 14 Sep 2017, 00:16    Post subject:  

I am in puppy 4.31 (zigbert's Stardust 013) and my palemoon 27.4.2 glibc219 tweaked. I am experimenting the first crash of palemoon on a particular italian site:

http://www.mercatoliberonews.com/

Perhaps the site has bad html code but it correctly displays with a chrooted firefox 45.9.0 esr. I report this for Walter Dnes to fix the mainline sse2 palemoon.

EDIT: further trials prove the crashing of the mainline sse2 palemoon 27.4.2 on that site even installed without glibc tweak in modern puppies. There is a segmentation fault. Current firefox correctly displays the site.
Back to top
View user's profile Send private message 
Walter Dnes

Joined: 30 Dec 2016
Posts: 94

PostPosted: Sat 16 Sep 2017, 03:58    Post subject:  

watchdog wrote:
EDIT: further trials prove the crashing of the mainline sse2 palemoon 27.4.2 on that site even installed without glibc tweak in modern puppies. There is a segmentation fault. Current firefox correctly displays the site.

I'm also doing a "contributed build" for the mainline (SSE2) linux 32-bit "unstable" version. This is the latest code, which will be part of the next version. It'll be posted in the Pale Moon forum thread https://forum.palemoon.org/viewtopic.php?f=37&t=14482&start=20 The tarball can be found in the ftp directory listing ftp://contrib:get@ftp.palemoon.org/32bit-unstable-Linux/ Try that on a Pentium 4 or higher machine to see if it helps.

I hope to get a new version uploaded today. I'm going away for a vacation on the 18th to the 22nd, so I won't be around to answer questions.
Back to top
View user's profile Send private message 
Robert123

Joined: 20 May 2016
Posts: 358
Location: Pacific

PostPosted: Sat 16 Sep 2017, 04:17    Post subject:  

watchdog wrote:
I am in puppy 4.31 (zigbert's Stardust 013) and my palemoon 27.4.2 glibc219 tweaked. I am experimenting the first crash of palemoon on a particular italian site:

http://www.mercatoliberonews.com/


Tried this myself in 4.31 on my T42 and it was fine on that site.

_________________
Devuan Linux, Stardust 013 (4.31) updated https://archive.org/details/Stardustpup013glibc2.10
s57(2018)barebonehttps://sourceforge.net/projects/puppy-linux-minimal-builds/files/s57%282018%29barebones.iso/download
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1455
Location: Italy

PostPosted: Sat 16 Sep 2017, 08:30    Post subject:  

Robert123 wrote:

http://www.mercatoliberonews.com/

Tried this myself in 4.31 on my T42 and it was fine on that site.


Yes, it is working also for me now. It was out for palemoon for one or a couple of days. Bad html code, I think.
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1455
Location: Italy

PostPosted: Sat 16 Sep 2017, 08:34    Post subject:  

Walter Dnes wrote:

I'm also doing a "contributed build" for the mainline (SSE2) linux 32-bit "unstable" version. This is the latest code, which will be part of the next version. It'll be posted in the Pale Moon forum thread https://forum.palemoon.org/viewtopic.php?f=37&t=14482&start=20 The tarball can be found in the ftp directory listing ftp://contrib:get@ftp.palemoon.org/32bit-unstable-Linux/ Try that on a Pentium 4 or higher machine to see if it helps.


Thanks Walter, I'll try your build. But the problem I reported is now solved: I think bad html code was responsible for making crash palemoon.
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1455
Location: Italy

PostPosted: Sat 16 Sep 2017, 09:45    Post subject:  

@Walter Dnes

Happy news: your build is working in puppy 4.31 with glibc219tweak. New libstdc++.so.6 was needed: I took it from ubuntu xenial xerus 32 bit.
screenshot.png
 Description   
 Filesize   185.93 KB
 Viewed   348 Time(s)

screenshot.png

Back to top
View user's profile Send private message 
Robert123

Joined: 20 May 2016
Posts: 358
Location: Pacific

PostPosted: Sat 16 Sep 2017, 15:17    Post subject:  

watchdog wrote:
@Walter Dnes

Happy news: your build is working in puppy 4.31 with glibc219tweak. New libstdc++.so.6 was needed: I took it from ubuntu xenial xerus 32 bit.


Cool thanks Watchdog thank you we can still use these old pups, because of your hard work.

_________________
Devuan Linux, Stardust 013 (4.31) updated https://archive.org/details/Stardustpup013glibc2.10
s57(2018)barebonehttps://sourceforge.net/projects/puppy-linux-minimal-builds/files/s57%282018%29barebones.iso/download
Back to top
View user's profile Send private message 
festus


Joined: 14 Jan 2015
Posts: 135

PostPosted: Mon 18 Sep 2017, 10:11    Post subject:  

Hey, all

I am running Stardustpup013glibc2.10, on an old box with a 2001 athlon processor, and was wondering if any of these modern palemoon spins will run on it?

These are the processor specs:
Code:
AMD Athlon(tm) processor
Socket Designation: Socket A
Manufacturer: AMD
Voltage: 3.3 V
External Clock: 133 MHz
Max Speed: 500 MHz
Current Speed of Core 0:1333 MHz


This old box also has 640 MB RAM

I tried walter's, palemoon-27.4.2SSE.linux-i686, from the terminal and this is what it reported: "Illegal instruction"

Am I using the incorrect build of p-moon, or it just will not run on this old of a processor?

Thank you for any advice

festus
Back to top
View user's profile Send private message 
watchdog

Joined: 28 Sep 2012
Posts: 1455
Location: Italy

PostPosted: Mon 18 Sep 2017, 11:05    Post subject:  

Hi, festus. Try one of the following 27.4.2 palemoon glibctweaked:

http://www.murga-linux.com/puppy/viewtopic.php?p=960621#960621

In console:

Code:
cat /proc/cpuinfo


If sse2 flag is reported use the mainline palemoon. Otherwise use the sse version.
Back to top
View user's profile Send private message 
festus


Joined: 14 Jan 2015
Posts: 135

PostPosted: Mon 18 Sep 2017, 12:42    Post subject:  

Thanks for the info, watchdog

Here is the report of:
Code:
# cat /proc/cpuinfo
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 6
model           : 4
model name      : AMD Athlon(tm) processor
stepping        : 2
cpu MHz         : 1333.305
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 mmx fxsr syscall mmxext 3dnowext 3dnow up
bogomips        : 2666.61
clflush size    : 32
power management:

I then installed palemoon-27.4.2-p4-sse-glibc219tweak.pet

terminal returned this:
Code:
# palemoon
/usr/bin/palemoon: line 3:  7063 Illegal instruction     /usr/lib/palemoon/glibc219/lib/ld-linux.so.2 --library-path /usr/lib/palemoon/glibc219/lib:/usr/lib/palemoon/glibc219/usr/lib:/usr/lib/palemoon/glibc219/libstdc++:/usr/X11R7/lib:/usr/lib/palemoon /usr/lib/palemoon/palemoon "$@"

To me it looks like this processor will NOT be able to run these versions of palemoon.

Oh well, maybe an older version of firefox will work.

Thanks, again,

festus
Back to top
View user's profile Send private message 
Robert123

Joined: 20 May 2016
Posts: 358
Location: Pacific

PostPosted: Tue 19 Sep 2017, 05:43    Post subject:  

Hi Festus,

Does this work?
http://murga-linux.com/puppy/viewtopic.php?t=107857

_________________
Devuan Linux, Stardust 013 (4.31) updated https://archive.org/details/Stardustpup013glibc2.10
s57(2018)barebonehttps://sourceforge.net/projects/puppy-linux-minimal-builds/files/s57%282018%29barebones.iso/download
Back to top
View user's profile Send private message 
festus


Joined: 14 Jan 2015
Posts: 135

PostPosted: Tue 19 Sep 2017, 11:55    Post subject:  

Robert123 wrote:
Hi Festus,

Does this work?
http://murga-linux.com/puppy/viewtopic.php?t=107857

Yes, this ffx-27 does work on my old box, and I'm a thanking you for the link. Smile

bliss,
festus
Back to top
View user's profile Send private message 
Robert123

Joined: 20 May 2016
Posts: 358
Location: Pacific

PostPosted: Tue 19 Sep 2017, 14:19    Post subject:  

Good thing is 8GEEE is working on it to keep it up to date.
_________________
Devuan Linux, Stardust 013 (4.31) updated https://archive.org/details/Stardustpup013glibc2.10
s57(2018)barebonehttps://sourceforge.net/projects/puppy-linux-minimal-builds/files/s57%282018%29barebones.iso/download
Back to top
View user's profile Send private message 
Jose A. Senna

Joined: 20 Dec 2016
Posts: 32

PostPosted: Tue 19 Sep 2017, 19:13    Post subject:
Subject description: 1998 CPU
 

Here is the cpuinfo for the machine I am using with Racy 5.5:

processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 5
model name : Pentium II (Deschutes)
stepping : 2
cpu MHz : 350.756
cache size : 512 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pse36 mmx fxsr up
bogomips : 701.74
clflush size : 32
cache_alignment: 32
address sizes : 36 bits physical, 32 bits virtual
power management:

I think this rules out Palemoon, from what I read in this thread and in Palemoon site.
Is there any other option ?
Back to top
View user's profile Send private message 
greengeek


Joined: 20 Jul 2010
Posts: 4660
Location: Republic of Novo Zelande

PostPosted: Fri 22 Sep 2017, 04:38    Post subject:  

I would be keen to see a separate thread for an SSE version of Palemoon - it's a bit of a struggle to find which post references a suitable version for a PC that lacks SSE2.

As an alternative to a separate thread - could anyone link to a post which offers a version for SSE only CPU?

cheers!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 30 of 33 [483 Posts]   Goto page: Previous 1, 2, 3, ..., 28, 29, 30, 31, 32, 33 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1117s ][ Queries: 14 (0.0220s) ][ GZIP on ]