Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 31 Oct 2014, 19:01
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
TahrPup 5.8.4
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 17 of 40 [597 Posts]   Goto page: Previous 1, 2, 3, ..., 15, 16, 17, 18, 19, ..., 38, 39, 40 Next
Author Message
666philb


Joined: 07 Feb 2010
Posts: 1803
Location: wales

PostPosted: Thu 24 Jul 2014, 08:15    Post subject: Re: Mouse ok, but no keyboard !  

Mayou wrote:
Mouse ok, but no keyboard ! even changing countries. Sorry, shall try later.


hi mayou, what computer and what keyboard are you using?

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1803
Location: wales

PostPosted: Thu 24 Jul 2014, 09:13    Post subject: Re: some modules missing in initramfs  

shinobar wrote:
666philb wrote:
i checked the DOTconfig and CONFIG_PATA_MARVELL=m ... needs to be set to y i'll have to recompile the kernel

Thanks.
Also 'y' need for CONFIG_NLS_CODEPAGE_852 and CONFIG_NLS_ISO8859_2.
Form slacko-6.0 beta thread:
http://www.murga-linux.com/puppy/viewtopic.php?t=94328&start=495


thanks shinobar

i've uploaded a new kernel with the suggested configs https://www.dropbox.com/s/pq3cfhh0mdq1wt9/kernel-3.14.13_PAE.tar.xz

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send private message 
sketchman


Joined: 01 Jun 2006
Posts: 251
Location: West Virginia, USA

PostPosted: Thu 24 Jul 2014, 13:17    Post subject:  

Appreciate the work on this. I'm booting from a flash drive, and running a completely diskless super compact Haswell based rig I built myself.

Quirky led me to this puplet, and I'm glad I took all the effort and time to get it running.

So tiny, yet so awesome. Smile



Thanks again.

_________________
"In a world that exists without walls and fences, who needs Windows and Gates?"
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Thu 24 Jul 2014, 14:30    Post subject: Re: some modules missing in initramfs  

666philb wrote:
i've uploaded a new kernel with the suggested configs https://www.dropbox.com/s/pq3cfhh0mdq1wt9/kernel-3.14.13_PAE.tar.xz

Thanks. Now my HDD under Marvel IDE interface is caught correctly. Very Happy
# probedisk
/dev/sda|drive|ATA ADATA SSD S510 1
/dev/sdb|drive|ATA ST32000542AS
/dev/sdc|drive|ATA WDC WD1600BB-00D
/dev/sdd|usbdrv|FLASH Drive SM_USB20
/dev/sr0|optical|PIONEER BD-RW BDR-206D
/dev/sr1|optical|MATSHITABD-MLT UJ240AF

Add the ID string:
# echo -n 't140711144545ZZZZ5.8.3XXXXXXXXXX' >> vmlinux

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Fri 25 Jul 2014, 07:34    Post subject: vlc media player  

When you have 2 optical drives, sr0 and sr1, cliking DVD on sr1 invokes vlc mediaplayer, but vlc fails because it tyies sr0.

Next config file solves this issue:
/root/.config/vlc/vclcrc
Code:
[main] # main program
# DVD device (string)
dvd=/dev/dvd

# VCD device (string)
vcd=/dev/dvd

# Audio CD device (string)
cd-audio=/dev/cdrom


Another issue:
VLC config has 'disable-screensaver' flag, but it does not work at all. Crying or Very sad
I don't know the reason. Rolling Eyes

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
mikeslr


Joined: 16 Jun 2008
Posts: 794
Location: Union New Jersey USA

PostPosted: Fri 25 Jul 2014, 22:48    Post subject: Thanks  

Hi 666philb

Thanks for your hard work. Tahr 5.8.3 works fine OOTB on a Dell Latitude E6400. I'm still exploring and haven't tried to print or scan. But so far I haven't had any difficulty installing pets, or loading sfses, originally built for raring or precise and haven't discovered any conflicts.

mikesLr
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Sat 26 Jul 2014, 07:13    Post subject: gstreamer  

TahrPup-5.8.3 has gstreamer built-in:
Code:
# grep gstreamer /root/.packages/woof-installed-packages | sort -u | cut -f1 -d'|'
gstreamer0.10-alsa_0.10.36
gstreamer0.10-fluendo-mp3_0.10.23.debian-3
libgstreamer-plugins-bad0.10-0_0.10.23
libgstreamer-plugins-base0.10-0_0.10.36
libgstreamer-plugins-base1.0-0_1.2.4-1
libgstreamer0.10-0_0.10.36
libgstreamer1.0-0_1.2.4
libqtwebkit4_2.3.2

But is it working? Working with what applications?

I am testing gstreamer with the net game Secondlife.
The streaming doesn't work in the Secondlfe.
Maybe adding some packages relating gstreamer-plugins-good, but the streaming in the secondlife can play back with the gstreamer-0.10.35-lucid.sfs made from the Ubuntu lucid repo.
http://shino.pos.to/party/bridge.cgi?puppy/opt/pup5/

The gstreamer is complex. I suggest to leave it as an optional and remove it from the main.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
sketchman


Joined: 01 Jun 2006
Posts: 251
Location: West Virginia, USA

PostPosted: Sun 27 Jul 2014, 09:42    Post subject:  

Possible issue. When you uncheck the option to auto-play DVD video and CD audio it completely stops the normal handler operation.

So instead of mounting or displaying the contents of a partition when you click on it, you just get the pmount window popping up.

Check the option for DVD and CD, and it goes back to normal.

_________________
"In a world that exists without walls and fences, who needs Windows and Gates?"
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Sun 27 Jul 2014, 09:44    Post subject: sfs_load-2.1.8  

sfs_load-2.1.8 test released.
All the extra sfs be handled by sfs_load to avoid long wait with the message 'next boot will be faster'.

Install sfs_load-2.1.8.pet and pman-2.3.pet to make fixmenu fast:
Note /etc/rc.d/rc.sysinit is modified by the pinstall.sh.
http://www.murga-linux.com/puppy/viewtopic.php?p=791192#791192

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
bwh1969

Joined: 25 Oct 2010
Posts: 132
Location: Allentown, PA

PostPosted: Tue 29 Jul 2014, 19:57    Post subject:  

@ bohocmasni PostPosted: Thu 17 Jul 2014, 02:31
Quote:
hi!
I have a problem:

after installing xkb-data_2.10.1-1ubuntu1_all.deb from ubuntu repo, (and after X restart) my keyboard doesn't work any more.
It is a dependency for workrave.
_________________
http://www.youtube.com/watch?v=G6D1YI-41ao


This has happened to me twice. Removing the package didn't help. I started from scratch because I had not installed/modified much. The second time this happened, I decided to work around this by downloading xkb-data_2.10.1-1ubuntu1_all.deb and extracted it on another computer to see what the files were, then I booted with pfix=ram clicked the pupsave file, and deleted the files that were installed in the package.

It is definitely a problem because it is a dependency for other applications as well.
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2631
Location: Japan

PostPosted: Wed 30 Jul 2014, 09:20    Post subject: defaults-chooser-0.9  

UPDATE: defaults-chooser-0.9.pet
http://shino.pos.to/party/bridge.cgi?puppy/opt/
# v0.9 30Jul2014 shinobar: add pdfviewer, screenshot

/root/Choices/MIME-types/application_pdf wrote:
#! /bin/sh
exec zathura "$1"

But it is better to be
Quote:
#! /bin/sh
exec defaultpdfviewer "$1"


Pressing the [Print Screen] key, launches defaultscreenshot.
I prefer 'mtpaint -s' rather than screeny as the defaultscreenshot.
Because screeny need more action after pressing the [Print Screen] key.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
666philb


Joined: 07 Feb 2010
Posts: 1803
Location: wales

PostPosted: Thu 31 Jul 2014, 13:48    Post subject: Re: gstreamer  

shinobar wrote:
TahrPup-5.8.3 has gstreamer built-in:
Code:
# grep gstreamer /root/.packages/woof-installed-packages | sort -u | cut -f1 -d'|'
gstreamer0.10-alsa_0.10.36
gstreamer0.10-fluendo-mp3_0.10.23.debian-3
libgstreamer-plugins-bad0.10-0_0.10.23
libgstreamer-plugins-base0.10-0_0.10.36
libgstreamer-plugins-base1.0-0_1.2.4-1
libgstreamer0.10-0_0.10.36
libgstreamer1.0-0_1.2.4
libqtwebkit4_2.3.2

But is it working? Working with what applications?
The gstreamer is complex. I suggest to leave it as an optional and remove it from the main.


hi shinobar

with gstreamer 0.10, barry put a note in DISTRO_PKGS_SPECS-ubuntu-trusty from his quirky tahr build saying ... "#qupzilla, seamonkey, etc need this" so i left that in.
as for gstreamer 1.0 i put that in as the new skype needed it .... i then discovered that the new skype is a pain on puppy so i will remove this one in the net build.

VLC i'll try and add the config in the next build and as for the disable-screensaver flag, i don't think it has ever worked for me in puppy with any media player or browser and i always end up disabling the screensaver.

SFS_LOAD the new sfs_load is working fine and it'll be in the next build

i'll put the new defaults chooser quickpet ...tahr fixes

thanks

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1803
Location: wales

PostPosted: Thu 31 Jul 2014, 13:55    Post subject:  

sketchman wrote:
Possible issue. When you uncheck the option to auto-play DVD video and CD audio it completely stops the normal handler operation.

So instead of mounting or displaying the contents of a partition when you click on it, you just get the pmount window popping up.

Check the option for DVD and CD, and it goes back to normal.


hi sketchman,

i can't test this as i don't have a cd/dvd drive, and not sure i know how to fix it. but maybe someone else will see this and know a fix?

thanks

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1803
Location: wales

PostPosted: Thu 31 Jul 2014, 13:57    Post subject:  

bwh1969 wrote:
@ bohocmasni PostPosted: Thu 17 Jul 2014, 02:31
Quote:
hi!
I have a problem:

after installing xkb-data_2.10.1-1ubuntu1_all.deb from ubuntu repo, (and after X restart) my keyboard doesn't work any more.
It is a dependency for workrave.
_________________
http://www.youtube.com/watch?v=G6D1YI-41ao


This has happened to me twice. Removing the package didn't help. I started from scratch because I had not installed/modified much. The second time this happened, I decided to work around this by downloading xkb-data_2.10.1-1ubuntu1_all.deb and extracted it on another computer to see what the files were, then I booted with pfix=ram clicked the pupsave file, and deleted the files that were installed in the package.

It is definitely a problem because it is a dependency for other applications as well.


hi bwh196,

this should be fixed... open quickpet, click update & update quickpet ... then click the update button again and choose 'tahrpup bug fixes'

thanks

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send private message 
sketchman


Joined: 01 Jun 2006
Posts: 251
Location: West Virginia, USA

PostPosted: Thu 31 Jul 2014, 14:40    Post subject:  

666philb wrote:
sketchman wrote:
Possible issue. When you uncheck the option to auto-play DVD video and CD audio it completely stops the normal handler operation.

So instead of mounting or displaying the contents of a partition when you click on it, you just get the pmount window popping up.

Check the option for DVD and CD, and it goes back to normal.


hi sketchman,

i can't test this as i don't have a cd/dvd drive, and not sure i know how to fix it. but maybe someone else will see this and know a fix?

thanks

I actually don't have any opticals either, but the option is still there. It's no big deal. I can work around it.

_________________
"In a world that exists without walls and fences, who needs Windows and Gates?"
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 17 of 40 [597 Posts]   Goto page: Previous 1, 2, 3, ..., 15, 16, 17, 18, 19, ..., 38, 39, 40 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1213s ][ Queries: 12 (0.0303s) ][ GZIP on ]